Restricted Rights Notice

The ENVI® and IDL® software programs and the accompanying procedures, functions, and documentation described herein are sold under license agreement. Their use, duplication, and disclosure are subject to the restrictions stated in the license agreement. Research System, Inc., reserves the right to make changes to this document at any time and without notice.

Limitation of Warranty

Research Systems, Inc. makes no warranties, either express or implied, as to any matter not expressly set forth in the license agreement, including without limitation the condition of the software, merchantability, or fitness for any particular purpose.

Research Systems, Inc. shall not be liable for any direct, consequential, or other damages suffered by the Licensee or any others resulting from use of the ENVI and IDL software packages or their documentation.

Permission to Reproduce this Manual

If you are a licensed user of these products, Research Systems, Inc. grants you a limited, nontransferable license to reproduce this particular document provided such copies are for your use only and are not sold or distributed to third parties. All such copies must contain the title page and this notice page in their entirety.

Acknowledgments

ENVI® and IDL® are registered trademarks of Research Systems, Inc., registered in the United States Patent and Trademark Office, for the computer program described herein. Dancing Pixels, Pixel Purity Index, PPI, n-Dimensional Visualizer, Spectral Analyst, Spectral Feature Fitting, SFF, Mixture-Tuned Matched Filtering, MTMF, 3D-SurfaceView, Band Math, Spectral Math, ENVI Extension, Empirical Flat Field Optimal Reflectance Transformation (EFFORT), and Virtual Mosaic are trademarks of Research Systems, Inc.

Numerical Recipes™ is a trademark of Numerical Recipes Software. Numerical Recipes routines are used by permission.

GRG2™ is a trademark of Windward Technologies, Inc. The GRG2 software for nonlinear optimization is used by permission.

NCSA Hierarchical Data Format (HDF) Software Library and Utilities
Copyright © 1988-1998 The Board of Trustees of the University of Illinois
All rights reserved.

CDF Library
Copyright © 1993-1996 University Corporation for Atmospheric Research/Unidata

NetCDF Library
Copyright © 1999 National Space Science Data Center
NASA/Goddard Space Flight Center

HDF EOS Library
Copyright © 1995 Hughes and Applied Research Corporation

This software is based in part on the work of the Independent JPEG Group.

This product contains StoneTable™, by StoneTablet Publishing. All rights to StoneTable™ and its documentation are retained by StoneTablet Publishing, PO Box 12665, Portland OR 97212-0665. Copyright © 1992-1997 StoneTablet Publishing

WASTE text engine © 1993-1996 Marco Piovanelli

Portions of this software are copyrighted by INTERSOLV, Inc., 1991-1998.

Use of this software for providing LZW capability for any purpose is not authorized unless user first enters into a license agreement with Unisys under U.S. Patent No. 4,558,302 and foreign counterparts. For information concerning licensing, please contact: Unisys Corporation, Welch Licensing Department - C1SW19, Township Line & Union Meeting Roads, P.O. Box 500, Blue Bell, PA 19424.

Portions of this computer program are copyright © 1995-1999 LizardTech, Inc. All rights reserved. MrSID is protected by U.S. Patent No. 5,710,835. Foreign Patents Pending.

Other trademarks and registered trademarks are the property of the respective trademark holders.
Tutorial 12:
Introduction to Hyperspectral Data and Analysis

The following topics are covered in this tutorial:

Overview of This Tutorial ............. 264
Introduction to Basic ENVI Spectral Processing ......................... 268
Compare Radiance and ATREM ........ 279
Compare Atmospheric Corrections .... 283
References ........................ 287
Overview of This Tutorial

This tutorial is designed to introduce you to the concepts of Imaging Spectrometry, hyperspectral images, and selected spectral processing basics using ENVI. For this exercise, we will use Airborne Visible/Infrared Imaging Spectrometer (AVIRIS) data to familiarize you with spatial and spectral browsing of imaging spectrometer data. We will start with 1995 AVIRIS radiance data for Cuprite, Nevada, USA, provided by Jet Propulsion Laboratory (JPL) and then compare the results of several reflectance calibration procedures.

Files Used in This Tutorial

**CD-ROM:** *ENVI Tutorial and Data CD No. 2*

**Path:** envidata/c95avsub

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>cup95_rd.int</td>
<td>Cuprite AVIRIS radiance data. 400 samples x 350 lines x 50 bands (Integer).</td>
</tr>
<tr>
<td>cup95_rd.hdr</td>
<td>ENVI Header for above</td>
</tr>
<tr>
<td>cup95_at.int</td>
<td>Cuprite ATREM-calibrated apparent reflectance data. 50 bands (Integer).</td>
</tr>
<tr>
<td>cup95_at.hdr</td>
<td>ENVI Header for above</td>
</tr>
<tr>
<td>cup95cal.sli</td>
<td>Spectral Library of calibration results for selected minerals (Integer).</td>
</tr>
<tr>
<td>cup95cal.hdr</td>
<td>ENVI Header for above</td>
</tr>
<tr>
<td>jpl1sli.dat</td>
<td>Spectral Library in ENVI format.</td>
</tr>
<tr>
<td>jpl1sli.hdr</td>
<td>ENVI Header for above</td>
</tr>
<tr>
<td>usgs_sli.dat</td>
<td>USGS Spectral Library in ENVI format</td>
</tr>
<tr>
<td>usgs_sli.hdr</td>
<td>ENVI Header for above</td>
</tr>
</tbody>
</table>
**Note**
Optional files listed may also be used if more detailed calibration comparisons are desired. All image data files have been converted to integer format by multiplying the reflectance values by 1000 because of disk space considerations. A value of 1000 therefore represents apparent reflectance of 1.0.

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>cup95_ff.int</td>
<td>Cuprite Flat-Field-calibrated apparent reflectance data. 50 bands (Integer).</td>
</tr>
<tr>
<td>cup95_ff.hdr</td>
<td>ENVI Header for above</td>
</tr>
<tr>
<td>cup95_ia.int</td>
<td>Cuprite Internal Average Relative Reflectance (IARR) data. 50 bands (Integer).</td>
</tr>
<tr>
<td>cup95_ia.hdr</td>
<td>ENVI Header for above</td>
</tr>
<tr>
<td>cup95_el.int</td>
<td>Cuprite Empirical Line calibrated apparent reflectance data. 50 bands (Integer).</td>
</tr>
<tr>
<td>cup95_el.hdr</td>
<td>ENVI Header for above</td>
</tr>
</tbody>
</table>

**Background: Imaging Spectrometry**

Imaging spectrometers or “hyperspectral sensors” are remote sensing instruments that combine the spatial presentation of an imaging sensor with the analytical capabilities of a spectrometer. They may have up to several hundred narrow spectral bands with spectral resolution on the order of 10 nm or narrower (Goetz et al., 1985). Imaging Spectrometers produce a complete spectrum for every pixel of the image (Figure 12-1).
Compare this to broad-band multispectral scanners such as Landsat Thematic Mapper (TM), which only has 6 spectral bands and spectral resolution on the order of 100 nm or greater (Figure 12-2). The end result of the high spectral resolution of imaging spectrometers is that we can identify materials, where with broad-band sensors we could previously only discriminate between materials.
Figure 12-2: Comparison of a simulated Landsat TM spectrum to the corresponding laboratory spectrum.
Introduction to Basic ENVI Spectral Processing

This portion of the tutorial is designed to familiarize you with ENVI features that are useful for spectral processing of imaging spectrometer data.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as described in the installation guide.

- To open ENVI in Unix, enter `envi` at the UNIX command line.
- To open ENVI from a Windows or Macintosh system, double-click on the ENVI icon.

The ENVI main menu appears when the program has successfully loaded and executed.

1. Select File → Open Image File and navigate to the `c95avsub` subdirectory of the ENVI Tutorial and Data CD No. 2.
2. Choose `cup95_rd.int` as the input file name.

The file contains 50 bands (1.99 - 2.48 µm) of JPL-calibrated AVIRIS radiance for the Cuprite Mining District, Nevada, USA.

The Available Bands List dialog will appear, listing the 50 spectral band names.

Display a Gray Scale Image

1. Use the scroll bar on the right side of the Available Bands List dialog to scroll through the list until Band 193 (2.2008 µm) is displayed.

2. Click on the Gray Scale radio button, then select Band 193 and click on the Load Band button at the bottom of the dialog.

The Main Image window containing the selected band will appear.

3. Position the red box outlining the Zoom window by clicking the left mouse button at the desired location in the Main Image window.

The Zoom window will be automatically updated.

4. Change the zoom factor by clicking the left mouse button in + graphic located in the lower left hand corner of the zoom window to zoom up or on the - button to zoom down.
Clicking the left mouse button in the Zoom window centers the selected pixel.

The Zoom window can also be changed by dragging the red outlining box within the Main Image window by using the left mouse button.

**Display a Color Image**

1. Load a color composite image by clicking on the RGB Color radio button in the Available Bands List dialog.
2. Click sequentially on Band 183, Band 193, and Band 207 (2.10, 2.20, and 2.35 µm).
3. Select New Display from the Display pull-down button at the bottom of the dialog to start a new display.
4. Click Load RGB at the bottom of the dialog.

The color image will be loaded into the new (second) image display.

**Link Two Displays**

Images can be linked to allow simultaneous, identical user action on multiple images. Once linked, moving the zoom box, the scroll box, changing the zoom factor, or resizing any of the image windows causes the same actions to occur in the linked windows.

1. Place the cursor in the Display #1 Main Image window and select Tools → Link → Link Displays.

   The Link Displays dialog will appear (Figure 12-3).

2. Use the defaults and click OK to enable the link.
3. Position the Zoom window for Display #1 by clicking the left mouse button in the red Zoom Window outlining box in the #1 Main Image Display and dragging it to a new location.

Note how the Display #2 Zoom window updates to correspond with the first display.

**Multiple Dynamic Overlays** are available when two or more images are linked, allowing real-time overlay and flicker of multiple gray scale or color images. Dynamic overlays are activated automatically when two or more windows are first linked.

4. Click the left mouse button in either of the linked images to cause the second linked image (the overlay) to appear in the first image (the base).

5. You can make a quick visual comparison of the images by repeatedly clicking and releasing the left mouse button, which causes the overlay area to flicker.

6. Change the size of the overlay by pressing the middle mouse button and dragging the corner of the overlay to the desired location.

7. After trying the different possibilities, turn off dynamic linking in the displayed color image by selecting **Tools → Link → Unlink Display.**

**Extract Spectral Profiles**

ENVI’s Z-profile capabilities provide integrated spectral analysis. You can extract spectra from any multispectral data set including MSS, TM, and higher spectral dimension data such as GEOSCAN (24 bands), GERIS (63 bands), and AVIRIS (224 bands).
bands). From the displayed color image, you can select **Tools → Profiles → Z Profile (Spectrum)** in the Main Image window menu bar to start a spectral profile.

**Current Spectrum**

The spectrum for the current cursor location will be plotted in a plot window. A vertical line on the plot is used to mark the wavelength position of the currently displayed band. If a color composite image is displayed, three colored lines will appear, one for each displayed band in the band’s respective color (red, green, or blue).

1. Select **Tools → Profiles → Z Profile (Spectrum)** in the Main Image window menu bar to start a spectral profile.

2. Move the cursor position in the Main Image or Zoom window.
   
   The spectrum will be extracted and plotted for the new location.

3. Browse the spectral profile by clicking and holding the left mouse button in the Main Image window and dragging the box across the image.
   
   The spectrum will be updated as the Zoom window box moves. Note that the spectra you are viewing are radiance—not reflectance—spectra, as you are currently working with Cuprite radiance data.

4. Save spectra for comparison using the **File → Save Plot As** option from the menu bar at the top of the plot window.

**Collect Spectra**

1. Select **Options → Collect Spectra** in the Spectral Profile window to accumulate spectra in this plot (**Figure 12-4**).

   Optionally, to collect spectra in another plot window, open a new plot window and save image spectra from the Spectral Profile window.

2. Select **Options → New Window: Blank** from the plot menu to open a new plot window to contain saved image spectra.

3. Click the right mouse button in the previous plot to display the spectrum name to the right of the plot window.

4. Click and hold the left mouse button on the first character of the spectrum name, drag the name to the new plot window, and release the mouse button.

5. Select a new spectrum from the image by moving the current pixel location in either the Main Image or Zoom window and repeat the drag-and-drop process to build a collection of spectra in the new plot window.
6. Once you have several plots in the plot window, select **Options → Stack Data** in new plot window. The spectra will be offset vertically to allow interpretation.

![An ENVI Spectral Profile window with collected spectra.](image)

**Figure 12-4:** An ENVI Spectral Profile window with collected spectra.

7. To change the color and line style of the different spectra, select **Edit → Data Parameters** in the new plot window.

   Each spectrum is listed by name/location in the **Data Parameters** dialog.

8. Select a line and change its properties as desired.

9. When completed, click **Cancel** to close the dialog.

10. Select **File → Cancel** to close the plots after completing this section.

### Animate the Data

You can animate gray scale images to make the spatial occurrence of spectral differences more obvious.

1. In the Main Image window of the previous gray scale image (Display #1), select **Tools → Animation** to create a movie using the Cuprite AVIRIS data.
The **Animation Input Parameters** dialog will appear (Figure 12-5). This dialog lists all the bands provided in the **Available Bands List**.

![Animation Input Parameters dialog](image)

*Figure 12-5: The Animation Input Parameters dialog.*

2. Choose a subset of the full set of bands for animation. Click and drag to select a desired range of bands, or use Control-Click to select specific bands. For the purposes of this exercise, select bands 197 - 216 (20 bands).

3. Change the **Window Size** field to 200 x 175 to reduce the size of the image to be animated (and thus increase the speed of the animation).

4. Click **OK** to start the animation loading process.

The **Animation Window** and the **Animation Controls** dialog will appear. The selected bands are loaded individually into the **Animation Window**. A status bar appears as each image is processed. You can cancel the animation in progress at any time by clicking **Cancel** in the status window.

Once all of the selected images have been loaded, the animation will start automatically. Selected bands are displayed sequentially.
The **Animation Controls** dialog (Figure 12-6) are used to specify the animation characteristics. The animation speed is varied from 1 to 100 using the spin box labeled **Speed**.

![Animation Controls dialog](image)

*Figure 12-6: The Animation Controls dialog.*

5. Use the control buttons (which look like CD player buttons) to run the animation forward and reverse and to pause a specific band. When paused, click and drag the slider to manually select the band to display.

6. Choose the **File → Cancel** to end the animation.

**Working with Cuprite Radiance Data**

Continue this exercise using the images displayed in the first section.

1. If you have quit ENVI and IDL, restart ENVI and select **File → Open Image File**.

2. Navigate to the `c95avsub` subdirectory of the `envidata` directory on the *ENVI Tutorial and Data CD No. 2*. Choose `cup95_rd.int` as the input file name.
Load AVIRIS Radiance Data

1. If you don’t already have this image displayed, load a color composite image by clicking on the RGB Color radio button in the Available Bands List dialog.

2. Click sequentially on Band 183, Band 193, and Band 207 and then Load RGB at the bottom of the dialog.

The color image will be loaded into the current image display.

Extract Radiance Spectra

You can extract selected image radiance spectra for specific targets in the AVIRIS radiance data with the following steps:

1. From the Main Image window menu bar, select Tools → Pixel Locator.

2. Position the Zoom window over Stonewall Playa, centered around the pixel at sample 590 and line 570 by entering these pixel coordinates in the Pixel Locator and clicking Apply.

3. Extract the radiance spectrum for this location by selecting the Tools → Profiles → Z-Profile (Spectrum) option.

4. Select Options → Collect Spectra to extract radiance spectra for the following locations and load into the same plot window for comparison (Figure 12-7).

5. Use the Pixel Locator dialog to obtain the spectra for the other locations.

<table>
<thead>
<tr>
<th>Location Name</th>
<th>Sample (with offset)</th>
<th>Line (with offset)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stonewall Playa</td>
<td>590</td>
<td>570</td>
</tr>
<tr>
<td>Varnished Tuff</td>
<td>435</td>
<td>555</td>
</tr>
<tr>
<td>Silica Cap</td>
<td>494</td>
<td>514</td>
</tr>
<tr>
<td>Opalite Zone with Alunite</td>
<td>531</td>
<td>541</td>
</tr>
<tr>
<td>Strongly Argillized Zone with Kaolinite</td>
<td>502</td>
<td>589</td>
</tr>
<tr>
<td>Buddingtonite Zone</td>
<td>448</td>
<td>505</td>
</tr>
<tr>
<td>Calcite</td>
<td>260</td>
<td>613</td>
</tr>
</tbody>
</table>
6. Select Options → Stack Data to be able to separately view each spectrum and right-click in the plot display to show the legend for the spectra.

7. Change the colors of the individual plots if necessary by selecting Edit → Data Parameters and making the appropriate changes in the subsequent dialog.

---

**Figure 12-7: AVIRIS Radiance Spectra.**

**Compare the Radiance Spectra**

Note how similar the radiance spectra appear. The overall shape of the spectra is caused by the typical combined solar/atmospheric response. Note small absorption features (minima) near 2.2 micrometers that may be attributable to surface mineralogy.

**Load Spectral Library Reflectance Spectra**

Now compare apparent reflectance spectra from the image to selected library reflectance spectra.


2. When the Spectral Library Input File dialog appears, click Open Spec Lib and select jpl1.sli from the spec_lib/jpl_lib subdirectory.

3. Click OK. The jpl1.sli file will appear in the Select Input File field of the dialog.
4. Click on the file name and click **OK** to open the **Spectral Library Viewer** dialog (Figure 12-8).

![Spectral Library Viewer](image)

*Figure 12-8: The Spectral Library Viewer dialog.*

5. Plot the following spectra in the **Spectral Library Viewer** window by clicking on the appropriate mineral name in the list of spectra:

- ALUNITE SO-4A
- BUDDINGTONITE FELDS TS-11A
- CALCITE C-3D
- KAOLINITE WELL ORDERED PS-1A

- If desired, change the X-Axis scale by choosing **Plot Parameters** from the **Edit** menu and entering the values 2.0 and 2.5 for the range.

This allows direct visual comparison of radiance (Figure 12-7) and reflectance (Figure 12-9), though the Y-axes will not have the same scale.
6. Click **Cancel** to close the **Plot Parameters** dialog.

![Figure 12-9: Library Spectra.](image)

**Compare Image and Library Spectra**

When visually comparing and contrasting the corresponding AVIRIS radiance spectra with the laboratory measurements for alunite, buddingtonite, calcite, and kaolinite, you should notice how difficult it is to visually identify the minerals by comparing features in the radiance spectra to absorption features shown in the laboratory spectra. You should also notice the effect of the superimposed convex-upward solar-atmospheric signature in the AVIRIS radiance data on visual identification.

**Close the Windows**

When you are finished with this section, close all of the plot windows by choosing **Windows → Close All Plot Windows** from the ENVI main menu.
Compare Radiance and ATREM

In this portion of the tutorial you will extract selected image radiance spectra and compare them to ATREM apparent reflectance spectra for specific targets in the AVIRIS radiance data.

Background: ATREM Calibration

The ATmospheric REMoval Program (ATREM) is a radiative transfer model-based technique for deriving scaled surface reflectance from AVIRIS data without a priori knowledge of surface characteristics (Gao and Goetz, 1990, CSES, 1992). It utilizes the 0.94 and 1.1 micrometer water vapor bands to calculate water vapor on a pixel-by-pixel basis from the AVIRIS data, the solar irradiance curve above the atmosphere, and transmittance spectra for each of the atmospheric gases CO2, O3, N2O, CO, CH4, and O2. At the time this tutorial was released, ATREM was unavailable for distribution. Additional information is available at http://cires.colorado.edu/cses/atrem.html (Center for the Study of Earth from Space, University of Colorado). The ATREM-calibrated data used for this tutorial were reduced to apparent reflectance using ATREM 1.3.1.

Note

ATREM is not included as part of ENVI. The other calibration methods examined in this tutorial and described here are implemented within ENVI.

Continue or Restart ENVI

Continue this exercise using the images displayed in the first section.

1. If you have quit ENVI and IDL, restart ENVI and select File → Open Image File and navigate to the c95avsub subdirectory of the envidata directory on the ENVI Tutorial and Data CD No. 2.

2. Choose cup95_rd.int as the input file name.

Load Radiance Data and Start the Z-Profiler

1. If it is not already loaded, load a color composite image by clicking on the RGB Color radio button in the Available Bands List dialog.

2. Click sequentially on Band 183, Band 193, and Band 207.

3. Click Load RGB at the bottom of the dialog.

The color image will be loaded into the current image display.
4. Extract the radiance spectrum by selecting **Tools → Profiles → Z Profile (Spectrum)** from the Main Image window menu bar.

5. Move the Z-Profile window to the bottom of the screen for easy access.

**Load ATREM Apparent Reflectance Data and Start the Z Profiler**

Now open a second AVIRIS data set.

1. Select **File → Open Image File** and choose `cup95_at.int` as the second input file name.

   This is 50 bands (1.99 - 2.48 µm) of AVIRIS data calibrated to apparent reflectance using the atmospheric model ATREM to process the AVIRIS radiance data. The 50 band names will be added to the **Available Bands List** dialog.

2. Use the scroll bar on the right side of the **Available Bands List** dialog to scroll through the list until Band 193 of `cup95_at.int` is listed.

3. Click on the **Gray Scale** radio button and select band 193.

4. Select **New Display** from the **Display** pull-down button at the bottom of the dialog, and then **Load Band** to start a second ENVI image display and load the selected band.

5. Extract the radiance spectrum by selecting **Tools → Profiles → Z Profile (Spectrum)** in the second Main Image window.

6. Move the Z-Profile window to the bottom of the screen next to the Z-Profile from the radiance data for easy comparison.

**Link Images and Compare Spectra**

1. Link the two AVIRIS images together by selecting **Tools → Link → Link Displays** from the first Main Image window and clicking **OK** in the subsequent **Link Displays** dialog.

2. Now turn the dynamic overlay off in the first Main Image window by selecting **Tools → Link → Dynamic Overlay Off**.

3. Once the images are linked and the overlay is turned off, positioning the current pixel in one image (either by clicking the left mouse button in the image, dragging the Zoom window box using the left mouse button, or by using the Pixel Locator) will also position the cursor in the second image.
The Z profiles for both images will change to show the radiance and apparent reflectance spectra at the current location.

4. Position the zoom window over Stonewall Playa, centered around the pixel at sample 590 and line 570 (use the **Pixel Locator** dialog found in the **Tools** menu of the Main Image window).

Visually compare both radiance and apparent reflectance spectrum for this location using the two Z-Profiles. If you wish, save the radiance spectrum in one new plot window and the reflectance spectrum in a second new plot window.

5. Now extract radiance and apparent reflectance spectra for the following locations and visually compare.

<table>
<thead>
<tr>
<th>Location Name</th>
<th>Sample (with offset)</th>
<th>Line (with offset)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stonewall Playa</td>
<td>590</td>
<td>570</td>
</tr>
<tr>
<td>Varnished Tuff</td>
<td>435</td>
<td>555</td>
</tr>
<tr>
<td>Silica Cap</td>
<td>494</td>
<td>514</td>
</tr>
<tr>
<td>Opalite Zone with Alunite</td>
<td>531</td>
<td>541</td>
</tr>
<tr>
<td>Strongly Argillized Zone with Kaolinite</td>
<td>502</td>
<td>589</td>
</tr>
<tr>
<td>Buddingtonite Zone</td>
<td>448</td>
<td>505</td>
</tr>
<tr>
<td>Calcite</td>
<td>260</td>
<td>613</td>
</tr>
</tbody>
</table>

**Note**

An alternate method for getting linked spectral profiles simultaneously from two or more images is to select **Tools** → **Profiles** → **Additional Z Profile** and choose additional datasets for extraction of profiles.

6. Select **Options** → **Stack Data** to offset data vertically for comparison.
7. Load the corresponding spectral library spectra into the apparent reflectance plot window for direct comparison of image apparent reflectance spectra (Figure 12-10) with laboratory spectra.

Figure 12-10: ATREM Apparent Reflectance Spectra.

Close the Windows

When you are finished with this section, you can close all of the plot windows by choosing **Windows → Close All Plot Windows**. Then you can close all of the image displays by choosing **Windows → Close all Displays**.
Compare Atmospheric Corrections

Background: Atmospheric Correction

This section of the tutorial compares several image apparent reflectance spectra. You will use a spectral library of apparent reflectance spectra generated using ENVI’s Flat Field Correction, Internal Average Relative Reflectance (IARR) Correction, and Empirical Line Correction functions to compare the characteristics of the various calibration methodologies. The calibration techniques used are briefly described below.

Flat Field Correction

The Flat Field Correction technique is used to normalize images to an area of known “flat” reflectance (Goetz and Srivastava, 1985; Roberts et al., 1986). The method requires that you locate a large, spectrally flat, spectrally uniform area in the AVIRIS data, usually defined as a Region of Interest (ROI). The radiance spectrum from this area is assumed to be composed of primarily atmospheric effects and the solar spectrum. The average AVIRIS radiance spectrum from the ROI is used as the reference spectrum, which is then divided into the spectrum at each pixel of the image. The result is apparent reflectance data that can be compared with laboratory spectra.

Internal Average Relative Reflectance (IARR)

The IARR calibration technique is used to normalize images to a scene average spectrum. This is particularly effective for reducing imaging spectrometer data to relative reflectance in an area where no ground measurements exist and little is known about the scene (Kruse et al., 1985; Kruse, 1988). It works best for arid areas with no vegetation. The IARR calibration is performed by calculating an average spectrum for the entire AVIRIS scene and using this as the reference spectrum. Apparent reflectance is calculated for each pixel of the image by dividing the reference spectrum into the spectrum for each pixel.

Empirical Line Calibration

The Empirical Line correction technique is used to force image data to match selected field reflectance spectra (Roberts et al., 1985; Conel et al., 1987; Kruse et al., 1990). This method requires ground measurements and/or knowledge. Two or more ground targets are identified and reflectance is measured in the field. Usually the targets consist of at least one light and one dark area. The same two targets are identified in the AVIRIS images and average spectra are extracted for Regions of
Interest. A linear regression is calculated between the field reflectance spectra and the image radiance spectra to determine a linear transform from radiance to reflectance for each band of the AVIRIS data set. Gains and offsets calculated in the regression are applied to the radiance spectra for each pixel to produce apparent reflectance on a pixel-by-pixel basis.

**Continue or Restart ENVI and Select Spectral Library of Calibration Results Spectra**

1. If you have quit ENVI and IDL, restart ENVI and select **Spectral → Spectral Libraries → Spectral Library Viewer**.
   
   The **Spectral Library Input File** dialog will appear to allow selection of a spectral library.

2. Click **Open File** at the bottom center of the dialog to start a standard file selection dialog.

3. Navigate to the `c95avsub` subdirectory of the `envidata` directory on the **ENVI Tutorial and Data CD No. 2**, and select the file `cup95cal.sli`. This is the spectral library containing the results from the various calibration methods.

4. In the **Spectral Library Input File** dialog, select the open library file name and click **OK**.

   The **Spectral Library Viewer** will appear with a list of the available spectra (**Figure 12-11**).

**Select Atmospherically Corrected Spectra from Spectral Library**

1. Select the ATREM, Flat Field, IARR, and Empirical Line corrected spectra for the mineral Alunite.

   The spectra are plotted in a **Spectral Library Viewer** plot (**Figure 12-12**). Visually compare the various calibrations and note and compare their characteristics.

2. Attempt to explain some of the differences in terms of the correction methodology used (see the above brief descriptions of the various methods).
3. When finished, select **Options → Clear Plots** in the menu bar at the top of the **Spectral Library Viewer** to clear the spectra.

![Spectral Library Viewer](image)

*Figure 12-11: The Spectral Library Viewer dialog showing spectra from various calibrations.*

**Compare Corrected Spectra**

Repeat the procedure for the minerals kaolinite, buddingtonite, calcite, and silica. What general conclusions can you draw about the quality of the different calibration procedures?

You can also compare the laboratory spectra for these minerals to the AVIRIS spectra by opening the *jpl1.sli* or the *usgs_sli.dat* spectral libraries, plotting
the corresponding spectra, and dragging and dropping into the Spectral Library Viewer plot for direct comparison.

![Spectral Library Plots](image)

**Figure 12-12: Comparison of Apparent Reflectance Spectra.**

**Optional: Browse Corrected Data Files**

The corrected data files for all of the different corrections are available for spectral browsing if desired. All files have been converted to integer format by multiplying the reflectance values by 1000 because of disk space considerations. Values of 1000 in the data indicate apparent reflectances of 1.0.
1. Open and load the files listed in the table below if desired.

<table>
<thead>
<tr>
<th>File Type</th>
<th>File Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATREM</td>
<td>cup95_at.int</td>
</tr>
<tr>
<td>Flat Field</td>
<td>cup95_ff.int</td>
</tr>
<tr>
<td>IARR</td>
<td>cup95_ia.int</td>
</tr>
<tr>
<td>Emp. Line</td>
<td>cup95_el.int</td>
</tr>
</tbody>
</table>

2. Use the Z-profiling and multiple linked images to compare apparent reflectance spectra for specific areas of interest.

3. After comparison of all of the correction methods for a variety of minerals, which calibration method(s) best reproduce(s) the laboratory spectra for all minerals? Is there one best calibration method?

**End the ENVI Session**

This concludes the Tutorial. You can quit your ENVI session by selecting **File → Exit (Quit on UNIX)** on the ENVI main menu, then click **OK** to exit IDL. If you are using ENVI RT, quitting ENVI will take you back to your operating system.

**References**


CSES (Center for the Study of Earth from Space), 1992, Atmospheric REMoval Program (ATREM), version 1.1, University of Colorado, Boulder, 24 p.


Tutorial 13: Basic Hyperspectral Analysis

The following topics are covered in this tutorial:

Overview of This Tutorial ............. 290  References ......................... 307
Overview of This Tutorial

This tutorial is designed to introduce you to the concepts of Spectral Libraries, Region of Interest (ROI) extraction of spectra, Directed Color composites, and to the use of 2-D scatter plots for simple classification. We will use 1995 Airborne Visible/Infrared Imaging Spectrometer (AVIRIS) apparent reflectance data of Cuprite, Nevada, USA, calibrated using the ATREM atmospheric modeling software. The subsetted data cover the 1.99 to 2.48 µm range in 50 spectral bands approximately 10 nm wide. You will extract ROIs for specific minerals, compare them to library spectra, and design RGB color composites to best display the spectral information. You will also use 2-D scatter plots to locate unique pixels, interrogate the data distribution, and perform simple classification.

Files Used in This Tutorial

**CD-ROM:** *ENVI Tutorial and Data CD No. 2*

**Path:**  envidata/c95avsub

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>cup95_at.int</td>
<td>Cuprite ATREM calibrated reflectance data. 50 bands (integer)</td>
</tr>
<tr>
<td>cup95_at.hdr</td>
<td>ENVI Header for above</td>
</tr>
<tr>
<td>jpl1sli.dat</td>
<td>JPL Spectral Library in ENVI format</td>
</tr>
<tr>
<td>jpl1sli.hdr</td>
<td>ENVI Header for above</td>
</tr>
<tr>
<td>usgs_min.sli</td>
<td>USGS Spectral Library in ENVI format</td>
</tr>
<tr>
<td>usgs_min.hdr</td>
<td>ENVI Header for above</td>
</tr>
<tr>
<td>cup95_av.roi</td>
<td>Saved ROI locations.</td>
</tr>
</tbody>
</table>

**Note**

The files listed are required to run this exercise. Selected data files have been converted from floating-point to integer format by multiplying by 1000 to conserve disk space. Data values of 1000 represent apparent reflectances of 1.0.
Spectral Libraries / Reflectance Spectra

This portion of the tutorial is designed to familiarize you with Spectral Libraries, browsing and extraction of image reflectance spectra, Region of Interest (ROI) definition in ENVI, and directed design of color composite images for spectral discrimination.

**Start ENVI and Load AVIRIS data**

Before attempting to start the program, ensure that ENVI is properly installed as described in the installation guide.

- To open ENVI on UNIX, enter `envi` at the UNIX command line.
- To open ENVI on Windows or Macintosh, double-click on the ENVI icon.

The ENVI main menu appears when the program has successfully loaded and executed.

1. On the ENVI main menu, select **File → Open Image File** and navigate to the `envidata/c95avsub` directory on the *ENVI Tutorial and Data CD No. 2*.
2. Choose `cup95_at.int` as the input file name and click **Open**. The **Available Bands List** dialog will appear, listing the 50 spectral band names.

**Display a Grayscale Image**

1. In the **Available Bands List** dialog, select **Band 193 (2.2008 μm)**.
2. Click the **Gray Scale** radio button and click **Load Band**. An ENVI image display containing the selected band will appear.
3. From the Main Image window menu, select **Tools → Profiles → Z Profile (Spectrum)** to extract an apparent reflectance spectrum.
Browse Image Spectra and Compare to Spectral Library

1. Move the Zoom window indicator box around the image while looking at the #1 Spectral Profile window to browse through image apparent reflectance spectra.

2. In the Main Image window, drag the box by grabbing and dragging with the left mouse button or click the middle mouse button to center the Zoom Indicator box on the selected pixel.

3. Compare apparent reflectance spectra from the image to selected library reflectance spectra.

   ENVI includes several spectral libraries. For the purposes of this exercise, you will use the JPL Spectral Library (Groves et al., 1992) and the USGS Spectral Library (Clarke et al., 1993).


5. In the Spectral Library Input File dialog, click Open File, select jpl1.sli from the spec_lib/jpl_lib subdirectory, and click OK.

6. Click on jpl1.sli in the Select Input File field and click OK.

7. In the Spectral Library Viewer dialog, select Options → Edit (x, y) Scale Factors, enter a value of 1000 into the Y Data Multiplier field to match the image apparent reflectance range (0 – 1000), and click OK.

8. Plot the following spectra by selecting the spectra names in the Spectral Library Viewer dialog:

   • ALUNITE SO-4A
   • BUDDINGTONITE FELDS TS-11A
   • CALCITE C-3D
   • KAOLINITNE WELL ORDERED PS-1A

The following plot is produced:
9. Customize the plot by selecting **Edit → Plot Parameters** from the plot window menu. In the **Plot Parameters** dialog, do the following:
   - Reduce the **Charsize** to 0.50.
   - Select the **X-Axis** radio button, and adjust the **Range** to 1.90 to 2.45.
   - With the **X-Axis** radio button selected, change the **Margin** fields until the X margins are as desired.
   - Select the **Y-Axis** radio button, and change the **Axis Title** to “Reflectance”.
   - With the **Y-Axis** radio button selected, change the **Margin** fields until the Y margins are as desired.
   - Click **Apply** then **Cancel**.

10. To display a legend of the spectra names, right click in the plot window. Drag the plot window to the desired size to accommodate the spectra names.

11. In the plot window, offset the plot data by selecting **Options → Stack Data**. The plot now looks like the following:

---

**Figure 13-1: Library Spectra**
12. Right click in the #1 Spectral Profile window to display a legend of X and Y pixel locations.

13. In the #1 Spectral Profile window, select **Options → New Window: Blank** to open a new plot window. Position the #1 Spectral Profile window and the new plot window so you can see both windows.

14. From the Main Image window menu, select **Tools → Pixel Locator**. We will use the **Pixel Locator** dialog to locate the exact pixels for the following locations:

<table>
<thead>
<tr>
<th>Location Name</th>
<th>Sample (with offset)</th>
<th>Line (with offset)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stonewall Playa</td>
<td>590</td>
<td>570</td>
</tr>
<tr>
<td>Varnished Tuff</td>
<td>435</td>
<td>555</td>
</tr>
<tr>
<td>Silica Cap</td>
<td>494</td>
<td>514</td>
</tr>
<tr>
<td>Opalite Zone with Alunite</td>
<td>531</td>
<td>541</td>
</tr>
<tr>
<td>Strongly Argillized Zone with Kaolinite</td>
<td>502</td>
<td>589</td>
</tr>
<tr>
<td>Buddington Zone</td>
<td>448</td>
<td>505</td>
</tr>
</tbody>
</table>
15. In the **Pixel Locator** dialog, enter 590 in the **Sample** field and enter 570 in the **Pixel** field to center the Zoom Indicator on pixel 590, 570 (Stonewall Playa). Click **Apply** to move to that location. The #1 Spectral Profile window updates to show the spectrum for this pixel. The legend should read “X:590 Y:570”.

16. Right click in the new plot window to display a legend of X and Y pixel locations.

17. In the #1 Spectral Profile window, click and hold the left mouse button on the legend item “X:590 Y:570”. Drag and drop this spectrum into the new plot window.

18. Repeat the previous steps for each site in the above table until the new plot window contains all 7 spectra.

19. In the new plot window, select **Options → Stack Data**. The new plot window should now look like the following:

![Image of ENVI Plot Window with stacked spectra]

*Figure 13-3: Individual ATREM Image Apparent Reflectance Spectra*

20. Visually compare these spectra to the library spectra extracted previously. Note the similarity of shape and absorption features between the laboratory spectra and the individual image apparent reflectance spectra.
Based on these similarities, we conclude that the image spectra similar to the alunite, buddingtonite, calcite, and kaolinite laboratory spectra represent pixels predominantly of the above minerals.

21. Drag and drop spectra from the Spectral Library Plots window into the #1 Spectral Profile window for direct comparison.

Identify Spectra

Use the Spectral Analyst™ to identify spectra:

ENVI has a spectral matching tool that provides a score with respect to the library spectra. The spectral analyst uses several methods to produce a score between 0 and 1, with 1 equaling a perfect match.

1. Select Spectral → Spectral Analyst from the ENVI main menu.
2. Click on the Open Spec Lib button at the bottom of the Spectral Analyst Input Spectral Library dialog.
3. Navigate to the usgs_min spectral library directory, select the usgs_min.sli spectral library, and click Open.
4. The file usgs_min.sli should now appear in the Spectral Analyst Input Spectral Library dialog. Select this file and click OK.
5. In the Edit Identify Methods Weighting dialog, click OK.
6. From the Main Image window menu, select Tools → Profiles → Z Profile (Spectrum). Right click in the #1 Spectral Profile window to display the legend of spectra.
7. From the Main Image window menu, select Tools → Pixel Locator.
8. Enter the pixel 502, 589 in the Pixel Locator dialog and click Apply.
10. In the Edit Identify Methods Weighting dialog, enter 0.33 in each of the Weight fields click OK. The different matching methods are described in the ENVI 3.5 User’s Guide.
11. In the Spectral Analyst dialog, click Apply. If more than one spectrum is displayed in the #1 Spectral Profile window, a list of spectra will appear. If this
list appears, select the spectrum for pixel 502, 589. The **Spectral Analyst** dialog shows the following:

![Spectral Analyst dialog](image)

**Figure 13-4:** The Spectral Analyst dialog, showing a high match to the mineral kaolinite for pixel 502, 589.

The Spectral Analyst scores the unknown spectrum against the library. The previous figure shows an identification for pixel 502, 589. Note the high number of kaolinite spectra at the top of the list. This, and the relatively high scores, indicates a high likelihood of kaolinite.

12. Now double click on the first spectrum name in the list. This will plot the unknown and the library spectrum in the same plot for comparison, as shown in the following figure:
13. Use the Spectral Analyst and the comparison plots to verify the mineralogy for the image spectra you have extracted. When you have identified several minerals, continue with the next section.

14. Optionally, compare spectra from the USGS Spectral Library `usgs_min.sli` with image spectra and the JPL Spectral library.

**Close Windows and Plots**


2. Close all of the previous plot windows by selecting Window → Close All Plot Windows.
Define Regions of Interest

Regions of Interest (ROIs) are used to extract statistics and average spectra from groups of pixels. You can define as many ROIs as you wish in any displayed image. Select **Overlay → Region of Interest** from the Main Image window menu to start the ROI Tool.

Create New Region of Interest

1. Click the left mouse button in the image.
2. Draw the ROI by clicking the left mouse button at the axes of a polygon, or draw continuously by clicking and dragging the left mouse button.
3. Complete the ROI by clicking the right mouse button to close the polygon and the right mouse button a second time to lock-in the ROI.
4. Click on the **Stats** button to calculate the statistics and plot a mean spectrum (white), the first standard deviation above and below the mean spectrum (green), and the Min/Max envelope containing all of the spectra in the ROI (red).
5. Select **File → Cancel** in the **File Statistics Report** dialog, and select **File → Cancel** in the Avg Spectrum plot.
6. Click **Delete** in the **ROI Tool** dialog to delete the selected ROI.
Load Previously Saved Regions of Interest

1. From the **ROI Tool** dialog menu, select **File → Restore ROIs**.

2. In the **Enter ROI Filename** dialog, navigate to the `envidata/c95avsub` directory, select the file `cup95_av.roi`, and click **Open**. Regions previously defined for known areas of specific minerals will be listed in an ENVI message dialog, and loaded into the **ROI Tool** dialog as shown in the following figure:

   ![ROI Tool showing restored regions](image)

   *Figure 13-7: ROI Tool showing restored regions*

3. Select the **Off** radio button at the top of the **ROI Tool** dialog to enable pixel positioning within the Main Image display.

4. Start a Z-Profile window by selecting **Tools → Profiles → Z-Profile (Spectrum)** in the Main Image window.

5. Move the current pixel position/cursor location into each ROI by clicking the middle mouse button on a pixel in the ROI.

6. Click on different pixels in the ROI to move the cursor position and display a new spectral profile in the Spectral Profile window.

   Note that the y-axis plot range is automatically rescaled to match the spectral profile for each new ROI. Examine the spectral variability within each ROI.

**Extract Mean Spectra from ROIs**

1. Select an ROI name in the **ROI Tool** dialog, then click **Stats** to extract statistics and a spectral plot of the selected ROI.
2. Examine the spectral variability of each ROI by comparing the mean spectrum (white) with the 1st standard deviation spectra (green above and below the mean) and the envelope spectra (red above and below the mean).

3. Repeat for each ROI.

4. If you wish, load the corresponding library signatures from the jpl1.sli library into the plot window for direct comparison/identification. Don’t forget to use a Y-Scaling Factor of 1000 when loading the library spectra.

5. When you have finished, close all of the File Statistics Report dialogs and plot windows.

6. In the ROI Tool dialog, select Options → Mean for All Regions to plot the average spectrum for each ROI in the same plot window.

7. In the plot window, select Options → Stack Data to offset spectra for comparison, as shown in the following figure:

![ROI Mean ATREM Image Apparent Reflectance Spectra](image)

**Figure 13-8: ROI Mean ATREM Image Apparent Reflectance Spectra**

8. Compare the spectral features of each spectrum and note unique characteristics that might allow identification.

9. If desired, load the corresponding spectral library signatures from the jpl1.sli library for direct comparison of image apparent reflectance spectra.
with laboratory spectra. Don’t forget to use a Y Factor of 1000 when loading the library spectra.

10. Optionally, compare spectra from the USGS Spectral Library usgs_min.sli with image spectra and the JPL Spectral library.

**Discriminate Mineralogy**

Design color images to discriminate mineralogy:

1. In the Available Bands List dialog, select the RGB Color radio button, and click sequentially on Band 183, Band 193, and Band 207.

2. Click Load RGB to load the color image into the current image display.

3. In the Main Image window, select Tools → Profiles → Z-Profile (Spectrum). Note that the positions of the bands used to make the RGB color composite image are marked in the Z-Profile with vertical red, green, and blue lines.

4. In the ROI Tool dialog, select the Off radio button and use the Z profiler accessed through the Main Image window to browse spectra at or near your ROI locations from above.

   Note where the selected RGB bands fall with respect to spectral features in the previously displayed mean spectra and how the spectral features affect the color observed in the image.

5. Change the plot bars in the spectral profile to the desired bands by clicking and dragging the plot bars with the left mouse button.

   **Note**
   
   (Note: one way to enhance specific materials is by centering one color bar in an absorption feature and the other two on opposite shoulders of the feature.)

6. Double click the left mouse button within the Z Profile plot window to load the new bands into the display window.

After inspecting a few sites, you should begin to understand how the color composite colors correspond with the spectral signature. For instance, the alunitic regions appear magenta in the RGB composite because the green band is within the alunite absorption feature, giving a low green value, while the red and blue bands are of almost equal reflectance. The combination of red and blue results in a magenta color for pixels containing alunite.

Based on the above results, try these exercises:
1. Predict how certain spectra will look, given a particular pixel’s color in the RGB image.
2. Explain the colors of the training sites, in terms of their spectral features.
3. Design and test specific RGB band selections that maximize your ability to map certain minerals, like kaolinite and calcite.

Close Plot Windows and ROI Controls

1. Close all open plot windows by selecting **Window → Close All Plot Windows**.
2. Close the **ROI Tool** dialog by selecting **File → Cancel**.

2-D Scatter Plots

Examine 2-D Scatter Plots

1. In the Main Image window, select **Tools → 2-D Scatter Plots** to start a 2-D scatter plot for the apparent reflectance image.
2. Select band 193 in the **Choose Band X** list and select band 207 in the **Choose Band Y** list.
3. Click **OK**.

The following scatter plot is displayed with a plot of the X vs. Y apparent reflectance values:

*Figure 13-9: Scatter Plot of bands 193 and 207 (ATREM Apparent Reflectance)*
Density Slice the Scatter Plot

1. From the scatter plot menu, select Options → Density On to automatically density-slice the scatter plot. The colors show the frequency of occurrence of specific apparent reflectance combinations for the two bands being scatter plotted. Purple is the lowest frequency, progressing through the colors blue, green, yellow, to red as the highest frequency of occurrence.

2. From the scatter plot menu, select Options → Density Off to turn off the color slice.

Scatter Plot Dancing Pixels

1. In the Main Image window, click and drag the left mouse button to toggle “Dancing Pixels” in the scatter plot. The red pixels in the scatter plot correspond to those pixels within a 10 x 10 box around the cursor in the Main Image window.

2. Try to predict the locations of certain image colors in the scatter plot, then check them. Notice the shape of the red sub-scatter plot of dancing pixels.

3. Change the box-cursor size in the scatter plot window by selecting Options → Set Patch Size, and observe the difference.

Image Dancing Pixels

1. In the scatter plot window, click and drag the middle mouse button over any portion of the white scatter plot to toggle “Dancing Pixels” in the Main Image window. The red pixels in the image correspond to those pixels within a 10 x 10 box around the cursor in the scatter plot window. Note the spatial distribution and coherency of the selected pixels.

2. Change the box-cursor size in the scatter plot window by selecting Options → Set Patch Size, and observe the difference.

Scatter Plots Linked to a Spectral Profile

1. From the scatter plot window menu, select Options → Z Profile, select an input file from which to extract the spectral profile, and click OK. This starts a blank ENVI spectral profile linked to the 2-D scatter plot.

2. Position the cursor in the 2-D scatter plot and click the right mouse button to extract the spectrum for the corresponding spatial pixel with those scatter plot characteristics.

3. Compare spectra from the different parts of the scatter plot and note what sorts of spectra appear at the “points” of the plot versus the center of the plot.
**Scatter Plot ROIs**

The scatter plot tool can also be used as a quick classifier.

1. Click the left mouse button in the scatter plot to select the first point of a Region of Interest (ROI).
2. Draw an ROI polygon in the scatter plot by selecting the desired line segments using the left mouse button.
3. Click the right mouse button to close the polygon. Image pixels with the two-band characteristics outlined by the polygon will be color-coded red in the Main Image window.
4. Choose another color from the Class pulldown menu in the scatter plot window.
5. Draw another polygon and the corresponding pixels will be highlighted in the selected color on the image.
6. To remove a class, select **Options → Clear Class**. You can also clear the current class by clicking the middle mouse button outside (below) the plot axes.
7. Use the 2-D scatter plot tool to work backwards from the scatter plot to see where certain pixels occur in the image.
8. Classes can be converted to ROIs to act as training sets for classification using all of the bands by selecting **Options → Export Class** or **Export All** from the scatter plot menu bar. ROIs exported in this fashion will appear in the ROI Tool dialog and be available for subsequent supervised classification. They can also be converted to a classification image by choosing **Classification → Create Class Image** from ROIs from the ENVI main menu.
9. Select **Options → Clear All** in the scatter plot to clear both scatter plot and image.

**Image ROIs**

The scatter plot tool also functions as a simple classifier from the image.

1. Choose **Options → Image ROI** in the scatter plot.
2. Draw polygons in the Main Image window using the left mouse button to draw lines and the right button to close and lock-in the polygon. They will be mapped to the scatter plot and highlighted in the currently selected color. After the pixels are highlighted on the scatter plot, all of the matching pixels in the image will be inverse-mapped to the Main Image window and highlighted in
the same color, as though you had drawn the scatter plot region yourself. This is the simplest form of 2-band classification, but it is still a powerful tool.

3. Draw a few image regions and note the correspondence between image color and scatter plot characteristics.

**Scatter Plots and Spectral Mixing**

Can you explain the overall diagonal shape of the scatter plot in terms of spectral mixing? Where do the purest pixels in the image fall on the scatter plot? Are there any secondary “projections” or “points” on the scatter plot?

1. Choose some other band combinations for scatter-plotting by selecting Options → Change Bands in the scatter plot. Try at least one pair of adjacent bands and other pairs that are far apart spectrally.

How do the scatter plots change shape with different band combinations? Can you describe the $n$-Dimensional “shape” of the data cloud?

**End the ENVI Session**

This concludes the tutorial. You can quit your ENVI session by selecting File → Exit (Quit on UNIX) from the ENVI main menu, then click Yes. If you are using ENVI RT, quitting ENVI will take you back to your operating system.
References


Clark, R.N., T.V.V. King, M. Klejwa, G. Swayze, and N. Vergo, 1990, High Spectral Resolution Reflectance Spectroscopy of Minerals: J. Geophys Res. 95, 12653-12680.

Grove, C. I., Hook, S. J., and Paylor, E. D., 1992, Laboratory reflectance spectra of 160 minerals, 0.4 to 2.5 Micrometers: JPL Publication 92-2.

