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Introducing ENVI

ENVI (the Environment for Visualizing Images) is a state-of-the-art image
processing system designed to provide comprehensive analysis of satellite and
aircraft remote sensing data. It provides a powerful, innovative, and user-friendly
environment to display and analyze images of any size and data type on a wide range
of computing platforms.

With its combined file- and band-based approach to image processing, ENVI allows
you to work with entire image files, individual bands, or both. When an input file is
opened, each spectral band becomes available to all system functions. With multiple
input files open, you can easily select bands from different files to be processed
together. ENVI also includes tools to extract spectra, use spectral libraries, and to
analyze high spectral resolution image datasets such as AVIRIS, GERIS, and
GEOSCAN and HyMap. In addition to its world-class hyperspectral analysis tools,
ENVI provides specialized capabilities for analysis of advanced SAR data sets such
as JPL’s SIR-C, AIRSAR, and TOPSAR.

ENVI is written entirely in IDL, the Interactive Data Language. IDL is a powerful,
array-based, structured programming language that provides integrated image
processing and display capabilities and an easy to use GUI toolkit. ENVI is available
as ENVI (offering full ENVI command line capabilities) and ENVI RT (the runtime
version of ENVI). The only difference between ENVI and ENVI RT is that ENVI RT
does not provide user access to the underlying IDL environment. You will not be able
to complete the User Function tutorial provided here if you are running ENVI RT.
Introducing ENVI ENVI Tutorials
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About These Tutorials

This document contains hands-on tutorials designed to help you become familiar
with ENVI’s features and capabilities. Each tutorial is formatted to clearly direct you
through required tasks.

Within each tutorial, the tasks you will perform have been broken down into
numbered steps, which appear in bold print. Optional steps and single-step activities
are preceded by a text bullet. The following formatting conventions will help you
identify the type of action required within the various steps:

• The titles of pull-down menu items appear bold. They are connected in order
of selection by an → (arrow). For example, select File → Open Image File.

• Dialog box names are bolded.

• Button menus, found in many dialogs, are bolded; however, items selected
from the pull-down menu are italicized like other pull-down menu selections.

• Text box names, radio buttons, spin box titles, and other buttons also appear in
bold.

• Filenames and paths appear in courier font. For example, open the file
cuptm_rf.img.

At the beginning of each tutorial, you will find a detailed outline of the topics covered
in that tutorial. Each tutorial begins with an overview and background explaining the
history and application of the functions you will be using. Also included are the
names of the files required to complete the tutorial.

Finally, at the end of each tutorial, references are provided for further exploration.

ENVI Quick Start

This tutorial, which is also distributed as a small booklet with the ENVI CD-ROM is
designed to get you quickly into the basics of ENVI. It allows you to start ENVI, load
either a gray scale or color image, and apply contrast stretches. It demonstrates image
animation (movies) and 2-dimensional scatterplots to help users determine the
spectral variability of their data. Regions of interest (ROI) selection instructions
allow new users to quickly move into multispectral classification. ENVI’s dynamic
overlay capabilities are used to compare color composites and classified images.
Finally, the tutorial provides a quick introduction to ENVI’s vector overlays and GIS
analysis capabilities.
ENVI Tutorials About These Tutorials
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ENVI Tutorial #1: Introduction to ENVI (Canon City, Colorado
Landsat TM)

This tutorial provides basic information about ENVI and some suggestions for your
initial investigations of the software. Landsat TM data of Canon City, Colorado are
used. This tutorial is designed to introduce first-time ENVI users to the basic
concepts of the package and to explore some of its key features. It assumes that you
are already familiar with general image-processing concepts.

ENVI Tutorial #2: Introduction to Panchromatic Data and
Basic Vector Overlays (Enfidaville, Tunisia SPOT and DXF)

This tutorial provides an introduction to using ENVI with Panchromatic (SPOT) data,
including display, contrast enhancement, basic information about ENVI and some
suggestions for your initial investigations of the software. It is designed to introduce
first-time ENVI users to the basic concepts of the package and to explore some of its
key features. It assumes that you are already familiar with general image-processing
concepts. This dataset is a SPOT Panchromatic image and corresponding DXF files
of Enfidaville, Tunisia, courtesy of Research Systems International France. These
data are Copyright CNES-Spot Image and IGN France.

ENVI Tutorial #3: Multispectral Classification (Canon City,
Colorado, Landsat TM)

This tutorial leads you through typical multispectral classification procedures using
Landsat TM data from Canon City, Colorado. Results of both unsupervised and
supervised classifications are examined and post classification processing including
clump, sieve, combine classes, and accuracy assessment are discussed. It is assumed
that you are already generally familiar with multispectral classification techniques.

ENVI Tutorial #4: Image Georeferencing and Registration
(Boulder, Colorado TM and SPOT)

This tutorial provides basic information about Georeferenced images in ENVI, and
Image-to-Image and Image-to-Map Registration using ENVI. Landsat TM and SPOT
data from Boulder, Colorado are used. The tutorial covers step-by-step procedures for
successful registration, discusses how to make image-maps using ENVI and
illustrates the use of multi-resolution data for image sharpening. The exercises are
designed to provide a starting point to users trying to conduct image registration.
They assume that you are already familiar with general image-registration and
resampling concepts.
About These Tutorials ENVI Tutorials
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ENVI Tutorial #5: Georeferencing Images Using Input
Geometry (Cuprite, Nevada HyMap)

Data from many sensors now comes with detailed acquisition (platform geometry)
information that allows model-based geometric rectification and map registration.
This tutorial provides basic information about Georeferenced images in ENVI and
Model-Based Geometric Correction using image input geometry within ENVI. It
discusses required data characteristics and covers step-by-step procedures for
successful registration. It assumes that you are already familiar with general image-
registration and resampling concepts. 1999 HyMap data of Cuprite, Nevada, used for
the tutorial are copyright 1999 Analytical Imaging and Geophysics (AIG) and
HyVista Corporation (All Rights Reserved), and may not be redistributed without
explicit permission from AIG (info@aigllc.com).

ENVI Tutorial #6: Orthorectification Using ENVI (Boulder,
Colorado Air Photos and SPOT)

ENVI provides basic tools for orthorectification of aerial photographs and SPOT
imagery. This tutorial describes the procedures to be followed and results of the
orthorectification process. Orthorectification is demonstrated using aerial
photographs from Boulder, Colorado and SPOT images. Because these data sets are
quite large, results only are shown, and no data are provided.

ENVI Tutorial #7: Mosaicking Using ENVI (Death Valley,
Nevada AVIRIS)

This tutorial is designed to give you a working knowledge of ENVI's image
mosaicking capabilities. It uses AVIRIS data from Death Valley, Nevada. Pixel-
based mosaicking demonstrates ENVI’s virtual mosaic concept and easy-to-use
mosaic tool. Georeferenced mosaicking shows ENVI’s automatic placement of map-
referenced images and cutline feathering. The exercises assume that you are already
generally familiar with mosaicking techniques.

ENVI Tutorial #8: Landsat TM and SPOT Data Fusion Using
ENVI (London, UK, TM and SPOT, Brest France, SPOT)

This tutorial is designed to demonstrate selected ENVI data fusion capabilities. For
additional data fusion details, please see the ENVI User's Guide or ENVI On-Line-
Help. Two examples are provided for this tutorial. The first uses Landsat TM and
SPOT data of London, UK (Data Courtesy of RSI International UK, Ltd). The TM
data are Copyright, European Space Agency, and distributed by Eurimage/NRSC.
ENVI Tutorials About These Tutorials
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The SPOT data are Copyright CNES, 1994, distributed by Spot Image/NRSC. Both
datasets are used with permission (NRSC, 1999). The second example uses SPOT XS
and Panchromatic data of Brest, France (Data Courtesy of RSI International, France,
Copyright CNES-Spot image., 1998. Used with permission of SPOT, 1999. These
data may not be used for commercial purposes).

ENVI Tutorial #9: Landsat TM and SAR Data Fusion Using
ENVI (Rome, Italy, TM and ERS)

This tutorial is designed to demonstrate selected ENVI data fusion capabilities.
Landsat TM data and ERS-2 SAR data of Rome, Italy are co-registered using ENVI
image-to-image registration. A Hue/Saturation/Intensity color transform is used to
fuse the two datasets and the fused data are compared to the individual datasets to
determine the advantages and disadvantages of data fusion. For additional data fusion
details, please see the ENVI User's Guide or ENVI Online Help. ERS and
LANDSAT images used in this tutorial are provided courtesy of the European
Space Agency (ESA) and Eurimage (used with permission) and may not be
redistributed without explicit permission from these organizations.

ENVI Tutorial #10: Vector Overlay and GIS Analysis
(Gonzales, California Space Imaging Data and Shape Files)

This tutorial introduces ENVI’s vector overlay and GIS analysis capabilities. Stand-
alone GIS analysis is demonstrated using ESRI-provided GIS data, including input of
ArcView shapefiles and associated .dbf attribute files, display in vector windows,
viewing/editing of attribute data, point-and-click spatial query, and math/logical
query operations. Part 2 of this tutorial demonstrates use of ENVI’s combined image
display/vector overlay and analysis capabilities using a simulated 4-meter resolution
Space Imaging/EOSAT multispectral dataset of Gonzales, California, USA. Data
courtesy of Space Imaging/EOSAT. The exercise includes cursor tracking with
attribute information, point-and-click query, and heads-up digitizing and vector layer
editing. Also demonstrated are generation of new vector layers using math/logical
query operations and raster-to-vector conversion of ENVI Regions of Interest (ROI)
and/or classification images. Finally, the exercise demonstrates ENVI’s vector-to-
raster conversion, using vector query results to generate ROIs for extraction of image
statistics and area calculations. It is assumed that the user already has a basic grasp of
GIS analysis concepts.
About These Tutorials ENVI Tutorials
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ENVI Tutorial #11: Map Composition Using ENVI
(Yellowstone, Wyoming, TM)

This tutorial is designed to give you a working knowledge of ENVI's map
composition capabilities. It uses Landsat TM data of Yellowstone National Park,
Wyoming, USA to show creation of an image-map with virtual borders,
latitude/longitude and map coordinate grids, map key and scale, declination diagram,
image insets, and text annotation using ENVI QuickMap.

ENVI Tutorial #12: Introduction to Hyperspectral Data and
Analysis (Cuprite, Nevada AVIRIS)

This tutorial is designed to introduce you to the concepts of Imaging Spectrometry,
hyperspectral images, and to selected spectral processing basics using ENVI. For this
exercise, we use Airborne Visible/Infrared Imaging Spectrometer (AVIRIS) data of
Cuprite, Nevada, USA, to familiarize you with spatial and spectral browsing of
imaging spectrometer data and then compare the results of several reflectance
calibration procedures.

ENVI Tutorial #13: Basic Hyperspectral Analysis (Cuprite,
Nevada AVIRIS)

This tutorial is designed to introduce you to the concepts of Spectral Libraries,
Region of Interest (ROI) extraction of spectra, Directed Color composites, and to the
use of 2-D scatterplots for simple classification. We use 1995 Airborne
Visible/Infrared Imaging Spectrometer (AVIRIS) apparent reflectance data of
Cuprite, Nevada, USA, to extract ROIs for specific minerals, compare them to library
spectra, and design R, G, B color composites to best display the spectral information.
You will also use 2-D scatterplots to locate unique pixels, interrogate the data
distribution, and perform simple classification.

ENVI Tutorial #14: Selected Mapping Methods Using
Hyperspectral Data (Cuprite, Nevada, AVIRIS)

This tutorial is designed to introduce you to advanced concepts and procedures for
analysis of imaging spectrometer data or hyperspectral images. You will use the 1995
Airborne Visible/Infrared Imaging Spectrometer (AVIRIS) data from Cuprite,
Nevada, USA, to investigate the unique properties of hyperspectral data and how
spectral information can be used to identify mineralogy. You will evaluate Effort
polished spectra vs ATREM-calibrated data, and review the Spectral Angle Mapper
classification. You will compare apparent reflectance spectra and continuum-
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removed spectra. You will also compare apparent reflectance images and continuum-
removed images and evaluate Spectral Feature Fitting results.

ENVI Tutorial #15: Advanced Hyperspectral Analysis
(Cuprite, Nevada AVIRIS)

This tutorial is designed to introduce you to additional advanced concepts and
procedures for analysis of imaging spectrometer data or hyperspectral images. You
will use the 1995 AVIRIS data from Cuprite, Nevada, USA, to investigate sub-pixel
properties of hyperspectral data and advanced techniques for identification and
quantification of mineralogy. You will use Effort polished ATREM-calibrated data,
and review matched filter and spectral unmixing results.

ENVI Tutorial #16: Hyperspectral Signatures and Spectral
Resolution (Cuprite, Nevada, TM, GEOSCAN, GER63,
AVIRIS, and HyMap)

This tutorial compares spectral resolution for several different sensors and the effect
of resolution on the ability to discriminate and identify materials with distinct
spectral signatures. The tutorial uses TM, GEOSCAN, GER63, AVIRIS, and HyMap
data from Cuprite, Nevada, USA, for inter-comparison and comparison to materials
from the USGS Spectral library.

ENVI Tutorial #17: Geology Hyperspectral Analysis Case
History (Cuprite, Nevada, HyMap)

This tutorial presents a case history for use of hyperspectral techniques for geologic
analysis using 1999 HyMap data from Cuprite, Nevada, USA. It is designed to be a
self-directed example using ENVI’s complete end-to-end hyperspectral tools to
produce image-derived endmember spectra and image maps. The processing should
be done using the standard ENVI methods (EFFORT → MNF → PPI → n-D
Visualization → Spectral Mapping → GLT Geocorrection). For more detail and
step-by-step procedures on performing such a hyperspectral analysis, please execute
the introductory through advanced ENVI hyperspectral tutorials prior to attempting
this tutorial. 1999 HyMap data of Cuprite, Nevada, used for the tutorial are copyright
1999 Analytical Imaging and Geophysics (AIG) and HyVista Corporation (All
Rights Reserved), and may not be redistributed without explicit permission from AIG
@info.aigllc.com).
About These Tutorials ENVI Tutorials
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ENVI Tutorial #18: Archaeology Hyperspectral Analysis Case
History (Selinunte, Italy MIVIS)

This tutorial presents a case history for use of hyperspectral techniques for
archeological analysis using MIVIS data from Selinunte, Sicily, Italy. It is designed
to be a self-directed example using ENVI’s complete end-to-end hyperspectral tools
to produce image-derived endmember spectra and image maps. The processing
should be done using the standard ENVI methods
(EFFORT → MNF → PPI → n-D Visualization → Spectral Mapping). For more
detail and step-by-step procedures on performing such a hyperspectral analysis,
please execute the introductory through advanced ENVI hyperspectral tutorials prior
to attempting this tutorial. The MIVIS data are courtesy of Research Systems Italia,
S.R.L. and the Italian National Research Council (CNR). Used with permission.

ENVI Tutorial #19: Vegetation Hyperspectral Analysis Case
History (Jasper Ridge, California HyMap)

This tutorial presents a case history for use of hyperspectral techniques for vegetation
analysis using 1999 HyMap data of Jasper Ridge, California, USA. It is designed to
be a self-directed example using ENVI’s complete end-to-end hyperspectral tools to
produce image-derived endmember spectra and image maps. For more detail and
step-by-step procedures on performing such a hyperspectral analysis, please execute
the detailed hyperspectral tutorials in this booklet prior to attempting this tutorial.
1999 HyMap data of Jasper Ridge, California, used for the tutorial are copyright
1999 Analytical Imaging and Geophysics (AIG) and HyVista Corporation (All
Rights Reserved), and may not be redistributed without explicit permission from AIG
(info@aigllc.com).

ENVI Tutorial #20: Near-shore Marine Hyperspectral Case
History (Moffett Field, California AVIRIS)

This tutorial presents a case history for use of hyperspectral techniques for analysis of
near-shore marine environments using 1994 AVIRIS data from Moffett Field,
California, USA. You will run through a complete example using a selection of
ENVI’s available tools to produce image-derived endmember spectra and image
maps.
ENVI Tutorials About These Tutorials
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ENVI Tutorial #21: Multispectral Processing using ENVI’s
Hyperspectral Tools (Bighorn Basin, Wyoming TM)

This tutorial is designed to show you how ENVI's advanced hyperspectral tools can
be used for improved analysis of multispectral data. Landsat TM data from the
Bighorn Basin, Wyoming, USA, are used. You view results from a classical
multispectral analysis approach, and then will run through a complete example using
a selection of ENVI’s available tools to produce image-derived endmember spectra
and image maps. To gain a better understanding of the hyperspectral concepts and
tools, please run the ENVI hyperspectral tutorials.

ENVI Tutorial #22: Introduction to HDF Data and MSI
Processing (Cuprite, Nevada MASTER)

This tutorial is designed to introduce you to HDF data and analysis of Multispectral
Imagery from the MODIS/ASTER Airborne Simulator (MASTER) sensor. The
exercise covers opening and reading HDF-format files, extracting spatial and spectral
subsets and spectra, comparison of spectra to spectral libraries and classical
multispectral processing. For additional details on specific functions, please see the
ENVI 3.5 User’s Guide or the ENVI On-Line help. This MASTER dataset and other
MASTER data are available for purchase from NASA through the EROS Data
Center, Sioux Falls, SD.

ENVI Tutorial #23 Introduction to Long Wave Infrared (LWIR)
Multispectral Data Analysis (Cuprite, Nevada MASTER)

This tutorial is designed to introduce you to analysis of LWIR Multispectral Imagery
from the MODIS/ASTER Airborne Simulator (MASTER) sensor. The exercise
covers opening and reading HDF-format files, extracting spatial and spectral subsets,
examination of LWIR spectra to define key spectral bands, decorrelation stretching
of color composites to enhance LWIR spectral differences, and comparison of SWIR
and LWIR mapping results. For additional details on specific functions, please see
the ENVI 3.5 User’s Guide or the ENVI On-Line help. This MASTER dataset and
other MASTER data are available for purchase from NASA through the EROS Data
Center, Sioux Falls, SD.

ENVI Tutorial #24: SAR Processing and Analysis (Bonn,
Germany RadarSat)

This tutorial is designed to give you a working knowledge of ENVI's basic tools for
processing single-band SAR data (such as RadarSat, ERS-1, JERS-1). A subset of
About These Tutorials ENVI Tutorials
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Radarsat data from Bonn, Germany, are used to demonstrate concepts for processing
SAR with ENVI including image display and contrast stretching, removing speckle
using adaptive filters, density slicing, edge enhancement and image sharpening, data
fusion, and image-map output.

ENVI Tutorial #25: Polarimetric SAR Processing and
Analysis (Death Valley, California SIR-C)

This tutorial demonstrates the use of ENVI’s polarimetric radar data analysis
functions. It uses Spaceborne Imaging Radar-C (SIR-C) data obtained over Death
Valley, California, USA, during the April 1994 mission of the Space Shuttle
Endeavor to demonstrate concepts such as multilooking, image synthesis from
complex scattering matrix data, selection and display of polarizaton and/or multi-
frequency images, slant-to-ground range conversion, adaptive filtering, and texture
analysis.

ENVI Tutorial #26: Analysis of DEMs and TOPSAR
(Tarrawarra, Australia TOPSAR/POLSAR)

This tutorial uses polarimetric SAR data and a Digital Elevation Model (DEM)
generated from JPL’s TOPSAR (interferometric SAR) data for Tarrawarra, Australia.
Data Courtesy of JPL. The exercise demonstrates display and analysis of the SAR
data and of the DEM using standard tools within ENVI. DEM analysis includes gray
scale and color-density-sliced display; generation and overlay of elevation contours,
use of ENVI’s X, Y, and arbitrary profiles (transects) to generate terrain profiles;
generation of slope, aspect, and shaded relief images; and 3-D perspective viewing
and image overlay.

ENVI Tutorial #27: ENVI Topographic Tools (ALPS TM
and DEM)

This tutorial is designed to give you a working knowledge of ENVI's Topographic
Analysis Tools. Data provided include processed TM data and a 25m DEM of an area
in the Swiss Alps. Selected tools reviewed include gray scale and color-density-sliced
display; generation and overlay of elevation contours, use of ENVI’s X, Y, and
arbitrary profiles (transects) to generate terrain profiles; generation of slope, aspect,
and shaded relief images; extraction of Topographic Feature Parameters (peak, ridge,
pass, plane, channel, pit), and 3-D perspective viewing and image overlay. Data
Courtesy of Research Systems International Ltd, UK, Digital Elevation Data ©
Eastern Geo Ltd 1999, Distributed by NPA Group, Edenbridge, Kent, UK, Tel: +44
1732 865023.
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ENVI Tutorial #28: ENVI 3-D Surface View and Fly-through
(Bighorn, Wyoming TM and DEM)

This tutorial is designed to provide a working knowledge of ENVI's 3-D
SurfaceView and Fly-Through capabilities. It covers overlay of a gray scale or color
composite image over a digital elevation model (DEM) as a 3-D Surface View,
interactively changing the 3D visualization, and creating 3D Fly-throughs. There is
also a discussion of the 3D SurfaceView function’s use as an analysis tool. Users
should also be able to produce similar results with their own coregistered image and
digital elevation model (DEM) data.

ENVI Tutorial #29: Introduction to ENVI User Functions

This tutorial provides basic information on programming in ENVI. It covers the
basics for creating user defined band math functions and Plug-in functions, including
creating compound widgets and writing data tiling operations. This tutorial assumes
that you are familiar with the Interactive Data Language (IDL) and understand how
to write functions and procedures in IDL. ENVI RT users cannot program in ENVI,
so only the Band Math portion of this tutorial is applicable to these users.

ENVI Tutorial #30: Introduction to ENVI Plot Functions

This tutorial provides information on how to implement an ENVI Plot Function. This
is a user-defined function called from the Plot Function pull-down menu on any
ENVI plot window. This exercise covers the basics for creating user-defined plot
functions and setting up the ENVI useradd.txt file to enable automatic installation
of the functions in the plot menu structure.This tutorial assumes that you are familiar
with the Interactive Data Language (IDL) and understand how to write functions and
procedures in IDL. ENVI RunTime users cannot program in ENVI, however, the plot
functions provided with this tutorial can be viewed with any text editor and installed
for use with either ENVI or ENVI RunTime.
About These Tutorials ENVI Tutorials
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Tutorial Data Files

Data files for these tutorials are contained on two CD-ROMs in subdirectories of the
envidata directory. Because the data sets are quite large— more than 1 GB of data
are included—you may wish to load the files into ENVI directly from the CD-ROM
rather than transferring the files to your hard disk. You will obtain better
performance, however, if you copy the files to your disk. The specific files used by
each exercise are described at the beginning of the individual tutorials.

In the tutorials, we use the term tutorial data directory to refer to the place where the
tutorial data sets are stored. Depending on your system and whether you choose to
copy the data sets to your hard disk, this could be the envidata directory on either
of the ENVI Tutorial and Data CD-ROMs, a directory containing links to the ENVI
CD-ROM (on some UNIX systems), or a place on your hard disk.

Mounting the CD-ROM for UNIX Systems

In order to have access to the ENVI tutorial data files, you must have a CD-ROM
drive connected to your computer or accessible on a network.

Some platforms automatically mount the CD-ROM when you insert it into your CD-
ROM drive. In most cases, the CD-ROM will be mounted as:

/cdrom/envidata1

or

/cdrom/envidata2

The following instructions work in most cases for the platform listed. Consult your
operating system documentation for instructions on mounting a CD-ROM on your
system.

Note
Replace CDROM-Dev with the actual name of the CD-ROM drive on your system.
Type mounting commands as a single line. On most systems, you must have root
permissions to mount the CD-ROM.
ENVI Tutorials Tutorial Data Files
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Note
We suggest that you mount the CD-ROM device in the directory /cdrom. If you
choose to mount the CD-ROM in another directory, substitute that directory name
for occurrences of /cdrom in these tutorials. Also, not all UNIX systems will read
the CD-ROM the same way.

Platform CD Mounting Command
Typical

CDROM-Device
Name

Compaq Tru64
UNIX

/usr/sbin/mount -t cdfs -r -o
rrip CDROM-Dev /cdrom

/dev/rz4c

HP-UX mount -r -F cdfs -o cdcase
CDROM-Dev /cdrom

/dev/dsk/c1t2d0

IBM AIX mount -r -v cdrfs CDROM-Dev
/cdrom

/dev/cd0

Linux mount -o ro -t iso9660 CDROM-Dev
/mnt/cdrom

/dev/cdrom

SGI IRIX (automatically mounted as /CDROM)

SUN Solaris (automatically mounted by volume manager as
/cdrom/envi_35)

CD-ROM Mounting Commands
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The following topics are covered in this tutorial:
Overview of This Tutorial . . . . . . . . . . . . . . 36 Getting Started with ENVI . . . . . . . . . . . . . 37
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36 ENVI® Quick Start
Overview of This Tutorial

This quick start tutorial is designed to give users trying ENVI for the first time a
quick demo script. The following exercises briefly introduce you to ENVI’s graphical
user interface and basic capabilities. The exercises assume that you have downloaded
and installed ENVI on your hard disk or have installed ENVI from the CD-ROM.
Please contact Research Systems directly for a fully functional CD-ROM or see the
ENVI download instructions to obtain the software via the Internet.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 2

Path: envidata/can_tm

Note
For instructions for mounting a CD-ROM on a UNIX system, see “Mounting the
CD-ROM for UNIX Systems” on page 33.

File Description

can_tmr.img Boulder, CO, TM Data

can_tmr.hdr ENVI Header for Above

can_lst.evf List of EVF Files

can_v1.evf ENVI VECTOR FILE 1

can_v2.evf ENVI VECTOR FILE 2

can_v3.evf ENVI VECTOR FILE 3

can_v4.evf ENVI VECTOR FILE 4
Overview of This Tutorial ENVI Tutorials
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Getting Started with ENVI

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To start ENVI on UNIX, enter envi at the UNIX command line.

• To start ENVI on Microsoft Windows systems, double-click on the ENVI icon
or select ENVI from the Windows 98, Windows NT 4.0, or Windows 2000
Start menu.

Load a Gray Scale Image

Open a multispectral Landsat Thematic Mapper (TM) data file representing Cañon
City, Colorado, USA.

Open an Image File

To open an image file:

1. Select File → Open Image File.

An Enter Input Data File file selection dialog appears.

2. Navigate to the can_tm subdirectory of the envidata directory just as you
would in any other application, and select the file can_tmr.img from the list
and click Open.

The Available Bands List dialog appears on your screen. This list allows you
to select spectral bands for display and processing.

Note
You have the choice of loading either a grayscale or an RGB color image.

3. Select TM Band 4 in the dialog by clicking on the band name in the Available
Bands List with the left mouse button.

The band you have chosen is displayed in the field marked Selected Band:

4. Click on the Gray Scale toggle button and then Load Band in the Available
Bands List to load the image into a new display.

Band 4 will be loaded as a gray scale image.
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Familiarize Yourself with the Displays

When the image loads, an ENVI image display appears on your screen. The display
group consists of an Image window, a Scroll window, and a Zoom window. These
three windows are intimately linked; changes to one window are mirrored in the
others.

All windows can be resized by grabbing and dragging a window corner with the left
mouse button.

1. Resize the Image window to be as large as possible. Note that the Scroll
window disappears.

2. Now, make the Image window smaller than the full extent of the image data
and the Scroll window reappears.

3. Next, try resizing the Zoom window to see how the outlining box changes in
the Image window.

The basic characteristics of the ENVI display group windows are described as
follows:

Scroll Window

The Scroll window displays the entire image at reduced resolution (subsampled). The
subsampling factor is listed in parentheses in the window Title Bar at the top of the
image. The highlighted scroll control box (red by default) indicates the area shown at
full resolution in the Image window.

1. To reposition the portion of the image shown in the Image window, position
the mouse cursor inside the scroll box, hold down the left mouse button, drag
to the desired location, and release. The Image Window is updated
automatically when the mouse button is released.

2. You can also reposition the cursor anywhere within the Scroll window and
click the left mouse button to move the selected Image Window area instantly.
If you click, hold, and drag the left mouse button in this fashion, the Image
window will be updated as you drag (the speed depends on your computer
resources).

Image Window

The Image window shows a portion of the image at full resolution. The zoom control
box (the highlighted box in the Image window) indicates the region that is displayed
in the Zoom window.

1. To reposition the portion of the image magnified in the Zoom window,
position the mouse cursor in the zoom control box, hold down the left mouse
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button, and move the mouse. The Zoom window is updated automatically
when the mouse button is released.

2. Alternately, you can reposition the cursor anywhere in the Zoom window and
click the left mouse button to move the magnified area instantly. If you click,
hold, and drag the left mouse button in this fashion, the Zoom window is
updated as you drag.

3. The Main Image window can also have optional scroll bars, which provide an
alternate method for moving through the Scroll window image, allowing you
to select which portion of the image appears in the Image window. To add
scroll bars to the Main Image window, select File → Preferences from the
Main Image window menu bar. In the second section of the dialog titled Image
Window, click on the spin box control next to the Scroll Bars text field to
toggle scroll bars on, then click OK at the bottom of the dialog.

The portion of the image displayed in the Main Image window can now be
controlled by clicking and dragging the scroll bars using the left mouse button.

Scroll bars can be turned on by default for all images from the Main ENVI
menu bar by selecting File → Preferences → Display Defaults and toggling
the Main Image window scroll bars field as described above.

Zoom Window

The Zoom window shows a portion of the image, magnified the number of times
indicated by the number in parentheses in the Title Bar of the window. The zoom area
is indicated by a highlighted box (the zoom control box) in the Image window.

There is a small control graphic (red by default) in the lower left corner of the Zoom
window. This controls the zoom factor and also the crosshair cursor in both the Zoom
and Main Image windows.

1. Move the mouse cursor in the Zoom window and click the left mouse button to
reposition the magnified area by centering the zoomed area on the selected
pixel.

2. Clicking and holding the left mouse button in the Zoom window while
dragging causes the Zoom window to pan within the Main Image display.

3. Clicking the left mouse button on the – (minus) graphic in the lower left corner
of the Zoom window zooms down by a factor of 1. Clicking the middle mouse
button on this graphic zooms down by a factor of 2. Clicking the right mouse
button on the graphic returns the zoom window to the default zoom factor.

4. Clicking the left mouse button on the + (plus) graphic in the lower left corner
of the Zoom window zooms up by a factor of 1. Clicking the middle mouse
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button on this graphic zooms up by a factor of 2. Clicking the right mouse
button on the graphic returns the Zoom window to the default zoom factor.

5. Click the left mouse button on the right (third) graphics box in the lower left
corner of the Zoom window to toggle the Zoom window crosshair cursor.
Click the middle mouse button on this graphic to toggle the Main Image
crosshair cursor. Click the right mouse button on this graphic to toggle the
Zoom box in the Main Image window on or off. Double-click the right mouse
button on this graphic to toggle scroll bars on or off in the Main Image
window.

Note
On Microsoft Windows systems with a two button mouse, click Ctrl-Left Mouse
Button to emulate the middle mouse button.

Main Image Display Menu Bar

A menu bar at the top of the Main Image window gives you access to many ENVI
features that relate directly to the images in the display group. You can select options
from it as you do from any other ENVI menu.

Apply a Contrast Stretch

By default, ENVI displays images with a 2% linear contrast stretch.

1. To apply a different contrast stretch to the image, select Enhance from the
Main Image display menu bar to display a list of six default stretching options
for each of the windows (Image, Zoom, Scroll) in the display group.

2. Select an item from the list (for example Enhance → [Image] Equalization to
apply a histogram equalization contrast stretch to the Image display, which
also updates the Scroll and Zoom windows of the display group. Try applying
several of the different available stretches.

Alternatively, you can define your contrast stretch interactively by selecting
Enhance → Interactive Stretching from the Main Image display menu bar.

Apply a Color Map

By default, ENVI displays images using a grayscale color table.

1. To apply a pre-defined color table to the image, from the Main Image window
menu select Tools → Color Mapping → ENVI Color Tables to display the
ENVI Color Tables dialog.
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2. Select a color table from the list at the bottom of the dialog to change the color
mapping for the three windows in the display group.

Note
In the ENVI Color Tables dialog, Options → Auto Apply On is selected by
default, so the color table will automatically be applied. You can turn this off by
selecting Options → Auto Apply Off in which case you must select
Options → Apply each time you wish to apply the color table and observe the
results.

3. In the ENVI Color Tables dialog, select Options → Reset Color Table to
return the display group to the default gray scale color mapping.

4. Select File → Cancel to dismiss the ENVI Color Tables dialog.

Cycle Through All Bands (Animate)

You can display all the bands in an image sequentially, creating an animation.

1. From the Main Image window menu, select Tools → Animation and click
OK in the Animation Input Parameters dialog.

Each of the six bands from the TM scene are loaded into an animation window.
Once all the bands are loaded, the images are displayed sequentially creating a
movie effect.

2. You can control the animation using the player controls (loop backward, loop
forward, change direction, and pause buttons) at the bottom of the Animation
Window, or by adjusting the value shown in the Speed spin box to change the
speed at which the bands are displayed.

3. Select File → Cancel from the display menu bar to end the animation.

Scatter Plots and Regions of Interest

Scatter plots allow you to quickly compare the values in two spectral bands
simultaneously. ENVI Scatterplots allow quick 2-band classification.

1. To display the distribution of pixel values between Band 1 and Band 4 of the
image as a scatter plot, select Tools → 2-D Scatter Plots.

The Scatter Plot Band Choice dialog appears.

2. Under Choose Band X: select Band 1. Under Choose Band Y: select Band 4.
Click OK to create the scatter plot.
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3. Place the cursor in the Image window, then press and hold the left mouse
button and move the cursor around in the window. Make sure not to press and
hold the mouse cursor inside the Zoom window box.

Notice that as you move the cursor, different pixels are highlighted in the
scatter plot. This dancing pixels display highlights the 2-band pixel values
found in a 10-pixel by 10-pixel region around the cursor.

4. Define a region of interest (ROI) in the Scatter Plot display by clicking the
left mouse button several times in the Scatter Plot window to select points
forming the vertices of a polygon, then clicking the right mouse button to close
the polygon.

Pixels in the Image and Zoom windows whose values match the values
contained in the selected region of the scatter plot are highlighted.

5. To define a second class, select a second color from the Class menu of the
Scatter Plot window and repeat the above steps.

6. Select Options → Export All from the Scatter Plot window menu to export
the regions of interest. The ROI Tool dialog appears. The ROI Tool dialog
can also be started from the Main Image Display menu bar by selecting
Overlay → Region of Interest.

By default, ENVI assigns Scatter Plot Export in the ROI Tool dialog, followed
by the color of the region and number of points contained in the region as the
name for the region of interest.

7. In the ROI Tool menu bar, select File → Cancel to dismiss the dialog. The
region definition is saved in memory for the duration of the ENVI session. In
the Scatter Plot window, close the scatter plot by selecting File → Cancel.

Load a Color Composite (RGB) Image

ENVI allows simultaneous, multiple grayscale and RGB color displays.

1. To load a color composite (RGB) image of the Cañon City area, click on the
Available Bands List. If you dismissed the Available Bands List during the
previous exercises, you can recall it by selecting Window → Available Bands
List from the Main ENVI menu bar.

2. Click on the RGB Color radio button in the Available Bands List. Red,
Green, and Blue fields appear in the center of the dialog.

3. Select Band 7, Band 4, and Band 1 sequentially from the list of bands at the top
of the dialog by clicking on the band names.
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The band names are automatically entered in the Red, Green, and Blue fields.

4. Click Load RGB to load the image into the Image window.

Classify an Image

ENVI provides two types of unsupervised classification and several types of
supervised classification. The following is an example of one of the supervised
classification methods.

1. From the ENVI Main menu bar, select
Classification → Supervised → Parallelepiped. When the Classification
Input File dialog appears, select can_tmr.img and click OK.

2. When the Parallelepiped Parameters dialog appears, select the regions of
interest you created by clicking on the region name in the Select Classes from
Regions list at the left of the dialog.

3. Select Memory in the upper right corner of the dialog to output the result to
memory.

4. Click on the small arrow button in the right-center of the Parallelepiped
Parameters dialog to toggle off Rule Image generation, and then click OK.

The classification function will calculate statistics and a progress window will
appear during the classification. A new entry titled Parallel (CAN_TMR.IMG)
is added to the Available Bands List.

5. To load the result of the classification into a new display group, select the New
Display by pulling down the menu button marked Display #1 in the Available
Bands List. Select Gray Scale for the display by clicking on the Gray Scale
radio button in the Available Bands List, then click on the Parallelepiped
result image name, and click on the Load Band button.

A new display group is created, containing the classified image.

Dynamically Overlay Images

You can link two display groups, allowing comparison of the images directly by
displaying one over the other.

1. From either Image window, select Tools → Link → Link Displays from the
Main Image display menu bar. The Link Displays dialog appears. Click OK
to link at the origin.

2. In either Image window, position the cursor outside the zoom control box and
hold down the left mouse button and move the cursor.
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A portion of the other image is superimposed.

3. You can change the size of the superimposed area by holding down the middle
mouse button and dragging until the superimposed area is the desired size.

4. Close the two image displays by selecting File → Cancel from each Image
window menu bar.

Overlaying and Working with Vectors

ENVI provides a full suite of vector viewing and analysis tools, including input of
ArcView Shapefiles, vector editing, and vector querying.

1. Re-display the grayscale image by clicking on TM Band 4 in the Available
Bands List, clicking on the Gray Scale radio button, and then on Load Band.

2. Open a vector file by selecting File → Open Vector File → ENVI Vector
File from the menu bar of the ENVI main menu. Navigate to the can_tm
directory and choose the file can_lst.evf which contains a list of vector
files for this area (alternatively, open each .evf file individually).

The Available Vectors List dialog appears listing the vectors corresponding
to the can_tmr.img display.

3. Click on one of the vector layer names and examine the information about the
layer at the bottom of the Available Vectors List.

4. Click on the Select All Layers near the bottom of the dialog to choose the
vectors to plot. Click on the Load Selected button at the bottom of the
Available Vectors List and the Load Vector Layer dialog will appear. Click
on Display #1 at the top of the dialog to load the vectors.

The vector layers are listed in the Display #1 Vector Parameters dialog.

5. Click on Apply in the Display #1 Vector Parameters dialog to load the
vectors onto the image, then choose Options → Vector Information in the
Vector Parameters dialog to start an information dialog about the vectors.

6. Click and drag with the left mouse button in the Main Image display to track
the currently selected vector layer and list basic information about the vectors.
Click on another layer name in the Vector Parameters dialog and then in the
Main Image display to track a different layer.

7. Edit the layer display characteristics by clicking on the Edit Layers button in
the Vector Parameters dialog. Change vector layer parameters as desired and
click on OK, then Apply to display the changes.
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Finish Up

You can finish your ENVI session by selecting File → Exit (Quit on UNIX) on the
ENVI main menu, then answer Yes to the prompt Terminate this ENVI Session?.
All files will be closed automatically. If you are running ENVI (ENVI with IDL
rather than ENVI Runtime), you may also have to exit IDL by choosing File → Exit
and answering Yes to the prompt Exit IDL.
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Tutorial 1:

Introduction to ENVI
The following topics are covered in this tutorial:
Overview of This Tutorial . . . . . . . . . . . . . . 48
Working with ENVI . . . . . . . . . . . . . . . . . . . 49

Basic ENVI Functions . . . . . . . . . . . . . . . . 55
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Overview of This Tutorial

This tutorial provides basic information about ENVI and some suggestions for your
initial investigations of the software. It is designed to introduce first-time ENVI users
to the basic concepts of the package and to explore some of its key features. It
assumes that you are already familiar with general image-processing concepts.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 2

Path: envidata/can_tm

File Description

can_tmr.img Cañon City, CO TM Data

can_tmr.hdr ENVI Header for Above
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Working with ENVI

ENVI uses a graphical user interface (GUI) to provide point-and-click access to
image processing functions. You select menu choices and functions using a three-
button mouse.

Note
If you are using ENVI for Windows with a two-button mouse, you can simulate a
middle mouse button press by holding down the Control key and pressing the left
mouse button. If you are using ENVI for Macintosh, hold down the Option key
while pressing the mouse button to simulate a middle mouse button press, or hold
down the Command key while pressing the mouse button to simulate a right mouse
button press.

When you start ENVI, the ENVI main menu appears as a menu bar. Clicking with
the left mouse button on any of the ENVI main menu topics brings up a menu of
options, which may in turn contain submenus with further options. The choices
selected from these submenus will often bring up dialog boxes that allow you to enter
information or set parameters relating to the ENVI function you have selected.

ENVI File Formats

ENVI uses a generalized raster data format consisting of a simple flat binary file and
a small associated ASCII (text) header file. This file format permits ENVI to use
nearly any image file, including those that contain their own embedded header
information.

Generalized raster data is stored as a binary stream of bytes in either Band Sequential
(BSQ), Band Interleaved by Pixel (BIP), or Band Interleaved by Line (BIL) format.

• BSQ is the simplest format, with each line of data followed immediately by the
next line of the same spectral band. BSQ format is optimal for spatial (X, Y)
access to any part of a single spectral band.

• BIP format provides optimal spectral processing performance. Images stored
in BIP format have the first pixel for all bands in sequential order, followed by
the second pixel for all bands, followed by the third pixel for all bands, etc.,
interleaved up to the number of pixels. This format provides optimum
performance for spectral (Z) access of the image data.

• BIL format provides a compromise in performance between spatial and
spectral processing and is the recommended file format for most ENVI
processing tasks. Images stored in BIL format have the first line of the first
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band followed by the first line of the second band, followed by the first line of
the third band, interleaved up to the number of bands. Subsequent lines for
each band are interleaved in similar fashion.

ENVI supports a variety of data types: byte, integer, long integer, floating-point,
double-precision floating-point, complex, and double-precision complex.

The separate text header file provides information to ENVI about the dimensions of
the image, any embedded header that may be present, the data format, and other
pertinent information. The header file is normally created (with your input) the first
time a particular data file is read by ENVI. You can view and edit it at a later time by
selecting File → Edit ENVI Header from the ENVI menu bar. You can also
generate ENVI header files outside ENVI, using a text editor.

ENVI Windows and Displays

As you work with ENVI, a number of different windows and dialog boxes will
appear on your screen. These allow you to manipulate and analyze your image. The
most important of these displays is a group of three windows that display your image,
allow you to move around in it, and allow you to magnify different areas. This group
of windows is collectively referred to as the Display group (Figure 1-1). The Display
group consists of:

• The Main Image Window – This window is where all or part of your image is
displayed at full resolution (one screen pixel is one data pixel).

• The Scroll Window – If your entire image does not fit in the Main Image
window, the Scroll window will appear. The Scroll window displays a
subsampled reduced-size version of the entire image, which allows you to
select the portion that is displayed in the Main Image window. A colored box
in the Scroll window indicates the spatial location and coverage of the full-
resolution Main Image display window. A number in the title bar of the Scroll
window tells you what reduction factor has been applied to the image to
display the full spatial extent within the Scroll window.

• The Zoom Window – This window displays an enlarged version of a selected
portion of the Main Image window. A colored box in the Main Image display
indicates the spatial location and coverage of the Zoom window. A number in
the title bar of the Zoom window tells you what zoom factor has been applied
to the image.

You may have any number of displays open on the screen at any time. There are a
wide variety of other types of ENVI windows with which you may work, including
scatter plots, spectral profiles, spectral plots, and vector windows.
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Figure 1-1: An ENVI Display group: the Main Image, Scroll, and Zoom windows.
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Menus in ENVI Windows

The Main Image display window has its own internal menus, which provide access to
interactive display and analysis functions (Figure 1-2). These menus appear as a
standard menu bar at the top of each Main Image display window. You can select
options from it as you do from any other ENVI menu.

Figure 1-2: The Overlay menu in the Main Image window
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The Available Bands List

ENVI provides access to both image files and to the individual spectral bands in
those files. The Available Bands List is a special ENVI dialog that contains a list of
all the available image bands in all open files (Figure 1-3).

Use the Available Bands List to load both color and gray scale images into a display
by starting a new display or selecting the display number from the pull-down list of
displays, clicking on the appropriate radio button, then selecting the desired bands
from the list by clicking on the band name(s).

The File pull-down menu at the top of the Available Bands List dialog provides
access to file opening and closing, file information, and the Cancel button. The
Options menu provides a function to find the band closest to a specific wavelength,
show the currently displayed bands, allows toggling between full and shortened band
names in the list, and the capability to fold all of the bands in a single open image into
just the image name. Folding and unfolding the bands into single image names or lists

Figure 1-3: The Available Bands List dialog
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of bands can also be accomplished by clicking on the + (plus) or – (minus) symbols
to the left of the file name in the Available Bands List dialog.
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Basic ENVI Functions

This section of the tutorial takes you on a step-by-step tour of ENVI’s basic
functions.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To open ENVI in UNIX, enter envi at the UNIX command line.

• To open ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

Open an Image File

To open an image file:

1. Select File → Open Image File.

Note that on some platforms you must hold the left mouse button down to
display the submenus from the Main Menu.

An Enter Input Data File file selection dialog appears.

2. Navigate to the CAN_TM subdirectory of the envidata directory on the ENVI
ENVI Tutorial and Data CD No. 2 just as you would in any other application
and select the file can_tmr.img from the list and click OK.

The Available Bands List dialog appears on your screen (Figure 1-3). This list
allows you to select spectral bands for display and processing.

You now have the choice of loading either a gray scale or an RGB color image.

3. Select one of the bands listed at the top of the dialog by clicking on the band
with the left mouse button.

The band you have chosen is displayed in the field marked Selected Band:.

4. Click the Load Band button to load the image into a new display.

Note
The Main Image window has a menu bar (Figure 1-2).
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Familiarize Yourself with the Displays

When the image loads, an ENVI image display appears on your screen. The display
consists of a Main Image window, a Scroll window, and a Zoom window (See Figure
1-1). These three windows are intimately linked; changes to one window are mirrored
in the others. To get a feel for how the display windows interact, try the following:

Drag the Zoom Indicator Box

• Note the small red box in the center of the Main Image window. This box
indicates the area of the image displayed in the Zoom window. You can drag
the box from place to place in the Main Image window by clicking inside the
box with the left mouse button and dragging it to a new position. The Zoom
window is updated automatically to show the new area when you release the
mouse button

• You can also reposition the zoom indicator box by placing the crosshair cursor
in the Main Image window and clicking the left mouse button. The zoom
region will be centered around the position you have chosen.

• Finally, if you click outside the zoom indicator box with the middle mouse
button and hold and drag the box to a new position, the Zoom window is
updated as you move the box.

• You can close either the Zoom and/or Scroll windows if you don’t want to
display them. They can again be displayed by selecting Window → Show
Scroll Window or Window → Show Zoom Window from the Main Image
window menu bar.

Zoom In and Out and Pan the Zoom Window

• Move the mouse cursor in the Zoom window and click the left mouse button to
reposition the magnified area by centering the zoomed area on the selected
pixel.

• Clicking and holding the left mouse button in the Zoom window while
dragging causes the Zoom window to pan within the Main Image display.

• Click the right mouse button in the Zoom window to toggle the menu graphic
on or off. The menu graphic is made up of three icons in the lower left corner
of the Zoom window.

• Clicking the left mouse button on the – (minus) graphic zooms down by a
factor of 1. Clicking the middle mouse button on this graphic zooms down by a
factor of 2. Clicking the right mouse button on the graphic returns the Zoom
window to the default zoom factor.
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• Clicking the left mouse button on the + (plus) graphic zooms up by a factor of
1. Clicking the middle mouse button on this graphic zooms doubles the Zoom
factor. Clicking the right mouse button on the graphic returns the Zoom
window to the default zoom factor.

• Click the left mouse button on the right (third) graphics box to toggle the
Zoom window crosshair cursor. Click the middle mouse button on this graphic
to toggle the Main Image crosshair cursor. Click the right mouse button on this
graphic to toggle the zoom box in the Main Image window on or off.

• Double-click the left mouse button on the right (third) graphics box to toggle
interpolation in the Zoom window. Double-click the right mouse button in this
graphic to toggle scroll bars on the Main Image window.

Scroll the Image

A red box in the Scroll window indicates what portion of the entire image is currently
displayed in the Main Image window. You can move the selected area by clicking
inside the scroll indicator box with the left mouse button and dragging the box to a
new position. The displays in the Main Image and Zoom windows are updated when
you release the mouse button. You can also reposition the scroll indicator box by
clicking at the desired location outside of the box using the left mouse button (as for
the Zoom window box above). If you click, hold and drag the left mouse button in
this fashion, the Main Image window is updated as you drag (the speed depends on
your computer resources).

Resize the Windows

You can resize the display windows the same way you would resize windows in other
applications, by dragging any of the corners. Note, however, that you cannot make
the Main Image window larger than the image size. When the Main Image window is
large enough to display the entire image, the Scroll window is unnecessary and is
automatically removed from your screen. The Scroll window reappears if the Main
Image window is resized smaller than the full image.

Scroll Bars

The Main Image window can also have optional scroll bars, which provide an
alternate method for moving through the Scroll image, allowing you to select which
portion of the image appears in the Image window. To add scroll bars, select
File → Preferences from the Main Image window menu bar. Click on the arrow
toggle button next to the Scroll Bars text field in the dialog to toggle scroll bars on,
then click OK at the bottom of the dialog. The portion of the image displayed in the
Main Image window can now be controlled by clicking and dragging the scroll bars
ENVI Tutorials Basic ENVI Functions



58 Tutorial 1: Introduction to ENVI
using the left mouse button. Scroll bars can be turned on by default for all images
from the ENVI menu bar by selecting File → Preferences → Display Defaults and
clicking on the toggle button for the Image window scroll bars as described above.

Use the Mouse Button Descriptions

ENVI has many interactive functions, and the mouse button combinations and
actions are different for each one. The Mouse Button Descriptions dialog is
provided to tell you what the mouse buttons do in each graphics window.

• To start the Mouse Button Descriptions dialog, select Window → Mouse
Button Descriptions from either the Main Image window menu bar, or from
the ENVI main menu bar.

Now whenever your cursor is in an ENVI display or graphics window, the mouse
button assignments will be listed in this dialog. MB1 is the left mouse button, MB2 is
the middle mouse button, and MB3 is the right mouse button.

Display the Cursor Location

• To display the cursor location and value, select Window → Cursor
Location/Value from the ENVI main menu or the Main Image window menu
bar.

The Cursor Location / Value dialog box appears displaying the location of
the cursor in the Main Image, Scroll, or Zoom windows (Figure 1-4). The
dialog also displays the screen value (color) and the actual data value of the
pixel underneath the crosshair cursor.

• To dismiss the dialog, select Cancel from the pull-down File menu at the top
of the Cursor Location /Value dialog.

• The Cursor Location/Value dialog can also be started/stopped by double-
clicking using the left mouse button in the Main Image window.
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Display Image Profiles

X (horizontal), Y (vertical), and Z (spectral) profile plots can be selected and
displayed interactively. These profiles show the data values across an image line (X),
column (Y), or spectral bands (Z).

1. Select Tools → Profiles → X Profile from the Main Image display menu bar
to display a window plotting data values versus sample number for a selected
line in the image (Figure 1-5).

2. Repeat the process, selecting Y Profile to display a plot of data value versus
line number, and selecting Z Profile to display a spectral plot (Figure 1-5).

Note
The Mouse Button Descriptions dialog contains the descriptions of the mouse
button actions in the Profile displays.

3. Position the Profile plot windows so you can see all three at once.

A red crosshair extends to the top and bottom and to the sides of the Main
Image window. The red lines indicate the line or sample locations for the
vertical or horizontal profiles.

4. Move the crosshair around the image (just as you move the zoom indicator
box) to see how the three image profile plots are updated to display data on the
new location.

Figure 1-4: The Cursor Location/Value dialog displays the screen and data
values of the selected pixel.
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5. Close the profile plots by selecting File → Cancel from within each plot
window.

Perform Quick Contrast Stretching

You can perform quick contrast stretches using default parameters and data from
either the Main Image window, the Zoom window, or the Scroll window. Using the
Enhance menu from the Main Image window menu bar, you can apply various
contrast stretches (Linear, Linear 0-255, Linear 2%, Gaussian, Equalization, and
Square Root).

1. Try the various stretches using the Main Image, Zoom, and Scroll as the
stretch data source.

2. Compare the effects of the various Linear, Gaussian, Equalization, and Square
Root stretches in the Display group windows.

Display Interactive Scatter Plots

You can plot the data values of two selected image bands versus each other in a
scatter plot to graphically display the overlapping values.

1. Select Tools → 2D Scatter Plots from the Main Image window menu bar.

The Scatter Plot Band Choice dialog appears, in which you choose the two
image bands to compare.

Figure 1-5: The Horizontal (X) Profile (left) and Spectral (Z) Profile (right) plots.
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2. Select one band for the X axis and another band for the Y axis and click OK.

It may take a few seconds for ENVI to extract and tabulate the data values.

3. Once the scatter plot has appeared (Figure 1-6), position the mouse cursor
anywhere in the Main Image window and drag with the left mouse button
pressed.

Pixel values contained in a ten-pixel by ten-pixel box surrounding the
crosshair will be highlighted in red on the scatter plot.

Note
The Mouse Button Descriptions dialog tells you the functions of the different
mouse button actions when applied in the Scatter Plot display.

4. Move the cursor around in the Main Image window to observe the dancing
pixels effect.

5. You can also use the scatter plot to highlight specific data values in the Main
Image window. Place the mouse cursor in the scatter plot window and click
and drag with the middle mouse button.

Figure 1-6: An Interactive Scatter Plot comparing band 1 values to band 4
values.
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A ten-pixel-square box will appear in red on the plot. Pixels with the values
contained in the box are highlighted on the image in the Main Image window
and appear to dance, as you drag the cursor in the Scatter Plot display moving
the 10-by-10 pixel area.

6. From the Scatter Plot menu bar, select File → Cancel to close the Scatter Plot
window.

Load a Color Image

1. If the Available Bands List dialog is not already on your screen, call it up
again from the ENVI Main menu bar by selecting Window → Available
Bands List (Figure 1-3).

2. Set up to load a color image in a second display by clicking on the radio button
labelled RGB Color in the Available Bands List dialog.

3. Select a band for each color (red, green, blue) from the list by clicking on the
band name. The radio buttons for assigning the R, G, and B colors
automatically advance when you click on a band name in the list.

4. When all three colors have band names associated with them, click the Display
#1 menu button to open a New Display from the pull-down menu.

5. Now, click on the Load RGB button to load the image in the new display.

Link Two Displays

Link the two displays together for comparison. When you link two displays, any
action you perform on one display (scrolling, zooming, etc.) is echoed in the linked
display. To link the two displays you have on screen now do the following.

1. From either of the two Main Image menu bars, select Tools → Link → Link
Displays. This opens the Link Displays dialog box.

2. Click OK in the Link Displays dialog to establish the link.

3. Now try scrolling or zooming in one display group and observe as your
changes are mirrored in the second display.

Dynamic Overlays

ENVI’s multiple Dynamic Overlay feature allows you to dynamically superimpose
parts of one or more linked images onto the other image. Dynamic overlays are
turned on automatically when you link two displays, and may appear in either the
Main Image window or the Zoom window.
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1. To start, click the left mouse button to see both displays completely overlaid
on one another.

2. To create a smaller overlay area, position the mouse cursor anywhere in either
Main Image window (or either Zoom window) and hold down and drag with
the middle mouse button. Upon button release, the smaller overlay area is set
and a small portion of the linked image will be superimposed on the current
image window.

3. Now click the left mouse button and drag the small overlay window around the
image to see the overlay effects.

4. You can resize the overlay area at any time by clicking and dragging the
middle mouse button until the overlay area is the desired size.

Select Regions Of Interest

ENVI lets you define regions of interest (ROIs) in your images. ROIs are typically
used to extract statistics for classification, masking, and other operations.

1. From the Main Image window menu bar, select Overlay → Region of
Interest. The ROI Tool dialog for that Main Image display will appear
(Figure 1-7).

2. Draw a polygon that represents the region of interest.

Figure 1-7: The ROI Tool dialog with two regions defined.
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• Click the left mouse button in the Main Image window to establish the first
point of the ROI polygon.

• Select further border points in sequence by clicking the left button again,
and close the polygon by clicking the right mouse button.The middle
mouse button deletes the most recent point, or (if you have closed the
polygon) the entire polygon. Click the right mouse button a second time to
fix the polygon.

• ROIs can also be defined in the Zoom and Scroll windows by selecting the
appropriate window radio button in the ROI Tool dialog.

When you have finished defining an ROI, it is shown in the dialog in the
Available Regions of Interest list, with the name, region color, and number of
pixels enclosed (Figure 1-7).

3. To define a new ROI, click the New Region button.

• You can enter a name for the region and select the color and fill patterns
for the region by clicking on the Edit button.

Other types of ROIs

ROIs can also be defined as polylines or as a collection of individual pixels by
selecting the desired ROI type from the ROI_Type pull-down menu. See the ENVI
3.5 User’s Guide or the hypertext online help for further discussion of these types of
ROI.
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Working with ROIs

You can define as many ROIs as you wish in any image (Figure 1-8).

1. Once you have created the ROI definitions, you can erase them from the
display (leaving the definition in the list) by selecting the ROI from the
Available Regions of Interest list and clicking on the Erase button.

2. Clicking on the Stats button allows you to view statistics about the ROI you
select.

3. Clicking the Delete button permanently deletes the selected ROI definitions
from the list.

4. The other buttons and options under the pull-down menus at the top of the
ROI Tool dialog let you calculate ROI means, save your ROI definitions, load
saved definitions, or display or delete all the definitions in the list.

Region of interest definitions are retained in memory after the ROI Tool dialog is
closed, unless you explicitly delete them. This means the ROIs are available to other
ENVI functions even if they are not displayed.

Figure 1-8: An image with two regions of interest (ROIs) defined.
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Annotate the Image

ENVI’s flexible annotation features allow you to add text, polygons, color bars, and
other symbols to your plots and images.

1. To annotate an image, select Overlay → Annotation from the Main Image
menu bar. The Annotation: Text dialog for that Main Image window will
appear (Figure 1-9).

2. To annotate plots, 3-D surfaces, and similar objects, select
Options → Annotation from the plot window menu bar.

Annotation Types

The Annotation: Text dialog allows you to choose from a variety of annotation
types. Different types are selected from the Object menu and include Text, Symbols,
Rectangles, Ellipses, Polygons, Polylines, Arrows, Map Scale Bars and Declination
Diagrams, Map Keys, Color Table Ramps, and Images. By default, the Annotation
dialog starts up with Text selected. Other fields in the dialog let you control the size,
color, placement, and angle of the annotation text. When you select different

Figure 1-9: The Annotation dialog, in Text mode.
Basic ENVI Functions ENVI Tutorials



Tutorial 1: Introduction to ENVI 67
annotation types from the Object menu, the fields in the dialog change to display
options appropriate to the new type.

Placing Annotation

Try placing a text annotation in your Main Image window:

1. Type some text in the text field of the Annotation: Text dialog.

2. Select a font, color, and size from the appropriate menus and parameters in the
dialog, then position the mouse pointer in the Main Image window and press
the left mouse button.

Note
The Mouse Button Description dialog describes the mouse button interactions
within annotation.

Your text is displayed in the window at the point you chose (Figure 1-10).

3. Drag the handle using the left mouse button to position the text in the window.

• You can continue to change the annotation’s properties and position by
changing the fields in the dialog box or dragging the text or symbol while
holding down the left mouse button.

4. When you are satisfied with the annotation, press the right mouse button to fix
the annotation in position.

Figure 1-10: An annotated image.
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Saving and Restoring Annotation

1. You can save your image annotation by selecting File → Save Annotation
from the Annotation: Text dialog menu bar.

2. This opens the Output Annotation Filename dialog in which you specify a
path and filename with a .ann extension for the saved annotation.

Note
If you do not save your annotation in a file, it will be lost when you close the
Annotation: Text dialog (you will be prompted to save the annotation if you close
without first saving).

3. You can also restore saved annotation files by selecting File → Restore
Annotation in the Annotation: Text dialog.

Editing Previously Placed Annotation

To edit an annotation element that has already been set in the image, do the
following.

1. Select Object → Selection/Edit in the Annotation: Text dialog.

2. Draw a box around the annotation you wish to edit by clicking and dragging
with the left mouse button.

3. When the handle reappears, Click and drag the handle and annotation to move
and configure the item just as you would a new annotation.

Suspending the Annotation Function Temporarily

1. To suspend annotation operations and return to normal ENVI functionality
temporarily, select the Off radio button at the top of the Annotation: Text
dialog.

This allows you to use the scroll and zoom features in your display without
losing your annotations.

2. To return to the annotation function, select the radio button in the Annotation:
Text dialog for the window you are annotating.

Leave your annotation on the Main Image window as you complete this tutorial.
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Add Grid Lines

Try adding a grid (Figure 1-11) to your image.

1. To overlay grid lines on your image, select Overlay → Grid Lines in the
Main Image window. This brings up the Grid Line Parameters dialog box.

Note
An image border is automatically added when you overlay grid lines.

2. You can adjust the grid line attributes by setting the line thickness and color
and the grid spacing using the Options → Edit Pixel Grid Attributes pull-
down menu from the Grid Lines Parameters dialog. This selection brings up
the Edit Pixel Attributes dialog box.

3. In the Edit Pixel Attributes dialog, you can change the color, thickness and
grid spacing for the labels, lines, box and corners of the grid. When the
attributes are set up to your satisfaction, click OK in the Edit Pixel Attributes
dialog to apply the changes to the grid on the images.

4. When you have added a satisfactory grid, click Apply in the Grid Line
Parameters dialog.
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Save and Output an Image

ENVI gives you several options for saving and outputting your filtered, annotated,
gridded images. You can save your work in ENVI’s image file format, or in several
popular graphics formats (including Postscript) for printing or importing into other
software packages. You can also output directly to a printer.

Saving your Image in ENVI Image Format

To save your work in ENVI’s native format (as an RGB file):

1. From the Main Image window menu bar, select File → Save Image
As → Image File. The Output Display to Image File dialog appears.

Figure 1-11: An annotated image with a grid overlaid.
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2. Select 24-Bit color or 8-Bit gray scale output, graphics options (including
annotation and gridlines), and borders.

If you have left your annotated and gridded color image on the display, both
the annotation and grid lines will be automatically listed in the graphics
options.

You can also select other annotation files to be applied to the output image.

3. Select output to Memory or File using the desired radio button.

• If output to File is selected, enter an output filename.

Note
If you select other graphics file formats from the Output File Type button
which, by default is set to ENVI, your choices will be slightly different.

4. Click OK to save the image.

Note
This process saves the current display values for the image, not the actual
data values.

End the ENVI Session

You can quit your ENVI session by selecting File → Exit (Quit on UNIX) on the
ENVI main menu, then click OK to terminate ENVI when prompted.
ENVI Tutorials Basic ENVI Functions



72 Tutorial 1: Introduction to ENVI
Basic ENVI Functions ENVI Tutorials



Tutorial 2:

Introduction to
Panchromatic Data and
Vector Overlays

The following topics are covered in this tutorial:
Overview of This Tutorial . . . . . . . . . . . . . . 74 Panchromatic Data and Vector Overlays . . 75
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Overview of This Tutorial

This tutorial provides an introduction to using ENVI with Panchromatic (SPOT) data,
including display, contrast enhancement, basic information about ENVI and some
suggestions for your initial investigations of the software. It is designed to introduce
first-time ENVI users to the basic concepts of the package and to explore some of its
key features. It assumes that you are already familiar with general image-processing
concepts. This dataset is a SPOT Panchromatic image and corresponding DXF files
of Enfidaville, Tunisia, courtesy of Research Systems International France. These
data are Copyright CNES-Spot Image and IGN France.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/enfidavi

File Description

enfidavi.bil SPOT Panchromatic Data, Enfidaville, Tunisia

enfidavi.hdr ENVI Header for above

enfidavi.dsc GeoSpot Volume Descriptor File

enfidavi.rep GeoSpot report file (REP/B: GEOSPOT Structure)

enfidavi.rsc GeoSpot Raster Source Description File

dxf.txt DXF coding descriptor file

alti.dxf Spot height DXF file

energy.dxf Oil or Gas Pipeline DXF file

hydro.dxf Hydrology DXF file

industry.dxf Industrial Areas DXF file

physio.dxf Physiographic areas DXF file

popu.dxf Urban Features (Population Centers) DXF file

transpor.dxf Transportation Networks DXF file

copyrite.txt Data Copyright Notice
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Panchromatic Data and Vector Overlays

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To open ENVI in UNIX, enter envi at the UNIX command line.

• To open ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

Open a Panchromatic (SPOT) Image File

To open an image file:

1. From the ENVI main menu, select File → Open Image File.

Note that on some platforms you must hold the left mouse button down to
display the submenus from the main menu.

An Enter Data Filenames file selection dialog appears.

2. In the file selection dialog, navigate to the enfidavi subdirectory of the
envidata directory on the ENVI Tutorial and Data CD No. 1 just as you
would in any other application and select the file enfidavi.bil from the list
and click Open (on Windows) or OK (on UNIX).

This is a SPOT Panchromatic image of Enfidaville, Tunisia, courtesy of RSI
France. The data in this file is copyrighted as Copyright CNES-Spot Image and
IGN France.

The Available Bands List dialog appears on your screen. This list allows you
to select spectral bands of the image for display and processing. You have the
choice of loading either a gray scale or an RGB color image of the available
bands.

Select and Load an Image Band

1. Select the band listed at the top of the dialog by clicking on the band with the
left mouse button.

The band you have chosen is displayed in the field marked Selected Band:.
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2. Click the Load Band button to load the image into a new display.

ENVI has many interactive functions, and the mouse button combinations and
actions are different for each one. The Mouse Button Descriptions dialog is
provided to tell you what the mouse buttons do in each graphics window.

3. To bring up the Mouse Button Descriptions dialog, select
Window → Mouse Button Descriptions from either the ENVI main menu or
the Main Image display menu bar.

Spatially Browse the Image

1. Move the Scroll window indicator box around the scroll image to display
different portions of the image in the Main Image display at full resolution.

Another method for scrolling the full resolution image is to add scroll bars to
the Main Image window. You can easily do this using the Zoom window
controls. In Zoom window position the cursor over the right-most control in
the lower left corner of the window. Double-click the right mouse button to
activate scroll bars in the Main Image window.

2. Now look at the image in greater detail. To do this, click and drag the Zoom
box around in the Main Image display using the left mouse button. When the
Zoom box is over an area of interest, release the mouse button and you’ll see
the image in greater detail in the Zoom window. You can also click and release
the left mouse button anywhere in the Main Image display to reposition the
Zoom box.

3. Position the Zoom box at various locations in the Main Image window and
examine the data.

Perform Interactive Contrast Stretching

Interactive contrast stretching plots a histogram and allows you to interactively
control the contrast of the displayed image. Many different types of stretches can be
applied. By default, a linear 2% stretch is applied to the data when it is first displayed.

• To access ENVI’s interactive contrast stretching functions, select
Enhance → Interactive Stretching from the Main Image window menu bar.

An Interactive Stretching dialog for the displayed band appears. This dialog
allows you to change the contrast stretch of the displayed image (Figure 2-1).
Two histogram plots display the color or gray scale range of the input image
(left) and the output image after contrast stretching (right). Initially, the input
Panchromatic Data and Vector Overlays ENVI Tutorials



Tutorial 2: Introduction to Panchromatic Data and Vector Overlays 77
and output histograms reflect the default stretch applied to the data when the
image was displayed.

• The Stretch_Type pull-down menu at the top of the histogram has a
variety of contrast-stretching options. Try applying the methods described
below and observe the results in the Main Image window.

• Also, try selecting both Histogram_Source → Zoom and
Histogram_Source → Scroll from the Interactive Stretching menu bar
and note the differences in the histograms and stretches of the Zoom
window and Scroll window.

Linear

When images are loaded into the Main Image window, a 2% linear contrast stretch is
applied by default.

Note
This default can be set by selecting File → Preferences → Display Defaults from
the ENVI main menu. You can edit the Display Default Stretch in the
Preferences: Display Defaults dialog which appears.

1. In the Main Image display, select Enhance → Interactive Stretching. An
Interactive Stretching dialog appears.

2. In the menu bar of the new dialog, choose Stretch_Type → Linear.

Figure 2-1: The Interactive Stretching Dialog.
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Note
Two vertical dotted lines appear in the input histogram plot—these bars can be
repositioned to control the minimum and maximum value used in the contrast
stretch.

3. Position the mouse cursor on the left bar and hold down the left mouse button
as you drag the bar from side to side.

As the left mouse button is pressed and the dotted vertical bar is moved across
the plot, numbers appear on the status bar of the dialog. Whenever the left
mouse button is clicked over the histogram plot, the status bar displays the
current data value, the number of pixels and the percentage of pixels that have
that value, and the cumulative percentage of pixels with values less than or
equal to the current value.

4. Since you’ll be changing the stretch conditions, it may be helpful to have the
changes automatically applied. To do this, select Options → Auto Apply On
from the Interactive Stretching dialog menu bar.

If you don’t wish the changes to be made until after you’re finished, then select
Options → Auto Apply Off, and use the Apply button on the dialog to apply
the stretch and observe the results.

5. Try positioning the left bar so that a cumulative percentage of pixels equaling
approximately 5% is selected. Now move the right bar so that the cumulative
percentage is approximately 95% of the pixels.

You can also position the bars by entering a minimum and maximum value in
the Stretch text fields of the dialog. You can enter either data values or
percentages.

6. Enter 4% in the left text field and 96% in the right text field and press the
Enter key.

The % values are converted to digital numbers and the left and right bars in the
display are updated with the data values at 4% and 96%, respectively.

Equalize

1. Select Stretch_Type → Equalization and note the change in the Output
Histogram plot in the dialog.

2. Again, you can choose to have the stretch automatically applied to the image
display group by ensuring the Options → Auto Apply On is selected from the
Interactive Stretching dialog menu.
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If you don’t wish the changes to be made until after you’re finished, then select
Options → Auto Apply Off, and use the Apply button on the dialog to apply
the stretch and observe the results.

Gaussian

1. From the Interactive Stretching dialog, select Stretch_Type → Gaussian.

2. Set the standard deviation by selecting Options → Set Gaussian Stdv.

3. The Set Gaussian Stdv dialog appears. You can adjust the standard deviation
value and see the effect when the new setting is applied to the image display
group.

4. Again, you can choose to have the stretch automatically applied to the image
display group by ensuring the Options → Auto Apply On is selected from the
Interactive Stretching dialog menu.

If you don’t wish the changes to be made until after you’re finished, then select
Options → Auto Apply Off, and use the Apply button on the dialog to apply
the stretch and observe the results.

5. Select File → Cancel to close the contrast stretching dialog.

Color Mapping

ENVI provides tools for quickly color slicing gray scale images.

1. Select Tools → Color Mapping → ENVI Color Tables from the Main Image
window menu bar. The ENVI Color Tables dialog appears.
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2. Apply quick stretches to the displayed image by sliding the Stretch Bottom
and Stretch Top sliders back and forth and observe the stretched image.

3. Click on several of the color table names in the Color Table list in the ENVI
Color Tables dialog and observe the color-coded image. Change the stretch as
in the previous step.

4. Select Options → Reset Color Table in the ENVI Color Tables dialog to
return to the original stretch and gray scale color table.

5. Select File → Cancel to close the ENVI Color Tables dialog.

Pixel Locator

The Pixel Locator dialog allows exact positioning of the cursor and displays the
screen and data values of the selected pixel.

Figure 2-2: The ENVI Color Tables dialog.
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1. Select Tools → Pixel Locator from the Main Image display menu bar to
display the Pixel Locator dialog.

2. Move and set the cursor in any of the three image displays to observe the
dialog as it reflects the pixel location for the current pixel.

3. The Pixel Locator dialog shows the pixel location in pixel coordinates by
default. To see the location in map coordinates, select Options → Map
Coordinates from the Pixel Locator menu bar.

4. Use the Proj:/Datum: spin box controls to toggle between true map
coordinates and latitude/longitude geographic coordinates. You can change the
selected projection by clicking on the Change Proj... button.

5. Close the Pixel Locator dialog by selecting File → Cancel from the dialog
menu.

Display the Georeferenced Cursor Location

Use ENVI’s cursor location/value function to view image values and geographic
location.

1. To display the cursor location and value, select Tools → Cursor
Location/Value from the Main Image window menu bar. You can also display

Figure 2-3: The Pixel Locator dialog allows exact positioning of the cursor and
displays the screen and data values of the selected pixel.
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it from the ENVI main menu by selecting Window → Cursor
Location/Value.

The Cursor Location / Value dialog box appears displaying the location of
the cursor in the Main Image, Scroll, or Zoom windows (Figure 2-4). The
dialog also displays the screen value (color) and the actual data value of the
pixel underneath the crosshair cursor.

2. To dismiss the dialog, select File → Cancel from the dialog pull-down menu.

Apply an Interactive Filter

ENVI gives you the ability to apply several different pre-defined or user-defined
filters to a display (file-based filtering is also available and is accessed via the Filter
menu on the ENVI main menu). The following example shows you how to apply a
pre-defined filter to the image in the Main Image window.

Choose a Filter

1. From the Main Image window menu bar, select Enhance → Filter and choose
the desired filter type from the pull-down filter menu to apply to the displayed
image.

2. Try the different sharpening, smoothing, and median filters on the displayed
image.

Figure 2-4: The Cursor Location dialog displays the screen and data values of
the selected pixel.
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Display Image in a Second Display and Apply a Different Filter

1. From the Available Bands List, select the Display #1 → New Display from
the pull-down menu button at the bottom of the dialog to create a second
display group.

2. Select the image band to be displayed in the second display group, and click
Load Band to load the image into the second display.

3. From the Main Image window of Image #2, choose Enhance → Filter and
select a filter different from that applied to Image #1 from the pull-down filter
menu.

Compare Images Using Dynamic Overlays

1. Select Tools → Link → Link Displays from the menu bar of either of the
Main Image windows and click OK to link the images.

2. Use the middle mouse button to resize the dynamic overlay and the left mouse
button to move the region for comparison. Note that the overlay area is defined
from the lower left corner of the display.

Review GeoSpot Map Information

To review the GeoSpot Map information in the ENVI Header file:

1. From the ENVI main menu, select File → Edit ENVI Header.

2. In the Edit Header Input File dialog, select enfidavi.bil as the input file,
and click OK.

The Header Info dialog appears.

Figure 2-5: The Header Info dialog.
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3. Click the Edit Attributes button and select Map Info from the pull-down
menu. The Map Information dialog appears. Note that the data are in UTM
projection, Zone 32 utilizing the NAD27 datum.

4. Click Cancel in the Map Information dialog and Cancel in the Header Info
dialog.

Open and Overlay DXF Vector Files

1. From the ENVI main menu, select File → Open Vector File → DXF. A
standard file selection dialog called Enter DXF Filenames appears.

2. In the file selection dialog, navigate to the ENVI Tutorial and Data CD No. 1
envidata/enfidavi directory. Set the file filter to *.dxf and select all of
the files with the .dxf extension. Click Open at the bottom of the file
selection dialog on Windows and Macintosh or click OK on UNIX to open the
Import DXF File Parameters dialog.

3. Midway down the Import DXF File Parameters dialog is the selection list of
projections. Select UTM as the Output Projection. This field refers to the map
units that the imported vector data is in.

4. Click the Datum button to bring up the Select Geographic Datum dialog.
Highlight the Mexico (NAD27) datum in the list and click OK.

5. In the Import DXF File Parameters dialog enter the UTM Zone as 32 North.

6. Click OK to load the DXF files and convert to .evf (ENVI Vector Files).

7. The Available Vectors List dialog appears. Click on the Select All Layers
button. Next, click on the Load Selected button.

8. A Load Vector dialog appears which lists all of the available Main Image
windows. Select Display #1 from the list.

9. The #1 Vector Parameters dialog appears showing the named vector layers.

10. Click Apply to load the vectors onto the display.

11. Click on one of the layer names in the #1 Vector Parameters dialog. In the
Main Image display click and drag the left mouse button to move the cursor in
the image and observe map coordinates for the selected vectors in the #1
Vector Parameters dialog.
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Basic Map Composition

Add Grid Lines

Add a grid to your image:

1. To overlay grid lines on your image, select Overlay → Grid Lines from the
Main Image window menu bar. An image border is automatically added when
you overlay grid lines.

2. You can adjust the grid lines by setting the line thickness and color and the
grid spacing using the Options pull-down menu.

3. When you have added a satisfactory grid, click Apply in the Grid Line
Parameters dialog.

Annotate the Image with a Map Key

ENVI’s flexible annotation features allow you to add text, polygons, color bars, and
other symbols to your plots and images.

1. To annotate the image, select Overlay → Annotation. The #1 Annotation:
Text dialog appears.

2. To annotate a map key corresponding to the DXF overlays, select
Object → Map Key in the #1 Annotation: Text dialog.

3. Edit the map key characteristics by clicking the Edit Map Key Items button in
the dialog. The Map Key Object Definition dialog appears.

4. You can change the names, colors, and fill (for polygons) using the Map Key
Object Definition dialog. Click OK to return to the #1 Annotation: Text
dialog.

5. Add a background color by selecting the color pull-down menu next to the
Back color swatch in the #1 Annotation: Text dialog.

6. Click the left mouse button to place the map key in the Main Image window.
Reposition the map key by clicking, or by clicking and dragging with the left
mouse button. Set the map key by clicking the right mouse button in the image.

Saving and Restoring Annotation

1. You can save your image annotation by selecting File → Save Annotation in
the #1 Annotation: Text dialog.
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Note
If you do not save your annotation in a file, it will be lost when you close the
Annotation dialog (you will be prompted to save the annotation if you close without
first saving).

2. You can also restore saved annotation files by selecting File → Restore
Annotation in the dialog.

Suspending the Annotation Function Temporarily

1. To suspend annotation operations and return to normal ENVI functionality
temporarily, select the Off radio button at the top of the Annotation: Text
dialog.

2. This allows you to use the scroll and zoom features in your display without
losing your annotations.

3. To return to the annotation function, select the radio button for the window you
are annotating.

Save and Output an Image (Burn-In)

ENVI gives you several options for saving and outputting your filtered, annotated,
gridded images. You can save your work in ENVI’s image file format, or in several
popular graphics formats (including Postscript) for printing or importing into other
software packages. You can also output directly to a printer.

Save your Image in GEOTIFF Format

To save your work as a GEOTIFF:

1. Select File → Save Image As → Image File in the Main Image window.

The Output Display to Image File dialog appears.

2. Click on the Output File Type button and select TIFF/GeoTIFF output from
the pull-down menu.

If you have left your annotated and gridded color image on the display, both
the annotation and grid lines will be automatically saved.

3. If output filename shown is not the one you want, enter an output filename in
the text box; otherwise, click OK to save the image.

• Because this is a georeferenced image, ENVI automatically saves it as a
GEOTIFF.
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Note
If you select other graphics file formats from the Output File Type button, your
choices will be slightly different.

End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click OK to exit IDL. If
you are using ENVI RT, quitting ENVI will take you back to your operating system.
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Tutorial 3:

Multispectral
Classification
The following topics are covered in this tutorial:
Overview of This Tutorial . . . . . . . . . . . . . . 90 Examine Landsat TM Color Images . . . . . 92
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Overview of This Tutorial

This tutorial leads you through a typical multispectral classification procedure using
Landsat TM data from Canon City, Colorado. Results of both unsupervised and
supervised classifications are examined and post classification processing including
clump, sieve, combine classes, and accuracy assessment are discussed. It is assumed
that you are already generally familiar with multispectral classification techniques.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 2

Path: envidata/can_tm

File Description

can_tmr.img Boulder Colorado TM Reflectance

can_tmr.hdr ENVI Header for Above

can_km.img K MEANS Classification

can_km.hdr ENVI Header for Above

can_iso.img ISODATA Classification

can_iso.hdr ENVI Header for Above

classes.roi Regions of Interest (ROI) for Supervised
Classification

can_pcls.img Parallelepiped Classification

can_pcls.hdr ENVI Header for Above

can_bin.img Binary Encoding Result

can_bin.hdr ENVI Header for Above

can_sam.img SAM Classification Result

can_sam.hdr ENVI Header for Above

can_rul.img Rule image for SAM classification

can_rul.hdr ENVI Header for Above

can_sv.img Sieved Image
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can_sv.hdr ENVI Header for Above

can_clmp.img Clump of sieved image

can_clmp.hdr ENVI Header for Above

can_comb.img Combined Classes image

can_comb.hdr ENVI Header for Above

can_ovr.img Classes overlain on gray scale image

can_ovr.hdr ENVI Header for Above

can_v1.evf Vector layer generated from class #1

can_v2.evf Vector layer generated from class #2

File Description
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Examine Landsat TM Color Images

This portion of the exercise will familiarize you with the spectral characteristics of
Landsat TM data of Canon City, Colorado, USA. Color composite images will be
used as the first step in locating and identifying unique areas for use as training sets in
classification.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To start ENVI in UNIX, enter envi at the UNIX command line.

• To start ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

Open and Display Landsat TM Data

To open an image file:

1. Select File → Open Image File on the ENVI main menu.

Note
On some platforms you must hold the left mouse button down to display the
submenus from the ENVI main menu.

An Enter Data Filenames file selection dialog appears.

2. Navigate to the can_tm subdirectory of the envidata directory on the ENVI
Tutorial and Data CD No. 2 just as you would in any other application and
select the file can_tmr.img from the list and click OK.

The Available Bands List dialog appears on your screen. This list allows you
to select spectral bands for display and processing.

Note
You have the choice of loading either a gray scale or an RGB color image.
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3. Select the RGB Color radio button in the Available Bands List, and then
click on bands 4, 3, and 2 sequentially with the left mouse button.

The bands you have chosen are displayed in the appropriate fields in the center
of the dialog.

4. Click on the Load RGB button to load the image into a new display.

Review Image Colors

Use the displayed color image as a guide to classification. This image is the
equivalent of a false color infrared photograph. Even in a simple three-band image,
it’s easy to see that there are areas that have similar spectral characteristics. Bright
red areas on the image represent high infrared reflectance, usually corresponding to
healthy vegetation, either under cultivation, or along rivers. Slightly darker red areas
typically represent native vegetation, in this case in slightly more rugged terrain,
primarily corresponding to coniferous trees. Several distinct geologic and
urbanization classes are also readily apparent as is urbanization.

The following figure shows the resulting Main Image window for these bands.

Figure 3-1: Canon City Landsat TM Data.
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Cursor Location/Value

Use ENVI’s Cursor Location/Value dialog to preview image values in the displayed
spectral bands. To bring up a dialog box that displays the location of the cursor in the
Main Image, Scroll, or Zoom windows.

1. Select Tools → Cursor Location/Value from the Main Image window menu
bar.

Alternatively, double-click the left mouse button in the image display to toggle
the Cursor Location/Value dialog on and off.

2. Move the cursor around the image and examine the data values in the dialog
for specific locations. Also note the relation between image color and data
value.

3. Select Files → Cancel in the Cursor Location/Value dialog to dismiss when
finished.

Examine Spectral Plots

Use ENVI’s integrated spectral profiling capabilities to examine the spectral
characteristics of the data.

1. Choose Tools → Profiles → Z Profile (Spectrum) from the Main Image
window menu bar to begin extracting spectral profiles.

2. Examine the spectra for areas that you previewed above using color images
and the Cursor/Location Value dialog by clicking the left mouse button in
any of the display group windows. Note the relations between image color and
spectral shape. Pay attention to the location of the image bands in the spectral
profile, marked by the red, green, and blue bars in the plot.
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3. Select File → Cancel in the Spectral Profile dialog to dismiss it.

Unsupervised Classification

Start ENVI’s unsupervised classification routines from the ENVI main menu, by
choosing Classification → Unsupervised → K-Means or IsoData, or review the
pre-calculated results of classifying the image in the can_tm directory.

K-Means

Unsupervised classification uses statistical techniques to group n-dimensional data
into their natural spectral classes. The K-Means unsupervised classifier uses a cluster
analysis approach which requires the analyst to select the number of clusters to be
located in the data, arbitrarily locates this number of cluster centers, then iteratively
repositions them until optimal spectral separability is achieved.

Choose K-Means as the method, use all of the default values and click on OK, or
review the results contained in can_km.img.

1. Open the file can_km.img, click on the Gray Scale radio button in the
Available Bands List, click on the band name at the top of the list, select New
Display on the Display button pull-down menu, and then Load Band.

Figure 3-2: Spectral Plots from Canon City TM Data.
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2. From the Main Image display menu, select Tools → Link → Link Displays
and click OK in the dialog to link the images.

3. Compare the K-MEANS classification result to the color composite image by
clicking and dragging using the left mouse button to move the dynamic
overlay around the image.

4. When finished, select Tools → Link → Unlink Display to remove the link
and dynamic overlay.

If desired, experiment with different numbers of classes, change thresholds, standard
deviations, and maximum distance error values to determine their effect on the
classification.

Isodata

IsoData unsupervised classification calculates class means evenly distributed in the
data space and then iteratively clusters the remaining pixels using minimum distance
techniques. Each iteration recalculates means and reclassifies pixels with respect to
the new means. This process continues until the number of pixels in each class
changes by less than the selected pixel change threshold or the maximum number of
iterations is reached.

Choose IsoData as the method, use all of the default values and click on OK, or
review the results contained in can_iso.img.

1. Open the file can_iso.img, click on the Gray Scale radio button in the
Available Bands List, click on the band name at the top of the list, select the
Display #1 button and choose New Display on the pull-down menu. Then
click on the Load Band button.

2. Select Tools → Link → Link Displays. Click OK to link this image to the
color composite image and the K-MEANS result.

3. Compare the IsoData classification result to the color composite image by
clicking and dragging using the left mouse button to move the dynamic
overlay around the image. Toggle the dynamic overlay of the third image by
holding the left mouse button down and simultaneously clicking on the middle
mouse button. Compare the ISODATA and K-MEANS classifications.

4. Select File → Cancel to dismiss the two image displays.

If desired, experiment with different numbers of classes, change thresholds, standard
deviations, maximum distance error, and class pixel characteristic values to
determine their effect on the classification.
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Supervised Classification

Supervised classification requires that the user select training areas for use as the
basis for classification. Various comparison methods are then used to determine if a
specific pixel qualifies as a class member. ENVI provides a broad range of different
classification methods, including Parallelepiped, Minimum Distance, Mahalanobis
Distance, Maximum Likelihood, Spectral Angle Mapper, Binary Encoding, and
Neural Net. Examine the processing results below, or use the default classification
parameters for each of these classification methods to generate your own classes and
compare results.

To perform your own classifications from the ENVI main menu, select
Classification → Supervised → [method], where [method] is one of the supervised
classification methods in the pull-down menu (Parallelepiped, Minimum Distance,
Mahalanobis Distance, Maximum Likelihood, Spectral Angle Mapper, Binary
Encoding, or Neural Net). Use one of the two methods below for selecting training
areas, also known as regions of interest (ROIs).

Select Training Sets Using Regions of Interest (ROI)

As described in Tutorial 1, “Introduction to ENVI” and summarized here, ENVI lets
you easily define regions of interest (ROIs) typically used to extract statistics for
classification, masking, and other operations. For the purposes of this exercise, you
can either use predefined ROIs, or create your own.

Restore Predefined ROIs

1. Use pre-selected regions of interest by starting the #1 ROI Tool dialog by
choosing from the #1 Main Image menu bar Overlay → Region of Interest.

2. In the #1 ROI Tool dialog choose File → Restore ROIs.

3. The Enter ROI Filename dialog opens. Select CLASSES.ROI as the input file
to restore.

Create Your Own ROIs

1. Select Overlay → Region of Interest from the Main Image window menu
bar. The ROI Tool dialog for the display group appears.

2. In the Main Image window draw a polygon that represents the new region of
interest. To accomplish this, do the following.

• Click the left mouse button in the Main Image window to establish the first
point of the ROI polygon.
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• Select further border points in sequence by clicking the left button again,
and close the polygon by clicking the right mouse button.The middle
mouse button deletes the most recent point, or (if you have closed the
polygon) the entire polygon. Fix the polygon by clicking the right mouse
button a second time.

• ROIs can also be defined in the Zoom and Scroll windows by choosing the
appropriate radio button at the top of the ROI Controls dialog.

When you have finished defining an ROI, it is shown in the dialog’s list of
Available Regions, with the name, region color, and number of pixels
enclosed, and is available to all of ENVI’s classification procedures.

3. To define a new ROI, click the New Region button.

• You can enter a name for the region and select the color and fill patterns
for the region by clicking on the Edit button to bring up the Edit ROI
Parameters dialog. Define the new ROI as described above.

Classical Supervised Multispectral Classification

The following methods are described in most remote sensing textbooks and are
commonly available in today’s image processing software systems.

Parallelepiped

Parallelepiped classification uses a simple decision rule to classify multispectral data.
The decision boundaries form an n-dimensional parallelepiped in the image data
space. The dimensions of the parallelepiped are defined based upon a standard
deviation threshold from the mean of each selected class.

1. Pre-saved results are in the file can_pcls.img. Examine these or perform
your own classification using the CLASSES.ROI regions of interest described
above. Try using the default parameters and various standard deviations from
the mean of the ROIs.

2. Use image linking and dynamic overlay to compare this classification to the
color composite image and previous unsupervised classifications.
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Maximum Likelihood

Maximum likelihood classification assumes that the statistics for each class in each
band are normally distributed and calculates the probability that a given pixel belongs
to a specific class. Unless a probability threshold is selected, all pixels are classified.
Each pixel is assigned to the class that has the highest probability (i.e., the maximum
likelihood).

1. Perform your own classification using the CLASSES.ROI regions of interest
described above. Try using the default parameters and various probability
thresholds.

2. Use image linking and dynamic overlay to compare this classification to the
color composite image and previous unsupervised and supervised
classifications.

Minimum Distance

The minimum distance classification uses the mean vectors of each ROI and
calculates the Euclidean distance from each unknown pixel to the mean vector for
each class. All pixels are classified to the closest ROI class unless the user specifies

Figure 3-3: Parallelepiped Classification Image.
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standard deviation or distance thresholds, in which case some pixels may be
unclassified if they do not meet the selected criteria.

1. Perform your own classification using the CLASSES.ROI regions of interest
described above. Try using the default parameters and various standard
deviations and maximum distance errors.

2. Use image linking and dynamic overlay to compare this classification to the
color composite image and previous unsupervised and supervised
classifications.

Mahalanobis Distance

The Mahalanobis Distance classification is a direction sensitive distance classifier
that uses statistics for each class. It is similar to the Maximum Likelihood
classification but assumes all class covariances are equal and therefore is a faster
method. All pixels are classified to the closest ROI class unless the user specifies a
distance threshold, in which case some pixels may be unclassified if they do not meet
the threshold.

1. Perform your own classification using the CLASSES.ROI Regions of Interest
described above. Try using the default parameters and various maximum
distance errors.

2. Use image linking and dynamic overlay to compare this classification to the
color composite image and previous unsupervised and supervised
classifications.

Spectral Classification Methods

The following methods are described in the ENVI 3.5 User’s Guide. These were
developed specifically for use on Hyperspectral data, but provide an alternative
method for classifying multispectral data, often with improved results that can easily
be compared to spectral properties of materials. They typically are used from the
Endmember Collection dialog using image or library spectra, however, they can also
be started from the classification menu, Classification → Supervised → [method],
where [method] represents one of the methods shown in the pull-down menu.

The Endmember Collection Dialog

The Endmember Collection:Parallel dialog is a standardized means of collecting
spectra for supervised classification from ASCII files, regions of interest, spectral
libraries, and statistics files.

1. To start the Classification Input File dialog from the ENVI main menu, select
Spectral → Mapping Methods → Endmember Collection.
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This dialog can also be started by choosing Classification → Endmember
Collection from the ENVI main menu.

2. In the Classification Input File dialog, click on the Open File button at the
bottom of the dialog.

3. A new file selection dialog appears. In the Please Select a File dialog, choose
the input file can_tmr.img and click Open (Windows) or OK (UNIX). The
can_tmr.img file will appear in the Select Input File: section of the
Classification Input File dialog.

4. Click on the can_tmr.img file within the Select Input File: section of this
dialog and then click OK.

5. This brings up the Endmember Collection:Parallel dialog.

The Endmember Collection dialog appears with the Parallelepiped classification
method selected by default. The available classification and mapping methods are
listed by choosing Algorithm → [method] from the Endmember Collection dialog
menu bar, where [method] represents one of the methods available: currently
including Parallelepiped, Minimum Distance, Manlanahobis Distance,
Maximum Likelihood, Binary Encoding, and the Spectral Angle Mapper (SAM).

Figure 3-4: Endmember Collection dialog.
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Binary Encoding Classification

The binary encoding classification technique encodes the data and endmember
spectra into 0s and 1s based on whether a band falls below or above the spectrum
mean. An exclusive OR function is used to compare each encoded reference
spectrum with the encoded data spectra and a classification image is produced. All
pixels are classified to the endmember with the greatest number of bands that match
unless the user specifies a minimum match threshold, in which case some pixels may
be unclassified if they do not meet the criteria.

1. Pre-saved Binary Encoding results are in the file can_bin.img. These were
created using a minimum encoding threshold of 75%. Examine these or
perform your own classification using the CLASSES.ROI regions of interest
described above. To do your own classification, select Algorithm → Binary
Encoding from the menu bar.

2. Use the predefined regions of interest in the file CLASSES.ROI. From the
Endmember Collection dialog menu bar, select Import → from ROI from
Input File.

3. The Input Regions of Interest dialog appears. Click the Select All Items
button, and click OK.

4. You can view the Endmember Spectra plots for the ROIs from the
Endmember Collections dialog menu bar by choosing Options → Plot
Endmembers.

5. In the Endmember Collections dialog click on Apply. This brings up the
Binary Encoding Parameters dialog box.

6. In the Binary Encoding Parameters dialog, click the Memory radio button in
the Output Result to section.

7. Click on the spin button for the Output Rule Images text field to change it to
No and click OK at the bottom of the dialog to start the classification.

8. Use image linking and dynamic overlays to compare this classification to the
color composite image and previous unsupervised and supervised
classifications.

Spectral Angle Mapper Classification

The Spectral Angle Mapper (SAM) is a physically-based spectral classification that
uses the n-dimensional angle to match pixels to reference spectra. The algorithm
determines the spectral similarity between two spectra by calculating the angle
between the spectra, treating them as vectors in a space with dimensionality equal to
the number of bands.
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1. Pre-saved SAM Classification results are in the file can_sam.img. Examine
these or perform your own classification using the CLASSES.ROI Regions of
Interest described above, which will be listed in the Endmember Collection
dialog. To do your own classification, select Algorithm → Spectral Angle
Mapper from the Endmember Collection menu bar. Click Apply to start the
classification.

2. If performing your own classification, enter the output filename
can_tmr.sam for the SAM classification image in the Endmember Collection
dialog. Also enter the filename can_rul.img as the rule output image name
and click OK at the bottom of the dialog to start the classification.

3. Use image linking and dynamic overlays to compare this classification to the
color composite image and previous unsupervised and supervised
classifications.

Rule Images

ENVI creates images that show the pixel values used to create the classified image.
These optional images allow users to evaluate classification results and to reclassify
if desired based on thresholds. These are gray scale images; one for each ROI or
endmember spectrum used in the classification.

Figure 3-5: Rule Image for Canon City Landsat TM, Spectral Angle Mapper
Classification. Stretched to show best matches (low spectral angles) as bright

pixels.
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The rule image pixel values represent different things for different types of
classifications, for example:

1. For the SAM classification above, load the classified image and the rule
images into separate displays and compare using dynamic overlays. Invert the
SAM rule images using Tools → Color Mapping → ENVI Color Tables and
dragging the Stretch Bottom and Stretch Top sliders to opposite ends of the
dialog. Areas with low spectral angles (more similar spectra) should appear
bright.

2. Create classification and rule images using the other methods. Use dynamic
overlays and Cursor Location/Value to determine if better thresholds could
be used to obtain more spatially coherent classifications.

3. If you find better thresholds, select Classification → Post
Classification → Rule Classifier from the ENVI main menu.

4. Double-click the can_tmr.sam input file to bring up the Rule Image
Classifier Tool, enter a threshold to create a new classified image. Compare
your new classification to the previous classifications.

Post Classification Processing

Classified images require post-processing to evaluate classification accuracy and to
generalize classes for export to image-maps and vector GIS. ENVI provides a series
of tools to satisfy these requirements

Classification Method Rule Image Values

Parallelepiped Number of bands that satisfied the parallelepiped
criteria.

Minimum Distance Sum of the distances from the class means

Maximum Likelihood Probability of pixel belonging to class

Mahalanobis Distance Distances from the class means

Binary Encoding Binary Match in Percent

Spectral Angle Mapper Spectral Angle in Radians (smaller angles indicate
closer match to the reference spectrum)
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Class Statistics

This function allows you to extract statistics from the image used to produce the
classification. Separate statistics consisting of basic statistics (minimum value,
maximum value, mean, std deviation, and eigenvalue), histograms, and average
spectra are calculated for each class selected.

1. Choose Classification → Post Classification → Class Statistics to start the
process and select the Classification Image can_pcls.img and click OK.

2. Next select the image used to produce the classification can_tmr.img and
click OK.

3. Use the Class Selection dialog to choose the classes for statistics. Click on
Select All Items, then OK.

4. Finally, choose the statistics to be calculated in the Compute Statistics
Parameters dialog, click OK at the bottom of the Compute Statistics
Parameters dialog.

Several plots and reports will appear, depending on the statistics options selected.

Confusion Matrix

ENVI’s confusion matrix function allows comparison of two classified images (the
classification and the “truth” image), or a classified image and ROIs. The truth image
can be another classified image, or an image created from actual ground truth
measurements.

Figure 3-6: Statistics reports from Parallelepiped Classification of Canon City,
CO, Thematic Mapper data.
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1. Select Classification → Post Classification → Confusion
Matrix → [method], where [method] is either Using Ground Truth Image,
or Using Ground Truth ROIs.

2. For the Ground Truth Image Method, compare the Parallelepiped and SAM
methods by entering the two filenames can_sam.img and can_pcls.img
and clicking OK (for the purposes of this exercise, we are using the
can_pcls.img file as the ground truth).

3. Use the Match Classes Parameters dialog to pair corresponding classes from
the two images and click OK.

4. Use Output Result to radio button to output the result to Memory and then
click OK in the Confusion Matrix Parameters dialog.

5. Examine the confusion matrix and confusion images. Determine sources of
error by comparing the classified image to the original reflectance image using
dynamic overlays, spectral profiles, and Cursor Location/Value.

6. For the Using Ground Truth ROIs method, select the classified image
can_sam.img to be evaluated.

7. Match the image classes to the ROIs loaded from CLASSES.ROI, and click
OK to calculate the confusion matrix.

8. Click OK in the Confusion Matrix Parameters dialog.

9. Examine the confusion matrix and determine sources of error by comparing
the classified image to the ROIs in the original reflectance image using
spectral profiles, and Cursor Location/Value.
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Clump and Sieve

Clump and Sieve provide means for generalizing classification images. Sieve is
usually run first to remove the isolated pixels based on a size (number of pixels)
threshold, and then clump is run to add spatial coherency to existing classes by
combining adjacent similar classified areas. Compare the pre-calculated results in the
files can_sv.img (sieve) and can_clmp.img (clump of the sieve result) to the
classified image can_pcls.img (parallelepiped classification) or calculate your
own images and compare to one of the classifications.

Figure 3-7: Confusion Matrix using a second classification image as Ground
Truth.
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1. To execute the function, select Classification → Post Classification → Sieve
Classes, choose one of the classified images, enter an output to Memory and
click OK.

2. Use the output of the sieve operation as the input for clumping. Choose
Classification → Post Classification → Clump Classes, choose the
previously-made image from memory and click OK.

3. Output to memory and click OK in the Clump Parameters dialog.

4. Compare the three images and reiterate if necessary to produce a generalized
classification image.

Combine Classes

The Combine Classes function provides an alternative method for classification
generalization. Similar classes can be combined to form one or more generalized
classes.

1. Examine the pre-computed image can_comb.img or perform your own
combinations as described below.

2. Select Classification → Post Classification → Combine Classes.

3. Select the can_sam.img file in the Combine Classes Input File dialog and
click OK.

4. Choose Region 3 to combine with Unclassified, click on Add Combination,
and then OK in the Combine Classes Parameters dialog. Output memory and
click OK.

5. Compare the combined class image to the classified images and the
generalized classification image using image linking and dynamic overlays.

Edit Class Colors

When a classification image is displayed, you can change the color associated with a
specific class by editing the class colors.

1. Select Tools → Color Mapping → Class Color Mapping in the Main Image
Display window.

2. Click on one of the class names in the Class Color Mapping dialog and
change the color by dragging the appropriate color sliders or entering the
desired data values. Changes are applied to the classified image immediately.
To make the changes permanent, select Options → Save Changes in the
dialog.
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Overlay Classes

Overlay classes allows the user to place the key elements of a classified image as a
color overlay on a gray scale or RGB image.

1. Examine the pre-calculated image can_ovr.img or create your own
overlay(s) from the can_tmr.img reflectance image and one of the classified
images above.

2. Select Classification → Post Classification → Overlay Classes from the
ENVI main menu.

3. Choose the current display as an input for class overly from the Available
Bands List dialog.

4. Select can_tmr.img band 3 for each RGB band (band 3 for the R band,
band 3 for the G band, and band 3 for the B band) in the Input Overlay RGB
Image Input Bands dialog and click OK.

5. Use can_comb.img as the classification input in the Classification Input File
dialog.

6. Click OK and then choose Region #1 and Region #2 in the Class Overlay to
RGB Parameters dialog to overlay on the image. Output to memory and click
OK to complete the overlay.

7. Load the overlay image into an image display and compare with the classified
image and the reflectance image using linking and dynamic overlays.

Interactive Classification Overlays

In addition to the methods above for working with classified data, ENVI also
provides an interactive classification overlay tool. This tool allows you to
interactively toggle classes on and off as overlays on a displayed image, to edit
classes, get class statistics, merge classes, and edit class colors.

1. Display band 4 of can_tmr.img as a gray scale image using the Available
Bands List dialog.

2. From the Main Image window menu bar, select Overlay → Classification.

3. Choose one of the available classified images (a good choice is
can_sam.img) in the Interactive Class Tool Input File dialog and click OK.

The Interactive Class Tool dialog will appear and each class will be listed
with it’s corresponding colors.
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4. Click in each On check box to change the display of each class as an overlay
on the gray scale image.

5. Try the various options for assessing the classification under the Options
menu.

6. Choose various options under the Edit menu to interactively change the
contents of specific classes.

7. Select File → Save Image As → [Device] in the Main Image window (where
[Device] is either Postscript or Image) to burn in the classes and output to a
new file.

8. Select File → Cancel to exit the interactive tool.

Classes to Vector Layers

Load the pre-calculated vector layers onto the gray scale reflectance image for
comparison to raster classified images, or execute the function and convert one of the
classification images to vector layers. You can use the following steps to load the pre-
calculated vector layers produced from the clumped classification image above:

1. Select Overlay → Vectors in the Main Image window with the clumped
image can_clmp.img displayed.

2. Choose File → Open Vector File → ENVI Vector File in the Vector
Parameters dialog and choose the files can_v1.evf and can_v2.evf. Choose
Select All Layers in the Available Vectors List dialog, then choose Load
Selected. Select the can_dmp.img. From the Vector Parameters dialog, click
Apply to load the vector layers onto the image display. The vectors derived
from the classification polygons will outline the raster classified pixels.

To complete your own classification to vector conversion:

1. Select Classification → Post Classification → Classification to Vector and
choose the generalized image can_clmp.img within the Raster to Vector
Input Band dialog.

2. Select Region #1 and Region #2 and enter the root name canrtv and click
OK to begin the conversion.

3. Select the two regions in the Available Vectors List dialog click on Load
Selected at the bottom of the dialog.

4. Choose the correct display number in the Load Vector dialog for the gray
scale reflectance image and the vector layers will be loaded into the Vector
Parameters dialog. Click Apply to display the vectors over the image. Use
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Edit Layers to change the colors and fill of the vector layers to make them
more visible.

Classification Keys Using Annotation

ENVI provides annotation tools to put classification keys on images and in map
layouts. The classification keys are automatically generated.

1. Choose Overlay → Annotation from the Main Image window menu bar for
either one of the classified images, or for the image with the vector overlay.

2. Select Object → Map Key to start annotating the image. You can edit the key
characteristics by clicking on the Edit Map Key Items button in the
Annotation: Map Key dialog and changing the desired characteristics.

3. Click and drag the map key using the left mouse button in the display to place
the key.

4. Click in the display with the right mouse button to finalize the position of the
key. For more information about image annotation, please see the ENVI 3.5
User’s Guide.

End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then clicking OK to exit IDL.

Figure 3-8: Classification image with classification key.
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If you are using ENVI RT, quitting ENVI will take you back to your operating
system.
Examine Landsat TM Color Images ENVI Tutorials



Tutorial 4:

Image Georeferencing
and Registration
The following topics are covered in this tutorial:
Overview of This Tutorial . . . . . . . . . . . . . 114
Georeferenced Images in ENVI . . . . . . . . 116

Georeferenced Data and Image-Map . . . . . 117

Image to Image Registration . . . . . . . . . . 125
Image to Map Registration . . . . . . . . . . . . 132

HSV Merge of Different Resolution
Georeferenced Data Sets . . . . . . . . . . . . . 139
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Overview of This Tutorial

This tutorial provides basic information about georeferenced images in ENVI and
Image-to-Image and Image-to-Map Registration using ENVI. It covers step-by-step
procedures for successful registration, discusses how to make image-maps using
ENVI and illustrates the use of multi-resolution data for HSV Sharpening. It is
designed to provide a starting point to users trying to conduct image registration. It
assumes that you are already familiar with general image-registration and resampling
concepts. This tutorial is designed to be completed in about 1 to 2 hours.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/bldr_reg

File Description

Required Files

bldr_sp.img Boulder SPOT Georeferenced Image Subset

bldr_sp.hdr ENVI Header for Above

bldr_sp.grd Boulder SPOT Map Grid Parameters

bldr_sp.ann Boulder SPOT Map Annotation

bldr_tm.img Non-Georeferenced Boulder TM Data

bldr_tm.hdr ENVI Header for Above

bldr_tm.pts GCPs for TM-SPOT Image-to-Image Registration

bldrtm_m.pts GCPs for TM-Map Registration

bldr_rd.dlg Boulder Roads DLG

bldrtmsp.grd Merged TM-SPOT Map Grids

bldrtmsp.ann Merged TM-SPOT Annotation

Generated Files

bldr_tm1.wrp Image-to-Image Result Using RST and Nearest
Neighbor

bldr_tm1.hdr ENVI Header for Above
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bldr_tm2.wrp Image-to-Image Result Using RST and Bilinear
Interpolation

bldr_tm2.hdr ENVI Header for Above

bldr_tm3.wrp Image-to-Image Result Using RST and Cubic
Convolution

bldr_tm3.hdr ENVI Header for Above

bldr_tm4.wrp Image-to-Image Result Using 1st degree polynomial
and Cubic Convolution

bldr_tm4.hdr ENVI Header for Above

bldr_tm5.wrp Image-to-Image Result Using Delaunay Triangulation
and Cubic Convolution

bldr_tm5.hdr ENVI Header for Above

bldr_tm5.hdr ENVI Header for Above

bldrtm_m.img Image-to-Map Result using RST and Cubic
Convolution for the Boulder TM data

bldrtm_m.hdr ENVI Header for Above

bldrtmsp.img Boulder TM/SPOT sharpening result using HSV
sharpening, 10 meter pixels

bldrtmsp.hdr ENVI Header for Above

File Description
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Georeferenced Images in ENVI

ENVI provides full support for georeferenced images in numerous predefined map
projections including UTM and State Plane. In addition, ENVI’s user-configurable
map projections allow construction of custom map projections utilizing 6 basic
projection types, over 35 different ellipsoids and more than 100 datums to suit most
map requirements.

ENVI map projection parameters are stored in an ASCII text file map_proj.txt
that can be modified by ENVI map projection utilities or edited directly by the user.
The information in this file is used in the ENVI Header files associated with each
image and allows simple association of a Magic Pixel location with known map
projection coordinates. Selected ENVI functions can then use this information to
work with the image in georeferenced data space.

ENVI’s image registration and geometric correction utilities allow you to reference
pixel-based images to geographic coordinates and/or correct them to match base
image geometry. Ground control points (GCPs) are selected using the full resolution
(Main Image) and Zoom windows for both image-to-image and image-to-map
registration. Coordinates are displayed for both base and uncorrected image GCPs,
along with error terms for specific warping algorithms. Next GCP point prediction
allows simplified selection of GCPs.

Warping is performed using resampling, scaling and translation (RST), polynomial
functions (of order 1 through n), or Delaunay triangulation. Resampling methods
supported include nearest-neighbor, bilinear interpolation, and cubic convolution.
Comparison of the base and warped images using ENVI’s multiple Dynamic Overlay
capabilities allows quick assessment of registration accuracy.

The following sections provide examples of some of the map-based capabilities built
into ENVI. Consult the ENVI 3.5 User’s Guide for additional information.
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Georeferenced Data and Image-Map

This portion of the exercise will familiarize you with the use of georeferenced data in
ENVI, allow you to construct an image-map complete with map grids and annotation,
and produce an output image.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To open ENVI in UNIX, enter envi at the UNIX command line.

• To open ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has loaded and executed.

Open and Display SPOT Data

To open the Georeferenced SPOT data:

1. Select File → Open Image File on the ENVI main menu.

Note
On some platforms you must hold the left mouse button down to display the
submenus from the menu bar.

2. When the Enter Data Filename file-selection dialog appears, navigate to the
bldr_reg subdirectory of the envidata directory and select the file
bldr_sp.img from the list.

3. Click OK.

4. When the Available Bands List dialog appears, click on the Gray Scale radio
button and select the SPOT band listed at the top of the dialog by clicking on
the band with the left mouse button.

The band you have chosen will be displayed in the field marked Selected
Band:.

5. Click the Load Band button to load the image into a new display.

Edit Map Info in ENVI Header

1. From the ENVI main menu, select File → Edit ENVI Header.
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2. When the Edit Header Input File dialog appears, select the file
bldr_sp.img and click OK.

3. The Header Info: [filename] dialog opens. In this dialog, select the Edit
Attributes button and Map Info from the pull-down menu to start the Map
Information dialog.

This dialog lists the basic map information used by ENVI in georeferencing. The
image coordinates correspond to the Magic Pixel used by ENVI as the starting point
for the map coordinate system. Because ENVI knows the map projection, pixel size,
and map projection parameters based on this header information and the map
projection text file, it is able to calculate the geographic coordinates of any pixel in
the image. Coordinates can be entered in either map coordinates or geographic
coordinates.

4. Click on the spin box arrow next to the Projection/Datum field to see the
latitude/longitude coordinates for the UTM Zone 13 North map projection.

ENVI makes this conversion on-the-fly.

5. Click on the active DMS or DDEG button to toggle between Degrees-
Minutes- Seconds, and Decimal Degrees, respectively.

6. Click Cancel to exit the Map Information dialog.

Figure 4-1: The Map Information Dialog.
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7. Click Cancel to exit the Header Info: [filename] dialog.

Cursor Location/Value

To open a dialog box that displays the location of the cursor in the Main Image,
Scroll, or Zoom windows, do the following.

1. From the Main Image window menu bar, select Tools → Cursor
Location/Value.

You can also open this dialog from both the ENVI main menu and the Main
Image window menu bar, by selecting Window → Cursor Location/Value.

Note that the coordinates are given in both pixels and georeferenced
coordinates for this georeferenced image.

2. Move the cursor around the image and examine the coordinates for specific
locations and note the relation between map coordinates and
latitude/longitude.

3. Select File → Cancel to dismiss the dialog when finished.

Overlay Map Grids

1. From the Main Image window menu bar, select Overlay → Grid Lines.

The #1 Grid Line Parameters dialog appears and a virtual border is added to
the image to allow display of map grid labels exterior to the image.

Figure 4-2: The Cursor Location dialog displays the pixel and georeferenced
coordinates for georeferenced images.
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2. In the new dialog, select File → Restore Setup. A file selection dialog opens.

3. In the Enter Grid Parameters Filename dialog, select the file bldr_sp.grd
and click Open.

Previously saved grid parameters are loaded into the dialog.

4. In the #1 Grid Line Parameters dialog you can examine the map parameters
by selecting Options → Edit Map Grid Attributes from the dialog menu bar.
An Edit Map Attributes dialog opens.

5. In the Edit Map Attributes dialog, note the grid spacing and the parameters
that control the color and other characteristics of the lines, labels, corners, and
the box (outlining box).

6. Click File → Cancel to close the dialog when you are finished.

7. Now in the #1 Grid Line Parameters dialog you can examine the geographic
parameters by selecting Options → Edit Geographic Grid Attributes from
the menu bar. This opens the Edit Grid Attributes dialog.

Figure 4-3: The Grid Line Parameters dialog.
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Note again the parameters for the geographic (latitude/longitude) grid. Click
Cancel to close the dialog when you are finished.

8. Click Apply in the Grid Line Parameters dialog to put the grids on the
image.

ENVI allows simultaneous pixel, map, and geographic coordinate grids.

Overlay Map Annotation

1. In the Main Image display, select Overlay → Annotation. This opens the #1
Annotation: Text dialog.

2. In the new dialog, select File → Restore Annotation. Doing this opens a
standard file selection dialog.

3. In the Enter Annotation Filename dialog, choose the file bldr_sp.ann
from the file list and click OK.

The pre-saved map annotation is loaded onto the image.

4. Enlarge the Scroll window by grabbing one of the corners and dragging.
Reposition the resized Scroll window so you can see the Main Image window
simultaneously.

5. In the resized Scroll window, move the main image indicator box using the left
mouse button and examine the map elements which appear in the Main Image
window.

6. In the #1 Annotation: Text dialog, click and hold the Object menu to examine
the objects you can use to annotate the map.

Output to Image or Postscript

ENVI gives you several options for saving and outputting your image-maps. You can
save your work in ENVI’s image file format, or in several popular graphics formats
(including Postscript) for printing or importing into other software packages.

Saving Your Image in ENVI Image Format

To save your work in ENVI’s native format (as an RGB file) do the following.

1. In the Main Image window, select File → Save Image As → Image File.

2. When the Output Display to Image File dialog appears, select the Output File
Type button pull-down menu (default file type setting is ENVI) to see the
different formats available.
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The Change Graphics Overlay Selections button opens a dialog of the same
name which allows you to add or delete many graphics overlay options,
including annotations and gridlines.

The Change Image Border Size button also opens a dialog of the same name.
This dialog allows you to change the top, bottom, left, and right border widths
and also the border color if desired.

If you have left your annotated and gridded color image on the display, both
the annotation and grid lines will be automatically listed in the graphics
options. You can also select other annotation files to be layered onto the output
image.

3. You can choose whether you want your result to be saved to a file on disk or to
memory by selecting either the radio button labeled Memory, or the File radio
button. This time, select Memory and click OK to output the image.

4. The Available Bands List now has the new image available. Open another
display by clicking on the Display #1 button pull-down menu in the Available
Bands List and choosing New Display from the menu.

5. Select the RGB Color radio button and load the image in from memory by
selecting the R, G, and B (Georeferenced SPOT) data bands successively.

6. Then select the Load RGB button to display the results of the annotation as a
raster image.

Saving your Image to Postscript

To save your work to a Postscript file perform the following.

1. In the Main Image window, select File → Save Image As → Postscript File.

The Output Display to Postscript File dialog appears. Both the annotation
and grid lines will be automatically listed in the graphics options. A graphical
representation of the output page appears at the right top of the dialog.
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2. Enter the desired size of the output image in the xsize and ysize parameter text
fields. By clicking the left mouse button in the representational graphic you
can see the new image size outline and position in the graphical representation
of the output page in the dialog.

3. Click the right mouse button in the graphic to center the image on the page.

• If you’d like scaled map output, enter the desired map scale in the Map
Scale text box, and then click the left mouse button in the graphic
representation to see the result.

If the scale makes the image larger than the available page size, ENVI
automatically creates a multi-page Postscript document.

Figure 4-4: The Display to Postscript dialog for output of the above image map.
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4. If you have a large-scale plotter, change the Page size to the plot size and the
scaled image will be output to a Postscript file that can be plotted to scale
directly on the plotter.

Note
Create the Postscript file only if you can print color output and print the file using
your standard operating system procedures for printing Postscript output.

5. Save the postscript print settings by clicking OK.

If you can’t print color output, click Cancel to cancel the output operation.

Direct Printing

ENVI also allows direct printing to devices supported by your operating system.

1. From the Main Image window, select File → Print. This opens your operating
systems standard Print dialog, and you can now follow your standard printing
procedures.

2. Once you have selected all of the parameters in the operating system’s
standard Print dialog and clicked OK, ENVI opens an Output Display to
Printer dialog to allow you to set additional basic ENVI printing parameters
similar to those used for postscript output procedure (see above). Adjust these
print settings as desired and click OK to begin printing.
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Image to Image Registration

This section of the tutorial takes you step-by-step through an Image to Image
registration. The georeferenced SPOT image will be used as the Base image, and a
pixel-based Landsat TM image will be warped to match the SPOT.

Open and Display Landsat TM Image File

1. From the ENVI main menu, select File → Open Image File.

2. When the Enter Data Filenames dialog appears, navigate to the bldr_reg
subdirectory of the envidata directory and select the file bldr_tm.img
from the list.

3. Click Open (OK on UNIX) in the file selection dialog to load the TM image
bands into the Available Bands List.

4. Click on Band 3 in the list, select the No Display button menu and New
Display from the pull-down menu.

5. Then click on the Load Band button to load the TM band 3 image into a new
display.

Display the Cursor Location/Value

To bring up a dialog box that displays the location of the cursor in the Main, Scroll,
or Zoom windows do the following.

1. From the Main Image display menu bar, select Tools → Cursor
Location/Value.

2. Move the cursor around the TM image in the Main Image, Scroll, and Zoom
windows.

Note that the coordinates are given in pixels since this is a pixel-based rather
than georeferenced image like the SPOT data above.

3. Select File → Cancel to dismiss the Cursor Location/Value dialog.

Start Image Registration and Load GCPs

1. From the ENVI main menu bar, select Map → Registration → Select GCPs:
Image to Image.
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2. The Image to Image Registration dialog appears. For the Base Image, click
on Display #1 (the SPOT image) to select it. For the Warp Image select
Display #2 (the TM image).

3. Click OK to start the registration. This opens the Ground Control Points
Selection dialog.

Individual ground control points (GCPs) are added by positioning the cursor
position in the two images to the same ground location.

4. Move the cursor in the SPOT image to 753, 826 by entering the values into the
Ground Control Points Selection dialog in the Base X and Y text boxes.

5. Move the cursor in the TM image to 331, 433 by entering the values in the
same way into the dialog in the Warp X and Y text boxes.

6. Examine the locations in the two Zoom windows and adjust the locations if
necessary by clicking the left mouse button in each Zoom window at the
desired locations.

Note that sub-pixel positioning is supported in the Zoom windows. The larger
the zoom factor, the finer the positioning capabilities.

7. In the Ground Control Points Selection dialog, click Add Point to add the
GCP to the list. Click Show List to view the GCP list. Try this for a few points
to get the feel of selecting GCPs.

Note the list of actual and predicted points in the dialog. Once you have at least
4 points, the RMS error is reported.

Figure 4-5: The Ground Control Points Selection dialog used for image to image
registration.
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8. In the Ground Control Points Selection dialog, select Options → Clear All
Points to clear all of your points.

9. In the Ground Control Points Selection dialog, choose File → Restore
GCPs from ASCII.

10. In the Enter Ground Control Points Filename dialog, select the file name
bldr_tm.pts, and click OK to load a list of pre-saved GCPs.

11. Click on individual GCPs in the Image to Image GCP List dialog and
examine the locations of the points in the two images, the actual and predicted
coordinates, and the RMS error. Resize the dialog to observe the total RMS
Error listed in the Ground Control Points Selection dialog.

Working with GCPs

The following descriptions are provided for information only. Perform only the
numbered Predict GCP button functions.

• The position of individual GCPs can be edited by selecting the appropriate
GCP in the Image to Image GCP List dialog and editing in the Ground
Control Points Selection dialog. Either enter a new pixel location, or move
the position pixel-by-pixel using the direction arrows in the dialog.

• Clicking on the On/Off button in the Image to Image GCP List dialog
removes selected GCPs from consideration in the Warp model and RMS
calculations. These GCPs aren’t actually deleted, just disregarded, and can be
toggled back on using the On/Off button.

Figure 4-6: Image to Image GCP LIst dialog for image to image registration.
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• In the Image to Image GCP List dialog, clicking on the Delete button
removes a GCP from the list.

• Positioning the cursor location in the two Zoom windows and clicking the
Update button in the Image to Image GCP List dialog updates the selected
GCP to the current cursor locations.

• The Predict button in the Image to Image GCP List dialog allows prediction
of new GCPs based on the current warp model.

1. Try positioning the cursor at a new location in the Main Image containing the
SPOT image. Click on the Predict button and the cursor position in the TM
image will be moved to match its predicted location based on the warp model.

2. The exact position can then be interactively refined by moving the pixel
location slightly in the TM data.

3. In the Ground Control Points Selection dialog, click Add Point to add the
new GCP to the list.

Warp Images

Images can be warped from the displayed band, or multiband images can be warped
all bands at once. We will warp only the displayed band.

1. In the Ground Control Points Selection dialog, select Options → Warp
Displayed Band.

2. The Registration Parameters dialog appears. Use the Warp Method button
menu to select RST, and the Resampling button menu to select Nearest
Neighbor resampling.
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3. Enter the filename bldr_tm1.wrp and click OK.

The warped image will be listed in the Available Bands List when the warp is
completed.

4. Now repeat steps 1 and 2 still using RST warping but with both Bilinear, and
Cubic Convolution resampling methods.

5. Output the results to bldr_tm2.wrp and bldr_tm3.wrp, respectively.

6. Repeat steps 1 and 2 twice more, this time performing a 1st degree Polynomial
warp using Cubic Convolution resampling, and again using a Delaunay
Triangulation warp with Cubic Convolution resampling.

7. Output the results to bldr_tm4.wrp and bldr_tm5.wrp, respectively.

Figure 4-7: The Registration Parameters dialog.
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Compare Warp Results

Use Dynamic Overlays to compare your warp results:

1. In the Available Bands List, click on the original TM Band 3 image name
bldr_tm.img and select File → Close Selected File from the menu bar.

2. In the subsequent ENVI Warning dialog, click Yes to close the associated
image file.

3. In the Available Bands List, select the BLDRTM_1.WRP file and click on the
Display # button pull-down menu. Select New Display and choose Load Band
to load the file into the new display.

4. Click the right mouse button in the Main Image window and select
Tools → Link → Link Displays.

5. Click OK in the Link Displays dialog to link the SPOT and the registered TM
image.

6. Now compare the SPOT and the TM images using the dynamic overlay by
clicking the left mouse button in the Main Image display.

7. Load bldr_tm2.wrp and bldr_tm3.wrp into new displays and use the
image linking and dynamic overlays to compare the effect of the three
different resampling methods: nearest neighbor, bilinear interpolation, and
cubic convolution.

Note how jagged the pixels appear in the nearest neighbor resampled image.
The bilinear interpolation image looks much smoother, but the cubic
convolution image is the best result, smoother, but retaining fine detail.

8. Close the displays containing bldr_tm1.wrp (RST warp, Nearest Neighbor
resampling) and bldr_tm2.wrp (RST, Bilinear interpolation) by clicking the
right mouse button in the appropriate Main Image display and selecting
File → Cancel.

9. Load bldr_tm4.wrp and bldr_tm5.wrp into two new displays and use the
image linking and dynamic overlays to compare to bldr_tm3.wrp (RST
Warp).

Note the effect of the three different warping methods, RST, 1st degree
Polynomial, and Delaunay Triangulation on the image geometry.

10. Use dynamic overlay to compare to the georeferenced SPOT data.
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Examine Map Coordinates

To bring up the Cursor Location/Value dialog:

1. Select Tools → Cursor Location/Value from the Main Image window menu
bar.

2. Browse the georeferenced data sets and note the effect of the different
resampling and warp methods on the data values.

3. Select File → Cancel to close the dialog.

Close All Files

You can close all of the data files by selecting File → Close All Files from the ENVI
main menu.
ENVI Tutorials Image to Image Registration



132 Tutorial 4: Image Georeferencing and Registration
Image to Map Registration

This section of the tutorial will take you step-by-step through an Image to Map
registration. Many of the procedures are similar to image to image and will not be
discussed in detail. The map coordinates picked from the georeferenced SPOT image
and a vector Digital Line Graph (DLG) will be used as the Base, and the pixel-based
Landsat TM image will be warped to match the map data.

Open and Display Landsat TM Image File

1. From the ENVI main menu, select File → Open Image File.

2. When the Enter Data Filenames dialog appears, navigate to the bldr_reg
subdirectory of the envidata directory and select the file bldr_tm.img
from the list.

3. Click OK to load the TM image bands into the Available Bands List.

4. Select Gray Scale in the Available Bands List and click on Band 3. Then
from the Display #1 pull-down menu button select the New Display button at
the bottom of the dialog.

5. Click the Load Band button to load the TM band 3 image into a new display.

Select Image-to-Map Registration and Restore GCPs

1. From the ENVI main menu, select Map → Registration → Select GCPS:
Image to Map. The Image to Map Registration dialog appears.

2. In the Image to Map Registration dialog select Display #1.

3. Then select UTM from the list of projections and enter 13 in the Zone text
field.

4. Leave the pixel size at 30 m and click OK to start the registration.

The Ground Control Points Selection dialog appears.
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5. Add Individual GCPs by moving the cursor position in the warp image to a
ground location for which you know the map coordinate (either read from a
map or ENVI vector file (see below)).

6. Enter the known map coordinates manually into the E (Easting) and N
(Northing) text boxes and click Add Point to add the new GCP.

7. Select File → Restore GCPs from ASCII in the dialog and open the file
bldrtm_m.pts.

8. In the Ground Control Points Selection dialog, click the Show List button.
The Image to Map GCP List dialog appears. Examine the base map
coordinates, the actual and predicted image coordinates, and the RMS error.
Resize the dialog to see the RMS error.

Figure 4-8: Ground Control Points Selection dialog for Image to Map
Registration.
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Add Map GCPs Using Vector Display of DLGs

1. From the ENVI main menu, select File → Open Vector File → USGS DLG.

2. In the Enter Optional USGS DLG Filenames dialog, choose the file
bldr_rd.dlg and click OK to open the file. This opens the Import Optional
DLG File Parameters dialog.

3. In the Import Optional DLG File Parameters dialog, select the Memory
radio button and click OK to read the DLG data.

4. The Available Vectors List appears. Highlight the ROADS AND TRAILS:
BOULDER, CO file in the Available Vectors Layers: list, and then click on
the Load Selected button.

5. In the Load Vector dialog, click New Vector Window. This opens the Vector
Window Parameters dialog and a new Vector Window.

6. Click Apply in the Vector Window Parameters dialog to plot the vectors in
the vector window.

7. Click and drag the left mouse button in the Vector window to activate a
crosshair cursor.

Figure 4-9: Image to Map GCP LIst dialog for image to map registration.
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The map coordinates of the cursor will be listed in the Location field of the
Vector Window Parameters dialog.

8. Position the image cursor on the road intersection at 402, 418 in the Main
Image display by selecting Tools → Pixel Locator, entering the values, and
clicking Apply.

Note that sub-pixel positioning accuracy is again available in the Zoom
window.

9. In the Vector window, position the vector cursor at the road intersection at
477593.74, 4433240.0 (40d 3m 3s N, -105d 15m 45s W) by clicking and
dragging with the left mouse button and releasing when the circle at the
crosshair intersection overlays the intersection of interest.

10. Click Export in the Vector Window Parameters #1 dialog. The new map
coordinates will appear in the Ground Control Points Selection dialog.

Figure 4-10: Vector Window Parameters dialog showing cursor location.
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11. In the Ground Control Points Selection dialog, click Add Point to add the
map-coordinate/image pixel pair and observe the change in RMS error.

Figure 4-11: The Vector Window display.
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RST and Cubic Convolution Warp

1. In the Ground Control Points Selection dialog, select Options → Warp
File.

2. In the Input Warp Image dialog, highlight the file name bldr_tm.img and
click OK to select all 6 TM bands for warping.

3. The Registration Parameters dialog appears. Choose RST for the Warp
Method, and set Resampling to Cubic Convolution in the Registration
Parameters dialog.

4. Change the background value to 255.

5. Enter the output file name bldrtm_m.img in the output file text box.

6. Click OK to start the image to map warp.

Display Result and Evaluate

Use Cursor Location/Value to evaluate the resulting warped color image.

1. Click on the RGB radio button in the Available Bands List followed by
clicking on bands 4, 3, and 2 (RGB) of the warped image.

2. Select New Display from the Display # button pull-down menu. Click on Load
RGB to load the TM warped color image.

Note the skew of the image resulting from removal of the Landsat TM orbit
direction. This image is georeferenced, but at 30 meter resolution versus the 10
meter resolution provided by the SPOT image.

• If desired, load the SPOT image into a new display window and compare
the image geometries and scale.

Close Selected Files

You can leave bldrtm_m.img and bldr_sp.img open as you will use these files in
the next exercise.

1. Click on any other file names in the Available Bands List and select
File → Close Selected File to close these images.

2. Click Cancel in the Vector Window Parameters #1 dialog to close the
Vector window.

3. Select File → Cancel in the Available Vectors List to close that dialog.
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4. Select File → Cancel in the Ground Control Points Selection dialog to close
that dialog. Save the GCPs if desired.
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HSV Merge of Different Resolution
Georeferenced Data Sets

This portion of the tutorial describes the procedures for merging two georeferenced
data sets containing different pixel sizes. We will use the TM color-composite image
registered above as the low-resolution color image and the georeferenced SPOT
image as the high resolution image. The result is a color composite image with
enhanced spatial resolution.

Display 30 m TM Color Composite

1. If you closed the registered TM image, reopen the file bldrtm_m.img.

2. Click on the RGB radio button in the Available Bands List, and load bands 4,
3, and 2 (R, G, and B) into a new display.

Display 10 m SPOT Data

1. If you closed the SPOT image, open the file bldr_sp.img.

2. Click on the Gray Scale radio button in the Available Bands List, then click
the Display # button and select New Display from the pull-down menu. Click
the Load Band button to load the SPOT data into a new display.

Compare with the TM data above and note the similar image geometry, but different
spatial coverage and image scales.

Perform HVS Sharpening

1. Select Transform → Image Sharpening → HSV from the ENVI main menu.

2. If you have the color image displayed, choose the appropriate display in the
Select Input RGB dialog. Otherwise, choose bands 4, 3, and 2 from the TM
Image in the Select Input RGB Input Bands dialog and click OK.

3. The High Resolution Input File dialog opens. Choose the SPOT image in the
Select Input Band list and click OK.

4. In the HSV Sharpening Parameters dialog, enter the output file name
bldrtmsp.img and click OK.

A processing status box will appear and the new image will be listed in the Available
Bands List when the processing is completed.
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Display 10 m Color Image

1. Load the enhanced color image into a New Display by selecting the RGB
Color radio button in the Available Bands List dialog, selecting the R, G, and
B bands from the new file from list and clicking Load RGB.

Compare the HSV sharpened color image to both the original TM color
composite and to the SPOT data.

2. Try the same process using the Color Normalized (Brovey) Transform by
selecting Transforms → Image Sharpening → Color Normalized (Brovey),
entering the required file information and clicking OK.

Overlay Map Grid

1. From the HSV Image display menu, select Overlay → Grid Lines.

The Grid Line Parameters dialog appears and a virtual border is added to the
image to allow display of map grid labels exterior to the image.

2. In the Grid Line Parameters dialog, select File → Restore Setup. In the
Enter Grid Parameters Filename dialog which opens, select
bldrtmsp.grd, and click Open (OK on UNIX).

Previously saved grid parameters will be loaded into the dialog.

3. Click Apply to put the grids on the image.

Overlay Annotation

1. From the HSV Main Image menu bar, select Overlay → Annotation.

2. In the Annotation: Text dialog for the HSV image display, select
File → Restore Annotation and choose the file bldrtmsp.ann from the file
list that appears and click Open (OK on UNIX).

The pre-saved map annotation will be loaded onto the image.

• Optionally, enlarge the Scroll window by grabbing one of its corners and
dragging it.

Output Image Map

To save your work, use the procedures described in “Output to Image or Postscript”
on page 121 for image output. You can:

• Create an image output file.
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• Create a Postscript file.

• Print a copy of the image-map (see “Direct Printing” on page 124).

End the ENVI Session

This concludes the Registration Tutorial. You can quit your ENVI session by
selecting File → Exit (Quit on UNIX) on the ENVI main menu, then click OK to
exit IDL. If you are using ENVI RT, quitting ENVI will take you back to your
operating system.
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Tutorial 5:

Georeferencing
Images Using
Input Geometry
The following topics are covered in this tutorial:
Overview of This Tutorial . . . . . . . . . . . . . 144
Georeferencing Using Input Geometry . . . 145

Uncorrected HyMap Hyperspectral Data . 147
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Overview of This Tutorial

Data from many sensors now comes with detailed acquisition (platform geometry)
information that allows model-based geometric rectification and map registration.
This tutorial provides basic information about Georeferenced images in ENVI and
Model-Based Geometric Correction using image input geometry within ENVI. It
discusses required data characteristics and covers step-by-step procedures for
successful registration. It assumes that you are already familiar with general image-
registration and resampling concepts. 1999 HyMap data of Cuprite, Nevada, used for
the tutorial are copyright 1999 Analytical Imaging and Geophysics (AIG) and
HyVista Corporation (All Rights Reserved), and may not be redistributed without
explicit permission from AIG (info@aigllc.com).

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 2

Path: envidata/cup99hym

File Description

cup99hy_true.img True Color Composite, Cuprite 1999 HyMap Data

cup99hy_true.hdr ENVI Header for above

cup99hy_geo_glt Geometry Lookup File

cup99hy_geo_glt.hdr ENVI Header for above

cup99hy_geo_igm Input Geometry File

cup99hy_geo_igm.hdr ENVI Header for above

copyright.txt Description of data copyright
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Georeferencing Using Input Geometry

ENVI provides full support for georeferenced images in numerous predefined map
projections including UTM and State Plane. In addition, ENVI’s user-configurable
map projections allow construction of custom map projections utilizing 6 basic
projection types, over 35 different ellipsoids, and more than 100 datums to suit most
map requirements.

ENVI map projection parameters are stored in an ASCII text file map_proj.txt

that can be modified by ENVI map projection utilities or edited directly by the user.
The information in this file is used in the ENVI Header files associated with each
image and allows simple association of a “Magic Pixel” location with known map
projection coordinates. Selected ENVI functions can then use this information to
work with the image in georeferenced data space.

Modern sensors collect ephemeris data along with their image data to allow precision
georeferencing to map coordinates. ENVI provides a paradigm for storing sensor
geometry information and automatically correcting image data to specified map
projections/coordinates. The Input Geometry (IGM) file contains the X and Y map
coordinates for a specified map projection for each pixel in the uncorrected input
image. The Geometry Lookup (GLT) file contains the sample and line that each pixel
in the output image came from in the input image. If the GLT value is positive, there
was an exact pixel match. If the GLT value is negative, there was no exact match and
the nearest neighboring pixel is used.

Three ENVI routines are provided to do the georeferencing:

• Map → Georeference from Input Geometry → Build GLT builds a GLT
file from input geometry information.

• Map → Georeference from Input Geometry → Georeference from GLT
performs geocorrection utilizing the Geometry Lookup images.

• Map → Georeference from Input Geometry → Georeference from IGM
performs geocorrection utilizing the input geometry and creates the GLT file

Users must have the IGM or GLT file as a minimum to conduct this form of
geocorrection. Image geometry data files are available for delivery as products from
several sensors, including AVIRIS, MASTER, and HyMap. HyMap is a state-of-the-
art aircraft-mounted commercial hyperspectral sensor developed by Integrated
Spectronics, Sydney, Australia, and operated by HyVista Corporation.

HyMap provides unprecedented spatial, spectral, and radiometric excellence. The
system is a whiskbroom scanner utilizing diffraction gratings and four 32-element
detector arrays (1 Si, 3 liquid-nitrogen-cooled InSb). Data consists of 126 spectral
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channels covering the 0.44 - 2.5 µm range with approximately 15nm spectral
resolution and 1000:1 SNR over a 512-pixel swath. Spatial resolution is 3-10 m
(approximately 8 meters for the Cuprite data used here). Because the instrument
utilizes a gyro-stabilized platform, the initial image geometry (prior to this
correction) is quite good and corrections are minor.

While geocorrected images produced using the above methods are visually pleasing
and map-correct, they do have several practical drawbacks. First, they have null
values around their edges that must be masked in processing. Second, they are often
inflated in size by replicated pixels as indicated in the GLT files. These two
disadvantages lead to our suggestion to acquire and process the hyperspectral
imagery in its raw spatial format, then apply the geocorrection to the derived final
products. We do not recommend geocorrecting the entire reflectance data cube.

The following sections provide examples of the model-based geocorrection built into
ENVI. Consult the ENVI 3.5 User’s Guide for additional information.
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Uncorrected HyMap Hyperspectral Data

This portion of the tutorial will familiarize you with uncorrected image geometry and
characteristics.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To open ENVI on UNIX, enter envi at the UNIX command line.

• To open ENVI on Windows or Macintosh, double-click on the ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

Open and Display HyMap Data

To open HyMap data:

1. Select File → Open Image File from the ENVI main menu.

Note
On some platforms, you must hold down the left mouse button to display the
submenus from the main menu.

2. In the Enter Data Filenames dialog, navigate to the envidata/cup99hym
directory of the ENVI Tutorial and Data CD No. 2 and select the file
cup99_hytrue.img from the list. This is a TrueColor image extracted from
the HyMap reflectance data.

3. Click Open and the default image bands will be loaded into a new display.
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Examine Uncorrected Data

Examine the characteristics of the uncorrected data as follows:

1. Display the Cursor Location/Value dialog by doing one of the following:

• Select Tools → Cursor Location/Value from the Main Image window
menu.

• Select Window → Cursor Location/Value from either the ENVI main
menu or the Main Image window menu.

• Double-click in the Main Image window.

2. A dialog box will appear displaying the location of the cursor in the Main
Image, Scroll, or Zoom windows. The dialog also displays the screen value
and the actual data value of the pixel underneath the crosshair cursor.

3. Move the cursor throughout the image. Examine the pixel locations and data
values, and geometric relations between pixels (rotation, road curvature, etc.).

4. To dismiss the dialog, select File → Cancel from the menu at the top of the
Cursor Location/Value dialog.

Figure 5-1: Uncorrected Cuprite HyMap Data
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Examine IGM files

To open a HyMap Input Geometry data file:

1. Select File → Open Image File from the ENVI main menu.

2. In the Enter Data Filenames dialog, navigate to the envidata/cup99hym
directory of the ENVI Tutorial and Data CD No. 2, select the Input Geometry
file cup99hy_geo_igm, and click Open.

3. In the Available Bands List dialog, select the Gray Scale radio button, and
select IGM Input X Map from the list. The band you have chosen will be
displayed in the Selected Band field.

4. Select New Display from the Display pull-down menu at the bottom of the
dialog.

5. Click the Load Band button to load the image into the new display.

6. Open the Cursor Location/Value dialog. Move the cursor throughout the
image, and examine the pixel locations and data values (Map Coordinates).

7. Repeat the steps above for the IGM Input Y Map band.

Geocorrect Image Using IGM File

1. Select Map → Georeference from Input Geometry → Georeference from
IGM from the ENVI main menu.

2. In the Input Data File dialog, click the Open File button.

3. In the Please Select a File dialog, select the file cup99hy.eff and click
Open.

4. In the Input Data File dialog, select the file cup99hy.eff and click the
Spectral Subset button.

5. In the File Spectral Subset dialog, select only band 109 and click OK.

6. In the Input Data File dialog, click OK.

7. In the Input X Geometry Band dialog, select the IGM Input X Map band
and click OK.

8. In the Input Y Geometry Band dialog, select the IGM Input Y Map band
and click OK.

9. In the Geometry Projection Information dialog, click OK. This produces an
image with the same map projection as the input geometry (UTM, Zone 13,
NAD27).
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10. In the Build Geometry Lookup File Parameters dialog, enter an output
filename for the GLT file, a background value of -9999, and an output
filename for the georeference image. Click OK.

Display and Evaluate Correction Results

Use Cursor Location/Value to evaluate the correction results:

1. In the Available Bands List dialog, select the Gray Scale radio button and
select the Georef band.

2. Click Load Band to load the image into a new display.

3. Open the Cursor Location/Value dialog. Move the cursor throughout the
image, and examine the image geometry, pixel locations, map coordinates, and
data values.

4. Close IGM displays when finished examining results.

Examine GLT Files

To open a HyMap Geometry Lookup file:

1. Select File → Open Image File from the ENVI main menu.

Figure 5-2: Cuprite HyMap IGM images. Left is IGM Input X Map. Right is IGM
Input Y Map.
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2. In the Enter Data Filenames dialog, navigate to the envidata/cup99hym
directory of the ENVI Tutorial and Data CD No. 2, select the Geometry
Lookup file cup99hy_geo_glt and click Open.

3. In the Available Bands List dialog, select the Gray Scale radio button and
select the GLT Sample Look-up band.

4. Select New Display from the Display pulldown menu at the bottom of the
dialog and click Load Band to load the image into the new display.

5. Open the Cursor Location/Value dialog. Move the cursor throughout the
image, and examine the pixel locations and data values (input pixel locations).
Pay particular attention to the negative values, which indicate use of nearest
neighbor pixels.

6. Repeat the above steps for the GLT Line Look-up band.

Geocorrect Image using GLT File

1. Select Map → Georeference from Input Geometry → Georeference from
GLT from the ENVI main menu.

2. In the Input Geometry Lookup File dialog, select the file
cup99hy_geo_glt and click OK.

3. In the Input Data File dialog, select the file cup99hy.eff and click the
Spectral Subset button.

4. In the File Spectral Subset dialog, select only band 109 and click OK.

Figure 5-3: Cuprite HyMap GLT images. Left is GLT Sample Look-up. Right is
GLT Line Look-up.
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5. In the Input Data File dialog, click OK.

6. In the Georeference from GLT Parameters dialog, enter a background value
of -9999 and an output filename for the georeferenced image, then click OK.

Display and Evaluate Correction Results

1. In the Available Bands List dialog, select the Gray Scale radio button and
select the Georef band.

2. Click Load Band to load the image into a new display.

3. Open the Cursor Location/Value dialog. Move the cursor throughout the
image, and examine the image geometry, pixel locations, map coordinates, and
data values.

4. Close GLT displays when finished examining results.

Using Build GLT with Map Projection

1. Select Map → Georeference from Input Geometry → Build GLT from the
ENVI main menu.

2. If the file cup99hy_geo_igm is not already open, select File → Open Image
File from the ENVI main menu and open the file.

3. In the Input X Geometry Band dialog, select the IGM Input X Map band
and click OK

Figure 5-4: Cuprite HyMap Geocorrected Image
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4. In the Input Y Geometry Band dialog, select the IGM Input Y Map band
and click OK

5. At the bottom of the Geometry Projection Information dialog, select State
Plane (NAD 27) as the Output Projection.

6. Click Set Zone and choose Nevada West (2703) as the output zone.

7. Click OK.

8. In the Build Geometry Lookup File Parameters dialog, enter an output
filename for the GLT file and click OK to create the GLT.

9. Using the steps listed under “Geocorrect Image using GLT File” on page 151,
geocorrect band 109 of the cup99hy.eff data and compare the resulting
image to the UTM-corrected image.

10. Close all displays by selecting Window → Close All Display Windows from
the ENVI main menu when finished examining results.

Overlay Map Grids

1. In the Available Bands List dialog, select one of the georeferenced images
produced above by clicking on the appropriate name, then click Load Band to
display the image.

2. Select Overlay → Grid Lines to start the Grid Line Parameters dialog. A
virtual border will be added to the image to allow display of map grid labels
exterior to the image.

3. Change the Map Grid Spacing to 1000 and the Geographic Grid Spacing to
1 minute and click Apply.

4. Utilize the Cursor Location/Value dialog to compare the grids to the pixel
coordinates.

Output to Image

ENVI gives you several options for saving and outputting your image maps. You can
save your work in ENVI’s image file format, or in several popular graphics formats
(including Postscript) for printing or importing into other software packages.

Saving your Image in ENVI Image Format

To save your work in ENVI’s native format (as an RGB file):

1. In the Main Image window, select File → Save Image As → Image File.
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2. In the Output Display to Image File dialog, click the Output File Type pull-
down button and select ENVI.

3. Select the Memory radio button and click OK to output the image.

4. Load into another display and examine the results of the grid annotation as a
raster image.

Direct Printing

ENVI also allows direct printing to devices supported by your operating system.
Select File → Print and follow your standard printing procedures. For example, in
Microsoft Windows, you would select the printer name from the pulldown menu,
change the properties as desired, and click on OK to print the image. Once you have
selected all of the parameters and clicked OK, a dialog appears to allow you to set
additional basic ENVI printing parameters similar to those used for postscript output
(see above). Set these as desired and click OK to begin printing.

End the ENVI Session

This concludes the tutorial. You can quit your ENVI session by selecting File → Exit
(Quit on UNIX) on the ENVI main menu, then click Yes. If you are using ENVI RT,
quitting ENVI will take you back to your operating system.
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The following topics are covered in this tutorial:
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Orthorectification in ENVI . . . . . . . . . . . . 157

Tips for Successful Orthorectification . . . 170
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Overview of This Tutorial

This tutorial is designed to give you a working knowledge of ENVI's
orthorectification capabilities. For additional details, please see the ENVI User's
Guide or ENVI On-Line Help.

Files Used in this Tutorial

This tutorial demonstrates ENVI’s orthorectification capabilities, but because of the
size of the required data sets, does not utilize any hands-on exercises. No data files
are required. Users should be able to produce similar results with their own scanned
aerial photographs or SPOT 1A, 1B, or SPOT CAP format data following the
procedures outlined.
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Orthorectification in ENVI

Orthorectification is the process by which the geometry of an image is made
planimetric (map-accurate) by modeling the nature and magnitude of geometric
distortions in the imagery. Camera or satellite models in conjunction with limited
ground control, allow construction of correction formulae that produce accurate,
geometrically correct, map-oriented imagery.

ENVI's Orthorectification function allows rectification of aerial photographs and
SPOT data using a digital elevation model (DEM). The orthorectification uses
geometric projections to produce geometrically correct images for mapping and
measurement. See the following reference for more details:

Wolf, R., 1974. Elements of Photogrammetry (2nd ed.), McGraw-Hill Inc.,
New York.

Tip
Because the orthorectification process is computationally intensive and time
consuming, before beginning an orthorectification make sure you have sufficient
disk space to save the resulting ortho image, as such images can be very large.

Steps for Orthorectification Using ENVI

The process of orthorectification using ENVI requires several steps that are the same
regardless of the type of photograph or sensor used to collect the digital data. These
include:

1. Build the Interior Orientation (aerial photographs only) — Building the
interior orientation establishes the relationship between the camera and the
aerial photograph. It uses tie points between the image and camera fiducial
marks (at least three) and the camera focal length.

2. Build the Exterior Orientation — The exterior orientation relates points in the
aerial photograph or satellite image to their known ground locations (map
coordinates) and elevations. It is built by selecting ground control points and
entering the corresponding map coordinates similar to an image-to-map
registration.

3. Orthorectify using a Digital Elevation Model — This step does the actual
orthorectification of the aerial photograph or satellite image using the
orientation files or satellite location and collinearity equations generated using
the above steps in conjunction with a digital elevation model (DEM).
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Aerial Photo Orthorectification Example

The ENVI aerial photograph orthorectification corrects for distortions introduced by
the camera geometry, look angles, and topography using a single photo. The
orthorectification is done in three steps as described above. The figure below shows
an original aerial photograph for Boulder, Colorado.

Building the Interior Orientation

1. Display the aerial photograph image to allow interactive selection of fiducial
marks. The figure below (Figure 6-2) shows a typical set of fiducial marks.

2. Select Map → Orthorectification → Build Air Photo Interior Orientation.
If more than one image is displayed, select the display number containing the
aerial photograph. The Ortho: Build Interior Orientation dialog appears.

Figure 6-1: Original Aerial Photograph
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3. Select a fiducial mark location by centering the Zoom window crosshair on the
fiducial mark and entering the fiducial location in camera units (mm) in the
Fiducial X and Fiducial Y text boxes (this information is obtained from the
camera report). Click on Add Point in the Build Interior Orientation dialog
to add the location to the list of tie points. Continue selecting fiducial mark
locations until three or more have been entered. Click on Show List at the
bottom of the dialog to show the actual points and errors. Be sure to review the
RMS error in the dialog to insure that the points were properly selected.

4. Select Options → Build Interior Orientation from the Ortho: Build
Interior Orientation dialog. Enter the camera focal length in mm and enter an
output filename with an .ort extension for consistency.

The output .ort file contains the fiducial tie point locations and the affine
transformation coefficients for both the camera coordinates to image pixels
and image pixels to camera coordinates. The following is an example of the
.ort file after the interior orientation has been calculated.

Figure 6-2: Aerial photograph showing locations of fiducial marks, and Zoom
window with individual fiducial mark.
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ENVI Orthorectification Parameters File
Sensor Type = Air Photo
Focal Length= 304.67100
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;;;;;;;;;;
; Interior Orientation Information
; interior points = {fiducial (x,y) millimeters, image (x,y)}
Interior Points = {
-106.0230, -105.9940, 302.33, 251.44,
105.9780, 106.0140, 7315.45, 7359.55,
-106.0210, 106.0100, 7364.71, 303.57,
105.9790, -105.9940, 254.33, 7309.67,
-110.0200, 0.0100, 3834.00, 143.80,
109.9750, 0.0100, 3783.43, 7467.71,
-0.0220, 110.0040, 7473.14, 3832.43,
-0.0320, -109.9880, 146.00, 3779.57}

;Affine Transformation (Camera Coords to Image Pixels)
; a0 = 3808.86863414
; a1 = -0.22975948
; a2 = 33.30821680
; b0 = 3806.73931581
; b1 = 33.28923748
; b2 = 0.23988471
;Affine Transformation (Image Pixels to Camera Coords)
; a0 = -113.52361324
; a1 = -0.00021635
; a2 = 0.03003821
; b0 = -115.13524789
; b1 = 0.03002113
; b2 = 0.00020719

Building the Exterior Orientation

1. Display the aerial photograph image as above and select
Map → Orthorectification → Build Air Photo Exterior Orientation. If
more than one image is displayed, select the display number containing the
aerial photograph.

2. Select the desired projection and enter a zone number if needed. The selected
projection will be used as the orthorectified output projection and does not
need to be the same projection as the DEM file. Click OK.

The Ortho: Build Exterior Orientation dialog appears. This dialog is similar
to the image-to-map registration Ground Control Points Selection dialog.
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3. Select a ground control point (GCP) by centering the Zoom window crosshair
over a pixel on the aerial photograph image and entering the corresponding
map coordinates in the appropriate text boxes. Enter an elevation for the
selected pixel in the Elev text box and click on Add Point to add the location
to the list of GCPs. Continue selecting ground control points until three or
more have been entered. (Note: It is recommended that you use as many GCPs
as possible spread over the image for best results). Be sure to review the RMS
error in the dialog to insure that the points were properly selected.

4. Select Options → Build Exterior Orientation from the Ortho: Build
Exterior Orientation dialog and enter the .ort parameters file created for the
interior orientation. The GCPs from the exterior orientation are added to the
selected .ort file. The following is an example of the exterior orientation
parameters and points.

Figure 6-3: Ortho: Build Interior Orientation and GCP List Dialogs
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;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;;;;;;;;;
; Exterior Orientation Information
; projection info = {UTM, 13, North}
; exterior points = {map (x,y,z) meters, image (x,y)}
Exterior Points = {
476788.860, 4434052.500, 1702.040, 2993.00, 545.00,
475174.630, 4430823.600, 1705.600, 2037.50, 2192.50,
478404.380, 4430819.300, 1672.630, 3748.00, 2296.00,
478602.050, 4428903.900, 1635.940, 3799.00, 3314.00,
481632.990, 4430804.900, 1613.830, 5439.00, 2391.00,
480787.590, 4429184.200, 1627.220, 4965.00, 3212.00,
476789.250, 4427487.300, 1713.750, 2815.00, 3997.00,
477837.900, 4424410.800, 1750.380, 3279.00, 5646.00,
480272.650, 4422811.100, 1707.080, 4501.00, 6550.00,
483949.430, 4423904.600, 1762.360, 6487.33, 6086.33}

; PHI = 0.08065113
; OMEGA = -0.29078090
; KAPPA = -87.39367868
; Projection Center x = 478695.7071
; Projection Center y = 4428046.0844
; Projection Center z = 20962.4655

Orthorectifying the Air Photo

1. Select Map → Orthorectification → Orthorectify Air Photo.

2. Select the input aerial photograph filename and any subsetting if desired.

3. Select the input digital elevation model (DEM) filename. The DEM for the
Boulder, Colorado, aerial photograph is shown in Figure 6-4.

4. Select the orientation parameters (.ort) filename created using the steps
described above.

5. When the Orthorectification Bounds dialog appears, enter or calculate the
approximate minimum value contained in the DEM file.

The Orthorectification Parameters dialog appears. Currently, only nearest
neighbor resampling is available.

6. Enter the value to ignore (missing data) in the DEM in the appropriate text
box.

7. To set the Background Value (the DN value used to fill areas where no image
data appears in the warped image) enter the DN value in the Background
Value text box.
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The output image dimensions are automatically set to the size of the bounding
rectangle that contains the warped input image. Therefore, the output warp
image size may not be the same size as the DEM image. The output size
coordinates are determined in the exterior orientation projection coordinates. If
desired, change the map coordinate or latitude/longitude information for the
upper left coordinate, pixel size, and image size by clicking Change Output
Parameters and entering the desired values.

The Change Projection button is used to change the projection for entering
the upper left coordinate only. The output projection of the image is set using
the Build Exterior Orientation function.

Figure 6-4: Boulder, Colorado DEM
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8. Select output to File or Memory and click OK to start the orthorectification.
The result of the orthorectification of the Boulder, Colorado, aerial photograph
is shown below.

Figure 6-5: Orthorectified Aerial Photograph of Boulder, Colorado
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SPOT Image Orthorectification Example

SPOT 1A, 1B and CAP data can be orthorectified using a DEM (digital elevation
model). The orthorectification is done in two steps. The first step builds the exterior
orientation using ground control points. The orthorectification uses satellite
ephemeris information from the SPOT leader file to generate an initial orbit and view
geometry model. Ground control points (GCPs) are used to optimize the orbital
model by performing a non-linear inversion. The satellite position and set of
collinearity equations for every line in the SPOT data are calculated and stored in a
.sot file. The second step performs the orthorectification using the orbit model and a
DEM file to correct the SPOT image pixel by pixel. See the following reference for
details.

Westin, Torbjorn, 1990. Precision rectification of SPOT imagery, Photogrammetric
Engineering & Remote Sensing, Vol. 56, No. 2, pp. 247-253.

Figure 6-6: Oregon, SPOT XS Level 1B Data
(Note pixel-based coordinates.)
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Building the Exterior Orientation

The exterior orientation is used to optimize the satellite orbit model by relating
points in the SPOT image to their known map coordinates and elevations. It is
built by selecting ground control points and entering the corresponding map
coordinates similar to an image-to-map registration. The SPOT image must be
displayed in an image window for selection of the ground control point
locations.

1. Display the SPOT image.

2. Select Map → Orthorectification → Build SPOT Exterior Orientation. If
more than one image is displayed, select the display number containing the
SPOT image.

3. Select the desired projection for the image output and enter a zone number if
needed. The selected projection will be used as the orthorectified output
projection and does not need to be the same projection as the DEM file. Click
OK.

The Ortho: Build Exterior Orientation dialog appears. This dialog is similar
to the image-to-map registration Ground Control Points Selection dialog.

4. Select a ground control point (GCP) by centering the Zoom window crosshair
over a pixel on the SPOT image and entering the corresponding map
coordinates in the appropriate text boxes. Enter an elevation for the selected
pixel in the Elev text box and click on Add Point to add the location to the list
of GCPs. Continue selecting ground control points until three or more have
been entered. Click on the Show List button to review the selected GCPs. Be
sure to review the RMS error in the Ortho: Build Exterior Orientation
dialog to ensure that the points were properly selected.

Note
It is recommended that you use as many GCPs as possible (dozens) spread over the
image to stabilize the satellite orbit inversion. Although the orthorectification can
be run with only 3 GCPs, it may produce instability in the satellite orbit inversion.

Once you have finished collecting GCPs, select Options → Build Exterior
Orientation from the Ortho: Build Exterior Orientation dialog. Select the
SPOT leader filename, typically lead_xx.dat where xx is the scene
number.
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5. Enter an output filename with a .sot extension for consistency. The.sot file
is in binary format and contains the satellite location and collinearity equations
for each line in the SPOT image.

Orthorectifying the SPOT Image

This section describes the orthorectification of the SPOT image using the .sot
parameters file generated above and a digital elevation model (DEM).

1. Select Map → Orthorectification → Orthorectify SPOT Image.

2. Select the input SPOT image filename and any subsetting if desired.

3. Select the input digital elevation model (DEM) filename.

4. Select the ortho parameters (.sot) filename created above.

5. Select the SPOT leader filename.

Figure 6-7: The Ortho: Build Exterior Orientation dialog.
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6. When the Orthorectification Bounds dialog appears, enter or calculate the
approximate minimum value contained in the DEM file. If your DEM has a
filler value for missing data, enter that value in the DEM Value to Ignore text
box.

Figure 6-8: Oregon, SPOT XS Level 1B Data
Note the geographic-based coordinates and that image rectification has been

cut off in the north at the edge of the DEM.
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7. Click OK and the Orthorectification Parameters dialog appears. Enter the
value to ignore (missing data) in the DEM in the appropriate text box. To set
the Background Value (the DN value used to fill areas where no image data
appears in the warped image) enter the DN value in the Background Value
text box.

The output image dimensions are automatically set to the size of the bounding
rectangle that contains the warped input image. Therefore, the output warp
image size may not be the same size as the DEM image. The output size
coordinates are determined in the exterior orientation projection coordinates.
This may be changed by modifying the map coordinate or latitude/longitude
information for the upper left coordinate, pixel size, and image size by clicking
Change Output Parameters and entering the desired values.

8. Select to output to File or Memory and click OK to start the orthorectification.
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Tips for Successful Orthorectification

ENVI’s Orthorectification routines were designed to be as flexible as possible, so
there are very few restrictions on the parameters that the user provides. While this
flexibility makes the tools easy to use, it also makes it possible to set up an
orthorectification incorrectly.

Spatial Resolution

Before beginning an orthorectification, it is important to consider the issue of spatial
resolution, as it is handled very differently here than in ENVI's “warp” registrations.
There are three key parameters:

• The pixel size of the DEM.

• The pixel size of the input image.

• The desired output pixel size for the resulting orthorectified image.

ENVI will let you proceed with any combination of pixel sizes, but these settings will
have a profound effect on your results. Ideally, the pixel size of the DEM should be
the same (or smaller) as that of the output ortho image you want to create. If the DEM
resolution is significantly larger than the desired output resolution, you will often end
up with artifacts in the ortho result that look like steps (or blocks) in the image. The
steps will occur where there is a boundary between groups of pixels in the output
ortho image which map back to the same DEM elevation (i.e., the same DEM pixel).
So, before doing an orthorectification in ENVI, use the [Basic Tools → Resize
Images (Spatial/Spectral)] to resample the DEM to the desired output ortho image
resolution. We recommend that you use bilinear interpolation for the resampling, as
cubic convolution is more likely to create features that are unrealistic; the nearest
neighbor technique will not smooth out the resampled DEM.

Resampling During the Orthorectification

When producing the ortho image, the value for each pixel in the output image (i.e.,
the ortho image’s DNs) is determined by figuring out which pixel in the input air
photo “belongs” in this position. This is accomplished by using the 2 models to trace
back which air photo DN occurs at a given map coordinate. Then, this air photo DN
is placed in the correct location in the output ortho image. While the map coordinate
of the center of each pixel in the output ortho image will map back to a single pixel in
the input air photo, the value that is used for the output ortho image is typically
adjusted by resampling it based on the values of the pixels in its immediate vicinity
(in the air photo). This resampling produces a smoother, more realistic looking ortho
image. Bilinear interpolation uses the values of the 4 nearest neighbors, while cubic
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convolution uses the 16 nearest neighbors. Currently only nearest neighbor
resampling is offered. Nearest neighbor resampling does not provide any smoothing
effects. When using nearest neighbor resampling, and the output pixel size of the
ortho image is considerably larger than that of the input air photo, you may end up
with an ortho image that does not have the spatial characteristics of a typical
photograph.

Consider a case where the input air photo has 1x1 meter pixels but the output ortho
image has been set up to have only 5x5 meter pixels. In the ortho result, each 5x5
meter pixel will have a DN based on a 1x1 meter area in the air photo. Further,
because the map location of the centers of neighboring pixels in the 5 meter ortho
result are separated by 5 pixels the air photo, neighboring pixels in the ortho result
will have DNs represented by pixels in the air photo that are not continuous. If you
wish for your ortho result to have a pixel size that is significantly larger than the air
photo, you may want to first resample the air photo to the pixel size of the desired
output ortho image.

Accuracy of GCPs

Unlike the GCPs used in “warp” registrations, the accuracy of each GCP used for the
Exterior Orientation is absolutely critical for locating the position of the air photo
camera. If the Exterior Orientation is not accurate, then the orthorectified image will
be in error, even if the Interior Orientation is perfect. It is not uncommon for GCPs to
be based on survey results and be located to sub-millimeter accuracy, especially
when orthorectifying air photos with a resolution of 1 meter or less. Also, in order to
optimally recover the camera position, try to spread the GCPs across the entire
image. It is better to have fewer GCPs that are well distributed than to have many
GCPs clustered together. Once at least 4 GCPs are entered in the Exterior
Orientation, an estimate of the (x.y) position error is reported as the RMS value. This
error estimate is calculated with an RST warping algorithm which is quite different
than the orthorectification procedure. The RMS error is provided simply to check for
large errors, such as those that might occur with a typo or a misplaced decimal point
when entering the GCPs. This error does not consider the Z-values of the GCPs and is
not an accurate assessment of the true error in the orthorectification.

Minimum DEM Value

After you have built the .ort file by defining the Interior and Exterior Orientations,
and you are running the Orthorectify Air Photo procedure, you will be prompted to
enter a Minimum DEM Value. For any given set of orthorectification parameters, the
greater the distance between the camera and the ground, the bigger the ortho image
must be. The value that is entered here is used to determine the size (in samples and
lines) of the orthorectification output image. This value will not affect the DNs of the
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resulting ortho image, however, entering an accurate value will likely reduce the
processing time and make a smaller resulting image file.

Output Pixel Size

The output pixel size for the resulting ortho image defaults to the pixel size of the
DEM. If this is not the pixel size you wish for your result, you can change the pixel
size in the dialog window by selecting the Change Output Parameters button
located in the middle of the last dialog window (the Orthorectification Parameters
dialog). Generally speaking, it is always a good idea to check the values in the Output
Image Parameters window before doing any kind of registration (orthorectification,
warping, converting map projections, etc.), because a quick glance at these
parameters can often identify problems with input parameters.
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Mosaicking Using ENVI
The following topics are covered in this tutorial:
Overview of This Tutorial . . . . . . . . . . . . . 174
Mosaicking in ENVI . . . . . . . . . . . . . . . . . 176

Pixel-Based Mosaicking Example . . . . . . 183
Georeferenced Mosaicking Example . . . . 187
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Overview of This Tutorial

This tutorial is designed to give you a working knowledge of ENVI's image
mosaicking capabilities. For additional details, please see the ENVI 3.5 User’s Guide
or the ENVI Online Help.

Files Used in this Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/avmosaic

File Description

Pixel-Based Mosaicking

dv06_2.img AVIRIS Scene 02

dv06_2.hdr ENVI Header for above

dv06_3.img AVIRIS Scene 03

dv06_3.hdr ENVI Header for above

dv06a.mos Mosaic Template for end-to-end AVIRIS mosaic

dv06b.mos Mosaic Template for feathered overlapping AVIRIS
mosaic

dv06_fea.img Feathered Mosaic image

dv06_fea.hdr ENVI Header for above

Georeferenced Mosaicking

lch_01w.img Warped, histogram matched image

lch_01w.hdr ENVI Header for above

lch_01w.ann Cut-line feathering annotation for above

lch_02w.img Warped, histogram matched image

lch_02w.hdr ENVI Header for above

lch_a.mos Mosaic Template for Georeferenced Image
Mosaicking
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lch_mos1.img Georeferenced mosaic result

lch_mos1.hdr ENVI Header for above

File Description
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Mosaicking in ENVI

Mosaicking is the art of combining multiple images into a single composite image. It
can be used to combine pixel-based images, to lay out images for publication or map
composition, or as a means for combining georeferenced images into an image
covering a larger geographic area. ENVI provides interactive capabilities for placing
pixel-based images within a mosaic, and automated placement of georeferenced
images within a georeferenced output mosaic. The software provides tools for
common mosaic requirements such as blending edges (feathering), image border
transparency, and histogram matching. ENVI's Virtual Mosaic capability allows
users to optionally create and display mosaics without creating large output files.

General Topics

The following sections walk you through some of the preparation required to make
mosaics in ENVI. The actual exercises begin with the section “Pixel-Based
Mosaicking Example” on page 183 or alternatively, for georeferenced mosaics, in the
section “Georeferenced Mosaicking Example” on page 187.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To open ENVI in UNIX, enter envi at the UNIX command line.

• To open ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

Preparing Images

Raw image data can be mosaicked together if desired (ENVI can be used to easily
produce multiband mosaics of multiple data types), however, most mosaics are for
output and usually require scaling (contrast stretching), and histogram matching to
minimize image differences in the output mosaic.

The first step in creating a mosaic using ENVI is usually to contrast stretch the
images. This is done by displaying the bands to be mosaicked and either using one of
ENVI's quick (default) stretches or using ENVI's interactive contrast stretching
capabilities.
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Start in either of the following Pixel-Based (“Steps for Creating a Pixel-Based
Mosaic” on page 180) or the Georeferenced Image Mosaic (“Create the
Georeferenced Mosaic Image” on page 187) sections and open the appropriate
images by navigating to the avmosaic subdirectory of the envidata directory on
the ENVI Tutorial and Data CD No. 1, selecting the desired image file and opening it
just as you would in any other application.

Open the Files

1. Select File → Open Image File. An Enter Data Filenames file selection
dialog appears. Select the desired file.

Note
On some platforms you must hold the left mouse button down to display the
submenus from the Main Menu.

2. Display the image(s) by selecting the desired bands in the Available Bands
List and clicking Load Band.

3. Select Enhance → [Image] Linear 2% to stretch the displayed image, or
select Enhance → Interactive Stretching.

4. Stretch the image to enhance the desired image features and output to memory
or a new file by selecting File → Save Image As → Image File in the Main
Display window.

Histogram Matching

When mosaicking two or more images that overlap, it is usually necessary to choose
a base image and balance gray scale values in the rest of the images to match the base
image. This is called histogram matching (Richards, 1993). ENVI provides an
interactive tool to perform histogram matching. The procedure for performing the
histogram matching is described below.

The following steps are provided for information and are not to be executed as part of
this tutorial.

1. Display the two images to be histogram matched in two display windows.
Select one of the images as the base image and stretch that image as desired
using either the default stretches under the Enhance menu or
Enhance → Interactive Stretching.

2. Identify the overlap areas, position the Zoom windows of both images within
the overlap, and resize and/or reposition the Zoom window to cover exactly the
same region in both images (try to cover as large an area as possible and a
broad range of cover types).
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3. Select Enhance → Histogram Matching from the Main Image Display menu
bar of the image you want to match to the base image. The Histogram
Matching Input dialog appears.

4. Select the display number of the base image to match, click on the Zoom radio
button, and then click OK.

The output histogram from the base image is applied to the histogram of the
second image and histogram matching is complete. The two images should
now have the same gray scale characteristics.

5. Save the two contrast stretched images by selecting File → Save Image
As → Image File in both Main Displays.

6. Select to save the stretched files either to memory or to new output files.

7. Repeat for additional overlapping images as required.

You may want to try the histogram matching yourself on the input file for the
“Georeferenced Mosaicking Example” on page 187. However, for the purpose of this
exercise, the pre-stretched, histogram-matched images lch_01w.img and
lch_02w.img are provided as input to the georeferenced mosaicking function.

Feathering

It is often desirable to blend or blur the seams between mosaicked images. ENVI
provides the capability of feathering the edges of overlapping areas using either edge
feathering or cutline feathering over a user specified distance. To use feathering when
mosaicking images, import the bottom image without feathering. Import the
overlapping images with feathering, either edge or cutline, as desired.

Edge Feathering

Edge Feathering uses the distance
specified in the Edge feathering
distance (pixels) text box in the
Mosaic Entry Input Parameters
dialog to blend the image seams along
the edges of the image. The edge
feathering distance specified is blended
using a linear ramp that averages the
two images across that distance. For
example, if the specified distance is 20
pixels, 0% of the top image is used in
the blending at the edge and 100% of
the bottom image is used to make the

Figure 7-1: Edge Feathering
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output image. At the specified distance (20 pixels) in from the edge, 100% of the top
image is used to make the output image and 0% of the bottom image is used. At 10
pixels in from the edge, 50% of each image is used to make the output image.

Cut-Line Feathering

Cut-Line Feathering uses the distance
specified in the Cutline feathering
distance (pixels) text box and the
annotation file selected from Ann File in
the Mosaic Entry Input Parameters
dialog to blend the image boundaries.
Cutlines must be defined using the
annotation tools prior to mosaicking.
The annotation file must contain a
polyline defining the cutline that is
drawn from edge-to-edge and a symbol
placed in the region of the image that
will be cut off. The cutline distance
specified is used to create a linear ramp that averages the two images across that
distance from the cutline outwards. For example, if the specified distance is 20 pixels,
100% of the top image is used in the blending at the cutline and 0% of the bottom
image is used to make the output image. At the specified distance (20 pixels) out
from the cutline, 0% of the top image is used to make the output image and 100% of
the bottom image is used. At 10 pixels in from the cutline, 50% of each image is used
to make the output image.

Virtual Mosaics

ENVI allows use of the mosaic template file as a means of constructing a “Virtual
Mosaic” — a mosaic that can be displayed and used by ENVI without actually
creating the mosaic output file.

1. To create a virtual mosaic, create the mosaic and save the template file using
File → Save Template in the Image Mosaicking dialog. This creates a small
text file describing the mosaic layout

2. To use the virtual mosaic, select File → Open Image File from the ENVI
main menu and open the mosaic template file. All of the images used in the
mosaic are opened and their bands are listed in the Available Bands List.
Display or process any of the bands in the virtual mosaic, and ENVI treats the
individual images as if they were an actual mosaic output file. The new
processed file has the specified size of the mosaic and the input files are in
their specified positions within the mosaic.

Figure 7-2: Cutline Feathering
ENVI Tutorials Mosaicking in ENVI



180 Tutorial 7: Mosaicking Using ENVI
Steps for Creating a Pixel-Based Mosaic

The following describes the steps required to create a pixel-based image mosaic.

Set up the Mosaicking Dialog

1. Select Map → Mosaicking → Pixel Based from the ENVI main menu.

The pixel-based option can also be used to place georeferenced images, where
the georeferencing information will not be retained. Pixel-based images can
also be placed within a georeferenced image using the
Map → Mosaicking → Georeferenced option.

2. For pixel-based images, set the size of the output mosaic by entering the
desired size in pixels in X Size (Samples) and Y Size (Line) parameters in the
dialog.

3. Also set the “Snap” factor, which controls a grid to which images will be
placed or snapped (for example, a snap of 5 means that pixel-based images will
be placed at the nearest intersection of a pixel grid with 5 x 5 pixel spacing).
Set the snap factor by selecting Options → Set Snap Value.

Import Images

Use one of the following methods to import images depending on the type of mosaic
and whether the images have overlapping areas.

Importing Images Without Feathering

Images that do not overlap, or images that do not require blending should be imported
using the Import file without feathering option as follows:

1. Select Import → Import file without feathering from the menu bar in the
pixel-based or georeferenced Mosaicking dialog.

2. Open and select the desired image in the Mosaic Input File dialog and
spectrally and/or spatially subset it if desired.

The image description will be listed in the dialog, and a graphic representing
the image and its position in the mosaic will be displayed in the draw widget
within the dialog.

3. Open and import the remaining images in the mosaic in the same fashion.
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Importing Images With Feathering

Images that overlap may require feathering of the overlap areas to avoid obvious
seams in the final mosaic.

1. Select Import → Import file with feathering from the menu bar in the
Mosaicking dialog.

If cutline feathering is being used, the cutline must already have been drawn as
a polyline annotation and saved to an annotation file as described in the section
“Cut-Line Feathering” on page 179.

2. For both cutline and edge feathering, specify a distance over which to feather
as described in “Feathering” on page 178.

Feathering blends adjoining images, but mosaicking with feathering is
computationally intensive and requires a long time to run, especially for large
mosaics.

Importing Images With a Background Value to Ignore

This option allows image transparency for overlapping images.

1. Select Import → Import file with feathering regardless of whether or not
you want to feather the images. This allows you to set a background value to
ignore when images overlay one another.

2. If feathering (which is used for mosaicking images with constant digital
number value borders) is desired, enter the desired values, however, if
feathering is not desired, leave the feathering values set to zero.

3. Enter the data value to be ignored in the labeled text box.

The overlap areas with this value will be transparent, allowing underlying images to
show through. This value will also be ignored during the feathering process if
selected.

Create a Virtual Mosaic or an Output Mosaic

Complete one of the following steps, either creating a template (virtual mosaic) or
creating an output mosaic:

1. To create a virtual mosaic, described in “Virtual Mosaics” on page 179, select
File → Save Template, enter the output filename, and click OK. To view this
mosaic, select File → Open Image File from the ENVI main menu, choose
the mosaic template file as the input file and click Open. Click on the mosaic
band name in the Available Bands List and then Load Band to automatically
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get the required images and display the virtual mosaic to the ENVI Image
Display.

2. Alternatively, to actually create the mosaic as a new file, select File → Apply
in the Mosaic dialog and enter an output filename. The output mosaic is a
standard ENVI file and can be displayed using the Available Bands List.
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Pixel-Based Mosaicking Example

This section leads you through creation of pixel-based mosaics using ENVI’s
mosaicking tools.

1. Start the ENVI pixel-based mosaic function by selecting
Map → Mosaicking → Pixel Based from the ENVI main menu.

2. The Pixel Based Image Mosaicking dialog appears.

Import and Position Images

To position pixel-based images:

1. Import each of the following two images, dv06_2.img and dv06_3.img, by
selecting Import → Import file without feathering from the Pixel Based
Image Mosaicking dialog.

2. Specify the mosaic size by entering the 614 for the X Size and 1024 for the Y
Size in the text boxes at the top of the Pixel Based Image Mosaicking dialog.

3. Click on the second image in the list of images in the dialog (dv06_3.img).

Figure 7-3: The Pixel Based Image Mosaicking Dialog
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The current position of the image in pixels will be listed in the text box at the
bottom of the dialog.

4. Change the image position by entering the desired XO (x offset) and YO (y
offset) values in pixels in the corresponding text boxes. Enter a value of 513
for the YO for dv06_3.img to place it directly below dv06_2.img.

Note
Images can also be positioned by clicking and holding the left mouse button on the
desired image in the mosaic diagram on the right side of the dialog, dragging the
selected image to the desired location, and releasing the left mouse button to place
the image.

5. Select File → Apply from the Pixel Based Image Mosaicking dialog menu
and enter the output filename dv06.img and click OK to create the mosaic.

6. Choose File → Save Template from the Pixel Based Image Mosaicking
dialog and enter the output filename dv06a.mos.

7. Display the mosaicked image by clicking on the dv06a.mos band name in
the Available Bands List and then clicking Load Band.

The second part of this example shows positioning of the two images into a
composite mosaic image, accomplished by either entering the XO and YO values, or
dragging the images to the desired locations within the dialog. The example also
includes edge feathering.
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1. Using the images already displayed, enter a value of 768 into both the Mosaic
X Size and Y Size text boxes to change the size of the output mosaic

2. Left-click within the green graphic outline of image #2 in the Pixel Based
Image Mosaicking dialog. Drag the #2 image to the lower right hand corner of
the diagram.

3. Edit the mosaic characteristics by selecting Options → Edit Entry in the
Pixel Based Image Mosaicking dialog. Enter a value of 25 for the Edge
Feathering Distance and a Background Data Value to Ignore of 0, and click
OK. Repeat for the second image.

4. Choose File → Save Template and enter the output filename dv06b.mos.
Click on the mosaic template name in the Available Bands List and select

Figure 7-4: Two Single-band AVIRIS Images (left) and the Final Seamless Join
of the Two (right)
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Load Band to display it. No feathering is performed when using virtual
mosaic.

5. Now make the same image as a feathered mosaic by actually creating the
output file. In the Pixel Based Image Mosaicking dialog, select
File → Apply and click OK.

6. Enter an output filename, and a Background Value of 255, then click OK.
Display the mosaic now listed in the Available Bands List in a new display
window.

7. Compare the virtual mosaic and the feathered mosaic using image linking and
dynamic overlays.

The following figure shows the feathered output mosaic produced by overlapping the
two AVIRIS scenes as described above.

Figure 7-5: The Final Feathered Mosaic
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Georeferenced Mosaicking Example

Putting together georeferenced, overlapping images requires considerable
preparation, including histogram matching and usually feathering. The following
sections of this tutorial describe some of the requirements and how to accomplish
these using ENVI.

Create the Georeferenced Mosaic Image

1. Start the ENVI Georeferenced Mosaic function by selecting
Map → Mosaicking → Georeferenced from the ENVI main menu.

Load the Mosaic Template

Select File → Restore Template and select the file lch_a.mos. This opens the files
and restores the mosaic parameters necessary for a georeferenced, feathered mosaic.

Figure 7-6: The Georeferenced Image Mosaicking Dialog
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Optionally Input and Position Images

Optionally, to manually position the georeferenced images and set the feathering
options, import the images individually. Images will automatically be placed in their
correct geographic locations. The location and size of the georeferenced images will
determine the size of the output mosaic.

View the Top Image, Cutline and Virtual, Non-Feathered Mosaic

1. In the Available Bands List, select the file lch_01w.img and display as a
gray scale by clicking on the band name and then the Load Band button.

2. Choose Overlay → Annotation from the Main Image Display menu bar to
start the Annotation dialog.

3. Select File → Restore Annotation and choose the file lch_01w.ann to
display the cutline used to blend the two images in this mosaic.

4. Display the second image lch_02w.img and examine the nature of the cutline
with respect to this image.

5. View the virtual, non-feathered mosaic. Select File → Open Image File from
the ENVI main menu and choose lch_a.mos as the input file. Load this
image to a new display using the Available Bands List and examine the non-
feathered edge between the two images used to create the mosaic.

Create the Output Feathered Mosaic

1. Select File → Apply in the Georeferenced Image Mosaicking dialog and
enter the output filename lch_mos.img and click OK to create the feathered
mosaic.

2. Close the two Image Display Windows containing the individual warped
images and load the mosaic image into a new display.

3. Compare the feathered mosaic to the non-feathered mosaic using image
linking and dynamic overlays.
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In the following figure, the left images show the warped, histogram-matched images
with the cutline selected. The right image is the mosaic resulting from using cutline
feathering.

Figure 7-7: Examples of Georeferenced Image Mosaicking
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Additional Options in the Pixel Based and Georeferenced
Mosaicking Dialogs

The following list describes additional options when using the mosaicking dialogs:

• To edit the characteristics of an image, such as modifying feathering distances,
setting the Background Data Value to Ignore (transparency), or changing the X
and Y image offsets, select Options → Edit Entry and enter the desired
values.

• To replace an image currently in a mosaic with another image of the same size,
select the image to be replaced, and select Options → Replace Entry and
select the image to use for the replacement.

• To delete the currently selected image from the mosaic, select
Options → Delete Entry.

• To remove all images from the mosaic and clear the mosaic, select
Options → Clear All Entries.

The following Pixel Based Image Mosaicking dialog options are available only for
pixel-based images:

• To float the pixel-based image to the top of the stack of overlapping images,
click on the image in the list, or the mosaic diagram, and select
Options → Percolate Entry.

• To center all of the current images in the mosaic as a group, select
Options → Center Entries.

• To place an image as if their upper left corner has the x, y coordinates of (1,1),
select Options → Do Not Use Image Offset.

Do this for images which were previously created as subsets from other larger
images and which have an image offset value. This means that the upper left
corner of the image has X and Y values corresponding to its position in the
original image.

• To place images in the mosaic at the location specified by its location in the
original image from which it was subset, select Options → Use Image Offset.

End the ENVI Session

You can quit your ENVI session by selecting File → Exit (Quit on UNIX) in the
ENVI main menu, then click Yes to end the session. If you are using ENVI RT,
quitting ENVI will take you back to your operating system.
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The following topics are covered in this tutorial:
Overview of This Tutorial . . . . . . . . . . . . . 192
Data Fusion . . . . . . . . . . . . . . . . . . . . . . . . 193

London, UK, Data Fusion Example . . . . . 194
Brest, France, Data Fusion Example . . . . 198
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Overview of This Tutorial

This tutorial is designed to demonstrate selected ENVI data fusion capabilities. For
additional data fusion details, please see the ENVI User's Guide or ENVI Online
Help. Two examples are provided for this tutorial. The first uses Landsat TM and
SPOT data of London, UK (Data Courtesy of RSI International UK, Ltd). The TM
data are Copyright, European Space Agency, and distributed by Eurimage/NRSC.
The SPOT data are Copyright CNES, 1994, distributed by Spot Image/NRSC. Both
datasets are used with permission (NRSC, 1999). The second example uses SPOT XS
and Panchromatic data of Brest, France (Data Courtesy of RSI International, France,
Copyright CNES-Spot image, 1998. Used with permission of SPOT, 1999. These
data may not be used for commercial purposes).

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/lontmsp (London, UK TM and SPOT example)
envidata/brestsp (Brest, France SPOT PAN and XS example)

File Description

London, UK TM and SPOT example

lon_spot London SPOT data

lon_spot.ers ER Mapper Header for above file

lon_tm London Landsat TM data

lon_tm.ers ER Mapper Header for above file

Brest, France SPOT PAN and XS example

s_0417_1.bil Brest, France, SPOT panchromatic data

s_0417_1.hdr ENVI Header for above file

s_0417_2.bil Brest, France, SPOT multispectral data

s_0417_2.hdr ENVI Header for above file

copyright.txt Data copyright statement
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Data Fusion

Data Fusion is the process of combining multiple image layers into a single
composite image. It is commonly used to enhance the spatial resolution of
multispectral datasets using higher spatial resolution panchromatic data or single-
band SAR data.

The following sections walk you through some of the preparation required to fuse
image datasets in ENVI and the actual data fusion process.

Preparing Images

To perform data fusion using ENVI, the files must either be georeferenced (in which
case spatial resampling is performed on the fly), or if not georeferenced, cover the
same geographic area, have the same pixel size, the same image size, and the same
orientation. The files used in this exercise are not georeferenced, therefore the low
resolution images must be resampled to have the same pixel size as the high spatial
resolution image (using nearest neighbor resampling).
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London, UK, Data Fusion Example

Read and Display ERMapper Images

The London data are TM and SPOT data binary files with ERMapper header files,
and can be automatically read using ENVI’s ERMapper reading routines.

1. Select File → Open External File → IP Software → ER Mapper, navigate
to the lontmsp subdirectory and select the file lon_tm.ers.

2. Click on the RGB Color radio button in the Available Bands List, click
sequentially on the Red Layer, Green Layer, and Blue Layer bands, then Load
RGB to display a true-color Landsat TM image.

1. Select File → Open External File → IP Software → ER Mapper, navigate
to the lontmsp subdirectory and select the file lon_spot.ers.

2. Click on the Gray Scale radio button in the Available Bands List, click on the
Pseudo Layer band, select New Display from the pull-down Display menu,
then click Load Band to display the gray scale SPOT image

Resize Images to Same Pixel Size

1. Click first on the SPOT image band in the Available Bands List and note its
spatial dimensions (2820 x 1569) and then click on the Landsat TM and note
its spatial dimensions (1007 x 560). The Landsat data have a spatial pixel size
of 28 meters, while the SPOT data are 10 meter spatial resolution. The Landsat
image has to be resized by a factor of 2.8 to create 10 m data that matches the
SPOT data.

2. Select Basic Tools → Resize Data (Spatial/Spectral) and choose the lon_tm
image then click OK. Enter a value of 2.8 into the xfac text box in the Resize
Data Parameters dialog. Enter a value of 2.8009 into the yfac text box (the
value of 2.8009 rather than 2.8 must be used to add an extra pixel to the y
dimension so the images will match exactly). This difference is insignificant
for the purposes of this exercise, but might be important for an actual
application. Enter an output filename and click OK to resize the TM image.

3. Display the resized image and select Tools → Link → Link Displays to link
the resized TM image and the SPOT Panchromatic image. Use the dynamic
overlay to compare the two images.
London, UK, Data Fusion Example ENVI Tutorials



Tutorial 8: Landsat TM and SPOT Data Fusion Using ENVI 195
Perform Manual HSI Data Fusion

Try manually performing data fusion in order to understand the process. First, the
color TM image is transformed into hue-saturation-value color space. The value band
is replaced with the higher resolution SPOT data and stretched from zero to one to fill
the correct data range. Then the hue and saturation from the TM data and value from
the SPOT data are transformed back to red-green-blue color space. This produces an
output image that contains the colors from the TM data and the spatial resolution of
the SPOT data.

Forward HSV Transform

1. Select Transform → Color Transforms → RGB to HSV from the ENVI
main menu, and select the resized TM data as the RGB image from the
Display. Enter an output filename and click OK to perform the transform.

2. Display the Hue, Saturation, and Value images as gray scale images or an
RGB.

Figure 8-1: Landsat TM True-Color Composite (28 m spatial resolution, left).
SPOT Panchromatic Image (10m spatial resolution, right).

Figure 8-2:
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Create a Stretched SPOT Image to Replace TM Band Value

1. Select Basic Tools → Stretch Data from the ENVI main menu, click on the
lon_spot file and then OK.

2. In the Output Data portion of the Data Stretching dialog, enter the value 0
for the Min and 1.0 for the Max values, enter an output filename, and click
OK to stretch the SPOT data to floating point data with a range of 0 to 1.0.

Inverse HSV Transform

1. Select Transform → Color Transforms → HSV to RGB from the ENVI
main menu, and select the transformed TM Hue and Saturation bands as the
H and S bands for the transformation.

2. Choose the stretched SPOT data as the V band for the transform, click OK.
Enter an output filename into the HSV to RGB Parameters dialog and click
OK to perform the inverse transform.

Display Results

1. Click on the RGB Color radio button in the Available Bands List, click
sequentially on the transformed R, G, and B bands, then click the Load RGB
button to display a fused true-color Landsat TM/SPOT image.

2. Display the fused image and select Tools → Link → Link Displays to link
with the resized TM image and the SPOT Panchromatic image. Use the
dynamic overlay to compare the images.

ENVI Automated HSV Fusion

1. Select Transform → Image Sharpening → HSV from the ENVI main menu.

2. If you have the resized TM color image displayed, choose the appropriate
display in the Select Input RGB dialog. Otherwise, choose the “Red Layer”,
“Green Layer”, and “Blue Layer” from the resized TM Image in the Select
Input RGB Input Bands dialog and click OK.

3. Choose the SPOT image in the High Resolution Input File dialog and click
OK.

4. Enter the output file name lontmsp.img and click OK in the HSV
Sharpening Parameters dialog.
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Display Results, Link and Compare

1. Load the fused color image into a new display by selecting the RGB Color
radio button in the Available Bands List dialog, selecting the R, G, and B
bands from the new file and clicking Load RGB.

2. Compare the HSV sharpened color image to the original TM color composite,
to the SPOT data, and to the manual data fusion result by selecting
Tools → Link Displays → Link from the Main Display Window menu bar.

Try the same process using the Color Normalized (Brovey) Transform by selecting
Transform → Image Sharpening → Color Normalized (Brovey), entering the
required file information and clicking OK.

Figure 8-2: Landsat TM data (30 m spatial resolution, left). Fused Landsat TM
and SPOT Panchromatic data (10 m spatial resolution, right).

Figure 8-3:
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Brest, France, Data Fusion Example

Open and Display Images

The Brest data are SPOT PAN and XS format data.

1. Select File → Open Image File, navigate to the brestsp subdirectory and
open the file s_0417_2.bil. This is SPOT-XS (multispectral) data. Three
bands appear in the Available Bands List.

2. Click on the RGB Color radio button in the Available Bands List, click
sequentially on bands 1, 2, and 3, then click Load RGB to display a false-color
infrared SPOT-XS image with 20 m spatial resolution.

1. Select File → Open Image File to open the file s_0417_1.bil. This is
SPOT Panchromatic data with 10 m spatial resolution. One band appears in the
Available Bands List.

2. Click on the Gray Scale radio button in the Available Bands List, click on the
SPOT band, then Load Band to display the SPOT Panchromatic data.

Resize Images to Same Pixel Size

1. Click in the Available Bands List, first on the SPOT Panchromatic image
band and note its spatial dimensions (2835 x 2227) and then the SPOT-XS
band and note its spatial dimensions (1418 x 1114). The SPOT-XS data have a
spatial pixel size of 20 meters, while the SPOT Panchromatic data are 10 meter
spatial resolution. The SPOT-XS image has to be resized by a factor of 2.0 to
create 10 m data that matches the SPOT data.

2. Select Basic Tools → Resize Data (Spatial/Spectral) and choose the SPOT-
XS image (s_0417_2.bil) then click OK. Enter a value of 1.999 into the
xfac text box in the Resize Data Parameters dialog. Enter a value of 1.999
into the yfac text box. The value of 1.999 rather than 2.0 must be used to add
an extra pixel to the x and y dimensions so the images will match exactly. This
difference is insignificant for the purposes of this exercise, but might be
important for an actual application. Enter an output filename and click OK to
resize the SPOT-XS image.

3. Display the resized image and select Tools → Link → Link Displays to link
the resized SPOT-XS image and the SPOT Panchromatic image. Use the
dynamic overlay to compare the two images.
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Fuse Using ENVI Methods

1. Select Transform → Image Sharpening → HSV from the ENVI main menu.

2. If you have the resized SPOT color image displayed, choose the appropriate
display in the Select Input RGB dialog. Otherwise, choose bands 1, 2, and 3
from the resized SPOT-XS Image in the Select Input RGB Input Bands
dialog and click OK.

3. Choose the SPOT Panchromatic image in the High Resolution Input File
dialog and click OK.

4. Enter the output file name brest_fused.img and click OK in the HSV
Sharpening Parameters dialog.

Figure 8-3: SPOT-XS data (20 m spatial resolution, left), SPOT Panchromatic
data (10 m spatial resolution, right).
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Display and Compare Results

1. Load the fused color image into a new display by selecting the RGB Color
radio button in the Available Bands List dialog, selecting the R, G, and B
bands from the new file and clicking Load RGB.

2. Compare the HSV sharpened color image to the original SPOT XS color
composite and to the SPOT Panchromatic data by selecting Tools → Link
Displays → Link from the Main Display Window menu bar.

End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click Yes to end the
session. If you are using ENVI RT, quitting ENVI will take you back to your
operating system.

Figure 8-4: SPOT-XS data (20 m spatial resolution, left). Fused SPOT-XS and
Panchromatic data (10 m spatial resolution, right).
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The following topics are covered in this tutorial:
Overview of This Tutorial . . . . . . . . . . . . . 202
Data Fusion . . . . . . . . . . . . . . . . . . . . . . . . 203

Rome, Italy, Data Fusion Example . . . . . . 204
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Overview of This Tutorial

This tutorial is designed to demonstrate selected ENVI data fusion capabilities.
Landsat TM data and ERS-2 SAR data of Rome, Italy are co-registered using ENVI
image-to-image registration. A Hue/Saturation/Intensity color transform is used to
fuse the two datasets and the fused data are compared to the individual datasets to
determine the advantages and disadvantages of data fusion. For additional data fusion
details, please see the ENVI User’s Guide or ENVI On-Line Help. ERS and
LANDSAT images used in this tutorial are provided courtesy of the European Space
Agency (ESA) and Eurimage (used with permission) and may not be redistributed
without explicit permission from these organizations.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/rometm_ers (Rome, Italy TM and ERS example)

File Description

rome_tm Landsat TM Data, Rome, Italy

rome_tm.hdr ENVI Header for above

romr_tm.pts GCPs for image-to-image registration

rome_ers2 ERS SAR data, Rome, Italy

rome_ers2.hdr ENVI Header for above
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Data Fusion

Data Fusion is the process of combining multiple image layers into a single
composite image. It is commonly used to enhance the spatial resolution of
multispectral datasets using higher spatial resolution panchromatic data or single-
band SAR data.

The following sections walk you through some of the preparation required to fuse
image datasets in ENVI and the actual data fusion process.

Preparing Images

To perform data fusion using ENVI, the files must either be georeferenced (in which
case spatial resampling is performed on the fly), or if not georeferenced, cover the
same geographic area, have the same pixel size, and the same image size. The files
used in this exercise are not georeferenced, therefore the low resolution images must
be resampled to have the same pixel size as the high spatial resolution image (using
nearest neighbor resampling).
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Rome, Italy, Data Fusion Example

The Rome, Italy data are TM and ERS format data.

Read and Display Images

1. Select File → Open Image File, navigate to the rometm_ers subdirectory,
and open the file rome_ers2. This is ERS-2 SAR data. One band appears in
the Available Bands List.

2. Click on the Gray Scale radio button in the Available Bands List, click on the
ERS band, then Load Band to display the SAR data.

3. Select File → Open Image File and open the file rome_tm. This is Landsat
TM data. Seven bands appear in the Available Bands List.

4. From the Display #1 button menu, select New Display.

5. Click on the RGB Color radio button in the Available Bands List, click
sequentially on bands 4, 3, and 2, then Load RGB to display a false-color
infrared Landsat TM image with 30m spatial resolution.

Register the TM images to the ERS image

1. Select Map → Registration → Select GCPs: Image-to-Image, choose
Display #1 (the ERS data) as the Base Image and Display #2 (the TM data) as
the Warp Image and click OK.

2. Select File → Restore GCPs from ASCII in the Ground Control Points
Selection dialog, choose the saved GCP file rome_tm.pts, and click OK.

3. Pre-selected GCPs will be loaded onto both the TM and ERS data. Review the
positions of these points in both images for accuracy and observe the total
RMS Error listed at the bottom of the GCP Selection dialog. Also click on the
Show List button at the bottom of the dialog and review the GCPs and error.
These GCPs are sufficient for a quick registration, however, you may want to
add more points to improve the match between images. See Chapter 4, “Image
Georeferencing and Registration” for additional details about how to perform
image-to-image registration.

4. Select Options → Warp File from the Ground Control Points Selection
dialog. Choose the file rome_tm, and click OK to warp all 7 TM bands to
match the ERS data.
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5. Click on Change Output Parameters in the middle of the Registration
Parameters dialog and enter 1 for the Upper Left Corner (XO), 1 for the
Upper Left Corner (YO), 5134 for the Number of Samples, and 5549 for
the Number of Lines, followed by OK.

6. Enter an output filename in the Registration Parameters dialog and click OK
to perform the image-to-image registration.

Perform HSI Transform to Fuse Data

1. Select Transform → Image Sharpening → HSV from the ENVI main menu.

2. If you have the registered TM color image displayed, choose the appropriate
display in the Select Input RGB dialog. Otherwise, choose bands 4, 3, 2 from
the TM Image in the Select Input RGB Input Bands dialog and click OK.

Figure 9-1: Landsat TM False-color Infrared Composite (bands 4, 3, 2 as RGB),
left. ERS-2 SAR Data, right.
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Note
If you select input from the Available Bands List, the data will be clipped to byte
data. The colors in the resulting image may be unexpected.

3. Choose the ERS-2 image in the High Resolution Input File dialog and click
OK.

4. Enter the output file name rome_fused.img and click OK in the HSV
Sharpening Parameters dialog.

Display and Compare Results

1. Load the fused color image into a new display by selecting the RGB Color
radio button in the Available Bands List dialog, selecting the R, G, and B
bands from the new file from list and clicking Load RGB.

2. Compare the HSV sharpened (fused) color image to the registered Landsat TM
color composite and to the ERS-2 data by selecting Tools → Link
Displays → Link from the Main Display Window menu bar.

3. Try fusing other color composites with the ERS data as above and compare the
results.

End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click Yes to end the
session. If you are using ENVI RT, quitting ENVI will take you back to your
operating system.
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Figure 9-2: Fused Landsat CIR Image with ERS-2 Data. Note improved texture
which aids in discrimination of specific land cover classes.
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The following topics are covered in this tutorial:
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Overview of This Tutorial

This tutorial introduces ENVI’s vector overlay and GIS analysis capabilities using
vector data from ESRI’s Maps and Data CD-ROM and a simulated 4-meter
resolution Space Imaging/EOSAT multispectral dataset and associated vector data of
Gonzales, California, USA. Data courtesy of ESRI and Space Imaging/EOSAT. Part
1 of this tutorial uses ESRI’s data to demonstrate stand-alone vector GIS analysis,
including input of ArcView Shape Files and associated .dbf attribute files, display in
vector windows, viewing/editing of attribute data, point-and-click spatial query, and
math/logical query operations. Part 2 of this tutorial uses the Space Imaging/EOSAT
data to demonstrate use of ENVI’s combined image display/vector overlay and
analysis capabilities, including cursor tracking with attribute information, point-and-
click query, and heads-up digitizing and vector layer editing. Also demonstrated are
generation of new vector layers using math/logical query operations and raster-to-
vector conversion of ENVI Regions of Interest (ROI) and/or classification images.
Finally, the exercise demonstrates ENVI’s vector-to-raster conversion, using vector
query results to generate ROIs for extraction of image statistics and area calculations.
It is assumed that the user already has a basic grasp of GIS analysis concepts.

Sources and Files Used in this Tutorial

The data used in this tutorial are provided courtesy of the Environmental Systems
Research Institute Inc. and Space Imaging/EOSAT and may not be redistributed
without explicit permission from those organizations.

ESRI Data and Maps Version 1 CD-ROM

Example data used in Part 1 of this tutorial come from the ESRI Data and Maps
Version 1 CD-ROM distributed with ARCView Version 3.0. Research Systems
strives to maintain import/export compatibility with ESRI GIS products and data
formats, including ARCView Shape files and ARC/INFO export files (.e00, non-
compressed).

Space Imaging EOSAT CarterraTM Agriculture Sampler Data

Example images and vector data used in Part 2 of this tutorial are from the Space
Imaging EOSAT Carterra Agriculture Sampler CD-ROM (Copyright © 1997, Space
Imaging EOSAT), and are used with their explicit permission. This sample data set
covers an agricultural area near Gonzales, California, USA; the north-central portion
of the Palo Escrito Peak, CA USGS 7.5 minute quadrangle. The digital imagery are
simulated data products designed to be similar to the space-based image data
products that have been collected and distributed by Space Imaging EOSAT in early
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1998. They are provided by Space Imaging EOSAT to give current users of digital
imagery a look at the imagery products that they collect from orbit. These simulated
data sets provide a reasonable example of the types of information extracted from the
Space Imaging EOSAT imagery products. The imagery data sets were generated
from digital image data collected by an air-borne multispectral scanner. The air-borne
data were geometrically rectified, solar corrected and mosaicked at a spatial
resolution simulating the CARTERRA data products. There are, however, both
radiometric and geometric differences between these data and satellite-based
products planned for delivery. Please see the Carterra Sampler readme.txt file
included in the si_eosat subdirectory for additional information.

Required Files

CD-ROM: ENVI Tutorial and Data CD No. 1
ENVI Tutorial and Data CD No. 2

Path: envidata/esri_gis (On CD No. 1 for Part 1 of this tutorial)
envidata/si_eosat (On CD No. 1 for Parts 1 and 2 of this tutorial)
envidata/can_tm (On CD No. 2 for Part 2 of this tutorial)

File Description

Required Vector GIS Files for Part 1 (envidata/esri_gis on CD No. 1)

cities.shp (.shx, .dbf,) USA Cities Points

states.shp (.shx, .dbf) USA States Polygons

Optional Vector GIS Files for Part 1 (envidata/esri_gis on CD No. 1)

counties.shp (.shx, .dbf) USA Counties Polygons

drainage.shp (.shx,.dbf) USA Drainage Polygons

rivers.shp (.shx, .dbf) USA Rivers Polylines

roads.shp (.shx, .dbf) USA Roads Polylines

Required Image Files for Part 2 (envidata/si_eosat on CD No. 1)

0826_ms.img 4-meter Multispectral data

0826_ms.hdr ENVI Header for above

Required Image Files for Part 2 (envidata/can_tm on CD No. 2)

can_tmr.img Canon City TM data
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can_tmr.hdr ENVI Header for above

can_sam.img Canon City SAM Classification

can_sam.hdr ENVI Header for above

can_pcls.img Canon City Parallelepiped Classification

can_pcls.hdr ENVI Header for above

can_sv.img Sieved Classification (threshold = 5)

can_sv.hdr ENVI Header for above

can_clmp.img Clumped (5 x 5) after sieve

can_clmp.hdr ENVI Header for above

can_tm1.roi Canon City TM ROI #1

can_tm2.roi Canon City TM ROI #2

Required Vector Files for Part 2 (envidata/si_eosat on CD No. 1)

vectors.shp (.shx, .dbf,
.evf)

Field outlines polygons

Optional Vector Files for Part 2 (envidata/si_eosat on CD No. 1)

gloria.evf, (.dbf) Query results polygons

lanini.evf, (.dbf) Query results polygons

sharpe.evf, (.dbf) Query results polygons

File Description
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Vector Overlay and GIS Concepts

Capabilities

ENVI provides extensive vector overlay and GIS analysis capabilities. These include:

• Import support for industry-standard GIS file formats including ArcView
Shape files and associated .dbf attribute files, Arc/Info Interchange
(uncompressed), MapInfo vector files (.mif) and attributes from associated
.mid files, Microstation DGN vector files, DXF, USGS DLG and USGS
SDTS formats. ENVI uses an internal binary format (.evf) to maximize
performance.

• Vector or Image/Vector Displays: ENVI provides a stand-alone GIS plot
window for displaying vector data and composing simple vector-only maps.
More importantly, ENVI provides vector overlays on standard ENVI displays
including true vectorization of overlays in all windows, including the Zoom
window.

• Generate world boundary vector layers including both low- and high-
resolution political boundaries, coastlines, and rivers, as well as the USA state
boundaries for display in vector windows or overlay on image displays.

• Heads-up (on-screen) digitizing can be performed in either the vector or raster
image window. Heads-up digitizing provides an easy means of creating new
vector layers by adding polygons, lines, or points.

• Image-based and vector window-based vector editing allows users to modify
individual polygons, polylines, and points in vector layers using standardized
editing tools, taking full advantage of the image backdrop provided by raster
images in ENVI.

• Regions-of-interest, specific image contour values, classification images and
other raster processing results can easily be converted to vector format for use
in GIS processing.

• Track vectors in either vector or image display windows. Display
latitude/longitude and map coordinate information. Export map coordinates to
image-to-map registration. Open a Vector Information window and display
attribute information in real-time as the cursor tracks each vector.
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• ENVI supports linked vectors and attribute tables with point-and-click query
for both vector and raster displays. Click on a vector in the display window,
and the corresponding vector and its associated information is highlighted in
the attribute table. Click on an attribute in the table, and the display scrolls to
and highlights the corresponding vector.

• Scroll and pan through rows and columns of data in attribute tables. Edit
existing information or replace individual attributes with constant values, or
with data imported from ASCII files. Add or delete attribute columns. Sort
column information in either forward or reverse order. Save attribute records to
ASCII format.

• Query vector GIS database information directly to generate new layers of
selected information with attributes. Allows GIS analysis of layers using
simple mathematical functions and logical operators to produce new
information and layers. In keeping with established ENVI processing
paradigms, results can either be held in memory, or saved to file for later
access.

• Edit GIS layer display characteristics: modify line-types, fill types, colors, and
symbols. Use attributes to control labels and symbol sizes. Add custom vector
symbols.

• Convert the vector layer from one projection to any other map projection

• Vector GIS data converted from vector to raster Regions of Interest for
extraction of statistics, calculation of areas, and use in ENVI’s many raster
processing functions.

• Generate GIS maps using standardized ENVI annotation on either vector or
image windows. Set border widths and background colors. Additional graphics
colors have been added for ENVI 3.0 and are fully user-configurable.
Automatically generate vector layer map keys. Insert objects such as
rectangles, ellipses, lines, arrows, symbols, text, and image insets. Select and
modify existing annotation objects. Save and restore annotation templates for
specific map compositions.

• Create ArcView Shape Files and associated .dbf attribute files and indexes, or
DXF files from internal ENVI .evf format. New vector layers generated
using ENVI’s robust image processing capabilities, and changes made to
vector layers in ENVI are easily exported to industry standard GIS formats.

• Use ENVI’s new direct printing capabilities to output to printers and plotters.
Vector Overlay and GIS Concepts ENVI Tutorials



Tutorial 10: Vector Overlay and GIS Analysis 215
Concepts

ENVI’s vector overlay and GIS analysis function generally follow the same
paradigms as ENVI’s raster processing routines. Standardized file opening
procedures are used, as are the standard dialog boxes for selection of options and for
file or memory output. The sections below describe some of the basic concepts.

ENVI Vector Files (.evf)

External vector files imported into ENVI are automatically converted to ENVI’s
internal vector format, which has the default file extension .evf. This speeds
processing and optimizes data storage. It is possible to utilize external vector files
without creating an .evf file by simply selecting Memory as the output option when
the file is first imported. In this case, no .evf file is created, and it will have to be
converted again the next time the file is used.

The Available Vectors List

Much like the Available Bands List used to list and load image bands, the Available
Vectors List provides access to all vector files open in ENVI (Figure 10-1). It
automatically appears when vector files are opened and converted, or it can be started
by selecting Window → Available Vectors List on the ENVI main menu. Vectors
are loaded to either vector or image displays by selecting the vectors to load in the list
and clicking on Load Selected at the bottom of the window. If an image window is
displayed, the user has the option of loading the vectors to the display, or to a new
vector window. In addition to listing and loading vector layers, the Available Vectors
List provides utilities to open vector files, to start new vector windows, to create
world boundaries (see below) and new vector layers, and to export analysis results to
both Regions of Interest (raster-to-vector conversion), and as ARCView Shape Files
and ancillary files.
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The following figure shows an example of the Available Vectors List.

Create World Boundaries

ENVI can utilize the IDL map sets to generate both low- and high-resolution world
boundaries in ENVI.evf vector format. Select Options → Create World
Boundaries from the Available Vectors List, or Vector → Create World
Boundaries from the ENVI main menu. The user can create political boundaries,
coastlines, rivers, and the USA state boundaries.

High-resolution format is available only if the IDL high-resolution maps are
installed. If these are not currently installed on your system, you can install them
using the ENVI Installation CD, modifying your installation to include the high-
resolution maps.

Figure 10-1: The ENVI Available Vectors List
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The Vector Window Parameters Dialog

When vectors are loaded to a vector or image window, the Vector Window
Parameters dialog appears to allow control of the way the vectors are displayed and
the functions that are available for vector processing and analysis (Figure 10-3).

Figure 10-2: ENVI World Boundaries

Figure 10-3: The ENVI Vector Window Parameters Dialog
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The Vector Window Parameters dialog provides for opening vector files, importing
vector layers from the Available Vectors List, arranging vector layer precedence,
setting plot parameters and annotating plots. It also controls the mode of operation in
the vector or image display toggling between cursor query versus heads-up digitizing
and editing. The Vector Window Parameters dialog initiates ENVI’s GIS analysis
functions (Options → ) including real-time vector information, attribute viewing and
editing, and vector query operations. Finally, the Vector Window Parameters dialog
provides utilities for export of analysis results to industry-standard ARCView Shape
files with ancillary attribute files as well as raster conversion to ENVI’s internal ROI
format. The current configuration of vector overlays can also be saved to a template
to allow simple reloading of the current vector overlays and overlay characteristics.

ENVI Attributes

ENVI provides access to fully attributed GIS data in the industry standard .dbf

format associated with ARCView Shape files. Attributes are listed in an editable
table, allowing point-and-click selection and editing (see Figure 10-4).

Figure 10-4: An ENVI Attributes Table
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Double-clicking in a particular cell selects that cell for editing. The table also
supports full column substitution using a uniform value and replacement with values
from an ASCII file. Options include adding and deleting individual columns and
sorting data forward and backward based on information within a column. ENVI
attributes can be saved to an ASCII output file, or to a .dbf file.

Point-and-click spatial query is supported in ENVI Attribute tables to allow location
of key features on either images or in a vector window. Specific records are selected
by clicking on the label at the left edge of the table for a specific row in the table.The
corresponding vector is highlighted in a contrasting color in the display or vector
window.
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Part 1: Stand-Alone Vector GIS

This part of the tutorial demonstrates how to use ENVI as a simple stand-alone vector
processing and analysis system for GIS data. The ESRI Data and Maps 1 CD-ROM
data, found on the ENVI Tutorial and Data CD No. 1 are used.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To open ENVI in UNIX, enter envi at the UNIX command line.

• To open ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

Open an ArcView Vector File (Shape File)

To open a vector file:

1. Select File → Open Vector File → ArcView Shape File.

Note that on some platforms you must hold the left mouse button down to
display the submenus from the Main Menu.

An Enter ArcView Shape Filenames file selection dialog appears.

2. Navigate to the esri_gis subdirectory of the envidata directory on the
ENVI Tutorial and Data CD No. 1 just as you would in any other application
and select the file cities.shp.

The Import ArcView Shape File Parameters dialog appears on your screen.
This list allows you to select either file or memory output, enter the output
filename for the ENVI .evf file, and choose the output projection for the data.

3. Select Memory Output and choose the default values by simply clicking on
OK. A status window will appear indicating the number of vector vertices
being read and the Available Vectors List appears when the data have been
converted.

4. Select the vector layer to be loaded by selecting the cities.shp entry in the
Available Vectors List. Click on Load Selected to open a new vector window
and the Vector Window Parameters dialog.
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5. Click on Apply in the Vector Window Parameters dialog to load
cities.shp into the vector display.

The cities of the United States will be plotted in the vector display.

Work with Vector Point Data

1. Click the left mouse button in the Vector window and hold down the button
and drag the cursor around the vector window to read latitude and longitude in
the Vector Window Parameters dialog.

2. Zoom in on just the contiguous 48 states by positioning the cursor just to the
northwest of cities marked in the state of Washington and clicking and
dragging using the middle mouse button to define a box covering the desired
region.

Releasing the mouse button defines the lower right corner of the area selected
and causes the display to be zoomed in on just that area. Multiple levels of
zoom are possible. Clicking the middle mouse button anywhere in the display
zooms out one level.

3. Change the symbol used to mark the cities, by clicking on Edit Layers in the
Vector Window Parameters dialog and selecting Flag from the pull-down
Symbol menu. Click on OK at the bottom of the dialog, then Apply at the
bottom of the Vector Window Parameters dialog.

Note
You can add your own symbols by defining them in the file usersym.txt in the
menu directory of your ENVI installation.

4. Also experiment with changing other vector display characteristics by
selecting Edit Layers and changing the desired characteristics (color, symbol,
size) in the Edit Vector Layers dialog.

Create the USA State Boundaries Using IDL Map Sets

1. Select Options → Create World Boundaries in the Available Vectors List.

The Create Boundaries dialog appears.

2. Click in the check box next to USA States, select the Memory radio button,
and click on OK to create the USA States boundaries, which is loaded into the
Available Vectors List.

3. Highlight USA States and then click on the Load Selected button a the bottom
of the Available Vectors List. In the Load Vector dialog, select Vector
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Window #1 as the location to load the vector. Click Apply in the Vector
Window Parameters dialog to plot the vectors.

Both the previously defined cities and the state boundaries appear in the vector
window. The state boundaries in this case are polylines, that is, they are not
true polygons (because of the way the were digitized and stored).

4. Click on USA States in the Vector Window Parameters dialog and choose
Edit Layers to change parameters for the state boundaries, including color,
line style, and thickness. After making any changes, click OK and then click
the Apply button in the Vector Window Parameters dialog to plot the
changes.

5. Clear the state boundaries by highlighting USA States in the Vector Window
Parameters dialog and then on Remove Layer.

Work with Vector Polygon Data

1. Select File → Open Vector File → ArcView Shape File from the menu in the
Vector Window Parameters dialog. Choose states.shp and click on
Open. Select Memory Output and choose the default values by simply clicking
on OK. A status window reports the number of vector vertices being read and
the Available Vectors List appears when the data have been converted.

This loads states.shp into the Available Vectors List.

2. Make sure that the USA States boundaries previously used are deselected in
the Available Vectors List and select states.shp. Click on Load Selected
and then choose Vector Window #1 in the Load Vector dialog. In the Vector
Window Parameters dialog, click Apply to display the vectors.

3. Select states.shp in the Vector Window Parameters dialog and click on
Edit Layers. Change the color to green, the fill to line and click on OK. In the
Vector Window Parameters dialog, click Apply to re-display the vectors
with changes applied.

4. Change the vector layer precedence by selecting Options → Arrange Layer
Order, clicking on one of the vector layer names in the Vector Layer
Ordering dialog and dragging it to the desired position in the stack.
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Get Vector Information and Attributes

1. Select cities.shp in the Vector Window Parameters dialog and choose
Options → Vector Information to open the Vector Information window.
Click and drag using the left mouse button on the city flags in the Vector
window to see the basic attribute information from the ArcView .dbf attribute
file displayed in the Vector Information window.

2. Find your hometown or the nearest city by examining the CITY_NAME
attribute in the Vector Information window and then find the latitude and
longitude by looking in the Vector Window Parameters dialog.

View Attributes and Point-and-Click Query

1. Make sure that cities.shp is selected and choose Options → View/Edit
Attributes in the Vector Window Parameters dialog to open an ENVI
Attributes table.

This is a fully editable table of the attributes for the selected layer.

2. Click in the left column to do a spatial query on the selected city. The
corresponding city flag will be highlighted in the vector window. If desired,
zoom in on the specific city selected by clicking and dragging a box around the
highlighted city using the left mouse button. Zoom back out by clicking the
middle mouse button in the window.

3. Verify that you have selected the correct city by clicking with the left mouse
button on the city flag and observing the attributes in the Vector Information
window.

4. Edit the elevation value for the selected city by scrolling the ENVI Attribute
window to the right until you can view the Elevation attribute, and double
clicking with the left mouse button in the corresponding elevation table cell.
Enter a new value and press the Enter keyboard key to change the value.

5. Now do a map-based query by clicking on a city flag and observing that the
corresponding record is highlighted in the ENVI Attributes table. Drag the
vector cursor around the country from city flag to city flag and note how the
ENVI Attribute table scrolls to follow the selected cities.
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Query Attributes

1. Make sure that cities.shp is selected in the Vector Window Parameters
dialog and select Options → Query Attributes. Enter a name for the layer to
be generated in the Query Layer Name text box. For this example, enter
Where State==California. Click on the Start button to begin the query.

The Query Condition dialog appears.

2. Click on CITY_FIPS and select STATE_NAME from the pull-down menu.
Now click the > symbol and select == from the list of options in the center of
the dialog. Finally, enter the string California (be sure to match case) in the
String Value text box.

3. When the Layer Attribute Query dialog appears, click the Memory radio
button and the OK to begin the query.

ENVI creates a new vector layer with associated .dbf file based on the results
of the query and lists the new layer in the Vector Window Parameters and the
Available Vectors dialogs.

4. Click Apply in the Vector Window Parameters dialog to show the selected
vectors in the vector window in a new color.

5. Zoom in on the selected vectors using the middle mouse button to drag and
draw an outlining box around the state of California. Open the new .dbf
attribute file by clicking on the new layer name in the Vector Window
Parameters dialog and then selecting Options → View/Edit Attributes.
When the ENVI Attributes table appears, try some point-and-click query
operations as described above to see the association between the selected
cities, their locations in the vector window, and the attributes.

Tip
The easiest way to find a specific city is to sort the attributes and then click on the
city name as described in the following step.

6. Click at the top of the CITY_NAME column in the ENVI Attributes table to
highlight that complete set of attributes. Select Options → Sort by selected
column forward to sort the column alphabetically. Now scroll down the
column and click on Sacramento to highlight the location of the capital of
California in a different color in the vector window.
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Annotate Map Key in Vector Window

ENVI provides tools to generate a basic vector map from the Vector window. These
are essentially the same as the annotation tools used for ENVI image and plot
annotation, so no details are covered here. The description below demonstrates how
to put a map key in the annotation window.

1. Select Options → Annotate Plot in the Vector Windows Parameters dialog
to begin.

2. In the Annotation dialog, select Object → Map Key to automatically create a
map key for the vector layers. Click the left mouse button in the Vector Display
window to place and move the annotation.

The characteristics of the key are controlled by clicking on the Edit Map Key
Items button in the Annotations dialog and selecting the desired changes.
Change the annotation characteristics by clicking OK.

3. Click the right mouse button in the Vector window to finalize placement of the
map key. All annotation in the vector window follows the same paradigms as
annotation in ENVI display windows. See the descriptions of Annotation in the
ENVI 3.5 User’s Guide for additional details.

Close all Windows and Files

1. Click on Select All Layers in the Available Vectors List and then click
Remove Selected. Close the Available Vectors List by selecting
File → Cancel.

2. Close the vector window and all associate dialogs and tables by selecting
File → Cancel in the Vector Window Parameters dialog.

This concludes Part 1 of the exercise.
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Figure 10-5: Results of GIS Attribute Queries and Annotations
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Part 2: Raster and Vector Processing

This section of the tutorial demonstrates how to use Vector Overlays and GIS data
and attributes in combination with raster images. Data from Space Imaging EOSAT
are used.

Load Image Data to Combined Image/Vector Display

To open an image file to use as a backdrop for vector layers:

1. Select File → Open Image File from the ENVI main menu.

Note that on some platforms you must hold the left mouse button down to
display the submenus from the Main Menu.

An Enter Data Filenames selection dialog appears.

2. Navigate to the si_eosat subdirectory of the envidata directory on the
ENVI Tutorial and Data CD No. 1 just as you would in any other application
and select the file 0826_ms.img.

The Available Bands List appears with four spectral bands listed. These data
are a simulated 4-meter Space Imaging EOSAT multispectral dataset with
spectral band coverage similar to the first 4 spectral bands of Landsat
Thematic Mapper data.

The bands to load into a color composite have already been selected using
ENVI default bands option in the ENVI header file, thus a true-color image has
automatically been loaded into a new image display window.

Open a Vector Layer and Load to Image Display

1. Select Overlays → Vectors from the main image display to open the Vector
Parameters dialog.

2. Select File → Open Vector File → ArcView Shape File from the menu bar in
the Vector Parameters dialog. Select the file vectors.shp from the list.

Note
You could also have used the File → Open Vector File → ArcView Shape File
method used above from the ENVI main menu to accomplish the same thing. ENVI
provides several methods of accessing the vector overlays. Users can choose the
method most consistent with their applications and approach to processing.
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The Import ArcView Shape File Parameters dialog that appears allows you
to select either file or memory output, enter the output filename for the ENVI
.evf file, and choose the output projection for the data.

3. In the Import ArcView Shape File Parameters dialog, click on State Plane
(NAD 83) as the Output Projection. Click on the Set Zone button and select
(404, 3351) California IV in the Select State Plane Zone dialog. Select
Memory output and click on OK in the Import ArcView Shape File
Parameters dialog to complete the projection selection.

Alternatively, use File → Open Vector File → ENVI Vector File (.evf) to
open the existing ENVI vector files.

A status window reports the number of vector vertices being read. When the
data have been converted (.shp) or imported (.evf), the Available Vectors
List displays the vector layer and automatically loads the vector layer into the
Vector Parameters dialog.

4. Click on Apply in the Vector Parameters dialog to load the vectors into the
image display as an overlay on the displayed image.

5. Choose Edit Layers in the Vector Parameters dialog and change the color of
the vectors to red and click OK. Then click Apply to re-apply the modified
vectors to the image.

Track Attributes with the Cursor

1. Select Options → Vector Information from the Vector Parameters dialog to
start the Vector Information window. Click and drag using the left mouse
button in the image to view the attribute information for the vectors. Also
observe the latitude and longitude listed in the Vector Parameters dialog.
Select the Scroll and Zoom radio buttons in the Vector Parameters dialog to
allow vector tracking in the corresponding window. Select the Off radio button
to allow normal scrolling in the Scroll and Main windows and zooming in the
Zoom window. Try different zoom factors in the Zoom window to assess the
accuracy of the vectors.

2. Select Options → View/Edit Attributes in the Vector Parameters dialog to
load the ENVI Attributes table for these data. Utilize point-and-click query as
described for the vector-only case above by clicking in the left (numbered)
column of the attribute table to find and highlight specific polygons on the
image.
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Heads-up (On-screen) Digitizing

ENVI provides vector editing routines for adding your own vectors to an existing
vector layer or for creating new vector layers. These vector editing routines function
are similar in fashion to ENVI’s annotation polygons, polylines, and points. ENVI
heads-up vector digitizing allows creation of new polygons, polylines, points,
rectangles, and ellipses.

To add new objects to a vector layer, first choose the layer name from the list in the
Vector Parameters dialog. Then select Mode → Add New [Object], where [Object]
is one of the available object types. For the purposes of this exercise, we will create a
new polygon layer as follows:

1. Create a new layer by selecting Options → Create New Layer from the
Vector Parameters dialog. Enter a name for the layer in the New Vector
Layer Parameters dialog, choose the Memory radio button, and click OK.

2. Click on the new layer name in the Vector Parameters dialog and a new .dbf
file is initialized. Choose Mode → Add New Polygon to begin adding
polygons to the layer.

3. In the image display window (or the Scroll or Zoom window if selected using
the radio button in the Vector Parameters dialog), use the mouse to define the
new polygon area as follows:

• Click the left mouse button to draw polygon segments.

• Click the middle mouse button to erase polygon segments.

• Click the right mouse button to close the polygon, and a right-click a
second time to accept the polygon.

Polylines (line segments) are added in the same manner described above.
However, when working with points, clicking the left mouse button places the
point, the middle deletes it, and the right mouse button finalizes the placement.

4. Draw a few polygons using field outlines on the image as guides.

5. To add attributes to the newly created polygons, select Options → Add
Attributes in the Vector Parameters dialog. In the Attribute Initialization
dialog, Enter Field ID in the Name field and choose Character for the
Type of the parameter. Click on the Add Field button at the bottom of the
dialog and enter a second attribute called Field Area in the Name field and
change the Type to Numeric. Click OK to create the Attribute Table.
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6. Now edit the attribute table as previously described. Double-click on a field to
make changes, enter the value, and press the Enter key on the keyboard. Use
point-and-click query to see which attributes are associated with which fields.

7. Close the Attribute table by selecting File → Cancel from the menu bar at the
top of the table.

Edit Vector Layers

1. In the Vector Parameters dialog, click on the new vector layer you created
and select Mode → Edit Existing Vectors. In the main image display, left-
click on one of the polygons you created previously.

The polygon will be highlighted and the nodes of the polygon will be marked
with a diamond. When the vector is selected, you can make the following
changes:

• Delete the entire polygon by selecting Mode → Delete Vector in the
Vector Parameters dialog.

• Exit the editing function without making any changes by clicking the
middle mouse button.

• Modify the vector by clicking on one of the markers with your left mouse
button and dragging to a new location.

• Finalize changes and redraw the polygon by clicking the right mouse
button.

2. To finish up this section, delete any new layers you have made by selecting,
those layers in the Available Vectors List and clicking on Remove Selected.
Do not remove the vectors.shp layer.

Query Operations

1. Choose the vectors.shp layer in the Vector Parameters dialog by clicking
on the layer name. Select Options → View/Edit Attributes to open an ENVI
Attributes table. Examine the RANCH attribute and note the predominance of
three owners “gloria”, “lanini”, and “sharpe”. Close the attribute table by
selecting File → Cancel.

2. Select Options → Query Attributes in the Vector Parameters dialog. Enter
the Query Layer Name Gloria Ranch in the Layer Attribute Query
dialog and click on the Start button. Click AREA and choose RANCH from
the pull-down menu. Set the condition to ==, and enter gloria for the string
value (be sure to match the case seen in the attribute table). Click OK.
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3. Select the Memory radio button in the Layer Attribute Query dialog and
click OK again. The new layer generated by the query is listed in the Vector
Parameters dialog.

4. Click on the layer name in the dialog and then on the Edit Layer button to
change layer parameters. Choose Line for the fill type and then click OK.
Click Apply in the Vector Parameters dialog.

The Gloria Ranch holdings are highlighted as a new layer.

5. Examine the attributes for this layer by selecting the layer name in the Vector
Parameters dialog and choosing Options → View/Edit Attributes. Examine
the query results.

6. Close the attribute table and repeat the query for the lanini and sharp
ranches, highlighting each in a different color or pattern.

7. Try other queries on combinations of attributes by choosing one of the logical
operators in the Layer Attribute Query dialog.

Vector-to-Raster Conversions

ENVI provides several important links between vector analysis and raster image
processing. This portion of the exercise describes how to take vector processing
results, create Regions of Interest for use on the images, and extract region statistics
and polygon area.

1. Open the ROI Tool dialog by selecting Overlay → Regions of Interest in the
Main Image Display window.

1. To create Regions of Interest (ROI) for use with ENVI raster processing, click
on the name of the layer to be exported to ROI. Select File → Export Layer
to ROI in the Vector Parameters dialog. Do this for several of the layers you
created using the query operations above.

The layers are listed in the ROI Tool dialog.

2. Click on the ROI name in the ROI Tool dialog and select Options → Report
Areas of ROIs → Meters2 to generate a report of the area of the selected
region.

3. Click on the ROI name in the ROI Tool dialog and click on the Stats button at
the bottom of the dialog to get the image statistics for the gloria ranch
polygons and multispectral data. Try the same thing for the other queries you
generated in the vector analysis and compare the areas and statistics.
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Now that these vector polygons are ENVI ROIs, you can use the power of all
of ENVI’s raster processing capabilities to analyze the image data with respect
to the ROIs. This includes such activities as masking, statistics, contrast
stretching, and supervised classification.

Image-Map Output

ENVI provides tools to generate image maps from the combined raster/vector
data in the ENVI Main Image Display window. These are essentially the same
as the annotation tools used for ENVI image and plot annotation, so no details
are covered here. The description below demonstrates how to put a map key in
the Main Image display window.

1. Generate a map-output image with a vector key using ENVI’s image-map
composition capabilities. From the Main Image Display menu bar, select
Overlay → Annotation.

2. Select Object → Map Key. Use the Annotation: Map Key dialog to
automatically create a map key for the vector layers. Click the left mouse
button in the Main Image Display window to place and move the annotation.

3. The characteristics of the key are controlled by clicking on Edit Map Key
Items and selecting the desired changes. Return to placing the annotation by
clicking OK.

4. Click the right mouse button in the Vector window to finalize placement of the
map key. All annotation in the vector window follows the same paradigms as
annotation in ENVI display windows. See the descriptions of Annotation in the
ENVI 3.5 User’s Guide for additional detail.
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The result of GIS vector overlay onto a raster image appears in the following figure.

Close All Windows and Files

1. Click on Select All Layers in the Available Vectors List then click Remove
Selected. Close the Available Vectors List by selecting File → Cancel.

2. Close the image window and all associated dialogs and tables by selecting
File → Close All Files from the ENVI main menu.

Figure 10-6: Results of GIS Vector Overlay on Raster Image
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Raster to Vector Conversions

ENVI can also easily convert raster processing results for use in ENVI vector
processing and analysis, as well as for export to external GIS systems such as
ArcView and ArcInfo. The last part of this tutorial illustrates the export of raster
information to vector GIS.

Export ROI to Vector Layer

Regions of Interest defined using any of ENVI’s standard methods can be exported to
become one or more vector layers

Load Image Data to Image Display

Open an image file to use as background for ROI definition and export to vector:

1. Select File → Open Image File from the ENVI main menu.

Note that on some platforms you must hold the left mouse button down to
display the submenus from the Main Menu.

An Enter Data Filenames file selection dialog appears.

2. Navigate to the can_tm subdirectory of the envidata directory on the ENVI
Tutorial and Data CD No. 2 just as you would in any other application and
select the file can_tmr.img.

3. Click on the Gray Scale toggle button in the Available Bands List, select
Band 4 in the list, then click Load Band to load a grayscale image of TM band
into a new image display window.

Load Predefined ROIs

Some regions of interest have been predefined using ENVI’s interactive ROI
definition tools.

1. Select Overlay → Region of Interest in the Main Display window to open the
ROI Tool dialog. Select File → Restore ROIs and select the ROI file
can_tm1.roi. An ENVI Message dialog reports what regions have been
restored. Click OK.

The predefined ROI is loaded into the ROI Tool dialog and plotted on the
image.

2. Repeat the above step for the file can_tm2.roi.

The ROIs are overlaid onto the TM Band 3 data.
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Convert ROIs to Vectors

1. To convert these ROIs to vector polygons, select File → Export ROI to EVF
in the ROI Tool dialog. The Export Region to EVF dialog appears. Choose
one of the regions by highlighting the region name. Choose the All points as
one record radio button option, enter a Layer Name in the appropriate text
box, click on Memory, and then OK to convert the first ROI and import it into
the Available Vectors List. Repeat the procedure for the second ROI.

2. In the Available Vectors List, click Select All Layers, then click the Load
Selected button.

3. Select New Vector Window in the Load Vector dialog to open a new vector
window and load the new vector polygons into the Vector Window
Parameters dialog. Click Apply in the Vector Window Parameters dialog to
load the polygons.

4. Choose Options → Add Attributes to add attributes to the polygons.

These can now be used in Query and GIS analysis with other vector data or
exported to ArcView Shape Files by selecting File → Export Layer to
ArcView in the Vector Window Parameters dialog.

Close All Windows and Files

1. Click on Select All Layers in the Available Vectors List then on Remove
Selected. Close the Available Vectors List by selecting File → Cancel.

2. Close the Vector display window by clicking on File → Cancel in the Vector
Window Parameters dialog.

3. Close the image window and all associated dialogs and tables by selecting
File → Close All Files from the ENVI main menu.

Export Classification Image to Vector Polygons

Classes defined using any of ENVI’s standard classification methods can be exported
to become one or more vector layers. ENVI also allows selection of individual image
brightness levels for export as a vector layer.

Load and Display a Classification Image

Open an image file to use as background for ROI definition and export to vector:

1. Select File → Open Image File from the ENVI main menu.

Note that on some platforms you must hold the left mouse button down to
display the submenus from the Main Menu.
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An Enter Data Filenames file selection dialog appears.

2. Navigate to the can_tm subdirectory of the ENVIDATA directory on the ENVI
Tutorial and Data CD No. 2 and select can_pcls.img.

This is a parallelepiped classification of the Canon City TM data with 3
classes.

3. Load this Classification into a gray scale image by clicking on the band name
in the Available Bands List and selecting Load Band.

Generalize the Classification Image.

To conduct successful raster-to-vector conversions, it is usually necessary to
generalize the results of raster processing. If you don’t do this, you end up with vector
polygons around individual pixels and small groups of pixels.

To demonstrate the results of generalization of the classification image, load and
display the results of a 5 pixel sieve operation followed by a 5 x 5 clump operation as
follows:

1. First open and display can_sv.img, the sieve results in Display #1. Next
display can_clmp.img, the clump results in Display #1. Both files are located
in the can_tm subdirectory of the envidata directory on the ENVI Tutorial
and Data CD No. 2.

2. Convert the generalized classification image to vector polygons. Select
Classification → Post Classification → Classification to Vector from the
main ENVI menu bar. Choose the can_clmp.img classification for
processing by clicking on the image name and then the OK button in the
Raster to Vector Input Band dialog. This open the Raster to Vector
Parameters dialog.

Create the Vector Polygons

1. Highlight Region #1 and Region #2 by clicking on each while holding down
the Shift key in the Raster to Vector Parameters dialog. Toggle to select One
Layer per Class for the Output. Select Memory output results and click OK.
A status dialog will appear while the vectorization takes place and the new
vector layers will appear in the Available Vectors List.

2. Select both layers by pressing Shift while clicking on the vector names and
click on Load Selected and choose Display Window #1.

3. Change the layer characteristics by selecting Edit Layers. Select the color
while and Line fill for the first layer. Highlight the second layer and select the
color yellow and Line fill. Click OK. Click Apply in the Vector Parameters
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dialog to display the vector outlines overlaid onto the clumped classification
image.

Alternatively, you could also select New Vector Window in the Load Vector
dialog to display in an ENVI vector window. Clicking on Apply in the Vector
Window Parameters dialog would load the selected vectors into the vector
display.

Examine the vector layer and the results of the vectorization of raster
classification. You can also overlay the vectors onto a gray scale can_tmr
band 3 if desired. This overlay is show in the following figure.

End the ENVI Session

You can quit your ENVI session by selecting File → Exit (Quit on UNIX) on the
ENVI main menu, then click Yes to end the session. If you are using ENVI RT,
quitting ENVI will take you back to your operating system.

Figure 10-7: Results of Raster-to-Vector Classification Conversion Overlaid onto
the Raster Image
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Tutorial 11:

Map Composition
Tutorial
The following topics are covered in this tutorial:
Overview of This Tutorial . . . . . . . . . . . . . 240 Map Composition in ENVI . . . . . . . . . . . 241
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Overview of This Tutorial

This tutorial is designed to give you a working knowledge of ENVI's map
composition capabilities. ENVI’s new QuickMap utility is used to generate a basic
map template, then additional information is added using ENVI’s annotation
capabilities. For additional information please see the ENVI User's Guide or the
ENVI Online Help.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/ys_tmsub

File Description

ysratio.img Yellowstone National Park TM Ratio Subset Image

ysratio.hdr ENVI Header for above

ysratio.ann Saved Annotation Result for above

ysratio.grd Saved Grid Parameters for above

ys_loc.tif Location Image for above
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Map Composition in ENVI

Map composition requires that you are able to easily and quickly go from an image to
an image-based map by interactively inserting key map components. The map
composition process usually consists of basic template generation (or restoring a
saved template) using ENVI’s QuickMap utility, followed by interactive
customization (if required) using ENVI annotation or other image overlays.
QuickMap allows you to set the map scale and the output page size and orientation;
to select the image spatial subset to use for the map; and to easily add basic map
components such as map grids, scale bars, map titles, logos, projection information,
and other basic map annotation. Additional custom ENVI annotation of QuickMap
output allows insertion of map keys, declination diagrams, arrows, images and/or
plots, and additional text. Interactive map composition using ENVI annotation and/or
grid line overlays also allows modification of QuickMap default overlays and custom
placement of all map elements.

Getting Started

Composing a map in ENVI is as simple as displaying the image, using ENVI’s
QuickMap utility to build or restore a basic map template, and then if necessary,
interactively adding to or modifying the individual map components such as
annotation, map scales, gridlines, etc. The map composition can be saved as an ENVI
Display Group and restored for future modification and/or printing. Additionally,
ENVI annotation allows you to individually build and save templates of common
map objects.

• To begin, select the image for map composition, open the file, and load as a
grayscale or RGB image into one of ENVI's display windows with the desired
contrast stretch as indicated in the next section.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To start ENVI in UNIX, enter envi at the UNIX command line.

• To start ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.
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Open and Display Landsat TM Data

To open an image file:

1. Select File → Open Image File on the ENVI main menu.

The Enter Input Data File file selection dialog appears.

2. Navigate to the ys_tmsub subdirectory of the envidata directory on the
ENVI Tutorial and Data CD No. 1 and select the file ysratio.img from the
list and click Open.

The file and bands are listed in the Available Bands List. The 5/7, 3/1, 3/4 ratio
bands are automatically loaded into the “R,” “G,” and “B” fields by default.
Note that you have the choice of loading either a grayscale or an RGB color
image. Click the RGB Color button.

3. Click Load RGB to load the image into a new display.

Once the image is displayed, complete the following steps to build a QuickMap
template and to add individual map components.

Build the QuickMap Template

1. From the Main Display menu, select File → QuickMap → New QuickMap.

The QuickMap Default Layout dialog appears. This dialog allows
modification of the output page size, the page orientation, and the map scale.

2. For the purposes of this tutorial, we will use all of the default values except for
the map scale. Change the Map Scale to 200,000 then click OK to proceed to
the image subset selection.

3. Select the image subset for the output map by positioning the red box in the
QuickMap Image Selection dialog using the left mouse button. You can also
change the portion of the image selected by resizing this box by grabbing and
dragging one of the box corners. For the purposes of this tutorial, we will use
the full image. Click using the left mouse button on the lower right corner of
the red box and drag down so that the whole image is selected. Click OK and
the QuickMap Parameters dialog appears (see Figure 11-1).

4. Click with the left mouse button in the Main Title text box in the dialog and
type the text “Yellowstone National Park Image-Map.”

5. Click with the right mouse button in the Lower Left Text text box in the dialog
and left-click the Load Projection Info menu button to load the image map
projection information from the ENVI header.
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6. Click with the left mouse button in the Lower Right Text text box in the dialog
and type the text “Map Generated Using.” Press the Enter key and type “ENVI
QuickMap.” Press the Enter key and type “Copyright 2001,” press the Enter
key and type “Research Systems, Inc.”

7. For the purposes of this tutorial, we recommend using the default Distance
Scale Bars, Grids, and North Arrows/Declination settings, however, if desired,
modify these using the check boxes and options on the right side of the
QuickMap Parameters dialog.

8. Select Save Template at the bottom of the dialog, enter the Output Filename
ysratio.qm, and click OK to save the QuickMap results as a QuickMap
template file. This template can be recalled for use on any image of the same
pixel size by simply displaying the desired image and selecting
File → QuickMap → from Previous Template to restore the saved
QuickMap template.

Figure 11-1: ENVI QuickMap Parameters dialog showing default settings and
text added for the tutorial map composition.
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9. Click Apply in the lower left corner of the QuickMap Parameter dialog to
display the QuickMap results in a standard ENVI display group.

If desired, you can modify the settings in the QuickMap Parameters dialog
and click Apply to change the displayed QuickMap.

10. At this stage, you can output the QuickMap to a printer or a Postscript file. See
“Save the Results” on page 259 and “Printing” on page 260 for more
information. Save or print a copy if desired, otherwise, continue with Step 11.

11. Review the QuickMap results using the ENVI display group. Observe the map
grids, scale bars, north arrow, and positioning of the default text.

Figure 11-2: ENVI QuickMap default output.
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Elements for Customizing Map Layouts

ENVI offers many options for customizing your map composition. Options include
adding virtual borders, text annotation, grid lines, contour lines, plot insets, vector
overlays, and classification overlays. You can use the ENVI Main Image window,
Scroll window, and/or Zoom window to perform additional, custom map
composition. (If you are working in the Scroll window, you may want to enlarge it by
dragging one of the corners to resize the display.) The following sections describe the
different elements and provide general instructions.

Adding Virtual Borders

Default ENVI displays contain only the image, with no surrounding blank space.
Map composition typically requires that some map objects reside outside the image
proper. ENVI provides a “Virtual Border” capability that allows annotation in the
image borders without creating a new image. Virtual borders can be added to an
image in several ways, which are described here:

Automatically When Using Image Grids in ENVI QuickMap

A virtual border is added to accommodate the QuickMap grid and a default grid is
displayed. See the following specific grid instructions for information on modifying
the grid. The required border is automatically added on all sides of the image.

1. To change from the default border, select Overlay → Grid Lines from the
Main Display menu bar of the QuickMap display and when the Grid Line
Parameters dialog appears, choose Options → Set Display Borders to start
the Display Borders dialog.

2. For the purposes of this tutorial, enter the values “100,” “400,” “150,” and
“100” as shown in Figure 11-3. Click OK.

The new virtual border characteristics are applied immediately to the image. If
you save the Grid Parameter File, the border information will be saved with the
grid and will be restored when the grid parameters file is restored.
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Using the Display Preferences

You can also change the Virtual Borders using the display preferences:

1. Select File → Preferences from the Main Image Display menu bar of the
QuickMap display.

The Display Parameters dialog appears, containing text boxes at the top of the
dialog similar to those described previously.

2. Enter the desired values and select the desired color for the border.

3. Click OK.

The new borders will be applied to the image immediately.

Using the Annotation Function

Virtual Borders are also controlled using the ENVI Annotation Function.

1. Select Overlay → Annotation from the Main Image Display menu bar of the
QuickMap display.

2. When the Annotation dialog appears, select Options → Set Display Borders
to start the Display Borders dialog.

3. Enter the desired border characteristics and click OK.

The new virtual border characteristics are applied immediately to the image. If you
save the Annotation File, the border information will be saved with the annotation
and will be restored when the annotation file is restored.

Figure 11-3: Set Display Borders dialog.
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Adding Grid Lines

ENVI supports simultaneous pixel, map coordinate, and geographic
(latitude/longitude) grids. A 100-pixel virtual border (which can be adjusted as
described in “Adding Virtual Borders” on page 245) is automatically appended to the
image to accommodate the grid labels when grids are applied. To add or modify
image grids, follow these steps:

1. Select Overlay → Grid Lines from the Main Image Display menu bar of the
QuickMap display.

The Grid Line Parameters dialog appears and a default grid is displayed with
default grid spacings set.

2. Change the grid spacing to 4000 meters by entering the value “4,000” in the
Grid Spacing text box.

If desired, choose Options → Edit Pixel Grid Attributes or Edit Map Grid
Attributes or Edit Geographic Grid Attributes to edit the attributes of the
selected grid, then click OK to apply the selected attributes.

This allows editing of the line and label characteristics for the grid.

3. In the Grid Line Parameters dialog click Apply to post the new grid to the
displayed image.

Figure 11-4: The Grid Line Parameters dialog.
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• To save Grid parameters for later use, select File → Save Setup from the Grid
Parameters menu bar and select an output file.

This saves a template of the grid parameters, which can be recalled for use on
another map composition by choosing File → Restore Setup from the Grid
Parameters menu bar.

Working with Annotation

Annotation is used as a generalized means of inserting (and positioning) map objects
in an ENVI display for map composition. Several classes of map objects are available
and all are placed using ENVI's standardized annotation procedures.

1. Select Overlay → Annotation in the Main Image Display menu bar of the
QuickMap display to start the Annotation dialog.

2. Choose the desired annotation object from the Object pull-down menu in the
Annotation dialog menu bar.

3. Place the object by dragging using the left mouse button and clicking the right
mouse button to lock the annotation in position.

• All annotation objects can be reselected and then modified by choosing
Object → Selection/Edit followed by selecting the object by drawing a
box around it using the left mouse button. The selected object can then be
moved by clicking the associated handle and dragging to a new location.
The object can be deleted or duplicated by choosing the appropriate option
from the selected menu.

• Clicking the right mouse button re-locks the annotation.

The various types of annotation available in ENVI are discussed in the following
sections. Please see the ENVI User's Guide or the ENVI Online Help for more
details.
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Text and Symbol Annotation

ENVI currently has a wide variety of text fonts and different standard symbol sets. In
addition, ENVI can utilize TrueType fonts installed on your system. This provides
access to a wide range of different text fonts and symbols. All of these can be
interactively scaled and rotated, and different colors and thickness can be set.

Note
ENVI provides some useful symbols (including special North Arrows) as a custom
TrueType font. Select ENVI Symbols from the Font pull-down button in the
Annotation dialog for use with either Text or Symbol annotation.

1. Select Object → Text or Object → Symbol from the Annotation menu bar.

Figure 11-5: The Annotation dialog.
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• For text annotation, select the font from the Font button menu in the left
center of the dialog. Select size, color, and orientation parameters using
the appropriate buttons and text boxes in the center of the dialog.

TrueType fonts provide more flexibility. Select one of the TrueType fonts
available on your system by choosing TrueType from the Font button
menu and selecting the desired font. Enter the character you want and
place using the methods described in “Working with Annotation” on
page 248.

• For symbols, select the desired symbol from the table of symbols that
appears in the Annotation dialog when this object is selected.

2. Place the text or symbol on the image as described in “Working with
Annotation” on page 248. Position with the left mouse button, and place by
clicking the right mouse button.

3. Reselect, modify, and move the annotation as desired.

Polygon and Shape Annotation

ENVI allows you to draw rectangles, squares, ellipses, circles, and free-form
polygons. These can be an outline only, or filled with a solid color or a pattern.
Placement is interactive, with easy rotation and scaling.

1. Select Object → Rectangle, Object → Ellipse, or Object → Polygon in the
Annotation dialog.

Figure 11-6: Text annotation.

Figure 11-7: Some TrueType font symbols.
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2. Drag and place the shapes as described in “Working with Annotation” on
page 248.

• For polygons, use the left mouse button to define polygon vertices and the
right mouse button to close the polygon.

Line and Arrow Annotation

ENVI annotation allows the placement of polylines (lines) and arrows. You have full
control over the color, thickness and linetype, and the fill and head characteristics for
arrows.

1. Select Object → Polyline or Object → Arrow in the Annotation dialog.

2. Define arrows and lines by clicking with the left mouse button.

3. Click using the right mouse button to close the current line.

Map Scale Annotation

Map Scales are automatically generated by ENVI based on the pixel size of the image
being used in the map composition. Options include feet, miles, meters, and
kilometers. Scales can be placed individually, or in groups. You can configure the
number of divisions and minor divisions, and the font and character size.

1. Select Object → Scale Bar in the Annotation dialog.

Figure 11-8: Annotation with shapes.

Figure 11-9: Line and arrow annotation.
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2. Enter the desired parameters, then place the scale bar using the left mouse
button.

3. Lock in the annotation using the right mouse button.

Declination Diagrams

ENVI automatically generates declination diagrams based on user-provided
characteristics. The size of the diagram and the azimuths for True North, Grid North,
and Magnetic North are entered in decimal degrees and the diagram is placed using
standard ENVI annotation procedure.

1. Select Object → Declination in the Annotation dialog.

2. Place the annotation using the left mouse button.

3. Lock in the annotation using the right mouse button.

Map Key Annotation

Shown in Figure 11-11 is an example of a map key built using ENVI's map key
editing feature. The box around the key is a rectangle placed as a separate annotation
object as is the key description at the top of the box.

1. Select Object → Map Key in the Annotation dialog.

2. Choose Edit Map Key Items to add, delete, or modify individual map key
items.

3. Place the map key using the left mouse button and lock in using the right
mouse button.

Figure 11-10: Scale Bar annotation.
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Map keys are generated automatically for classification images and vector layers.

Color Ramp Annotation

You can create grayscale ramps and color bars for grayscale and color-coded images
respectively.

Note
This option is not available when an RGB image is displayed.

1. Select Object → Color Ramp in the Annotation dialog.

2. Enter minimum and maximum values and intervals as desired and set vertical
or horizontal orientation.

3. Place the color ramp using the left mouse button.

4. Lock in the annotation using the right mouse button.

Image Insets as Annotation

While many images can be inset into another image using ENVI's mosaicking
capabilities, ENVI annotation provides the capability to inset images into other
images during the map composition/annotation process as well.

Figure 11-11: ENVI Map Key.

Figure 11-12: ENVI Color Ramp with labels.
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1. Select Object → Image in the Annotation dialog.

2. Click Select New Image to choose the image to be inserted (the image must
previously be opened and listed in the Available Bands List).

3. Pick the image from the Available Bands List, perform any spatial subsetting,
and resize on-the-fly if desired.

4. Place the image using the left mouse button.

5. Lock the image in using the right mouse button.

Because 8-bit displays can’t easily assign a new color table to the inset image, ENVI
only shows a representation of the image in the display window. The actual image is
placed when the image is output to a file and the annotation is “burned in.”

Plot Insets as Annotation

ENVI annotation also provides the capability to inset ENVI plots into other images
during the map composition/annotation process. These vector plots will maintain
their vector character (will not be rasterized) on output to “Printer” or “Postscript”
(note: they will not show up on output to image.)

1. Select Object → Plot from the Annotation dialog menu.

2. Click Select New Plot to choose the plot be inserted (the plot must currently
be displayed). Types of plots supported include X-, Y-, spectral-, and arbitrary
profiles, and spectral plots.

3. Select the plot from the Select Plot Window dialog, set the size of the plot by
entering the desired dimensions, and click OK.

4. Place the plot using the left mouse button.

5. Lock the plot annotation into the image using the right mouse button.

Because 8-bit displays can’t easily assign a new color table to the inset plot, ENVI
only shows a representation of the plot in the display window. The actual plot is
placed when the image is output directly to the printer or a postscript file and the
annotation is burnt in. Again, this option does not produce a vector plot when output
to “Image.”

Overlaying Classification Images

ENVI Classification images can be used as overlays during map composition. First
classify the image using standard ENVI classification procedures or open an existing
ENVI classification image. Once the classified image is listed in the Available Bands
List, then it can be used as an overlay. See the ENVI User's Guide or online help for
additional details about image classification.
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1. Select Overlay → Classification from the Display menu of the image being
used for the map composition and choose the ENVI classification image in the
Interactive Class Tool Input File dialog then click OK.

The Interactive Class Tool dialog will appear.

2. Turn on specific classes on the map composition by clicking in the
corresponding On box in the dialog. Multiple classes can be selected. The
selected classes will appear in the appropriate color as an overlay on the image.

3. Class colors/names can be changed by choosing Options → Edit class
colors/names in the Interactive Class Tool dialog and changing as desired.

Overlaying Contour Lines

ENVI provides the capability to contour the “Z” value of images and overlay the
contour lines as vectors on an image background. Digital Elevation Models (DEMs)
work best. The contours can be simply added to a map composition as follows:

1. Select Overlay → Contour Lines from the Main Display menu bar of the
image being used for map composition.

2. Choose the desired image to contour in the Contour Band Choice dialog and
click OK.

3. To use the default contour values click Apply in the Contour Plot dialog.

4. New contour levels can be added, levels edited, colors and line types changed,
etc. using the Contour Plot dialog. See the ENVI User's Guide or online help
for additional details.

Incorporating Regions of Interest

Regions of interest created using a variety of methods can be incorporated into ENVI
map compositions. Generate ROIs by drawing, thresholding specific image bands,
utilizing 2-D or n-D scatterplots, or vector-to-raster conversions. To display the ROI
on the map composition:

1. Select Overlay → Region of Interest from the Display menu of the image
being used for the map composition.

Any existing Regions of Interest having the same dimensions as the displayed
image will be listed in the ROI Tool and displayed on the image.

2. Add or modify ROIs as desired using standard ENVI methods. See the ENVI
User's Guide or online help for additional details.
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Overlaying Vector Layers

ENVI can import ArcShape, Arc/Info Interchange, DXF, and DLG vector formats.
Vectors from these files and internal ENVI Vector Files (.evf) can be used in an
ENVI map composition.

1. Open the files by selecting File → Open Vector File from the ENVI main
menu and then select the file type.

2. Load the vectors into the map composition display, by clicking on Apply and
adjust the attributes to obtain the desired colors, thickness, and linetypes.

See the Vector Overlay and GIS Analysis Tutorials or see the ENVI User’s
Guide or online help for additional information.

Customize the Map Layout

In this section, several of the elements described in the previous sections are used to
demonstrate some of ENVI’s custom map composition capabilities. The previously
created ENVI QuickMap result serves as the basis for this portion of the exercise.

If you don’t already have the ENVI QuickMap result from the first part of this tutorial
displayed, display the image using the following instructions.

1. Select File → Open Image File on the ENVI main menu.

The input file selection dialog appears.

2. Navigate to the ys_tmsub subdirectory of the envidata directory on the
ENVI Tutorial and Data CD No. 1 and select the file ysratio.img from the
list and click Open.

The Available Bands List dialog appears. This list allows you to select
spectral bands for display and processing.

Note that you have the choice of loading either a grayscale or an RGB color
image. The 5/7, 3/1, 3/4 ratio bands are loaded as the defaults in the “R,” “G,”
and “B” fields.

3. Click Load RGB to load the image into a new display.

Load the QuickMap Template

Once the image is displayed, follow these steps to load the previously saved
QuickMap template and to add individual map components:

1. Recall the previously saved QuickMap Template by simply displaying the
desired image and selecting File → QuickMap → from Previous Template
Map Composition in ENVI ENVI Tutorials



Tutorial 11: Map Composition Tutorial 257
to display the Enter QuickMapTemplate Filename dialog. Click on the
saved QuickMap template ysratio.qm then Open.

2. Click Apply in the QuickMap Parameters dialog to generate the QuickMap
image.

3. Restore some saved grid parameters by selecting Overlay → Grid Lines from
the Main Display menu bar in the QuickMap image, selecting File → Restore
Setup in the Grid Line Parameters dialog, choosing the saved grid
parameters file ysratio.grd and clicking Open, then Apply. Try modifying
some of the parameters and clicking Apply to display them on the image.

Note
Be sure to save any changes using File → Save Setup.

4. Restore some saved ENVI annotation by selecting Overlay → Annotation
from the Main Display menu in the QuickMap image, selecting
File → Restore Annotation in the Annotation dialog, choosing the saved
annotation file ysratio.ann and clicking Open, then Apply.

5. Click on the Image button at the top of the annotation dialog, then try selecting
Object → Selection/Edit and clicking and dragging a box around an object in
the image using the left mouse button.

A red “handle” will appear for selected object(s).

6. Move the selected object(s) by grabbing the red “handle” with the left mouse
button and dragging to a new location. Try modifying some of the parameters
for the selected object. Fix the selected object(s) at the new location by
clicking the right mouse button in the image.
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Note
Be sure to save any changes using File → Save Annotation. See the ENVI User's
Guide or online help for additional details.

Figure 11-13: Custom map composition using ENVI annotation.
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Save the Results

The image-map composition can be saved from the Main Image window either
for future modification as an ENVI Display Group, or with the map composition
burned-in.

Saving for Future Modification

This is the most flexible option.

1. Select File → Save as Display Group in the Main Image window.

2. Enter the output filename ysratio.grp and click OK.

3. This map composition can be restored later by choosing File → Restore
Display Group from the ENVI main menu, clicking on the filename
ysratio.grp, then clicking Open.

Saving as a “Burned-in” Image

1. Select File → Save Image As → Postscript File

• Choose Standard Printing to output a postscript file with user-specified
page size and scaling parameters.

This option provides additional control, but may produce a map that
doesn’t fit the originally selected QuickMap scale.

• Choose Output QuickMap to Postscript to output a postscript file at the
specified QuickMap page size and scaling. If your additional annotation
has caused the image to be too large to be put out on the specified page
size, ENVI will ask if you want to output to multiple pages. If this is the
case, click Yes, and ENVI automatically creates multiple postscript files.

Saving as an Image File

You can save your map composition as an image file. Output formats include ENVI
(binary) image, BMP, HDF, JPEG, PICT, PNG, SRF, TIFF/GeoTIFF, and XWD, as
well as common image processing system formats such as ERDAS (.lan),
ERMAPPER, PCI, and ArcView Raster.

1. Select File → Save Image As → Image File.

2. Set the resolution, output file type and other parameters as described in the
ENVI User's Guide or online help, enter an output filename, and click OK.
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Printing

You can also select direct printing of the ENVI map composition, in which case, the
map composition will be printed directly to your printer using system software
drivers.

1. Select File → Print and choose either Standard Printing or Output
QuickMap to Printer as described previously for the Postscript option.

2. Choose your printer, then click OK.

In all of the output options just described, graphics and map composition objects will
be burned into the image on output. Figure 11-14 shows an example of a final map
composition produced in ENVI using QuickMap and custom map composition as
described in this tutorial.

Figure 11-14: An example of the final image created using the ENVI map
composition capabilities.
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End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on Unix) on the ENVI main menu, then click OK to exit IDL. If
you are using ENVI RT, quitting ENVI will take you back to your operating system.
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Overview of This Tutorial

This tutorial is designed to introduce you to the concepts of Imaging Spectrometry,
hyperspectral images, and selected spectral processing basics using ENVI. For this
exercise, we will use Airborne Visible/Infrared Imaging Spectrometer (AVIRIS) data
to familiarize you with spatial and spectral browsing of imaging spectrometer data.
We will start with 1995 AVIRIS radiance data for Cuprite, Nevada, USA, provided
by Jet Propulsion Laboratory (JPL) and then compare the results of several
reflectance calibration procedures.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 2

Path: envidata/c95avsub

File Description

Required Files

cup95_rd.int Cuprite AVIRIS radiance data. 400 samples x 350
lines x 50 bands (Integer).

cup95_rd.hdr ENVI Header for above

cup95_at.int Cuprite ATREM-calibrated apparent reflectance data.
50 bands (Integer).

cup95_at.hdr ENVI Header for above

cup95cal.sli Spectral Library of calibration results for selected
minerals (Integer).

cup95cal.hdr ENVI Header for above

jpl1sli.dat Spectral Library in ENVI format.

jpl1sli.hdr ENVI Header for above

usgs_sli.dat USGS Spectral Library in ENVI format

usgs_sli.hdr ENVI Header for above
Overview of This Tutorial ENVI Tutorials



Tutorial 12: Introduction to Hyperspectral Data and Analysis 265
Note
Optional files listed may also be used if more detailed calibration comparisons are
desired. All image data files have been converted to integer format by multiplying
the reflectance values by 1000 because of disk space considerations. A value of
1000 therefore represents apparent reflectance of 1.0.

Background: Imaging Spectrometry

Imaging spectrometers or “hyperspectral sensors” are remote sensing instruments
that combine the spatial presentation of an imaging sensor with the analytical
capabilities of a spectrometer. They may have up to several hundred narrow spectral
bands with spectral resolution on the order of 10 nm or narrower (Goetz et al., 1985).
Imaging Spectrometers produce a complete spectrum for every pixel of the image
(Figure 12-1).

Optional Files

cup95_ff.int Cuprite Flat-Field-calibrated apparent reflectance data.
50 bands (Integer).

cup95_ff.hdr ENVI Header for above

cup95_ia.int Cuprite Internal Average Relative Reflectance (IARR)
data. 50 bands (Integer).

cup95_ia.hdr ENVI Header for above

cup95_el.int Cuprite Empirical Line calibrated apparent reflectance
data. 50 bands (Integer).

cup95_el.hdr ENVI Header for above

File Description
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Compare this to broad-band multispectral scanners such as Landsat Thematic
Mapper (TM), which only has 6 spectral bands and spectral resolution on the order of
100 nm or greater (Figure 12-2). The end result of the high spectral resolution of
imaging spectrometers is that we can identify materials, where with broad-band
sensors we could previously only discriminate between materials.

Figure 12-1: The imaging spectrometer concept; hundreds of spectral images,
thousands to millions of individual spectra (from Vane, 1985).
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Figure 12-2: Comparison of a simulated Landsat TM spectrum to the
corresponding laboratory spectrum.
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Introduction to Basic ENVI Spectral
Processing

This portion of the tutorial is designed to familiarize you with ENVI features that are
useful for spectral processing of imaging spectrometer data.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To open ENVI in Unix, enter envi at the UNIX command line.

• To open ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

1. Select File → Open Image File and navigate to the c95avsub subdirectory of
the ENVI Tutorial and Data CD No. 2.

2. Choose cup95_rd.int as the input file name.

The file contains 50 bands (1.99 - 2.48 µm) of JPL-calibrated AVIRIS radiance for
the Cuprite Mining District, Nevada, USA.

The Available Bands List dialog will appear, listing the 50 spectral band names.

Display a Gray Scale Image

1. Use the scroll bar on the right side of the Available Bands List dialog to scroll
through the list until Band 193 (2.2008 µm) is displayed.

2. Click on the Gray Scale radio button, then select Band 193 and click on the
Load Band button at the bottom of the dialog.

The Main Image window containing the selected band will appear.

3. Position the red box outlining the Zoom window by clicking the left mouse
button at the desired location in the Main Image window.

The Zoom window will be automatically updated.

4. Change the zoom factor by clicking the left mouse button in + graphic located
in the lower left hand corner of the zoom window to zoom up or on the - button
to zoom down.
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• Clicking the left mouse button in the Zoom window centers the selected
pixel.

• The Zoom window can also be changed by dragging the red outlining box
within the Main Image window by using the left mouse button.

Display a Color Image

1. Load a color composite image by clicking on the RGB Color radio button in
the Available Bands List dialog.

2. Click sequentially on Band 183, Band 193, and Band 207 (2.10, 2.20, and 2.35
µm).

3. Select New Display from the Display pull-down button at the bottom of the
dialog to start a new display.

4. Click Load RGB at the bottom of the dialog.

The color image will be loaded into the new (second) image display.

Link Two Displays

Images can be linked to allow simultaneous, identical user action on multiple images.
Once linked, moving the zoom box, the scroll box, changing the zoom factor, or
resizing any of the image windows causes the same actions to occur in the linked
windows.

1. Place the cursor in the Display #1 Main Image window and select
Tools → Link → Link Displays.

The Link Displays dialog will appear (Figure 12-3).

2. Use the defaults and click OK to enable the link.
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3. Position the Zoom window for Display #1 by clicking the left mouse button in
the red Zoom Window outlining box in the #1 Main Image Display and
dragging it to a new location.

Note how the Display #2 Zoom window updates to correspond with the first
display.

Multiple Dynamic Overlays are available when two or more images are
linked, allowing real-time overlay and flicker of multiple gray scale or color
images. Dynamic overlays are activated automatically when two or more
windows are first linked.

4. Click the left mouse button in either of the linked images to cause the second
linked image (the overlay) to appear in the first image (the base).

5. You can make a quick visual comparison of the images by repeatedly clicking
and releasing the left mouse button, which causes the overlay area to flicker.

6. Change the size of the overlay by pressing the middle mouse button and
dragging the corner of the overlay to the desired location.

7. After trying the different possibilities, turn off dynamic linking in the
displayed color image by selecting Tools → Link → Unlink Display.

Extract Spectral Profiles

ENVI’s Z-profile capabilities provide integrated spectral analysis. You can extract
spectra from any multispectral data set including MSS, TM, and higher spectral
dimension data such as GEOSCAN (24 bands), GERIS (63 bands), and AVIRIS (224

Figure 12-3: The Link Displays dialog.
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bands). From the displayed color image, you can select Tools → Profiles → Z
Profile (Spectrum) in the Main Image window menu bar to start a spectral profile.

Current Spectrum

The spectrum for the current cursor location will be plotted in a plot window. A
vertical line on the plot is used to mark the wavelength position of the currently
displayed band. If a color composite image is displayed, three colored lines will
appear, one for each displayed band in the band’s respective color (red, green, or
blue).

1. Select Tools → Profiles → Z Profile (Spectrum) in the Main Image window
menu bar to start a spectral profile.

2. Move the cursor position in the Main Image or Zoom window.

The spectrum will be extracted and plotted for the new location.

3. Browse the spectral profile by clicking and holding the left mouse button in the
Main Image window and dragging the box across the image.

The spectrum will be updated as the Zoom window box moves. Note that the
spectra you are viewing are radiance—not reflectance—spectra, as you are
currently working with Cuprite radiance data.

4. Save spectra for comparison using the File → Save Plot As option from the
menu bar at the top of the plot window.

Collect Spectra

1. Select Options → Collect Spectra in the Spectral Profile window to
accumulate spectra in this plot (Figure 12-4).

Optionally, to collect spectra in another plot window, open a new plot window
and save image spectra from the Spectral Profile window.

2. Select Options → New Window: Blank from the plot menu to open a new
plot window to contain saved image spectra.

3. Click the right mouse button in the previous plot to display the spectrum name
to the right of the plot window.

4. Click and hold the left mouse button on the first character of the spectrum
name, drag the name to the new plot window, and release the mouse button.

5. Select a new spectrum from the image by moving the current pixel location in
either the Main Image or Zoom window and repeat the drag-and-drop process
to build a collection of spectra in the new plot window.
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6. Once you have several plots in the plot window, select Options → Stack Data
in new plot window. The spectra will be offset vertically to allow
interpretation.

7. To change the color and line style of the different spectra, select Edit → Data
Parameters in the new plot window.

Each spectrum is listed by name/location in the Data Parameters dialog.

8. Select a line and change its properties as desired.

9. When completed, click Cancel to close the dialog.

10. Select File → Cancel to close the plots after completing this section.

Animate the Data

You can animate gray scale images to make the spatial occurrence of spectral
differences more obvious.

1. In the Main Image window of the previous gray scale image (Display #1),
select Tools → Animation to create a movie using the Cuprite AVIRIS data.

Figure 12-4: An ENVI Spectral Profile window with collected spectra.
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The Animation Input Parameters dialog will appear (Figure 12-5). This dialog lists
all the bands provided in the Available Bands List.

2. Choose a subset of the full set of bands for animation. Click and drag to select
a desired range of bands, or use Control-Click to select specific bands. For the
purposes of this exercise, select bands 197 - 216 (20 bands).

3. Change the Window Size field to 200 x 175 to reduce the size of the image to
be animated (and thus increase the speed of the animation).

4. Click OK to start the animation loading process.

The Animation Window and the Animation Controls dialog will appear. The
selected bands are loaded individually into the Animation Window. A status
bar appears as each image is processed. You can cancel the animation in
progress at any time by clicking Cancel in the status window.

Once all of the selected images have been loaded, the animation will start
automatically. Selected bands are displayed sequentially.

Figure 12-5: The Animation Input Parameters dialog.
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The Animation Controls dialog (Figure 12-6) are used to specify the
animation characteristics. The animation speed is varied from 1 to 100 using
the spin box labeled Speed.

5. Use the control buttons (which look like CD player buttons) to run the
animation forward and reverse and to pause a specific bands. When paused,
click and drag the slider to manually select the band to display.

6. Choose the File → Cancel to end the animation.

Working with Cuprite Radiance Data

Continue this exercise using the images displayed in the first section.

1. If you have quit ENVI and IDL, restart ENVI and select File → Open Image
File.

2. Navigate to the c95avsub subdirectory of the envidata directory on the
ENVI Tutorial and Data CD No. 2. Choose cup95_rd.int as the input file
name.

Figure 12-6: The Animation Controls dialog.
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Load AVIRIS Radiance Data

1. If you don’t already have this image displayed, load a color composite image
by clicking on the RGB Color radio button in the Available Bands List
dialog.

2. Click sequentially on Band 183, Band 193, and Band 207 and then Load RGB
at the bottom of the dialog.

The color image will be loaded into the current image display.

Extract Radiance Spectra

You can extract selected image radiance spectra for specific targets in the AVIRIS
radiance data with the following steps:

1. From the Main Image window menu bar, select Tools → Pixel Locator.

2. Position the Zoom window over Stonewall Playa, centered around the pixel at
sample 590 and line 570 by entering these pixel coordinates in the Pixel
Locator and clicking Apply.

3. Extract the radiance spectrum for this location by selecting the
Tools → Profiles → Z-Profile (Spectrum) option.

4. Select Options → Collect Spectra to extract radiance spectra for the
following locations and load into the same plot window for comparison
(Figure 12-7).

5. Use the Pixel Locator dialog to obtain the spectra for the other locations.

Location Name
Sample

(with offset)
Line

(with offset)

Stonewall Playa 590 570

Varnished Tuff 435 555

Silica Cap 494 514

Opalite Zone with Alunite 531 541

Strongly Argillized Zone
with Kaolinite

502 589

Buddingtonite Zone 448 505

Calcite 260 613
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6. Select Options → Stack Data to be able to separately view each spectrum and
right-click in the plot display to show the legend for the spectra.

7. Change the colors of the individual plots if necessary by selecting
Edit → Data Parameters and making the appropriate changes in the
subsequent dialog.

Compare the Radiance Spectra

Note how similar the radiance spectra appear. The overall shape of the spectra is
caused by the typical combined solar/atmospheric response. Note small absorption
features (minima) near 2.2 micrometers that may be attributable to surface
mineralogy.

Load Spectral Library Reflectance Spectra

Now compare apparent reflectance spectra from the image to selected library
reflectance spectra.

1. Select Spectral → Spectral Libraries → Spectral Library Viewer from the
ENVI main menu.

2. When the Spectral Library Input File dialog appears, click Open Spec Lib
and select jpl1.sli from the spec_lib/jpl_lib subdirectory.

3. Click OK. The jpl1.sli file will appear in the Select Input File field of the
dialog.

Figure 12-7: AVIRIS Radiance Spectra.
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4. Click on the file name and click OK to open the Spectral Library Viewer
dialog (Figure 12-8).

5. Plot the following spectra in the Spectral Library Viewer window by clicking
on the appropriate mineral name in the list of spectra:

• ALUNITE SO-4A

• BUDDINGTONITE FELDS TS-11A

• CALCITE C-3D

• KAOLINITE WELL ORDERED PS-1A

• If desired, change the X-Axis scale by choosing Plot Parameters from the
Edit menu and entering the values 2.0 and 2.5 for the range.

This allows direct visual comparison of radiance (Figure 12-7) and reflectance
(Figure 12-9), though the Y-axes will not have the same scale.

Figure 12-8: The Spectral Library Viewer dialog.
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6. Click Cancel to close the Plot Parameters dialog.

Compare Image and Library Spectra

When visually comparing and contrasting the corresponding AVIRIS radiance
spectra with the laboratory measurements for alunite, buddingtonite, calcite, and
kaolinite, you should notice how difficult it is to visually identify the minerals by
comparing features in the radiance spectra to absorption features shown in the
laboratory spectra. You should also notice the effect of the superimposed convex-
upward solar-atmospheric signature in the AVIRIS radiance data on visual
identification.

Close the Windows

When you are finished with this section, close all of the plot windows by choosing
Windows → Close All Plot Windows from the ENVI main menu.

Figure 12-9: Library Spectra.
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Compare Radiance and ATREM

In this portion of the tutorial you will extract selected image radiance spectra and
compare them to ATREM apparent reflectance spectra for specific targets in the
AVIRIS radiance data.

Background: ATREM Calibration

The ATmospheric REMoval Program (ATREM) is a radiative transfer model-based
technique for deriving scaled surface reflectance from AVIRIS data without a priori
knowledge of surface characteristics (Gao and Goetz, 1990, CSES, 1992). It utilizes
the 0.94 and 1.1 micrometer water vapor bands to calculate water vapor on a pixel-
by-pixel basis from the AVIRIS data, the solar irradiance curve above the
atmosphere, and transmittance spectra for each of the atmospheric gases CO2, O3,
N2O, CO, CH4, and O2. At the time this tutorial was released, ATREM was
unavailable for distribution. Additional information is available at
http://cires.colorado.edu/cses/atrem.html (Center for the Study of Earth from Space,
University of Colorado). The ATREM-calibrated data used for this tutorial were
reduced to apparent reflectance using ATREM 1.3.1.

Note
ATREM is not included as part of ENVI. The other calibration methods examined
in this tutorial and described here are implemented within ENVI.

Continue or Restart ENVI

Continue this exercise using the images displayed in the first section.

1. If you have quit ENVI and IDL, restart ENVI and select File → Open Image
File and navigate to the c95avsub subdirectory of the envidata directory on
the ENVI Tutorial and Data CD No. 2.

2. Choose cup95_rd.int as the input file name.

Load Radiance Data and Start the Z-Profiler

1. If it is not already loaded, load a color composite image by clicking on the
RGB Color radio button in the Available Bands List dialog.

2. Click sequentially on Band 183, Band 193, and Band 207.

3. Click Load RGB at the bottom of the dialog.

The color image will be loaded into the current image display.
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4. Extract the radiance spectrum by selecting Tools → Profiles → Z Profile
(Spectrum) from the Main Image window menu bar.

5. Move the Z-Profile window to the bottom of the screen for easy access.

Load ATREM Apparent Reflectance Data and Start the Z
Profiler

Now open a second AVIRIS data set.

1. Select File → Open Image File and choose cup95_at.int as the second
input file name.

This is 50 bands (1.99 - 2.48 µm) of AVIRIS data calibrated to apparent
reflectance using the atmospheric model ATREM to process the AVIRIS
radiance data. The 50 band names will be added to the Available Bands List
dialog.

2. Use the scroll bar on the right side of the Available Bands List dialog to scroll
through the list until Band 193 of cup95_at.int is listed.

3. Click on the Gray Scale radio button and select band 193.

4. Select New Display from the Display pull-down button at the bottom of the
dialog, and then Load Band to start a second ENVI image display and load the
selected band.

5. Extract the radiance spectrum by selecting Tools → Profiles → Z Profile
(Spectrum) in the second Main Image window.

6. Move the Z-Profile window to the bottom of the screen next to the Z-Profile
from the radiance data for easy comparison.

Link Images and Compare Spectra

1. Link the two AVIRIS images together by selecting Tools → Link → Link
Displays from the first Main Image window and clicking OK in the
subsequent Link Displays dialog.

2. Now turn the dynamic overlay off in the first Main Image window by selecting
Tools → Link → Dynamic Overlay Off.

3. Once the images are linked and the overlay is turned off, positioning the
current pixel in one image (either by clicking the left mouse button in the
image, dragging the Zoom window box using the left mouse button, or by
using the Pixel Locator) will also position the cursor in the second image.
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The Z profiles for both images will change to show the radiance and apparent
reflectance spectra at the current location.

4. Position the zoom window over Stonewall Playa, centered around the pixel at
sample 590 and line 570 (use the Pixel Locator dialog found in the Tools
menu of the Main Image window).

Visually compare both radiance and apparent reflectance spectrum for this
location using the two Z-Profiles. If you wish, save the radiance spectrum in
one new plot window and the reflectance spectrum in a second new plot
window.

5. Now extract radiance and apparent reflectance spectra for the following
locations and visually compare.

Note
An alternate method for getting linked spectral profiles simultaneously from two or
more images is to select Tools → Profiles → Additional Z Profile and choose
additional datasets for extraction of profiles.

6. Select Options → Stack Data to offset data vertically for comparison.

Location Name
Sample

(with offset)
Line

(with offset)

Stonewall Playa 590 570

Varnished Tuff 435 555

Silica Cap 494 514

Opalite Zone with Alunite 531 541

Strongly Argillized Zone
with Kaolinite

502 589

Buddingtonite Zone 448 505

Calcite 260 613
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7. Load the corresponding spectral library spectra into the apparent reflectance
plot window for direct comparison of image apparent reflectance spectra
(Figure 12-10) with laboratory spectra.

Close the Windows

When you are finished with this section, you can close all of the plot windows by
choosing Windows → Close All Plot Windows. Then you can close all of the image
displays by choosing Windows → Close all Displays.

Figure 12-10: ATREM Apparent Reflectance Spectra.
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Compare Atmospheric Corrections

Background: Atmospheric Correction

This section of the tutorial compares several image apparent reflectance spectra. You
will use a spectral library of apparent reflectance spectra generated using ENVI’s Flat
Field Correction, Internal Average Relative Reflectance (IARR) Correction, and
Empirical Line Correction functions to compare the characteristics of the various
calibration methodologies. The calibration techniques used are briefly described
below.

Flat Field Correction

The Flat Field Correction technique is used to normalize images to an area of known
“flat” reflectance (Goetz and Srivastava, 1985; Roberts et al., 1986). The method
requires that you locate a large, spectrally flat, spectrally uniform area in the AVIRIS
data, usually defined as a Region of Interest (ROI). The radiance spectrum from this
area is assumed to be composed of primarily atmospheric effects and the solar
spectrum. The average AVIRIS radiance spectrum from the ROI is used as the
reference spectrum, which is then divided into the spectrum at each pixel of the
image. The result is apparent reflectance data that can be compared with laboratory
spectra.

Internal Average Relative Reflectance (IARR)

The IARR calibration technique is used to normalize images to a scene average
spectrum. This is particularly effective for reducing imaging spectrometer data to
relative reflectance in an area where no ground measurements exist and little is
known about the scene (Kruse et al., 1985; Kruse, 1988). It works best for arid areas
with no vegetation. The IARR calibration is performed by calculating an average
spectrum for the entire AVIRIS scene and using this as the reference spectrum.
Apparent reflectance is calculated for each pixel of the image by dividing the
reference spectrum into the spectrum for each pixel.

Empirical Line Calibration

The Empirical Line correction technique is used to force image data to match
selected field reflectance spectra (Roberts et al., 1985; Conel et al., 1987; Kruse et
al., 1990). This method requires ground measurements and/or knowledge. Two or
more ground targets are identified and reflectance is measured in the field. Usually
the targets consist of at least one light and one dark area. The same two targets are
identified in the AVIRIS images and average spectra are extracted for Regions of
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Interest. A linear regression is calculated between the field reflectance spectra and the
image radiance spectra to determine a linear transform from radiance to reflectance
for each band of the AVIRIS data set. Gains and offsets calculated in the regression
are applied to the radiance spectra for each pixel to produce apparent reflectance on a
pixel-by-pixel basis.

Continue or Restart ENVI and Select Spectral Library of
Calibration Results Spectra

1. If you have quit ENVI and IDL, restart ENVI and select Spectral → Spectral
Libraries → Spectral Library Viewer.

The Spectral Library Input File dialog will appear to allow selection of a
spectral library.

2. Click Open File at the bottom center of the dialog to start a standard file
selection dialog.

3. Navigate to the c95avsub subdirectory of the envidata directory on the
ENVI Tutorial and Data CD No. 2, and select the file cup95cal.sli.

This is the spectral library containing the results from the various calibration
methods.

4. In the Spectral Library Input File dialog, select the open library file name
and click OK.

The Spectral Library Viewer will appear with a list of the available spectra (Figure
12-11).

Select Atmospherically Corrected Spectra from Spectral
Library

1. Select the ATREM, Flat Field, IARR, and Empirical Line corrected spectra for
the mineral Alunite.

The spectra are plotted in a Spectral Library Viewer plot (Figure 12-12).
Visually compare the various calibrations and note and compare their
characteristics.

2. Attempt to explain some of the differences in terms of the correction
methodology used (see the above brief descriptions of the various methods).
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3. When finished, select Options → Clear Plots in the menu bar at the top of the
Spectral Library Viewer to clear the spectra.

Compare Corrected Spectra

Repeat the procedure for the minerals kaolinite, buddingtonite, calcite, and silica.
What general conclusions can you draw about the quality of the different calibration
procedures?

You can also compare the laboratory spectra for these minerals to the AVIRIS
spectra by opening the jpl1.sli or the usgs_sli.dat spectral libraries, plotting

Figure 12-11: The Spectral Library Viewer dialog showing spectra from various
calibrations.
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the corresponding spectra, and dragging and dropping into the Spectral Library
Viewer plot for direct comparison.

Optional: Browse Corrected Data Files

The corrected data files for all of the different corrections are available for spectral
browsing if desired. All files have been converted to integer format by multiplying
the reflectance values by 1000 because of disk space considerations. Values of 1000
in the data indicate apparent reflectances of 1.0.

Figure 12-12: Comparison of Apparent Reflectance Spectra.
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1. Open and load the files listed in the table below if desired.

2. Use the Z-profiling and multiple linked images to compare apparent
reflectance spectra for specific areas of interest.

3. After comparison of all of the correction methods for a variety of minerals,
which calibration method(s) best reproduce(s) the laboratory spectra for all
minerals? Is there one best calibration method?

End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click OK to exit IDL. If
you are using ENVI RT, quitting ENVI will take you back to your operating system.
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Overview of This Tutorial

This tutorial is designed to introduce you to the concepts of Spectral Libraries,
Region of Interest (ROI) extraction of spectra, Directed Color composites, and to the
use of 2-D scatter plots for simple classification. We will use 1995 Airborne
Visible/Infrared Imaging Spectrometer (AVIRIS) apparent reflectance data of
Cuprite, Nevada, USA, calibrated using the ATREM atmospheric modeling software.
The subsetted data cover the 1.99 to 2.48 µm range in 50 spectral bands
approximately 10 nm wide. You will extract ROIs for specific minerals, compare
them to library spectra, and design RGB color composites to best display the spectral
information. You will also use 2-D scatter plots to locate unique pixels, interrogate
the data distribution, and perform simple classification.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 2

Path: envidata/c95avsub

Note
The files listed are required to run this exercise. Selected data files have been
converted from floating-point to integer format by multiplying by 1000 to conserve
disk space. Data values of 1000 represent apparent reflectances of 1.0.

File Description

cup95_at.int Cuprite ATREM calibrated reflectance data. 50 bands
(integer)

cup95_at.hdr ENVI Header for above

jpl1sli.dat JPL Spectral Library in ENVI format

jpl1sli.hdr ENVI Header for above

usgs_min.sli USGS Spectral Library in ENVI format

usgs_min.hdr ENVI Header for above

cup95_av.roi Saved ROI locations.
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Spectral Libraries / Reflectance Spectra

This portion of the tutorial is designed to familiarize you with Spectral Libraries,
browsing and extraction of image reflectance spectra, Region of Interest (ROI)
definition in ENVI, and directed design of color composite images for spectral
discrimination.

Start ENVI and Load AVIRIS data

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To open ENVI on UNIX, enter envi at the UNIX command line.

• To open ENVI on Windows or Macintosh, double-click on the ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

1. On the ENVI main menu, select File → Open Image File and navigate to the
envidata/c95avsub directory on the ENVI Tutorial and Data CD No. 2.

2. Choose cup95_at.int as the input file name and click Open. The Available
Bands List dialog will appear, listing the 50 spectral band names.

Display a Grayscale Image

1. In the Available Bands List dialog, select Band 193 (2.2008 µm).

2. Click the Gray Scale radio button and click Load Band. An ENVI image
display containing the selected band will appear.

3. From the Main Image window menu, select Tools → Profiles → Z Profile
(Spectrum) to extract an apparent reflectance spectrum.
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Browse Image Spectra and Compare to Spectral Library

1. Move the Zoom window indicator box around the image while looking at the
#1 Spectral Profile window to browse through image apparent reflectance
spectra.

2. In the Main Image window, drag the box by grabbing and dragging with the
left mouse button or click the middle mouse button to center the Zoom
Indicator box on the selected pixel.

3. Compare apparent reflectance spectra from the image to selected library
reflectance spectra.

ENVI includes several spectral libraries. For the purposes of this exercise, you
will use the JPL Spectral Library (Groves et al., 1992) and the USGS Spectral
Library (Clarke et al., 1993).

4. Select Spectral → Spectral Libraries → Spectral Library Viewer from the
ENVI main menu.

5. In the Spectral Library Input File dialog, click Open File, select jpl1.sli
from the spec_lib/jpl_lib subdirectory, and click OK.

6. Click on jpl1.sli in the Select Input File field and click OK.

7. In the Spectral Library Viewer dialog, select Options → Edit (x, y) Scale
Factors, enter a value of 1000 into the Y Data Multiplier field to match the
image apparent reflectance range (0 – 1000), and click OK.

8. Plot the following spectra by selecting the spectra names in the Spectral
Library Viewer dialog:

• ALUNITE SO-4A

• BUDDINGTONITE FELDS TS-11A

• CALCITE C-3D

• KAOLINITE WELL ORDERED PS-1A

The following plot is produced:
Spectral Libraries / Reflectance Spectra ENVI Tutorials



Tutorial 13: Basic Hyperspectral Analysis 293
9. Customize the plot by selecting Edit → Plot Parameters from the plot
window menu. In the Plot Parameters dialog, do the following:

• Reduce the Charsize to 0.50.

• Select the X-Axis radio button, and adjust the Range to 1.90 to 2.45.

• With the X-Axis radio button selected, change the Margin fields until the
X margins are as desired.

• Select the Y-Axis radio button, and change the Axis Title to
“Reflectance”.

• With the Y-Axis radio button selected, change the Margin fields until the
Y margins are as desired.

• Click Apply then Cancel.

10. To display a legend of the spectra names, right click in the plot window. Drag
the plot window to the desired size to accommodate the spectra names.

11. In the plot window, offset the plot data by selecting Options → Stack Data.
The plot now looks like the following:

Figure 13-1: Library Spectra
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12. Right click in the #1 Spectral Profile window to display a legend of X and Y
pixel locations.

13. In the #1 Spectral Profile window, select Options → New Window: Blank to
open a new plot window. Position the #1 Spectral Profile window and the new
plot window so you can see both windows.

14. From the Main Image window menu, select Tools → Pixel Locator. We will
use the Pixel Locator dialog to locate the exact pixels for the following
locations:

Figure 13-2: Customized Plot Parameters

Location Name
Sample

(with offset)
Line

(with offset)

Stonewall Playa 590 570

Varnished Tuff 435 555

Silica Cap 494 514

Opalite Zone with Alunite 531 541

Strongly Argillized Zone
with Kaolinite

502 589

Buddington ZOne 448 505
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15. In the Pixel Locator dialog, enter 590 in the Sample field and enter 570 in the
Pixel field to center the Zoom Indicator on pixel 590, 570 (Stonewall Playa).
Click Apply to move to that location. The #1 Spectral Profile window updates
to show the spectrum for this pixel. The legend should read “X:590 Y:570”.

16. Right click in the new plot window to display a legend of X and Y pixel
locations.

17. In the #1 Spectral Profile window, click and hold the left mouse button on the
legend item “X:590 Y:570”. Drag and drop this spectrum into the new plot
window.

18. Repeat the previous steps for each site in the above table until the new plot
window contains all 7 spectra.

19. In the new plot window, select Options → Stack Data. The new plot window
should now look like the following:

20. Visually compare these spectra to the library spectra extracted previously.

Note the similarity of shape and absorption features between the laboratory
spectra and the individual image apparent reflectance spectra.

Calcite 260 613

Figure 13-3: Individual ATREM Image Apparent Reflectance Spectra

Location Name
Sample

(with offset)
Line

(with offset)
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Based on these similarities, we conclude that the image spectra similar to the
alunite, buddingtonite, calcite, and kaolinite laboratory spectra represent pixels
predominantly of the above minerals.

21. Drag and drop spectra from the Spectral Library Plots window into the #1
Spectral Profile window for direct comparison.

Identify Spectra

Use the Spectral AnalystTM to identify spectra:

ENVI has a spectral matching tool that provides a score with respect to the library
spectra. The spectral analyst uses several methods to produce a score between 0 and
1, with 1 equaling a perfect match.

1. Select Spectral → Spectral Analyst from the ENVI main menu.

2. Click on the Open Spec Lib button at the bottom of the Spectral Analyst
Input Spectral Library dialog.

3. Navigate to the usgs_min spectral library directory, select the
usgs_min.sli spectral library, and click Open.

4. The file usgs_min.sli should now appear in the Spectral Analyst Input
Spectral Library dialog. Select this file and click OK.

5. In the Edit Identify Methods Weighting dialog, click OK.

6. From the Main Image window menu, select Tools → Profiles → Z Profile
(Spectrum). Right click in the #1 Spectral Profile window to display the
legend of spectra.

7. From the Main Image window menu, select Tools → Pixel Locator.

8. Enter the pixel 502, 589 in the Pixel Locator dialog and click Apply.

9. In the Spectral Analyst dialog, select Options → Edit Method Weights.

10. In the Edit Identify Methods Weighting dialog, enter 0.33 in each of the
Weight fields click OK. The different matching methods are described in the
ENVI 3.5 User’s Guide.

11. In the Spectral Analyst dialog, click Apply. If more than one spectrum is
displayed in the #1 Spectral Profile window, a list of spectra will appear. If this
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list appears, select the spectrum for pixel 502, 589. The Spectral Analyst
dialog shows the following:

The Spectral Analyst scores the unknown spectrum against the library. The
previous figure shows an identification for pixel 502, 589. Note the high
number of kaolinite spectra at the top of the list. This, and the relatively high
scores, indicates a high likelihood of kaolinite.

12. Now double click on the first spectrum name in the list. This will plot the
unknown and the library spectrum in the same plot for comparison, as shown
in the following figure:

Figure 13-4: The Spectral Analyst dialog, showing a high match to the mineral
kaolinite for pixel 502, 589.
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13. Use the Spectral Analyst and the comparison plots to verify the mineralogy for
the image spectra you have extracted. When you have identified several
minerals, continue with the next section.

14. Optionally, compare spectra from the USGS Spectral Library usgs_min.sli
with image spectra and the JPL Spectral library.

Close Windows and Plots

1. Close the Spectral Library Viewer and Pixel Locator dialogs.

2. Close all of the previous plot windows by selecting Window → Close All Plot
Windows.

Figure 13-5: Comparison plot of the unknown against the best-match library
spectrum for kaolinite showing a high degree of match.
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Define Regions of Interest

Regions of Interest (ROIs) are used to extract statistics and average spectra from
groups of pixels. You can define as many ROIs as you wish in any displayed image.
Select Overlay → Region of Interest from the Main Image window menu to start
the ROI Tool.

Create New Region of Interest

1. Click the left mouse button in the image.

2. Draw the ROI by clicking the left mouse button at the axes of a polygon, or
draw continuously by clicking and dragging the left mouse button.

3. Complete the ROI by clicking the right mouse button to close the polygon and
the right mouse button a second time to lock-in the ROI.

4. Click on the Stats button to calculate the statistics and plot a mean spectrum
(white), the first standard deviation above and below the mean spectrum
(green), and the Min/Max envelope containing all of the spectra in the ROI
(red).

5. Select File → Cancel in the File Statistics Report dialog, and select
File → Cancel in the Avg Spectrum plot.

6. Click Delete in the ROI Tool dialog to delete the selected ROI.

Figure 13-6: Region of Interest Tool
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Load Previously Saved Regions of Interest

1. From the ROI Tool dialog menu, select File → Restore ROIs.

2. In the Enter ROI Filename dialog, navigate to the envidata/c95avsub
directory, select the file cup95_av.roi, and click Open. Regions previously
defined for known areas of specific minerals will be listed in an ENVI message
dialog, and loaded into the ROI Tool dialog as shown in the following figure:

3. Select the Off radio button at the top of the ROI Tool dialog to enable pixel
positioning within the Main Image display.

4. Start a Z-Profile window by selecting Tools → Profiles → Z-Profile
(Spectrum) in the Main Image window.

5. Move the current pixel position/cursor location into each ROI by clicking the
middle mouse button on a pixel in the ROI.

6. Click on different pixels in the ROI to move the cursor position and display a
new spectral profile in the Spectral Profile window.

Note that the y-axis plot range is automatically rescaled to match the spectral profile
for each new ROI. Examine the spectral variability within each ROI.

Extract Mean Spectra from ROIs

1. Select an ROI name in the ROI Tool dialog, then click Stats to extract
statistics and a spectral plot of the selected ROI.

Figure 13-7: ROI Tool showing restored regions
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2. Examine the spectral variability of each ROI by comparing the mean spectrum
(white) with the 1st standard deviation spectra (green above and below the
mean) and the envelope spectra (red above and below the mean).

3. Repeat for each ROI.

4. If you wish, load the corresponding library signatures from the jpl1.sli
library into the plot window for direct comparison/identification. Don’t forget
to use a Y-Scaling Factor of 1000 when loading the library spectra.

5. When you have finished, close all of the File Statistics Report dialogs and
plot windows.

6. In the ROI Tool dialog, select Options → Mean for All Regions to plot the
average spectrum for each ROI in the same plot window.

7. In the plot window, select Options → Stack Data to offset spectra for
comparison, as shown in the following figure:

8. Compare the spectral features of each spectrum and note unique characteristics
that might allow identification.

9. If desired, load the corresponding spectral library signatures from the
jpl1.sli library for direct comparison of image apparent reflectance spectra

Figure 13-8: ROI Mean ATREM Image Apparent Reflectance Spectra
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with laboratory spectra. Don’t forget to use a Y Factor of 1000 when loading
the library spectra.

10. Optionally, compare spectra from the USGS Spectral Library usgs_min.sli
with image spectra and the JPL Spectral library.

Discriminate Mineralogy

Design color images to discriminate mineralogy:

1. In the Available Bands List dialog, select the RGB Color radio button, and
click sequentially on Band 183, Band 193, and Band 207.

2. Click Load RGB to load the color image into the current image display.

3. In the Main Image window, select Tools → Profiles → Z-Profile (Spectrum).
Note that the positions of the bands used to make the RGB color composite
image are marked in the Z-Profile with vertical red, green, and blue lines.

4. In the ROI Tool dialog, select the Off radio button and use the Z profiler
accessed through the Main Image window to browse spectra at or near your
ROI locations from above.

Note where the selected RGB bands fall with respect to spectral features in the
previously displayed mean spectra and how the spectral features affect the
color observed in the image.

5. Change the plot bars in the spectral profile to the desired bands by clicking and
dragging the plot bars with the left mouse button.

Note
(Note: one way to enhance specific materials is by centering one color bar in
an absorption feature and the other two on opposite shoulders of the feature.)

6. Double click the left mouse button within the Z Profile plot window to load the
new bands into the display window.

After inspecting a few sites, you should begin to understand how the color composite
colors correspond with the spectral signature. For instance, the alunitic regions
appear magenta in the RGB composite because the green band is within the alunite
absorption feature, giving a low green value, while the red and blue bands are of
almost equal reflectance. The combination of red and blue results in a magenta color
for pixels containing alunite.

Based on the above results, try these exercises:
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1. Predict how certain spectra will look, given a particular pixel’s color in the
RGB image.

2. Explain the colors of the training sites, in terms of their spectral features.

3. Design and test specific RGB band selections that maximize your ability to
map certain minerals, like kaolinite and calcite.

Close Plot Windows and ROI Controls

1. Close all open plot windows by selecting Window → Close All Plot
Windows.

2. Close the ROI Tool dialog by selecting File → Cancel.

2-D Scatter Plots

Examine 2-D Scatter Plots

1. In the Main Image window, select Tools → 2-D Scatter Plots to start a 2-D
scatter plot for the apparent reflectance image.

2. Select band 193 in the Choose Band X list and select band 207 in the Choose
Band Y list.

3. Click OK.

The following scatter plot is displayed with a plot of the X vs. Y apparent reflectance
values:

Figure 13-9: Scatter Plot of bands 193 and 207 (ATREM Apparent Reflectance)
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Density Slice the Scatter Plot

1. From the scatter plot menu, select Options → Density On to automatically
density-slice the scatter plot. The colors show the frequency of occurrence of
specific apparent reflectance combinations for the two bands being scatter
plotted. Purple is the lowest frequency, progressing through the colors blue,
green, yellow, to red as the highest frequency of occurrence.

2. From the scatter plot menu, select Options → Density Off to turn off the color
slice.

Scatter Plot Dancing Pixels

1. In the Main Image window, click and drag the left mouse button to toggle
“Dancing Pixels” in the scatter plot. The red pixels in the scatter plot
correspond to those pixels within a 10 x 10 box around the cursor in the Main
Image window.

2. Try to predict the locations of certain image colors in the scatter plot, then
check them. Notice the shape of the red sub-scatter plot of dancing pixels.

3. Change the box-cursor size in the scatter plot window by selecting
Options → Set Patch Size, and observe the difference.

Image Dancing Pixels

1. In the scatter plot window, click and drag the middle mouse button over any
portion of the white scatter plot to toggle “Dancing Pixels” in the Main Image
window. The red pixels in the image correspond to those pixels within a 10 x
10 box around the cursor in the scatter plot window. Note the spatial
distribution and coherency of the selected pixels.

2. Change the box-cursor size in the scatter plot window by selecting
Options → Set Patch Size, and observe the difference.

Scatter Plots Linked to a Spectral Profile

1. From the scatter plot window menu, select Options → Z Profile, select an
input file from which to extract the spectral profile, and click OK. This starts a
blank ENVI spectral profile linked to the 2-D scatter plot.

2. Position the cursor in the 2-D scatter plot and click the right mouse button to
extract the spectrum for the corresponding spatial pixel with those scatter plot
characteristics.

3. Compare spectra from the different parts of the scatter plot and note what sorts
of spectra appear at the “points” of the plot versus the center of the plot.
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Scatter Plot ROIs

The scatter plot tool can also be used as a quick classifier.

1. Click the left mouse button in the scatter plot to select the first point of a
Region of Interest (ROI).

2. Draw an ROI polygon in the scatter plot by selecting the desired line segments
using the left mouse button.

3. Click the right mouse button to close the polygon. Image pixels with the two-
band characteristics outlined by the polygon will be color-coded red in the
Main Image window.

4. Choose another color from the Class pulldown menu in the scatter plot
window.

5. Draw another polygon and the corresponding pixels will be highlighted in the
selected color on the image.

6. To remove a class, select Options → Clear Class. You can also clear the
current class by clicking the middle mouse button outside (below) the plot
axes.

7. Use the 2-D scatter plot tool to work backwards from the scatter plot to see
where certain pixels occur in the image.

8. Classes can be converted to ROIs to act as training sets for classification using
all of the bands by selecting Options → Export Class or Export All from the
scatter plot menu bar. ROIs exported in this fashion will appear in the ROI
Tool dialog and be available for subsequent supervised classification. They can
also be converted to a classification image by choosing
Classification → Create Class Image from ROIs from the ENVI main menu.

9. Select Options → Clear All in the scatter plot to clear both scatter plot and
image.

Image ROIs

The scatter plot tool also functions as a simple classifier from the image.

1. Choose Options → Image ROI in the scatter plot.

2. Draw polygons in the Main Image window using the left mouse button to draw
lines and the right button to close and lock-in the polygon. They will be
mapped to the scatter plot and highlighted in the currently selected color. After
the pixels are highlighted on the scatter plot, all of the matching pixels in the
image will be inverse-mapped to the Main Image window and highlighted in
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the same color, as though you had drawn the scatter plot region yourself. This
is the simplest form of 2-band classification, but it is still a powerful tool.

3. Draw a few image regions and note the correspondence between image color
and scatter plot characteristics.

Scatter Plots and Spectral Mixing

Can you explain the overall diagonal shape of the scatter plot in terms of spectral
mixing? Where do the purest pixels in the image fall on the scatter plot? Are there
any secondary “projections” or “points” on the scatter plot?

1. Choose some other band combinations for scatter-plotting by selecting
Options → Change Bands in the scatter plot. Try at least one pair of adjacent
bands and other pairs that are far apart spectrally.

How do the scatter plots change shape with different band combinations? Can
you describe the n-Dimensional “shape” of the data cloud?

End the ENVI Session

This concludes the tutorial. You can quit your ENVI session by selecting File → Exit
(Quit on UNIX) from the ENVI main menu, then click Yes. If you are using ENVI
RT, quitting ENVI will take you back to your operating system.
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Overview of This Tutorial

This tutorial is designed to introduce you to advanced concepts and procedures for
analysis of imaging spectrometer data or hyperspectral images. We will use 1995
Airborne Visible/Infrared Imaging Spectrometer (AVIRIS) data from Cuprite,
Nevada, to investigate the unique properties of hyperspectral data and how spectral
information can be used to identify mineralogy. We will evaluate EFFORT
“polished” spectra versus ATREM-calibrated data, and review the Spectral Angle
Mapper classification. We will compare apparent reflectance spectra and continuum-
removed spectra. We will also compare apparent reflectance images and continuum-
removed images and evaluate Spectral Feature FittingTM results.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 2

Path: envidata/c95avsub

File Description

cup95_at.int Cuprite ATREM calibrated apparent reflectance data.
50 bands (integer).

cup95_at.hdr ENVI Header for above.

cup95eff.int Cuprite EFFORT-Corrected ATREM calibrated
apparent reflectance data. 50 bands (integer).

cup95eff.hdr ENVI Header for above.

jpl1sli.dat JPL Spectral Library in ENVI format.

jpl1sli.hdr ENVI Header for above.

usgs_min.sli USGS Spectral Library in ENVI format.

usgs_min.hdr ENVI Header for above.

cup95_av.roi Saved ROI locations.

cupsamem.asc Optional file of ROI mean spectra.

cupsam1.img SAM classification image using ROI image spectra
endmembers.

cupsam1.hdr ENVI Header for above.
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Note
The files listed are required to run this exercise. Optional files listed below may also
be used if more detailed calibration comparisons are desired. All image data files
have been converted to integer format by multiplying the reflectance values by
1000 because of disk space considerations. A value of 1000 therefore represents
apparent reflectance of 1.0.

cuprul1.img SAM rule image using ROI image spectra
endmembers.

cuprul1.hdr ENVI Header for above.

cupsam2.img SAM classification image using Spectral Library EM.

cupsam2.hdr ENVI Header for above.

cuprul2.img SAM rule images using Spectral Library endmembers.

cuprul2.hdr ENVI Header for above.

cup95_cr.dat Continuum-removed data (floating point)

cup95_cr.hdr ENVI Header for above.

cup95sff.dat Spectral Feature Fitting Results

cup95sff.hdr ENVI Header for above.

cup95sfr.dat Spectral Feature Fitting Band-Math Results

cup95sfr.hdr ENVI Header for above.

File Description
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Removal of Residual Calibration Errors

Use EFFORT (Empirical Flat Field Optimized Reflectance Transformation) to
remove residual calibration errors. EFFORT is a correction used to remove residual
“saw-tooth” instrument (or calibration-introduced) noise and atmospheric effects
from ATREM-calibrated AVIRIS data. It is a custom correction designed to improve
overall quality of spectra. It provides the best reflectance spectra available from
AVIRIS data, so the EFFORT data are used in later exercises in this tutorial.
EFFORT is a relatively automated improvement on the Flat-Field Calibration method
(Boardman and Huntington, 1996). The EFFORT correction selects those AVIRIS
spectra that match a low-order polynomial estimate in a least-squares sense as
representative featureless spectra. These spectra are averaged and a mild gain factor
is determined to remove systematic, coherent noise, present in every spectrum,
including small residual atmospheric effects near 2.0 µm range attributable to CO2.
EFFORT is run from ENVI by selecting Spectral → Effort Polishing. We will not
run this function during this exercise, but will instead compare pre-calculated
EFFORT-corrected data to 1995 AVIRIS data corrected to reflectance using only
ATREM without the corresponding EFFORT correction.

Open and Load the 1995 EFFORT-Corrected Data

1. Select File → Open Image File from the ENVI main menu, navigate to the
envidata/c95avsub directory on the ENVI Tutorial and Data CD No. 2,
select the file cup95eff.int, and click Open. This is the 1995 AVIRIS
ATREM-calibrated apparent reflectance data with the EFFORT correction.

2. Select Tools → Profiles → Z Profile (Spectrum) from #1 Image window
menu.

3. Start a new display (#2) by selecting New Display from the Display pulldown
button at the bottom of the Available Bands List dialog.

4. Select File → Open Image File from the ENVI main menu, select the file
cup95_at.int, and click Open. This is the 1995 ATREM calibrated
apparent reflectance data.

5. In the Available Bands List dialog, select band 193 (2.20 µm), select the
Gray Scale radio button, and click Load Band.

6. Select Tools → Profiles → Z Profile (Spectrum) from #2 Image window
menu.

7. Compare the two spectral profiles.
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Compare ATREM and Effort Spectra

1. From the #1 image window menu, select Tools → Link → Link Displays.

2. Click OK in the Link Displays dialog to activate the link.

3. From the #1 image window menu, select Tools → Link →
Dynamic Overlay Off to enable normal mouse interaction.

Moving the Zoom window indicator box in this image will cause the cursor
location to be updated in the #2 image window. Both spectral profiles will
show the spectrum for the current pixel.

4. Move the Zoom window indicator box around the image and compare the
corresponding ATREM and EFFORT spectra. Note where the major
differences occur.

5. In the #1 image window, select Tools → Pixel Locator, and position the
cursor at 503, 581.

6. Right-click in the #1 plot window to display the plot legend.

7. Drag and drop the EFFORT spectrum in the #1 plot window by grabbing the
first character of the legend name and dragging onto the #2 (ATREM-only)
plot window.

8. From the #2 plot window menu, select Edit → Data Parameters.

9. In the Data Parameters dialog, change the color of the EFFORT spectrum
and add the text “(EFFORT)” to the Name. Similarly, add the text
“(ATREM-Only)” to the Name of the ATREM spectrum.

10. Stack the spectra by selecting Options → Stack Data. The plot should now
resemble the following:
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11. Compare the EFFORT-corrected spectrum to the ATREM-only spectrum.
Note how similar the two spectra are, but how very small coherent noise
“wiggles” have been removed from the EFFORT spectrum. Also note the
correction of residual CO2 at 2.01 µm.

12. In the #2 (ATREM) spectral profile window, delete the imported spectrum by
clicking the right mouse button on the first character of the EFFORT spectrum
name.

13. In the #1 image window, move the cursor location to 542, 533 using the Pixel
Locator, and drag the spectrum from the #1 spectral profile window to the #2
spectral profile window. Note how EFFORT changes the spectrum.

14. Try selecting some other points in the two images using the Pixel Locator and
compare the spectra. What are the major differences?

Close All Files, Displays, and Plots

Close all of the files used in the previous section by selecting File → Close All Files
from the ENVI main menu and clicking Yes. The associated plot windows will also
be closed.

Figure 14-1: Comparison of EFFORT Apparent Reflectance (top) and
ATREM-only (bottom) Spectra.
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Spectral Angle Mapper Classification

Next, we will use both image and laboratory spectra to classify the AVIRIS data
using the “Spectral Angle Mapper” (SAM). We will go through the endmember
selection process for SAM, but will not actually run the algorithm. We will examine
previously calculated classification results to answer specific questions about the
strengths and weaknesses of the SAM classification.

The Spectral Angle Mapper (SAM) is an automated method for comparing image
spectra to individual spectra or a spectral library (Boardman, unpublished data;
CSES, 1992; Kruse et al., 1993a). SAM assumes that the data have been reduced to
apparent reflectance (true reflectance multiplied by some unknown gain factor
controlled by topography and shadows). The algorithm determines the similarity
between two spectra by calculating the “spectral angle” between them, treating them
as vectors in a space with dimensionality equal to the number of bands (nb). A
simplified explanation of this can be given by considering a reference spectrum and
an unknown spectrum from two-band data. The two different materials will be
represented in the 2-D scatter plot by a point for each given illumination, or as a line
(vector) for all possible illuminations.

Because it uses only the “direction” of the spectra, and not their “length,” the method
is insensitive to the unknown gain factor, and all possible illuminations are treated
equally. Poorly illuminated pixels will fall closer to the origin. The “color” of a
material is defined by the direction of its unit vector. Notice that the angle between

Figure 14-2: Two-dimensional example of the Spectral Angle Mapper
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the vectors is the same regardless of the length. The length of the vector relates only
to how fully the pixel is illuminated.

The SAM algorithm generalizes this geometric interpretation to nb-dimensional
space. SAM determines the similarity of an unknown spectrum t to a reference
spectrum r, by applying the following equation (CSES, 1992):

which also can be written as:

where nb equals the number of bands in the image.

For each reference spectrum chosen in the analysis of a hyperspectral image, the
spectral angle α is determined for every image spectrum (pixel). This value, in
radians, is assigned to the corresponding pixel in the output SAM image, one output
image for each reference spectrum. The derived spectral angle maps form a new data
cube with the number of bands equal to the number of reference spectra used in the
mapping. Gray-level thresholding is typically used to empirically determine those
areas that most closely match the reference spectrum while retaining spatial
coherence.

The SAM algorithm implemented in ENVI takes as input a number of “training
classes” or reference spectra from ASCII files, ROIs, or spectral libraries. It
calculates the angular distance between each spectrum in the image and the reference
spectra or “endmembers” in n-dimensions. The result is a classification image
showing the best SAM match at each pixel and a “rule” image for each endmember
showing the actual angular distance in radians between each spectrum in the image
and the reference spectrum. Darker pixels in the rule images represent smaller
spectral angles, and thus spectra that are more similar to the reference spectrum. The
rule images can be used for subsequent classifications using different thresholds to
decide which pixels are included in the SAM classification image.
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Select Image Endmembers

1. Open the 1995 AVIRIS ATREM-calibrated apparent reflectance data file,
cup95eff.int. This is image window #1.

2. In the Available Bands List dialog, select band 193 (2.20 µm), select the
Gray Scale radio button, and click Load Band.

3. From the ENVI main menu, select Classification → Supervised
Classification → Spectral Angle Mapper (or alternatively,
Spectral → Mapping Methods → Spectral Angle Mapper) to start the SAM
endmember selection process.

4. In the Classification Input File dialog, select the file cup95eff.int as the
input file and click OK.

5. In the SAM Endmember Collection dialog, select Import → from ASCII file.

6. Select the file cup95_em.asc and click Open.

7. In the Input ASCII File dialog, hold down the Ctrl key and deselect the
spectra Dark/black, Bright/playa, Silica? (Dark), and Alunite (2.18) in the
Select Y Axis Columns list. This will leave you with the mean spectra Zeolite,
Calcite, Alunite (2.16), Kaolinite, Illite/Muscovite, Silica (Bright), and
Buddingtonite.

8. Click OK to load all of the endmember spectra into the
Endmember Collection:SAM dialog.

9. From the Endmember Collection:SAM dialog menu, select
Options → Plot Endmembers to plot the endmember spectra.

10. From the Endmember Spectra plot window, select Options → Stack Data for
improved comparison of spectral features, then right click in the plot window
to display the legend. The result is shown in the following figure:
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Normally, you would click Apply on the Endmember Collection:SAM
dialog to start the classification, but because classification can take some time,
preprocessed results are provided for this exercise.

11. If sufficient time and resources are available, click Apply in the
Endmember Collection:SAM dialog, enter output file names in the Spectral
Angle Mapper Parameters dialog, and click OK.

Or

In the Endmember Collection:SAM dialog, click Cancel and continue by
reviewing previously calculated SAM results as described below.

Execute SAM

1. Open the SAM classification image by selecting File → Open Image File and
choosing cupsam1.img as the input file name. The classification image is one
band with coded values for each class (for example, alunite is coded as “1”).
When opened, the classified image will appear in the Available Bands List
dialog.

2. In the Available Bands List dialog, ensure that the Gray Scale radio button is
selected.

Figure 14-3: Spectral Endmembers for use with SAM.
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3. Click Display → New Display, select the SAM classification image, then
click Load Band. This is image window #2. The classes will automatically be
color coded as follows:

Note
The number of pixels displayed as a specific class is a function of the threshold
used to generate the classification. Just because a given pixel is classified as a
specific mineral doesn’t make it so. SAM is a similarity measure, not an identifier.

4. In the Available Bands List dialog, click Display → New Display. This is
image window #3.

5. Select the RGB Color radio button, then select in sequence bands 183, 193,
and 207 of the EFFORT data. Click Load RGB.

6. Start a spectral profile by selecting Tools → Profiles → Z-Profile in the #3
image window.

7. Compare the SAM classification results with the distributions shown by the
color composite image.

8. Open the SAM rule image by selecting File → Open Image File and choosing
cuprul1.img as the input file name.

The rule image has one band for each endmember classified, with the pixel
values representing the spectral angle in radians. Lower spectral angles (darker
pixels) represent better spectral matches to the endmember spectrum.

When opened, one band for each endmember will appear in the Available
Bands List dialog.

Mineral Color

Zeolites White

Calcite Green

Alunite Yellow

Kaolinite Red

Illite/Muscovite Dark Green

Silica Blue

Buddingtonite Maroon
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9. In the Available Bands List dialog, ensure that the Gray Scale radio button is
selected. Select Display → New Display, then click Load Band. This is
image window #4.

10. Evaluate the image with respect to the color composite and the SAM
classification image as well as the ROI means and individual spectra extracted
using the Z Profiler.

11. In image window #4, select Tools → Color Mapping → ENVI Color Tables.

12. Use the Stretch Bottom and Stretch Top sliders to adjust the SAM rule
thresholds to highlight those pixels with the greatest similarity to the selected
endmember.

13. Pull the Stretch Bottom slider all the way to the right and the Stretch Top
slider all the way to the left to highlight the most similar pixels in white.

14. Move the Stretch Bottom slider gradually to the left to reduce the number of
highlighted pixels and show only the best SAM matches in white. You can use
a rule image color composites or image animation if desired to compare
individual rule images.

15. Repeat the process with each SAM rule image. Select File → Cancel when
finished to close the ENVI Color Tables dialog.

16. Select Windows → Close All Display Windows.

Select Spectral Library Endmembers

In this exercise, we will once again go through the endmember selection process, but
we won’t actually perform the SAM classification. Previously saved SAM results
will be used for comparisons. If you have time, you can perform your own SAM
classification using spectral library endmembers.

1. From the ENVI main menu, select Spectral → Spectral Libraries →
Spectral Library Viewer.

2. Click Open File, select the file envidata/spec_lib/jpl_lib/jpl1.sli
and click Open.

3. In the Spectral Library Input File dialog, select jpl1.sli and click OK.

4. In the Spectral Library Viewer dialog, plot the following spectra by clicking
on the mineral name in the list of spectra:

• ALUNITE SO-4A

• BUDDINGTONITE FELDS TS-11A
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• CALCITE C-3D

• CHABAZITE TS-15A (a zeolite mineral)

• ILLITE PS-11A

• KAOLINITE WELL ORDERED PS-1A

5. Start the SAM endmember selection process by selecting
Classification → Supervised → Spectral Angle Mapper from the ENVI
main menu. You can also access this function from the ENVI Spectral menu.

6. If the file cup95eff.int does not appear in the input file list in the
Classification Input File dialog, click Open File, select the file
envidata/c95avsub/cup95eff.int and click Open.

7. In the Classification Input File dialog, select the file cup95eff.int as the
input file and click OK.

8. In the Endmember Collection: SAM dialog, select Import →
from Spectral Library.

9. In the Spectral Input Library File dialog, select the file jpl1.sli and click
OK.

10. In the Input Spectral Library dialog, hold down the Ctrl key and select the
following spectra, then click OK:

• ALUNITE SO-4A

• BUDDINGTONITE FELDS TS-11A

• CALCITE C-3D

• CHABAZITE TS-15A (a zeolite mineral)

• ILLITE PS-11A

• KAOLINITE WELL ORDERED PS-1A

11. From the ENVI main menu, select Spectral → Spectral Libraries →
Spectral Library Viewer.

12. In the Spectral Library Input File dialog, click Open File.

13. In the Please Select a File dialog, select the file
envidata/spec_lib/usgs_min/usgs_min.sli and click Open.

14. In the Spectral Library Input File dialog, select usgs_min.sli and click
OK.
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15. Select the endmember “opal2.spc Opal TM8896 (Hyalite)” from the list of
spectra. Note that the spectra are automatically resampled to the AVIRIS
wavelengths and resolution using the AVIRIS band positions and FWHM and
listed in the Endmember Collection dialog.

16. Select Options → Plot Endmembers to plot the endmember spectra for these
AVIRIS data.

17. Choose Options → Stack Data in the plot window to offset the spectra
vertically for comparison.

18. Compare these spectra to the image spectra plotted in the previous SAM
exercise.

19. Since we will not actually be performing the SAM classification because of
time constraints, click Cancel in the Endmember Collection dialog to
continue the exercise. If you have time, you can generate your own SAM
classification by clicking Apply.

Review SAM Results

1. Open the pre-calculated SAM classification image generated using Spectral
Library Endmembers by selecting File → Open Image File.

2. Select envidata/c95avsub/cupsam2.img as the input file name and click
Open.

The classification image is one band with coded values for each class (for
example, alunite is coded as “1”). When opened, the classified image will
appear in the Available Bands List dialog.

3. Ensure that the Gray Scale radio button is selected.

4. Load the SAM classification image into a new ENVI display window by
clicking on the classified image name, clicking Display → New Display and
then Load Band.

The classes will automatically be color coded as follows:

Mineral Color

Zeolites White

Calcite Green

Alunite Yellow

Kaolinite Red
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Note
The number of pixels displayed as a specific class is a function of the threshold
used to generate the classification. Just because a given pixel is classified as a
specific mineral doesn’t make it so. SAM is a similarity measure, not an identifier).

5. Compare the classification results with the distributions shown by the color
composite image, the previous classification using image spectra, and the
library spectra. Use image linking for direct comparison if desired.

6. Load the SAM rule images by selecting File → Open Image File and
selecting envidata/c95avsub/cuprul2.img as the input file name and
clicking Open.

Again, the rule image has one band for each endmember classified, with the
pixel values representing the spectral angle in radians. Lower spectral angles
(darker pixels) represent better spectral matches to the endmember spectrum.
When opened, one band for each endmember will appear in the Available
Bands List dialog.

7. Ensure that the Gray Scale radio button is selected.

8. Load a SAM rule image into a new ENVI display window by clicking on the
classified image name, selecting Display → New Display, then clicking
Load Band.

9. Evaluate the image using the ENVI Color Tables as above and with respect to
the color composite and the SAM classification image as well as the ROI
means and individual spectra extracted using the Z Profiler. Also use a rule
image color composite or image animation if desired to compare individual
rule images.

10. Repeat the process with each SAM rule image. Based upon the results of the
two SAM classifications, answer the following questions:

• What ambiguities exist in the SAM classification based on your images
and spectra above?

Illite/Muscovite Dark Green

Silica Blue

Buddingtonite Maroon

Mineral Color
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• Why are the two classifications so different? What factors could affect
how well SAM matches the endmember spectra?

• How could you determine which thresholds represent a true map of the
selected endmembers?

• Can you see the topographic shading effects in the SAM data? Why or
why not?

• Make a sketch map of the Cuprite surface mineralogy for all classes on a
separate piece of paper. Do some classes co-occur?

• In light of some of the ambiguities in the SAM classification, how could
you select better endmembers?

Optional: Generate new SAM Classified Images Using Rule
Classifier

If you have extra time at the end of the exercise, try generating new classified images
based on different thresholds in the rule images.

1. Display the individual bands of one of the two previously calculated rule
images cuprul1.img or cuprul2.img and define the threshold for the
classification by browsing using the Cursor Location/Value dialog.
Thresholds can also be defined using ENVI’s interactive density slice tool, by
selecting Tools → Color Mapping → Density Slice in the main image
window.

2. Now select Classification → Post Classification → Rule Classifier and
choose the rule file as viewed above for classification.

3. In the Rule Image Classifier dialog, select a rule file and click OK.

4. In the Rule Image Classifier Tool dialog, select “Minimum Value” in the
Classify by field, and enter the previously defined SAM threshold.

All of the pixels with values lower than the minimum will be classified. Lower
thresholds result in fewer pixels being classified.

5. Click either Quick Apply or Save to File to begin the processing. After a short
wait, the new classification image will appear.

6. Compare with previous classifications and comment on the differences and
what they mean.
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Close Files and Plots

• To close all of the files used in this portion of the exercise, select File → Close
All Files in the Available Bands List dialog, then click Yes.

• To close all of the spectral plots, select Window → Close All Plot Windows.
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Spectral Feature Fitting and Analysis

Spectral Feature FittingTM (SFFTM) is an absorption-feature-based method for
matching image spectra to reference endmembers, similar to methods developed at
the U. S. Geological Survey, Denver (Clark et al., 1990, 1991, 1992; Clark and
Swayze, 1995).

Most methods used for analysis of hyperspectral data still do not directly identify
specific materials. They only indicate how similar the material is to another known
material or how unique it is with respect to other materials. Techniques for direct
identification of materials, however, via extraction of specific spectral features from
field and laboratory reflectance spectra have been in use for many years (Green and
Craig, 1985; Kruse et al., 1985; Yamaguchi and Lyon, 1986; Clark et al., 1987).
Recently, these techniques have been applied to imaging spectrometer data, primarily
for geologic applications (Kruse et al., 1988; Kruse, 1988; Kruse, 1990; Clark et al.,
1990, 1991, 1992; Clark and Crowley, 1992; Kruse et al. 1993b, 1993c; Kruse and
Lefkoff, 1993, Swayze et al., 1995).

All of these methods require that data be reduced to reflectance and that a continuum
be removed from the reflectance data prior to analysis. A continuum is a
mathematical function used to isolate a particular absorption feature for analysis
(Clark and Roush, 1984; Kruse et al, 1985; Green and Craig, 1985). It corresponds to
a background signal unrelated to specific absorption features of interest. Spectra are
normalized to a common reference using a continuum formed by defining high points
of the spectrum (local maxima) and fitting straight line segments between these
points. The continuum is removed by dividing it into the original spectrum.

Figure 14-4: Example of a fitted continuum and a continuum-removed spectrum
for the mineral kaolinite.
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Spectral feature fitting requires that reference endmembers be selected from either
the image or a spectral library, that both the reference and unknown spectra have the
continuum removed, and that each reference endmember spectrum be scaled to match
the unknown spectrum. A “Scale” image is produced for each endmember selected
for analysis by first subtracting the continuum-removed spectra from one, thus
inverting them and making the continuum zero. A single multiplicative scaling factor
is then determined that makes the reference spectrum match the unknown spectrum.
Assuming that a reasonable spectral range has been selected, a large scaling factor is
equivalent to a deep spectral feature, while a small scaling factor indicates a weak
spectral feature.

A least-squares-fit is then calculated band-by-band between each reference
endmember and the unknown spectrum. The total root-mean-square (RMS) error is
used to form an RMS error image for each endmember. An optional ratio image of
Scale/RMS provides a “Fit” image that is a measure of how well the unknown
spectrum matches the reference spectrum on a pixel-by-pixel basis.

Open and Load the Continuum-Removed Data

For the purposes of this exercise, you can use pre-calculated data if you do not wish
to create your own continuum-removed data. If you want to use pre-calculated data,
you can skip to the To Use Pre-Calculated Data section.

To Create Your Own Data

1. Open the file cup95eff.int and select Spectral → Mapping Methods → 
Continuum Removal.

2. In the Continuum Removal Input File dialog, select the file cup95eff.int,
perform spectral subsetting if desired to limit the spectral range for continuum
removal, and click OK.

3. Enter the continuum-removed output file name (cup95cr.dat for example)
in the Continuum Removal Parameters dialog and click OK to create the
continuum-removed image.

This image will have the same number of spectral bands as the input image if
no spectral subsetting was done.

To Use Pre-Calculated Data

1. Open the file cup95_cr.dat.

This is the continuum-removed data (floating point 0 - 1.0 range) derived from
the 1995 AVIRIS Effort-calibrated apparent reflectance as described above.
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2. In the Available Bands List dialog, select band 193 (2.20 µm), select the
Gray Scale button, and click Load Band.

3. Start a Z-Profile by selecting Tools → Profile → Z-profile (Spectrum) in the
Main Image window.

4. In the Spectral Profile window, select Options → Auto-scale Y-axis: Off.

5. Choose Edit → Plot Parameters in the Spectral Profile window, select the
Y-Axis radio button, and enter the range 0.5 - 1.0, and click Apply to apply the
new Y-axis range.

6. Click Cancel to close the Plot Parameters dialog.

7. Move the Spectral Profile window to the bottom of the screen for comparison
with the EFFORT data.

Open and Load the 1995 EFFORT-Corrected Data

1. Open the file cup95eff.int.

This is the 1995 AVIRIS ATREM-calibrated apparent reflectance data with
the EFFORT correction applied.

2. In the Available Bands List dialog, start a new display by selecting
Display → New Display.

3. Select band 193 (2.20 µm), select the Gray Scale button, and click Load
Band.

4. Start a Z-Profile by selecting Tools → Profile → Z-profile (Spectrum) in the
Main Image window.

5. In the Spectral Profile window, select Options → Auto-scale Y-axis Off.

6. Choose Edit → Plot Parameters in the Spectral Profile window, select the
Y-Axis radio button, enter the range 0 - 500, and click Apply to apply the new
Y-axis range.

7. Click Cancel to close the Plot Parameters dialog.

8. Move the Spectral Profile window to the bottom of the screen for comparison
with the continuum-removed data.

Compare Continuum-removed spectra and EFFORT Spectra

1. Link the two displays by selecting Tools → Link → Link Displays in the
continuum-removed image window.
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2. Click OK in the Link Displays dialog to activate the link.

3. In the Continuum-Removed image window, select Dynamic Overlay Off in
the Tools → Link menu in order to enable normal mouse interaction.

(Alternatively, select Tools → Profiles → Additional Z-Profile and select the
EFFORT data to link a second Z-profile to the spatial location in the
continuum-removed image).

Moving the Zoom Window indicator box in this image will cause the cursor
location to be updated in the EFFORT Main Display window. Both spectral
profiles will show the spectrum for the current pixel.

4. Move the Zoom window indicator box around the image and compare the
corresponding Continuum-Removed and EFFORT spectra.

Note how the continuum-removed spectrum normalizes and enhances spectral
features.

5. Now position the cursor at (503, 581) by selecting Tools → Pixel Locator in
the image display and Apply. Compare the continuum-removed spectrum to
the EFFORT spectrum.

6. Move the cursor location to (542, 533) using the Pixel Locator and repeat the
comparison. Note how continuum-removal affects the spectrum.

7. Try selecting some other points in the two images using the Pixel Locator and
compare the spectra. What are the major differences? What improvements in
visual analysis does the continuum-removal procedure allow?

Figure 14-5: Comparison of continuum-removed (left) and EFFORT Apparent
Reflectance (right) Spectra.
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Compare Continuum-Removed and Effort Images

1. Load a color composite image consisting of EFFORT bands 183, 193, and 207
(2.10, 2.20, and 2.34 µm) into RGB.

2. Click the left mouse button in the EFFORT image window to activate the
dynamic overlay.

3. Compare the continuum-removed image for band 193 (2.20 µm) to the color
composite image.

Note the correspondence between dark areas on the continuum-removed image
and red-to-purple areas on the color composite. The dark areas are areas with
absorption bands near 2.2 µm.

4. Move the Zoom window indicator box to some of these dark areas by dragging
with the left mouse button or by clicking in the desired location with the left
mouse button in the Main Image window.

5. Compare the corresponding spectral profiles for both the continuum-removed
data and the EFFORT data and note the image colors.

6. Load continuum-removed band 207 (2.34 µm) in the appropriate display.

Note by moving the Zoom window to the dark areas and examining the spectra
that these correspond to absorption features near 2.34 µm in both the
continuum-removed and Effort spectra.

Close the Effort Display and Spectral Profile

Click on one of the EFFORT bands in the Available Bands List dialog, then select
File → Close Selected File. The associated display windows and spectral plot will
also be closed. ENVI will warn you that it will need to close out the display windows.
You can confirm this by clicking on the Yes button.

Open and Load the SFF Scale and RMS Images

For the purposes of this exercise, you can use pre-calculated data if you do not wish
to create your own Spectral Feature Fitting Scale or RMS data. If you do not want to
create your own data, you can skip to the To Use Pre-Calculated Data section.

To Create Your Own Data

1. Open the file cup95_cr.dat and select Spectral → Mapping Methods →
Spectral Feature Fitting.
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2. Select the cup95_cr.dat file, perform spectral subsetting if desired to limit
the spectral range for fitting, and click OK.

3. Use ENVI’s standardized Endmember Collection dialog to import image or
library spectra to use as endmembers in the SFF and click Apply in the
Endmember Collection dialog.

4. Choose “Output separate Scale and RMS Images” in the Spectral Feature
Fitting Parameters dialog, enter an output file name, and click OK to create the
Scale and RMS error images.

The output image will have two images for each endmember, a Scale image
and an RMS error image.

To Use Pre-Calculated Data

1. Open the file cup95sff.dat.

This contains the Scale and RMS images derived from spectral feature fitting
of a library of image endmember spectra from the 1995 AVIRIS EFFORT-
calibrated apparent reflectance data. Library spectra could also have been
used, but the image spectra were used to allow direct comparison with other
methods that use image spectra.

2. In the Available Bands List dialog, select Display → New Display, select the
band “Scale (Mean: Kaolinite...)”, select the Gray Scale radio button, and
click Load Band.

3. In the Available Bands List dialog, select Display → New Display, select the
band “Scale (Mean: Alunite 2.16...)”, select the Gray Scale radio button, and
click Load Band.

4. Link the two Scale and the Continuum-Removed displays by selecting Tools
→ Link → Link Displays.

5. In the Link Displays dialog, click OK.

6. Use the dynamic overlay function to compare the images.

7. Select Tools → Cursor Location/Value, move the cursor around one of the
images, and compare the actual values for the two Scale images.

Note that although similar as stretched images, the values for the two images
are very different.

8. Load the “RMS (Mean: Kaolinite...)” image as a gray scale image into the
display that contains the Kaolinite Scale Image.
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9. Load the “RMS (Mean: Alunite 2.16...)” image as a gray scale image into the
display that contains the Alunite Scale Image.

10. Again, use the dynamic overlay function to compare the images and the Cursor
Location/Value functions to compare the actual values for the two RMS
images.

Low RMS values correspond to good spectral matches.

2-D Scatterplots of SFF Results

1. Start 2-D Scatter plots from the RMS (Mean: Kaolinite...) image by selecting
Tools → 2-D Scatter plots.

2. In the Scatter Plot Band Choice dialog, select Kaolinite Scale for band X and
Kaolinite RMS for band Y, then click OK.

3. Draw a Region of Interest (ROI) on the scatterplot at low RMS values for all
ranges of Scale by clicking the left mouse button to draw lines connecting the
vertices of a polygon and the right mouse button to close the polygon.

Note the highlighted pixels in the RMS Kaolinite.

4. Select Options → Change Bands in the Scatter Plot window.

5. Load other combinations of Scale and RMS for the various endmembers.

6. Close the 2-D scatter plot by selecting File → Cancel in the Scatter Plot
window.

7. Select Window → Close All Plot Windows.

Spectral Feature Fitting Ratios — “Fit” Images

For the purposes of this exercise, you can use pre-calculated data if you do not wish
to create your own SFF Fit Images. If you do not want to create your own data, you
can skip to the To Use Pre-Calculated Data section.

To Create Your Own Data

1. Open the file cup95_cr.dat and select Spectral → Mapping Methods →
Spectral Feature Fitting.

2. Select the cup95_cr.dat file, perform spectral subsetting (if desired) to limit
the spectral range for fitting, and click OK.

3. Use ENVI’s standardized Endmember Collection dialog to import image or
library spectra to use as endmembers in the SFF and click Apply.
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4. Use the toggle arrows in the Spectral Feature Fitting Parameters dialog to
select Output combined (Scale/RMS) images, enter an output file name, and
click OK to create the fit images.

The output image will have one fit image for each endmember.

To Use Pre-Calculated Data

1. Open the file cup95sfr.dat. This contains the images that are the ratio of
Scale/RMS for each of the endmembers.

2. In the Available Bands List dialog, select the “Fit (Mean: Kaolinite...)” band,
select the Gray Scale button, and click Load Band to load the band into the
existing display containing the continuum-removed data.

The bright pixels represent the best fit to the reference endmember spectrum of
Kaolinite.

3. Load the “Scale (Mean: Kaolinite...)” and “RMS (Mean: Kaolinite...)” images
into the other two displays if not already loaded.

4. Link the image displays and compare the Fit, Scale, and RMS images.

Note how the Scale and RMS image interact to produce the Fit result.

5. Load the EFFORT data again and extract spectral profiles for the bright pixels
in the Fit image.

6. Compare the Fit, Scale, and RMS images as well as the spectral profiles for the
other endmembers.

7. Make one or more color composite images by loading Fit images for different
endmembers as RGB. What conclusions can you draw regarding the
effectiveness of spectral feature fitting for identifying specific endmembers?

End the ENVI Session

This concludes the tutorial. You can quit your ENVI session by selecting File → Exit
(Quit on UNIX) from the ENVI main menu, then click Yes. If you are using ENVI
RT, quitting ENVI will take you back to your operating system.
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Overview of This Tutorial

This tutorial is designed to introduce you to advanced concepts and procedures for
analysis of imaging spectrometer data or hyperspectral images. We will use 1995
Airborne Visible/Infrared Imaging Spectrometer (AVIRIS) data from Cuprite,
Nevada, to investigate sub-pixel properties of hyperspectral data and advanced
techniques for identification and quantification of mineralogy. We will use EFFORT
polished ATREM-calibrated data, and review matched filter and spectral unmixing
results. This tutorial is designed to be completed in two to four hours.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 2

Path: envidata/c95avsub

File Description

Required Files

cup95eff.int Effort” corrected ATREM apparent reflectance data,
50 bands, 1.96 - 2.51 mm.

cup95eff.hdr ENVI Header for above

cup95mnf.dat First 25 MNF bands

cup95mnf.hdr ENVI Header for above

cup95mnf.asc MNF eigenvalue spectrum

cup95mnf.sta MNF statistics

cup95ns.sta Noise statistics from Shift Difference

cup95ppi.dat Pixel Purity Index (PPI) Image

cup95ppi.hdr ENVI Header for above

cup95ppi.roi Region of Interest for PPI values greater than 1750

cup95ppi.ndv N-D Visualizer Saved State File.

cup95ndv.roi ROI endmembers corresponding to the N-D Visualizer
Saved State File
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Note
The files listed are required to run this exercise. Optional spectral library files listed
below may also be used if more detailed comparisons are desired. Selected data
files have been converted to integer format by multiplying the reflectance values by
1000 because of disk space considerations. Values of 1000 in the files represent
reflectance values of 1.0.

cup95_em.asc EFFORT ASCII file of 11 spectral endmembers
selected using the PPI threshold, MNF images, and n-
Matched Filtering and Unmixing

cup95_mnfem.asc MNF ASCII file of 11 spectral endmembers elected
using the PPI threshold, MNF images, and n-D
Visualization - used in Matched Filtering and
Unmixing

cup95unm.dat Unmixing Results—Fractional Abundance images

Optional Files

jpl1sli.dat JPL Spectral Library in ENVI format

jpl1sli.hdr ENVI Header for above

usgs_sli.dat USGS Spectral Library in ENVI format

usgs_sli.hdr ENVI Header for above

File Description
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Open the 1995 Effort-Corrected Data

1. Open the file cup95eff.int. This is the 1995 AVIRIS ATREM-calibrated
apparent reflectance data with the Effort correction applied.

2. Load band 193 as a gray scale image in the new image display by clicking on
the Gray Scale radio button, selecting the band, and clicking on the Load
Band button.

These data will be used for comparison with MNF bands and to extract spectral
endmembers for PPI results.
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MNF Transform Data, Endmembers, and
Spectral Unmixing

Background: Minimum Noise Fraction

The minimum noise fraction (MNF) transformation is used to determine the inherent
dimensionality of image data, to segregate noise in the data, and to reduce the
computational requirements for subsequent processing (See Boardman and Kruse,
1994). The MNF transform as modified from Green et al. (1988) and implemented in
ENVI is essentially two cascaded Principal Components transformations. The first
transformation, based on an estimated noise covariance matrix, decorrelates and
rescales the noise in the data. This first step results in transformed data in which the
noise has unit variance and no band-to-band correlations. The second step is a
standard Principal Components transformation of the noise-whitened data. For the
purposes of further spectral processing, the inherent dimensionality of the data is
determined by examination of the final eigenvalues and the associated images. The
data space can be divided into two parts: one part associated with large eigenvalues
and coherent eigenimages, and a complementary part with near-unity eigenvalues
and noise-dominated images. By using only the coherent portions, the noise is
separated from the data, thus improving spectral processing results.

Figure 15-1 summarizes the MNF procedure in ENVI. The noise estimate can come
from one of three sources; from the dark current image acquired with the data (for
example AVIRIS), from noise statistics calculated from the data themselves, or from
statistics saved from a previous transform. Both the eigenvalues and the MNF images
(eigenimages) are used to evaluate the dimensionality of the data. Eigenvalues for
bands that contain information will be an order of magnitude larger than those that
contain only noise. The corresponding images will be spatially coherent, while the
noise images will not contain any spatial information.
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Open and Load MNF Image

1. Open the file cup95mnf.dat.

This dataset contains the first 25 MNF bands (floating point) from the 1995
Cuprite Effort data.

2. Load the first MNF band as a gray scale image in a new image display by
clicking on the Gray Scale radio button, selecting the band, and clicking on
Load Band in the Available Bands List dialog.

Compare MNF Images

1. Load several other MNF bands, either one at a time for individual examination
or in RGB composites for intercomparison.

2. Use the Z-Profile, image linking, and dynamic overlay to compare MNF-
spectra with Apparent Reflectance spectra from the Effort image.

3. Try to determine the relation(s) between the MNF image and the apparent
reflectance images. Relate MNF band number to MNF image quality.

Figure 15-1: MNF Procedures in ENVI.
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Examine MNF Scatter Plots

1. Use Tools → 2-D Scatter Plots in the Main Image window for forward and
inverse mapping modes to understand the MNF images.

2. Be sure to examine the high variance (low band number) MNF bands. Also be
sure to examine at least one scatter plot of a low variance (high band number)
MNF band (change the bands by selecting Options → Change Bands in the
Scatter Plot window).

Notice the corners (pointed edges) on some MNF scatter plots (Figure 15-2).

3. Use linked windows, overlays, and Z-profiles to understand the reflectance
spectra of the MNF corner pixels.

Look for areas where the MNF data stops being “pointy” and begins being
“fuzzy”. Also notice the relationship between scatter plot pixel location and
spectral mixing as determined from image color and individual reflectance
spectra.

How do you explain these patterns? How can you exploit them?

Figure 15-2: MNF 2-D Scatter Plot.
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Use Scatter Plots to Select Endmembers

We will now investigate the possibilities of deriving unmixing endmembers from the
data using MNF images and the 2-D scatter plot tools.

1. Load a scatter plot of MNF bands 1 and 2.

2. In the scatter plot, use the ROI drawing functions to circle the extreme few
pixels in one or more of the corners or arms of the data cloud.

These will be mapped into the image as colored pixels.

3. Use different colors for several classes by selecting the desired color from the
Class pull-down menu in the Scatter Plot window.

4. Use image and scatter plot dancing pixels (double-click and drag with the
middle mouse button) to help identify unique areas.

5. Select Options → Export All in the Options pull-down menu of the scatter
plot to export these lists of pixels as ENVI Regions of Interest (ROI).

6. Load these ROIs into the window displaying the apparent reflectance data by
choosing selecting Overlay → Region of Interest in the Main Image window
menu bar.

7. Continue to select MNF-corner ROIs using different combinations of the first
several MNF bands.

8. Use the Mean for All Regions menu item in the Options pull-down menu of
the ROI Tool to extract the mean apparent reflectance spectra of the ROIs.

9. Use the linked windows and Z-profiles to examine the relations between the
MNF and reflectance spectra.

Note
Corner pixels on the scatter plots generally make good endmember estimates.
However, note also the occurrence of overlapping or repeat ROIs. This is a
limitation of examining the data in a pairwise fashion (2-D).

10. Close the 2-D scatter plot by selecting File → Cancel in the Scatter Plot
window.
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Pixel Purity Index

In this portion of the exercise, you will examine the role of convex geometry in
determining the relative purity of pixels. Separating purer from more mixed pixels
reduces the number of pixels to be analyzed for endmember determination and makes
separation and identification of endmembers easier.

The Pixel-Purity-IndexTM (PPITM) is a means of finding the most “spectrally pure,” or
extreme, pixels in multispectral and hyperspectral images. See Boardman et al.
(1995). The most spectrally pure pixels typically correspond to mixing endmembers.
The Pixel Purity Index is computed by repeatedly projecting n-dimensional scatter
plots onto a random unit vector. The extreme pixels in each projection are recorded
and the total number of times each pixel is marked as extreme is noted. A Pixel Purity
Index (PPI) image is created in which the DN of each pixel corresponds to the
number of times that pixel was recorded as extreme. Figure 15-3 summarizes the use
of PPI in ENVI.

Figure 15-3: Pixel Purity Index procedures in ENVI.
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Display and Analyze the Pixel Purity Index

1. Open the file cup95ppi.dat and display it as a gray scale image.

Brighter pixels represent more spectrally extreme finds (hits) and indicate
pixels that are more spectrally pure. Darker pixels are less spectrally pure.

2. Try various interactive stretches from the Enhance pull-down menu on the
Main Image window menu bar to understand the PPI image’s histogram and
data distribution.

Why is the histogram skewed to the low values. What does this mean from a
mixing point of view?

3. If it is not already open and displayed, open the MNF (cup95mnf.dat) and
Effort apparent reflectance (cup95eff.int) files and load bands from each of
these two into two new windows.

The PPI image is the result of several thousand iterations of the PPI algorithm
discussed above on the MNF data. The values in the image indicate the number
of times each pixel was discovered as extreme in some projection. These
numbers then indicate the degree of local convexity of the data cloud near each
pixel and the proximity of each pixel to the convex hull of the data. In short,
the higher values indicate pixels that are nearer to corners of the n-
Dimensional data cloud, and are thus relatively purer than pixels with lower
values. Pixels with values of zero were never found to be extreme.

4. Link all three windows using Tools → Link → Link Displays and create Z-
profiles in the MNF and reflectance image displays.

In this configuration, you can examine the spectral profiles of certain pixels as
they are selected in the PPI display.

5. To determine the range of values present in the image, use the Cursor
Location/Value dialog (by selecting Tools → Cursor Location/Value from
the Main Image window menu bar.

6. Move around the image using the Z-profiles and dynamic overlay tools to
examine the purest pixels both spatially and spectrally.

Do any of the high PPI values fall in the regions of the image corresponding to
the 2-D scatter plot corners you picked in the previous exercise? Why?
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Threshold PPI to Regions of Interest

1. Restore the file cup95ppi.roi by selecting Tools → ROI Tool from the
Main Image window using File → Restore ROIs in the ROI Tool dialog.

This is a list of pixels where the PPI value is over 1000.

How many high PPI pixels are there?

Now try making some of your own thresholded PPI Regions of Interest.

2. Select Enhance → Interactive Stretching in the PPI image.

3. Determine a threshold to use for choosing only the purest pixels by using the
left mouse button to read values off the histogram.

4. Click the middle mouse button in the histogram to zoom in on the lower end of
the distribution.

5. Select a value on the high tail of the histogram as the minimum threshold (if
you have difficulty with this try a value of 2000 as a starting point).

6. Start the ROI Tool by choosing Overlay → Region of Interest from the Main
Image window menu bar. Choose Options → Band Threshold to ROI in the
ROI Tool dialog to create an ROI containing only the pixels with high PPI
values.

7. Choose the PPI file for thresholding and click OK

8. Enter the value selected above for the minimum threshold into the Band
Threshold to ROI Parameters dialog and click OK.

ENVI will determine the number of pixels that meet the selected criteria and
post a message.

Note
For the purposes of this exercise, if your threshold results in more than 2000 pixels
being selected, you should select a higher minimum threshold.

9. Click OK in the ENVI Question dialog and a standard ENVI ROI will be
created and listed in the ROI Tool dialog.

Only those pixels with values greater than the selected minimum will be
included in the ROI built from the PPI image.

10. Select and display the ROI by clicking on the name in the ROI Tool dialog.

This ROI contains the pixel locations of the purest pixels in the image
regardless of the endmember to which they correspond. The n-Dimensional
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Visualizer will be used in the next portion of the exercise to isolate the specific
pure endmembers.
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n-Dimensional Visualization

Spectra can be thought of as points in an n-dimensional scatter plot, where n is the
number of bands. See Boardman et al. (1995). The coordinates of the points in n-
space consist of “n” values that are simply the spectral radiance or reflectance values
in each band for a given pixel. The distribution of these points in n-space can be used
to estimate the number of spectral endmembers and their pure spectral signatures.

ENVI’s n-Dimensional VisualizerTM provides an interactive tool for selecting the
endmembers in n-space. In this section, you will examine a Grand Tour of the n-
dimensional data. Because the computer method is computer intensive, it only
operates well with no more than a few thousand pixels in a few dozen bands. From a
theoretical standpoint, it makes little sense to view all the mixed pixels. The most
important pixels, those that best suggest the endmember materials, are the purest
pixels, previously selected using the PPI thresholding. Figure 15-4 summarizes the
steps involved in using the n-Dimensional Visualizer to select endmember spectra.

Compare n-D Data Visualization with 2-D Scatter Plot

1. Select Spectral → n-Dimensional Visualizer → Visualize with New Data
from the ENVI main menu,

2. Select the MNF file cup95mnf.dat for visualization using the first 10 MNF
bands (click Spectral Subset to specify only the first 10 bands) and click OK.

Remember that these bands encompass almost all the signal variability and
limiting the number of bands will improve the interactive visualization

Figure 15-4: Steps used in the n-Dimensional Visualizer.
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performance. The other, higher-order MNF bands have already been discarded
as primarily noise.

If you only have one valid ROI listed in the ROI Tools dialog, that ROI data
will automatically be loaded into the n-Dimensional Visualizer. If you have
more than one ROI, choose the ROI derived using the PPI threshold when
queried.

After a short wait, the n-D scatter plotting window and controls will appear.
The numbers 1 through 10 on the n-D Controls dialog refer to the ten spectral
bands chosen.

3. Click on 1 and 2 to create a 2-D scatter plot of the purest pixels of band 1 and 2
(Figure 15-5).

4. Meanwhile, also start a standard 2-D scatter plot of MNF bands 1 and 2
(Figure 15-6) for comparison by selecting Tools → 2-D Scatter Plot in the
Main window.

Figure 15-5: MNF 2-D Scatter Plot “thinned” using the PPI.
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5. Compare the two scatter plots.

Can you see how pixels were excluded from the n-D scatter plot based on pixel
purity? Why is this important?

Use the n-D Visualizer

1. Close the 2-D scatter plot and try several different 2-band combinations in the
n-D Visualizer.

Note the shape of the data clouds. Be sure to examine some of the higher order
MNF bands.

2. Now try several three-band combinations by clicking on three of the band
numbers.

3. When only 3 bands are selected, you can change the view of the projection by
selecting Options → 3D: Drive Axes in the n-D Controls dialog.

4. Subsequently clicking and dragging with the left mouse button in the n-D
Visualizer rotates the projection.

Again, note the shape of the data clouds. Be sure to examine some of the
higher order MNF bands. Turn on the axes by selecting Options → Axes: On.

Figure 15-6: MNF 2-D Scatter Plot.
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5. Change back to Options → 3D: ROI Definition when finished with the 3-D
visualization; we will use the ROIs in higher dimensional rotations.

6. Click on the Start button to start the many various rotations.

This is an animation of random projections of n-Dimensional space into the
scatter plot. In this mode, any number of bands can be examined
simultaneously.

7. Click on bands 1, 2, 3, 4, and 5 to view a projection of 5-D data.

8. Click on bands again to deselect them.

9. Try a few different combinations of 2, 3, and more different bands to get a
feeling for the n-D data. Stop the rotation by clicking on the Stop button and
then use the arrow buttons next to the Step text label to step forward and
backward through the projections. The New button loads a new random
projection. Enter lower or higher values in the Speed spin box to slow down or
speed up the rotation.

10. Try MNF band 9 versus MNF band 10 to see how they compare to 1 versus 2.

11. Select the Options → Axes: On option to display the axes for the various
bands in the n-Dimensional projection.

Notice how the rotations seem different when more than three bands are
included. This is the result of dimensions greater than 3 being folded in upon
themselves in the projection. This should convince you that the data is truly
high dimensional and why 2-D scatter plots are inadequate for dealing with
hyperspectral data.

Paint Your Own Endmembers

1. Go back to the n-D Controls and restart the rotation using the Start button.

2. When you see an interesting projection (one with points or corners), stop the
rotation, select a color from the list under the Class pull-down menu, and use
the cursor to circle the points at one or more of the corners (Figure 15-7).
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3. Use the left mouse button to define the segments of a ROI in the scatter plot,
and the right mouse button to complete the ROI.

4. Continue spinning the data and update classes as needed as they split up in
further projections.

Use the n-D Class Controls

1. Select Options → Class Controls to start the n-D Class Controls dialog.

This is used to change class colors, turn classes on and off, and control
clipping of class values.

2. Click on one of the colored class boxes to make that class the active class.

3. Select a Symbol to display in the n-D Visualizer for the selected class from
the pull-down list for pixels in the active class.

Figure 15-7: The n-Dimensional Visualizer and Controls with selected pixels
highlighted.
ENVI Tutorials n-Dimensional Visualization



354 Tutorial 15: Advanced Hyperspectral Analysis
4. Calculate statistics (Stats), a mean spectrum (Mean), plot the class (Plot),
clear (Clear), or export (Export) by selecting the corresponding button in the
n-D Class Controls dialog.

5. Try turning classes on and off by clicking on the check box next to a class.

Link the n-D Visualizer to Spectral Profiles

You can view reflectance spectra for specific endmembers while you’re painting
endmembers and rotating the scatter plot. This allows you to preview spectra before
finalizing spectral classes

1. Select Options → Z-Profile in the n-D Controls dialog. Choose the
reflectance data cup95eff.int from the list and click OK. A blank spectral
plot appears.

2. Click the middle mouse button in the n-D Visualizer, and a spectrum will
appear for the current pixel in the n-D Profile window. Dragging the cursor
around the image with the middle mouse button depressed allows real-time
spectral browsing. When the cursor is in an n-D-defined class, the plotted
spectrum will match the color of that class.

3. Click the right mouse button in the n-D Profile window, then right-click and
drag in the n-D Visualizer to turn on spectrum collection. Each subsequent
spectrum will be retained in the one plot, without erasing the previous
spectrum. Click in the n-D Visualizer using the middle mouse button to clear
the plot and return to single spectrum mode.

Link the Spectral Analyst to the n-D Visualizer Spectra

The Spectral AnalystTM matches unknown spectra to library spectra and provides a
score with respect to the library spectra. The spectral analyst uses several methods to
produce a score between 0 and 1, with 1 equaling a perfect match. Linking the
Spectral Analyst to the n-D Visualizer profile provides a means of identifying
endmember spectra on-the-fly.

1. Select Spectral → Spectral Analyst from the ENVI main menu.

2. Click on the Open Spectral Library button at the bottom of the Spectral
Analyst Input Spectral Library dialog.

3. Navigate to the usgs_min spectral library directory in the spec_lib
directory of the main ENVI distribution and select and open the
usgs_min.sli spectral library.
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4. When the Edit Identify Methods Weighting dialog appears, click OK. The
different matching methods are described in the ENVI User's Guide.

5. Select Options → Auto Input via-Z Profile in the Spectral Analyst dialog
and click on the n-D Profile in the list of available profiles. Click the middle
mouse button on one of the painted classes in the n-D visualizer and the
Spectral Analyst scores the unknown spectrum against the library. High
scores indicates a high likelihood of match.

6. Double-click on the spectrum name at the top of the list to plot the unknown
and the library spectrum in the same plot for comparison. Use the Spectral
Analyst and the comparison plots to determine the mineralogy for the n-D
Visualizer spectra you have extracted. When you have identified several
minerals, continue with the next section.

Load Individual Spectra Into the n-D Visualizer

1. Make sure that ROI drawing is turned off in the displayed image (Select the
Off radio button in the ROI Tool dialog).

2. Select Tools → Profiles → Z Profile to display an EFFORT spectrum from
the Cuprite data.

3. Select Tools → Profiles → Additional Z Profile and select the MNF data for
the second associated spectral profile.

Because the data in the n-D Visualizer are in MNF space, you must import the
MNF spectra that represent the materials of interest.

4. Select Options → Import Library Spectra from the n-D Controls dialog.
The n-D Visualizer Import Spectra dialog appears (a standard ENVI
Endmember Collection dialog).

5. To import the single spectrum from the Additional Z Profile window, first
move the cursor in the image until the desired reflectance spectrum is
displayed in the primary spectral profile. The additional spectral profile
spectrum is linked and will show the corresponding MNF spectrum.

6. Drag and drop by clicking the right mouse button in the plot window to show
the spectrum name, selecting the spectrum name with the left mouse button
and dragging and dropping in the black draw window at the top of the
Endmember Collection dialog.

7. The spectrum will be plotted in the n-Dimensional Visualizer window with a
flag marking its position. Repeat for as many spectra as desired.
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8. These spectra can be rotated along with the PPI-derived data in the n-D
Visualizer.

Collapse Classes in the n-D Visualizer

Once you have identified a few endmembers, it may be difficult to find additional
endmembers, even though you run the rotations or many different 2-D projections of
the n-Dimensional data.

Class Collapsing in ENVI is a means of simplifying this endmember determination
problem by allowing you to group the endmembers you have already found into one
group representing the background. The net result is that mixing features that were
previously hidden become visible, and can be selected using ENVI’s ROI drawing in
the n-D Visualizer window.

You can collapse on means by selecting Options → Collapse Classes by Means
from the n-D Controls menu bar to geometrically project the selected data according
to their class mean values. You can also alternatively select Options → Collapse
Classes by Variance. The Z-profile can be used to verify that you are choosing
homogeneous endmember classes.

Notice that the bands selected are now listed in red and only two are chosen.
Additionally, a MNF plot appears, estimating the dimensionality of the data, and the
number of endmembers remaining to be found. Repeat the endmember selection and
class collapsing process until there are no new endmembers found.

Export Your Own ROIs

You can also export mean spectra for the selected endmembers.

1. Delete all of the previous ROIs by selecting Options → Delete All Regions in
the ROI Tool dialog.

2. Export your best set of classes to ROIs by selecting Options → Export All in
the n-D Control dialog. You can also export individual classes from the n-D
Class Controls dialog (access with Options → Class Controls). Examine the
ROI spatial locations.

3. Extract the average spectra for the different ROIs using either the Stats or
Mean buttons in the n-D Control dialog. Compare these endmembers to
endmembers extracted using the 2-D scatter plots and those used in the
previous exercises.

4. Use Options → Z-Profile in the n-D Controls dialog to compare single
spectra with average spectra.
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Save Your n-D Visualizer State

1. Select File → Save State in the n-D Controls dialog, enter an output filename
cup95.ndv and click OK. This saved state can be restored for later use.

Restore n-D Visualizer Saved State

1. Start another n-D Visualizer session using previously saved parameters and
painted endmembers by selecting Spectral → n-D Visualizer → Visualize
with Previously Saved Data.

1. Select the file cup95ppi.ndv.

2. Click on the Start button to start rotating the data.

The colored pixels in the visualizer represent previously selected endmembers.

3. Examine different projections and numbers of bands in the visualizer.

4. Click on Stop to stop the rotation.

5. Select Options → Delete All Regions in the ROI Tool dialog to remove all
previous regions of interest.

6. Now select Options → Export All in the n-D Controls dialog.

7. In the ROI Tool dialog, make sure that the display is set to the Effort apparent
reflectance image and then select Options → Mean for All Regions to extract
average reflectance spectra for all of the endmembers (Figure 15-8).
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8. Examine the relations between reflectance spectra and the painted pixels in the
n-D Visualizer.

9. Pay particular attention to similar spectra and the positions of painted clusters.

Figure 15-8: Endmember Spectra extracted using the n-D Visualizer.
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Close all Displays and Other Windows

1. Select File → Close All Files from the Available Bands List dialog to close
all open files and their associated displays.

2. Select File → Cancel in the n-D Controls to close those windows and the n-D
Visualizers.
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Spectral Mapping

ENVI provides a variety of mapping methods, but their success depends on the data
type and quality, and the desired results. These include the Spectral Angle Mapper
(SAM) Classification, Spectral Unmixing, Matched Filtering, and Mixture-Tuned
Matched Filtering.

SAM is an automated method for comparing image spectra to individual spectra that
determines the similarity between two spectra by calculating the “spectral angle”
between them, treating them as vectors in a space with dimensionality equal to the
number of bands. This provides a good first cut at spectral mapping of the
predominant spectrally active material present in a pixel, however, natural surfaces
are rarely composed of a single uniform material. Spectral mixing occurs when
materials with different spectral properties are represented by a single image pixel.
Several researchers have investigated mixing scales and linearity. Singer and
McCord (1979) found that if the scale of the mixing is large (macroscopic), mixing
occurs in a linear fashion (Figure 15-9) For microscopic or intimate mixtures, the
mixing is generally nonlinear (Nash and Conel, 1974; Singer, 1981).

The linear model assumes no interaction between materials. If each photon only sees
one material, these signals add (a linear process). Multiple scattering involving
several materials can be thought of as cascaded multiplications (a non-linear

Figure 15-9: Macroscopic (linear) mixing.
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process). The spatial scale of the mixing and the physical distribution of the materials
governs the degree of non-linearity. Large-scale aerial mixing is very linear. Small-
scale intimate mixtures are slightly non-linear. In most cases, the non-linear mixing is
a second order effect. Many surface materials mix in non-linear fashions but linear
unmixing techniques, while at best an approximation, appear to work well in many
circumstances (Boardman and Kruse, 1994). While abundance determined using the
linear techniques are not as accurate as those determined using non-linear techniques,
to the first order they appear to adequately represent conditions at the surface.

What Causes Spectral Mixing

A variety of factors interact to produce the signal received by the imaging
spectrometer:

• A very thin volume of material interacts with incident sunlight. All the
materials present in this volume contribute to the total reflected signal.

• Spatial mixing of materials in the area represented by a single pixel result in
spectrally mixed reflected signals.

• Variable illumination due to topography (shade) and actual shadow in the area
represented by the pixel further modify the reflected signal, basically mixing
with a black endmember.

• The imaging spectrometer integrates the reflected light from each pixel.
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Modeling Mixed Spectra

The simplest model of a mixed spectrum is a linear one, in which the spectrum is a
linear combination of the pure spectra of the materials located in the pixel area,
weighted by their fractional abundance (Figure 15-10).

This simple model can be formalized in three ways: a physical model a mathematical
model, and a geometric model. The physical model as discussed above includes the
Ground Instantaneous Field of View (GIFOV) of the pixels, the incoming irradiance,
the photon-material interactions, and the resulting mixed spectra. A more abstract
mathematical model is required to simplify the problem and to allow inversion, or
unmixing (Figure 15-11).

Figure 15-10: Linear mixing for a single pixel.

Figure 15-11: The linear algebra model of spectral mixing. A (m x n) columns are
the endmember spectra, x (n x 1) is a vector of unknown abundance, and b (m x
1) is the observed spectrum where m is the # bands, n is the # endmembers and

all x values are positive and sum to unity.
Spectral Mapping ENVI Tutorials



Tutorial 15: Advanced Hyperspectral Analysis 363
A spectral library forms the initial data matrix for the analysis. The ideal spectral
library contains endmembers that when linearly combined can form all other spectra.
The mathematical model is a simple one. The observed spectrum (a vector) is
considered to be the product of multiplying the mixing library of pure endmember
spectra (a matrix) by the endmember abundance (a vector). An inverse of the original
spectral library matrix is formed by multiplying together the transposes of the
orthogonal matrices and the reciprocal values of the diagonal matrix (Boardman,
1989). A simple vector-matrix multiplication between the inverse library matrix and
an observed mixed spectrum gives an estimate of the abundance of the library
endmembers for the unknown spectrum

The geometric mixing model provides an alternate, intuitive means to understand
spectral mixing. Mixed pixels are visualized as points in n-dimensional scatter-plot
space (spectral space), where n is the number of bands. In two dimensions, if only
two endmembers mix, then the mixed pixels will fall in a line (Figure 15-12A). The
pure endmembers will fall at the two ends of the mixing line. If three endmembers
mix, then the mixed pixels will fall inside a triangle (Figure 15-12B). Mixtures of
endmembers fill in between the endmembers.

All mixed spectra are interior to the pure endmembers, inside the simplex formed by
the endmember vertices, because all the abundance are positive and sum to unity.
This convex set of mixed pixels can be used to determine how many endmembers are
present and to estimate their spectra. The geometric model is extensible to higher

Figure 15-12: Geometric mixing model.(A). two dimensional mixing (two
endmembers). (B). three dimensional mixing (three endmembers). Higher

dimensions of mixing are represented by higher dimension geometric figures
(eg: four endmembers mix within a tetrahedron, etc.).
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dimensions where the number of mixing endmembers is one more than the inherent
dimensionality of the mixed data.

Practical Unmixing Methods

Two very different types of unmixing are typically used: Using known endmembers
and using derived endmembers.

Using known endmembers, one seeks to derive the apparent fractional abundance of
each endmember material in each pixel, given a set of known or assumed spectral
endmembers. These known endmembers can be drawn from the data (averages of
regions picked using previous knowledge), drawn from a library of pure materials by
interactively browsing through the imaging spectrometer data to determine what pure
materials exist in the image, or determined using expert systems as described above
or other routines to identify materials.

The mixing endmember matrix is made up of spectra from the image or a reference
library. The problem can be cast in terms of an over-determined linear least squares
problem. The mixing matrix is inverted and multiplied by the observed spectra to get
least-squares estimates of the unknown endmember abundance fractions. Constraints
can be placed on the solutions to give positive fractions that sum to unity. Shade and
shadow are included either implicitly (fractions sum to 1 or less) or explicitly as an
endmember (fractions sum to 1).

The second unmixing method uses the imaging spectrometer data themselves to
“derive” the mixing endmembers (Boardman and Kruse, 1994). The inherent
dimensionality of the data is determined using a special orthogonalization procedure
related to principal components:

• A linear sub-space (flat) that spans the entire signal in the data is derived.

• The data are projected onto this subspace, lowering the dimensionality of the
unmixing and removing most of the noise.

• The convex hull of these projected data is found.

• The data are shrink-wrapped by a simplex of n-dimensions, giving estimates of
the pure endmembers.

• These derived endmembers must give feasible abundance estimates (positive
fractions that sum to unity).

Spectral unmixing is one of the most promising hyperspectral analysis research areas.
Analysis procedures using the convex geometry approach already developed for
AVIRIS data have produced quantitative mapping results for a a variety of materials
(geology, vegetation, oceanography) without a priori knowledge. Combination of the
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unmixing approach with model-based data calibration and expert system
identification capabilities could potentially result in an end-to-end quantitative yet
automated analysis methodology.
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Unmixing Results

In this section, you will examine the results of unmixing using the means of the ROIs
restored above and applied to the first ten MNF bands. You will then run your own
unmixing using endmember suites of your own choosing.

Open and Display the Unmixing Results

1. Open the file cup95unm.dat.

2. Load the Kaolinite abundance image by clicking on the Kaolinite band name
and then Load Band in the Available Bands List dialog.

Brighter areas correspond to higher abundances.

Use contrast stretching, if necessary, to show only the higher values (larger
apparent abundances).

3. Load the other fractional abundance images into one or more displays and
compare the distribution of endmembers.

Determine Abundance

1. Select Tools → Cursor Location/Value and investigate the values at specific
pixels.

2. Open the EFFORT data cup95eff.int and create spectral Z profiles of the
reflectance data to reconcile absorption band strength with apparent abundance
of the various endmembers.

Display a Color Composite

1. Choose three good unmixing result images and make an RGB color composite.

2. Use spatial and spectral clues to evaluate the results of the unmixing.

3. Explain the colors in the RGB composite of fraction endmembers in terms of
mixing.

Notice the occurrence of non-primary colors (not R, G, or B).

Are all of the fractions feasible?
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Notice areas where unreasonable results were obtained (e.g., fractions greater
than one or less than zero).

4. Examine the RMS Error image and look for areas with high errors (bright
areas in the image).

Are there other endmembers that could be used for iterative unmixing? How
do you reconcile these results if the RMS Error image doesn’t have any high
errors yet there are negative abundance or abundance greater than 1.0?
ENVI Tutorials Unmixing Results



368 Tutorial 15: Advanced Hyperspectral Analysis
Mixture-Tuned Matched Filtering

Matched Filtering removes the requirement of knowing all of the endmembers by
maximizing the response of a known endmember and suppressing the response of the
composite unknown background, thus matching the known signature (Chen and
Reed, 1987; Stocker et al., 1990; Yu et al., 1993; Harsanyi and Chang, 1994). It
provides a rapid means of detecting specific minerals based on matches to specific
library or image endmember spectra. This technique produces images similar to the
unmixing, but with significantly less computation and without the requirement to
know all the endmembers. It does, however, suffer from high false alarm rates, where
materials may be randomly matched if they are rare in a pixel (thus not contributing
to the background covariance).

Mixture-Tuned Matched FilteringTM (MTMFTM) is a hybrid method based on the
combination of well-known signal processing methodologies and linear mixture
theory (Boardman, 1998). This method combines the strength of the Matched Filter
method above (no requirement to know all the endmembers) with physical
constraints imposed by mixing theory (the signature at any given pixel is a linear
combination of the individual components contained in that pixel). Mixture-Tuning
uses linear spectral mixing theory to constrain the result to feasible mixtures and
reduce false alarm rates (Boardman, 1998). Mixture-Tuned Matched filter results are
presented as two sets of images, the MF score (Matched Filter image), presented as
gray-scale images with values from 0 to 1.0, which provide a means of estimating
relative degree of match to the reference spectrum (where 1.0 is a perfect match) and
the Infeasibility image, where highly infeasible numbers indicate that mixing
between the composite background and the target is not feasible. The best match to a
target is obtained when the Matched Filter Score is high (near 1) and the infeasibility
score is low (near 0).

Perform Your Own Mixture-Tuned Matched Filtering

Display and compare the EFFORT and MNF Data

1. Display the MNF-transformed data (MTMF requires these). Select
File → Open Image File and choose cup95mnf.dat as the input file. In the
Available Bands List, click on the RGB radio button, then sequentially
choose MNF bands 1, 2, and 3, then click on Load RGB.

2. Display a color composite of the EFFORT data. Select File → Open Image
File and choose cup95eff.int. In the Available Bands List, click on the
RGB radio button, then sequentially choose bands 183, 193, and 207, then
select New Display from the Display pull-down menu and click Load RGB.
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3. Link the two images using Tools → Link → Link Displays. Turn the
dynamic overlay off in the EFFORT color image by choosing
Tools → Link → Dynamic Overlay off.

4. Start a spectral profile for each dataset using Tools → Profiles → Z Profile
(Spectrum). Move the cursor in the EFFORT image and observe the two sets
of spectral profiles. Note that the MNF spectra don’t make it possible to
identify the materials.

Collect the MNF Endmember Spectra for Use in MTMF

1. Select Window → Start New Plot Window in the Main Image window.
Select File → Input Data → ASCII, in the plot window and choose the file
cup95_em.asc. Click OK in the Input ASCII File dialog to plot the
EFFORT spectra.

2. Select Window → Start New Plot Window. Select File → Input
Data → ASCII, in the plot window and choose the file cup95_mnfem.asc.
Click OK in the Input ASCII File dialog to plot the MNF spectra.

3. Compare the EFFORT and MNF spectra. The MNF spectra will be used with
the MNF data to do the MTMF mapping.

Calculate MTMF Images

1. Choose Spectral → Mapping Methods → Mixture Tuned Matched
Filtering. Click on the file cup95mnf.dat then click OK.

2. In the Endmember Collection dialog, select Import → From ASCII File and
choose cup95_mnfem.ascii as the input file (these are the MNF-
transformed endmember spectra). Click OK to load the endmembers.

3. Click Apply at the bottom of the Endmember Collection dialog. In the
MTMF Parameters dialog, enter an output file name for the MTMF statistics
and for the MTMF image, then click OK. (For ease of comparison, these
results are also pre-calculated on the ENVI Tutorial and Data CD No. 2 in the
file cup95_mtmf.img).

Display MTMF Results

1. Load Matched Filter score bands as gray scale images. Stretch using
interactive stretching from 0.0 to 0.25 abundances and look at the pixel
distributions for the various endmembers.Try other stretches to minimize false
alarms (scattered pixels).
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2. Click on the RGB radio in the Available Bands List dialog, then sequentially
on the Kaolinite, Alunite, and Buddingtonite MF images and click Load RGB
to display a color composite of MF scores (Figure 15-13).

In this color composite, using only MF, kaolinite appears red, alunite green, and
buddingtonite blue. This is a pretty good looking image map, but has many obvious
false alarms (every pixel has a color).

Figure 15-13: MTMF Results image (MF Score Only) for Kaolinite, Alunite,
Buddingtonite (RGB).
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Display Scatter Plots of MF Score versus Infeasibility

1. Display a gray scale of EFFORT band 193 by Gray Scale radio button,
selecting the appropriate band, then clicking Load Band.

2. Select Tools → 2-D Scatter Plot from the Main Image window menu bar and
scatter plot Buddingtonite MF Score versus Buddingtonite Infeasibility. Circle
all the pixels that have a high MF score and low infeasibilities (Figure 15-14).

Notice the highly selective nature of the MTMF. The selection of the desired
endmember is very selective and there are very few false alarms when using
this method.

3. Start scatter plots for the other endmembers using File → New Scatter Plot
from the existing scatter plot window. Select Options → Export Class in each
scatter plot to build ROIs showing the individual minerals (Figure 15-15).

Figure 15-14: 2-D Scatter Plot of MF Score versus Infeasibility for the
Buddingtonite endmember.
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4. Compare your MTMF results to the MF color composite, to the MNF data, and
to the EFFORT data. Compare to the Linear Spectral Unmixing results.

5. Link the MTMF results window with the EFFORT image window to browse
spectra and compare them to the endmember spectra, MTMF images, ROIs
and scatter plots. Extract spectra from the EFFORT data and verify the
sensitivity of the MTMF mapping.

Figure 15-15: Kaolinite, Alunite, and Buddingtonite MTMF mapping results
overlain on AVIRIS band 193.
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End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click OK to exit IDL. If
you are using ENVI RT, quitting ENVI will take you back to your operating system.
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376 Tutorial 16: Hyperspectral Signatures and Spectral Resolution
Overview of This Tutorial

This tutorial compares spectral resolution for several different sensors and the effect
of resolution on the ability to discriminate and identify materials with distinct
spectral signatures. The tutorial uses TM, GEOSCAN, GER63, AVIRIS, and HyMap
data from Cuprite, Nevada, USA, for intercomparison and comparison to materials
from the USGS Spectral library.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 2

Path: envidata/cup_comp
envidata/cup99hym
envidata/c95avsub

File Description

Required Files (envidata/cup_comp)

usgs_em.sli Subset of USGS Spectral Library

usgs_em.hdr ENVI Header for Above

cuptm_rf.img Cuprite TM reflectance subset

cuptm_rf.hdr ENVI Header for Above

cuptm_em.txt Kaolinite and Alunite average spectra from above

cupgs_sb.img Cuprite Geoscan Reflectance Image Subset

cupgs_sb.hdr ENVI Header for above

cupgs_em.txt Kaolinite and Alunite average spectra from above

cupgersb.img Cuprite GER64 Reflectance Image Subset

cupgersb.hdr ENVI Header for above

cupgerem.txt Kaolinite and Alunite average spectra from above

Required Files (envidata/cup99hym)

cup99hy.eff Cuprite 1999 HyMap EFFORT Data

cup99hy.hdr ENVI Header for above
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Note
The files listed, along with their associated .hdr files, are required to run this
exercise. Optional spectral library files listed below may also be used if more
detailed comparisons are desired. Selected data files have been converted to integer
format by multiplying the reflectance values by 1000 because of disk space
considerations. Values of 1000 in the files represent reflectance values of 1.0.

Background

Spectral resolution determines the way we see individual spectral features in
materials measured using imaging spectrometry. Many people confuse the terms
spectral resolution with spectral sampling. These are very different. Spectral
resolution refers to the width of an instrument response (band-pass) at half of the
band depth (the Full Width Half Max [FWHM]). Spectral sampling usually refers to
the band spacing - the quantization of the spectrum at discrete steps - and may be
very different from the spectral resolution. Quality spectrometers are usually
designed so that the band spacing is about equal to the band FWHM, which is why
band spacing is often thought of as equal to spectral resolution. These are two
different things, however, so be careful in the use of terms.

cup99hy_em.txt Kaolinite and Alunite average spectra from above

Required Files (envidata/c95avsub)

cup95eff.int Cuprite 1995 AVIRIS Reflectance Image Subset (in
the c95avsub directory)

cup95eff.hdr ENVI Header from above (in the c95avsub directory)

cup95eff.txt Kaolinite and Alunite average spectra from above in
the c95avsub directory

Optional Files (envidata/c95avsub)

usgs_sli.dat USGS Spectral Library

usgs_sli.hdr ENVI Header for Above

File Description
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This exercise compares the effect of the spectral resolution of different sensors on the
spectral signatures of minerals.

Spectral Modeling and Resolution

Spectral modeling shows that spectral resolution requirements for imaging
spectrometers depend upon the character of the material being measured. For
example, for the mineral kaolinite, shown in the plot below, we are still able to
distinguish the characteristic doublet near 2.2 µm at 20 nm resolution. Even at 40 nm
resolution, the asymmetrical shape of the band may be enough to identify the
mineral, even though the spectral features have not been fully resolved.

The spectral resolution required for a specific sensor is a direct function of the
material you are trying to identify, and the contrast between that material and the
background materials. The following figure shows modeled spectra for the mineral
kaolinite for several different sensors.

Figure 16-1: Modeled effect of spectral resolution on the appearance of spectral
features of kaolinite. Spectral resolution from top to bottom: 5, 10, 20, 40, and 80

nm resolution
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Figure 16-2: Modeled signatures of different hyperspectral sensors for the
mineral kaolinite. From Swayze, 1997.
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Figure 16-3: Alteration map for Cuprite, Nevada.
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Case History: Cuprite, Nevada, USA

This example is provided to illustrate the effects of spatial and spectral resolution on
information extraction from multispectral/hyperspectral data. Several images of the
Cuprite, Nevada, USA, area acquired with a variety of spectral and spatial resolutions
serve as the basis for discussions on the effect of these parameters on mineralogic
mapping using remote sensing techniques. These images have not been
georeferenced, but image subsets covering approximately the same spatial areas are
shown. Cuprite has been used extensively as a test site for remote sensing instrument
validation (Abrams et al., 1978; Kahle and Goetz, 1983; Kruse et al., 1990; Hook et
al., 1991). A generalized alteration map is provided for comparison with the images.
Examples from Landsat TM, GEOSCAN MkII, GER63, HyMap and AVIRIS
illustrate both spatial and spectral aspects.

All of these data sets have been calibrated to reflectance. Only three of the numerous
materials present at the Cuprite site were used for the purposes of this comparison.
Average kaolinite, alunite, and buddingtonite image spectra were selected from
known occurrences at Cuprite. Laboratory spectra from the USGS Spectral Library
(Clark et al., 1990) of the three selected minerals are provided for comparison to the
image spectra. The following is a synopsis of selected instrument characteristics and
a discussion of the images and spectra obtained with each sensor

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the Installing and Licensing ENVI manual.

• To start ENVI for UNIX, enter envi at the UNIX command line.

• To start ENVI for Windows or Macintosh, double-click on the ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

Open a Spectral Library File

To open a spectral library:

1. Select Spectral → Spectral Libraries → Spectral Library Viewer. Click
the Open Spec Lib button to display the file selection dialog.

2. Navigate to the cup_comp subdirectory of the envidata directory on the
ENVI Tutorial and Data CD No. 2 and select the file usgs_em.sli from the
list and on Windows and Macintosh click Open and on UNIX click OK.
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382 Tutorial 16: Hyperspectral Signatures and Spectral Resolution
3. Double-click the usgs_em.sli file in the Select Input File section of the
Spectral Library Input File dialog. The Spectral Library Viewer dialog
displays with four laboratory spectra for the Cuprite site listed.

View Library Spectra

This step uses library Spectra (approximately 10 nm Spectral Resolution) from the
USGS Spectral Library.

1. Plot each of the four spectra from the spectral library in an ENVI spectral plot
by clicking on the spectrum name in the Spectral Library Viewer window.

2. Examine the detail available in the library spectral plots paying special
attention to the absorption feature positions, depths, and shapes near 2.2 - 2.4
µm. You may want to select Edit → Plot Parameters and change the X-Axis
range to 2.0 - 2.5 µm to accomplish this comparison or click and drag a box
outlining the desired subset using the middle mouse button.

3. Place this plot window to one side of the screen for use with data from the
hyperspectral sensors.

View Landsat TM Image and Spectra

This dataset is Landsat Thematic Mapper data with spatial resolution of 30 meters
and spectral resolution of up to 100nm. The Cuprite TM data were acquired on 4
October 1984 and are in the public domain.
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The figure below (Figure 16-5) is a plot of the Region of Interest (ROI) average
spectra for the three materials shown in the library spectra above (Figure 16-4). The
small squares indicate the TM band 7 (2.21 µm) center point. The lines indicate the
slope from TM band 5 (1.65 µm). Note the similarity of all of the “spectra” and how
it is not possible to discriminate between the three endmembers.

Figure 16-4: Laboratory measurements for the minerals kaolinite, alunite, and
buddingtonite measured on the USGS Denver Beckman Spectrometer.
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1. Select File → Open Image File from the ENVI main menu, navigate to the
cup_comp directory, and open the file cuptm_rf.img.

This is the Landsat TM reflectance data for Cuprite, Nevada, produced using
ENVI’s Landsat TM calibration Utility.

2. Load TM band 3 as a grayscale image in a new image display by choosing the
Gray Scale radio button in the Available Bands List dialog, clicking on Band
3, clicking “New Display” on the Display pulldown button, and then click
Load Band.

3. Start a Z-Profile by selecting Tools → Profiles → Z-Profile in the Main
Image Display window and use to examine apparent reflectance spectra.

4. Start a new plot window from the Window → Start New Plot Window option
in the ENVI main menu and load the ASCII file cuptm_em.txt. Compare the

Figure 16-5: Landsat TM Measurements for TM Band 7.
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two spectra to the library spectra in the Spectral Library Viewer. Drag and drop
spectra from the Spectral Library Viewer plot window into this new plot
window by clicking the right mouse button in the plot to toggle on the spectra
names, then clicking and dragging using the left mouse button on the
beginning of the spectrum name and releasing the left mouse button when the
spectrum name appears in the second plot window.

5. Select Tools → Pixel Locator and use the Pixel Locator to locate and browse
around the location of the Kaolinite (248, 351) and the Alunite (260, 330) and
examine the spectral variability. Examine spectra near 202, 295
(Buddingtonite) and near 251, 297 (Silica or Opal) and compare to the library
spectra. Drag-and-drop spectra for best comparison. Answer questions
pertaining to the TM data in “Draw Conclusions” on page 395.

6. Place this plot window to one side of the screen for comparison with data from
the other sensors.

View GEOSCAN Data

This dataset is Cuprite GEOSCAN imagery with approximately 60 nm Resolution
with 44 nm sampling converted to apparent reflectance using a flat field correction.
The GEOSCAN MkII sensor, flown on a light aircraft during the late 1980s was a
commercial aircraft system that acquired up to 24 spectral channels selected from 46
available bands. GEOSCAN covered the range from 0.45 to 12.0 µm using grating
dispersive optics and three sets of linear array detectors (Lyon and Honey, 1989). A
typical data acquisition for geology resulted in 10 bands in the visible/near infrared
(VNIR, 0.52 - 0.96 µm), 8 bands in the shortwave infrared (SWIR, 2.04 - 2.35 µm),
and thermal infrared (TIR, 8.64 - 11.28 µm) regions (Lyon and Honey, 1990). The
GEOSCAN data were acquired in June 1989. The figure below (Figure 16-6) is a plot
of the ROI average spectra for the three materials shown in the library spectral plot
above. Compare these to library spectra and the Landsat TM spectra and note that the
three minerals appear quite different in the GEOSCAN data, even with the relatively
widely spaced spectral bands.
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Figure 16-6: Geoscan SWIR spectra.
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GEOSCAN is high spatial resolution makes it suitable for detailed geologic mapping
(Hook et al., 1991). The relatively low number of spectral bands and, low spectral
resolution limit mineralogic mapping capabilities to a few groups of minerals in the
absence of ground information. Strategic placement of the SWIR bands, however,
does provide more mineralogic information than would intuitively be expected based
on the spectral resolution limitations.

1. Select File → Open Image File from the ENVI main menu and open the
Cuprite GEOSCAN data cupgs_sb.img.

2. Click on the Gray Scale radio button in the Available Bands List, Band 15 in
the list, and then click Load Band to display the image.

3. Start a Z-Profile by selecting Tools → Profiles → Z-Profile in the Main
Image Display window and use to browse through some of the apparent
reflectance spectra.

4. Load a color composite image of bands 13, 15, and 18 (RGB) to enhance
mineralogical differences.

5. Start a new plot window from the Window → Start New Plot Window menu
and load the ASCII file cupgs_em.txt. Compare the two spectra to the
library spectra in the Spectral Library Viewer, and to the spectra from the
other sensors. Drag and drop spectra as described above for direct comparison.

6. Select Tools → Pixel Locator and use the Pixel Locator to locate and browse
around the location of the Kaolinite (275, 761) and the Alunite (435, 551) and
examine the spectral variability. Examine spectra near 168, 475
(Buddingtonite) and near 371, 592 (Silica or Opal) and compare to the library
spectra and spectra from the other sensors. Answer questions pertaining to the
GEOSCAN data in “Draw Conclusions” on page 395.

7. Place this plot window to one side of the screen for comparison with data from
the other sensors.

View GER63 Data

This dataset is Cuprite Geophysical and Environmental Research 63-band scanner
data (GER63). It has an advertised spectral resolution of 17.5 nm, but comparison
with other sensors and laboratory spectra suggests that 35 nm resolution with 17.5 nm
sampling is more likely. Four bad bands have been dropped so that only 59 spectral
bands are available. The GER63 data described here were acquired during August
1987. Selected analysis results were previously published in Kruse et al. (1990). The
figure below (Figure 16-7) is a plot of the ROI average spectra for the three materials
shown in the library spectra above. Note that the GER63 data adequately discriminate
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the alunite and buddingtonite, but do not fully resolve the kaolinite “doublet” near 2.2
µm shown in the laboratory.

1. Select File → Open Image File from the ENVI main menu and open the
Cuprite GER64 data cupgersb.img.

2. Click on the Gray Scale radio button in the Available Bands List, Band 42 in
the list, and then click Load Band to display the image.

3. Start a Z-Profile by selecting Tools → Profiles → Z-Profile in the Main
Image Display window and use to browse through some of the apparent
reflectance spectra.

4. Load a color composite image of bands 36, 42, and 50 (RGB) to enhance
mineralogical differences.

Figure 16-7: GER-63 SWIR spectra.
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5. Start a new plot window from the Window → Start New Plot Window menu
and load the ASCII file cupgerem.txt. Compare the two spectra to the
library spectra in the Spectral Library Viewer, and to the spectra from the
other sensors. Drag and drop spectra as described above for direct comparison.

6. Select Tools → Pixel Locator. Use the Pixel Locator to locate and browse
around the location of the Kaolinite (235, 322) and the Alunite (303, 240) and
examine the spectral variability. Examine spectra near 185, 233
(Buddingtonite) and near 289, 253 (Silica or Opal) and compare to the library
spectra and spectra from the other sensors. Drag-and-drop spectra for best
comparison. Answer questions pertaining to the GER63 data in “Draw
Conclusions” on page 395.

7. Place this plot window to one side of the screen for comparison with data from
the other sensors.

View HyMap Data

HyMap is a state-of-the-art aircraft-mounted commercial hyperspectral sensor
developed by Integrated Spectronics, Sydney, Australia, and operated by HyVista
Corporation. HyMap provides unprecedented spatial, spectral and radiometric
excellence (Cocks et al., 1998). The system is a whiskbroom scanner utilizing
diffraction gratings and four 32-element detector arrays (1 Si, 3 liquid-nitrogen-
cooled InSb) to provide 126 spectral channels covering the 0.44 - 2.5 µm range over
a 512-pixel swath. Spectral resolution varies from 10 - 20 nm with 3-10m spatial
resolution and SNR over 1000:1. The HyMap data described here were acquired on
September 11, 1999. Selected analysis results were have been published in Kruse et
al. (1999). The figure below (Figure 16-8) is a plot of the ROI average spectra for the
three materials shown in the library spectra above (Figure 16-4).

1. Select File → Open Image File from the ENVI main menu, navigate to the
cup99hym directory, and open the file cup99hy.eff.

This is the HyMap reflectance data for Cuprite, Nevada, produced by running
calibrated radiance data through the ATREM atmospheric correction followed
by EFFORT polishing (Kruse et al., 1999). The data is rotated 180 degrees
from north (north is towards the bottom of the image).

2. Load HyMap band 109 as a grayscale image in a new image display by
choosing the Gray Scale radio button in the Available Bands List, clicking on
the band name, clicking New Display in the pulldown Display menu, and then
clicking Load Band.

3. Start a Z-Profile by selecting Tools → Profiles → Z-Profile in the Main
Image Display window and use to examine apparent reflectance spectra.
ENVI Tutorials Case History: Cuprite, Nevada, USA



390 Tutorial 16: Hyperspectral Signatures and Spectral Resolution
4. Start a new plot window from the Window → Start New Plot Window menu
and load the ASCII file cup99hy_em.txt. Compare the two spectra to the
library spectra in the Spectral Library Viewer. Drag and drop spectra from the
Spectral Library Viewer plot window into this new plot window by clicking
the right mouse button in the plot to toggle on the spectra names, then clicking
and dragging using the left mouse button on the beginning of the spectrum
name and releasing the left mouse button when the spectrum name appears in
the second plot window.

5. Load a color composite image of bands 104, 109, 117 (RGB) to enhance
mineralogical differences.

6. Select Tools → Pixel Locator and use the Pixel Locator to locate and browse
around the location of the Kaolinite (248, 401) and the Alunite (184, 568) and
examine the spectral variability. Examine spectra near 370, 594
(Buddingtonite) and near 172, 629 (Silica or Opal) and compare to the library
spectra. Drag-and-drop spectra for best comparison. Answer questions
pertaining to the GER63 data in “Draw Conclusions” on page 395 pertaining
to the 1999 HyMap data in Figure 16-8.
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7. Place this plot window to one side of the screen for comparison with data from
the other sensors.

View AVIRIS Data

These data are Cuprite 1995 Airborne Visible Infrared Imaging Spectrometer
(AVIRIS), which have approximately 10 nm spectral resolution and 20 m spatial
resolution. The AVIRIS data shown here were acquired during July 1995 as part of
an AVIRIS Group Shoot (Kruse and Huntington, 1996). The data were corrected to
reflectance using the ATREM method and residual noise was removed using the
EFFORT procedure. The figure below (Figure 16-9) is a plot of the ROI average

Figure 16-8: HyMap SWIR spectra.
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spectra for the three materials shown in the library spectral plot. Compare these to the
laboratory spectra above and note the high quality and nearly identical signatures.

1. Select File → Open Image File and navigate to the c95avsub subdirectory
and select the file cup95eff.int from the list and click OK.

2. Display a grayscale image and then start a Z-Profile by selecting
Tools → Profiles → Z-Profile in the Main Image Display window and use to
browse through some of the apparent reflectance spectra.

3. Load a color composite image of bands 183, 193, and 207 (RGB) to enhance
mineralogical differences.

4. Start a new plot window from the Window → Start New Plot Window menu
and load the ASCII file cup95eff.txt. Compare the two spectra to the
library spectra in the Spectral Library Viewer, and to the spectra from the
other sensors. Drag and drop spectra as described above for direct comparison.

5. Select Tools → Pixel Locator. Use the Pixel Locator to locate and browse
around the location of the Kaolinite (500, 581) and the Alunite (538, 536) and
examine the spectral variability. Examine spectra near 447, 484
(Buddingtonite) and 525, 505 (Silica or Opal) and compare to the library
spectra and spectra from the other sensors. Drag-and-drop spectra for best
comparison. Answer questions pertaining to the GER63 data in “Draw
Conclusions” on page 395 pertaining to the 1995 AVIRIS data in Figure 16-9.
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Evaluate Sensor Capabilities

These four sensors and the library spectra represent a broad range of spectral
resolutions.

1. Using the Library Spectra as the ground truth, evaluate how well each of the
sensors is able to represent the ground truth information. Consider what it
means to discriminate between materials versus identification of materials.

Figure 16-9: AVIRIS SWIR spectra.
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End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click OK to exit IDL. If
you are using ENVI RT, quitting ENVI will take you back to your operating system.
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Draw Conclusions

1. Using the selected library spectra provided, what is the minimum spacing of
absorption features in the 2.0 - 2.5 µm range?

2. The TM data obviously dramatically undersample the 2.0 - 2.5 µm range, as
only TM band 7 is available. What evidence do you see for absorption features
in this range? What differences are apparent in the TM spectra of minerals
with absorption features in this range?

3. The GEOSCAN data also undersample the 2.0 - 2.5 µm range, however, the
bands are strategically placed. What differences are there between the
GEOSCAN spectra for the different minerals? Could some of the bands have
been placed differently to provide better mapping of specific minerals?

4. The GER63 data provide improved spectral resolution over the GEOSCAN
data and individual features can be observed. The advertised spectral
resolution of the GER63 between 2.0 - 2.5 µm is 17.5 nm. Examine the GER-
63 kaolinite spectrum and defend or refute this resolution specification. Do the
more closely spaced spectral bands of the GER63 sensor provide a significant
advantage over the GEOSCAN data in mapping and identifying these
reference minerals?

5. What are the main differences between mineral spectra at Cuprite caused by
the change from 10nm spectral resolution for AVIRIS to the 17nm spectral
resolution of HyMap?

6. The AVIRIS data provide the best spectral resolution of the sensors examined
here. How do the AVIRIS and laboratory spectra compare? What are the major
similarities and differences? What factors affect the comparison of the two
data types?

7. Examine all of the images and spectra. What role does spatial resolution play
in the comparison?

8. Based on the Library spectra, provide sensor spectral and spatial resolution
design specifications as well as recommendations on placement of spectral
bands for mineral mapping. Examine the trade-offs between continuous high-
spectral resolution bands and strategically placed, lower resolution bands.
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Overview of This Tutorial

This tutorial presents a case history for use of hyperspectral techniques for geologic
analysis using 1999 HyMap data from Cuprite, Nevada, USA. It is designed to be a
self-directed example using ENVI’s complete end-to-end hyperspectral tools to
produce image-derived endmember spectra and image maps. The processing should
be done using the standard ENVI methods (EFFORT → MNF → PPI → n-D
Visualization → Spectral Mapping → GLT Geocorrection). For more detail and
step-by-step procedures on performing such a hyperspectral analysis, please execute
the introductory through advanced ENVI hyperspectral tutorials prior to attempting
this tutorial. 1999 HyMap data of Cuprite, Nevada, used for the tutorial are copyright
1999 Analytical Imaging and Geophysics (AIG) and HyVista Corporation (All
Rights Reserved), and may not be redistributed without explicit permission from AIG
@info.aigllc.com).

Objectives

1. To examine application of ENVI end-to-end hyperspectral processing
methodology to a geology case study.

2. To give students hands-on experience in actually running the procedures rather
than reviewing pre-calculated results (preprocessed results are provided for
comparison).

3. To provide students with guidance to perform data exploration in a loosely
structured framework.

4. To compare analysis results with known ground information.

Tasks

1. Evaluate Atmospherically Corrected (ATREM) EFFORT-corrected data.

2. Conduct Spatial/Spectral browsing to evaluate data, determine presence and
nature of spectral variability, and to select wavelength range (s) for further
analysis.

3. Reduce data dimensionality using MNF transform.

4. Select spectral endmember candidates using PPI.

5. Evaluate and select endmembers using n-D Visualizer.

6. Map endmember distribution and abundance using ENVI mapping methods.
Compare and contrast results.
Overview of This Tutorial ENVI Tutorials
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7. Reconcile image and lab spectra/ground information.

8. Optionally geocorrect the data.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 2

Path: envidata/cup99hym
envidata/c95avsub

File Description

Required Files (envidata/cup99hym)

cup99hy.eff EFFORT-corrected HyMap data

cup99hy.hdr ENVI Header for above

cup99hy_geo_glt ENVI Geometry Lookup file

cup99hy_geo_glt.hdr ENVI Header for above

cup99hy_geo_igm ENVI Input Geometry file

cup99hy_geo_igm.hdr ENVI Header for above

cup99hy_mnf MNF results of 32 SWIR bands, using data to
estimate noise covariance

cup99hy_mnf.hdr ENVI Header for above

cup99hy_mnf.sta MNF stats from MNF run

cup99hy_mnfevs.txt ASCII file of MNF Eigenvalues

cup99hy_mtmf MTMF results using endmembers from mtmf.roi
mean

cup99hy_mtmf.hdr ENVI Header for above

cup99hy_mtmf.roi ROIs of classes picked in n-d visualizer

cup99hy_mtmfems.txt ASCII file of MTMF endmember spectra

cup99hy_noi.sta Noise statistics from MNF run

cup99hy_ppi PPI image

cup99hy_ppi.hdr ENVI Header for above
ENVI Tutorials Overview of This Tutorial
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Note
The files listed are required to run this exercise. Miscellaneous files listed below
provide additional information that may be useful. Selected data files have been
converted to integer format by multiplying the reflectance values by 1000 because
of disk space considerations. Values of 1000 in the files represent reflectance values
of 1.0.

Cuprite Background Materials

The Cuprite site has been used as a remote sensing test site by JPL and others since
the early 1980s. A generalized alteration map is provided in Tutorial 16,
“Hyperspectral Signatures and Spectral Resolution” ENVI tutorial for comparison
with processing results derived during this analysis. AVIRIS Standard Datasets are
available from JPL for 1992-2000.

cup99hy_ppi.cnt PPI count file

cup99hy_true.img True-Color Image

cup99hy_true.hdr ENVI Header for above

Required Files (envidata/c95avsub)

usgs_sli.dat USGS Spectral Library

usgs_sli.hdr ENVI Header for above

File Description
Overview of This Tutorial ENVI Tutorials
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HyMap Processing Flow

The Figure 17-1 illustrates an approach for analysis of hyperspectral data that is
implemented with ENVI.

The following outlines in general terms the implementation of this approach. The
student is expected to follow the procedures below, referring to previous tutorials and
the ENVI User’s Guide for guidance in performing specific tasks where required. The
purpose of this tutorial isn’t to teach you how to run the ENVI tools, but how to apply
the methodology and tools to a general hyperspectral remote sensing problem.

Figure 17-1: End-to-End Hyperspectral Processing with ENVI.
ENVI Tutorials HyMap Processing Flow
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Geologic Hyperspectral Analysis

1. Examine HyMap EFFORT apparent reflectance data: Load a gray scale and/or
color composite images. Start a spectral profile and examine spectra for
residual atmospheric absorption features (CO2 bands near 2.0 micrometers).

2. Conduct spatial/spectral browsing. Display a gray scale image. Extract
reflectance signatures and examine for mineral spectral features. Animate the
data and extract spectra for areas of high variability. Determine bad spectral
bands. Load color composite images designed to enhance spectral contrast.
Determine spectral subset(s) to use for mineral mapping. Extract reflectance
signatures for vegetation and geologic materials. Compare to spectral libraries.

3. Apply MNF Transform to the EFFORT data to find the data’s inherent
dimensionality. Review MNF eigenvalue plot to determine break-in-slope and
relate to spatial coherency in MNF eigenimages. Determine MNF cut-off
between signal and noise for further analysis.

Make your own MNF-Transformed dataset or review the results in the files
below:

File Description

cup99hy.eff EFFORT-corrected HyMap data

cup99hy.hdr ENVI Header for above

File Description

cup99hy.eff EFFORT-corrected HyMap data

cup99hy.hdr ENVI Header for above

File Description

cup99hy_mnf.sta MNF stats from MNF run

cup99hy_ppi PPI image

cup99hy_ppi.hdr ENVI Header for above

cup99hy_ppi.cnt PPI count file

cup99hy_mtmf.roi ROIs of classes picked in n-D visualizer
Geologic Hyperspectral Analysis ENVI Tutorials
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4. Apply PPI Analysis to the MNF output to rank the pixels based on relative
purity and spectral extremity. Use the FAST PPI option to perform
calculations quickly in system memory, creating the PPI image. Display the
PPI image, examine the histogram, and threshold to create a list of the purest
pixels, spatially compressing the data.

Generate your own PPI results and ROIs or review the results in the files
below:

5. Perform n-Dimensional Visualization of the high PPI value pixels, using the
high signal MNF data bands to cluster the purest pixels into image-derived
endmembers. Rotate the MNF data interactively in 3-D, or spin in 3-or-more
dimensions and paint pixels that occur on the points (extremities) of the
scatterplot. Use Z-Profiles connected to the EFFORT apparent reflectance data
and the n-D Visualizer to evaluate spectral classes. Use class collapsing to
iteratively find all of the endmembers. Evaluate mixing and endmembers. Save
your n-D results to a save state file (.ndv). Export classes to ROIs and extract
mean spectra. Compare mean spectra to spectral libraries. Use spectral/spatial
browsing to compare image spectra to ROI means.

Extract endmembers and make your own ROIs or review the results below:

cup99hy_mtmfems.
txt

ASCII file of MTMF endmember spectra

File Description

cup99hy_ppi PPI image

cup99hy_ppi.hdr ENVI Header for above

cup99hy_ppi.cnt PPI count file

File Description

cup99hy_mnf MNF results of 32 SWIR bands, using
data to estimate noise covariance

cup99hy_mnf.hdr ENVI Header for above

cup99hy_mnf.sta MNF stats from MNF run

cup99hy_ppi PPI image

File Description
ENVI Tutorials Geologic Hyperspectral Analysis
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6. Use ENVI’s wide variety of mapping methods to map the spatial occurrence
and abundance of materials at Cuprite. As a minimum, try the Spectral Angle
Mapper (SAM) and MTMF. Use SAM to determine spectral similarity to
image endmember spectra. If time and space permit, try a SAM classification
using one of the Spectral Libraries. Be sure to evaluate the Rule Images. Use
the MTMF mapping method to determine material abundance. Be sure to use
both the MF and Infeasibility images in a 2-D scatterplot to select the best
matches (high MF and low Infeasibility Score). Compare abundance image
results to the endmember spectra and spectral libraries using spatial/spectral
browsing.

Use the provided GLT and/or IGM files to produce geocorrected output images of the
MTMF processing. Follow the procedures described in Tutorial 5, “Georeferencing
Images Using Input Geometry” ENVI tutorial “Georeferencing Images Using Input

cup99hy_ppi.hdr ENVI Header for above

cup99hy_ppi.cnt PPI count file

cup99hy_mtmf.roi ROIs of classes picked in n-D visualizer

cup99hy_mtmfems.txt ASCII file of MTMF endmember
spectra

File Description

cup99hy_mnf MNF results of 32 SWIR bands, using
data to estimate noise covariance

cup99hy_mnf.hdr ENVI Header for above

cup99hy_mnf.sta MNF stats from MNF run

cup99hy_mtmf MTMF results using endmembers
fromtmf.roi mean

cup99hy_mtmf.hdr ENVI Header for above

cup99hy_mtmf.roi ROIs of classes picked in n-D visualizer

cup99hy_mtmfems.txt ASCII file of MTMF endmember
spectra

File Description
Geologic Hyperspectral Analysis ENVI Tutorials
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Geometry” to geocorrect mineral maps. Add map grids and annotation and produce a
final map produce.

End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click OK to exit IDL. If
you are using ENVI RT, quitting ENVI will take you back to your operating system.

Figure 17-2: Selected endmember spectra and portion of geocorrected image-
map result for Cuprite, Nevada 1999 HyMap data.
ENVI Tutorials Geologic Hyperspectral Analysis
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Overview of This Tutorial

This tutorial presents a case history for use of hyperspectral techniques for
archeological analysis using MIVIS data from Selinunte, Sicily, Italy. It is designed
to be a self-directed example using ENVI’s complete end-to-end hyperspectral tools
to produce image-derived endmember spectra and image maps. The processing
should be done using the standard ENVI methods (EFFORT → MNF → PPI → n-
D Visualization → Spectral Mapping). For more detail and step-by-step procedures
on performing such a hyperspectral analysis, please execute the introductory through
advanced ENVI hyperspectral tutorials prior to attempting this tutorial. The MIVIS
data are courtesy of Research Systems Italia, S.R.L. and the Italian National Research
Council (CNR). Used with permission.

Objectives

1. To examine application of ENVI end-to-end hyperspectral processing
methodology to an archaeology case study.

2. To give students hands-on experience in actually running the procedures rather
than reviewing pre-calculated results (preprocessed results are provided for
comparison).

3. To provide students with guidance to perform data exploration in a loosely
structured framework.

4. To compare analysis results with known ground information.

Tasks

1. Evaluate Radiance Data.

2. Perform empirical (Flat-Field) Atmospheric Correction.

3. Evaluate Atmospherically Corrected data.

4. Conduct Spatial/Spectral browsing to evaluate data, determine presence and
nature of spectral variability, and to select wavelength range (s) for further
analysis.

5. Reduce data dimensionality using MNF transform.

6. Select spectral endmember candidates using PPI.

7. Evaluate and select endmembers using n-D Visualizer.
Overview of This Tutorial ENVI Tutorials
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8. Map endmember distribution and abundance using ENVI mapping methods.
Compare and contrast results.

9. Reconcile image and field spectra/ground information.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/selmivis

File Description

Required Files

selinunte_rad.bil MIVIS 92 band radiance subset

selinunte_rad.hdr ENVI Header for above

selinunte.ann ENVI annotation for above

mivis_waves.txt Text Wavelength file for MIVIS

selinunte_ff.roi ROI used for Flat Field correction

Generated Files

selinunte_ff.bil MIVIS Flat Field Apparent Reflectance Data

selinunte_ff.hdr ENVI Header for above

selinunte_mnf.bil MNF for 91 MIVIS bands

selinunte_mnf.hdr ENVI Header for above

selinunte_mnf.txt ASCII file of MNF Eigenvalues

selinunte_mnf.sta MNF Statistics

selinunte_ns.sta Noise Statistics

selinunte_ppi.img Pixel Purity Index Image

selinunte_ppi.hdr ENVI Header for above

selinunte_ppi.cnt PPI count file

selinunte_ppi.roi Thresholded PPI ROI

selinunte_ppi.ndv Saved n-D Visualizer state
ENVI Tutorials Overview of This Tutorial
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Selinunte/MIVIS Background Materials

Selinunte is an abandoned ancient Greek city with ruins of an acropolis and
numerous temples (Figure 18-1), located on the southwest coast of Sicily, Italy, in the
province of Trapani. The city was founded between 650 and 630 BC, and effectively
destroyed by the Carthaginians in 409 BC.

The city of Selinunte, the Acropolis, is situated on high ground overlooking the
Mediterranean. Selinunte is surrounded by a park (Parco Archeologico di Selinunte)
extending approximately 1,300 meters east to west. There are five temples within the
Acropolis, some of which have been excavated. Others are essentially jumbled piles
of stones. The entire Acropolis has never been completely excavated, but the
surrounding walls were mostly reconstructed by archaeologists in 1927. See
http://www.bestofsicily.com/selinunte.htm for additional information.

Daedalus AA5000 MIVIS data were flown over the Selinunte Park during 1996 with
approximately 3-meter spatial resolution. MIVIS, the Multispectral Infrared and
Visible Imaging Spectrometer, owned and operated by the Italian National Research
Council (CNR), is a 102 channel scanner with 92 bands covering the approximately
0.4 to 2.5 micrometer (VNIR-SWIR) range and 10 bands over the 8-14 micrometer
(LWIR) range. For the purposes of this tutorial, we will use 90 of the 92 VNIR-SWIR
bands (excluding bands 63 and 87 as bad bands). MIVIS data are courtesy of RSI
Italy and CNR.

selinunte_ndv.roi n-D Visualizer regions of interest

selinunte_ndvems.txt n-D Visualizer endmember

selinunte_sam.img Spectral Angle Mapper result

selinunte_sam.hdr ENVI Header for above

selinunte_mtmf.img MTMF results images

selinunte_mtmf.hdr ENVI Header for above

File Description
Overview of This Tutorial ENVI Tutorials
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Figure 18-1: Reference map and selected archaeological features annotated on
a MIVIS true-color image.
ENVI Tutorials Overview of This Tutorial
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MIVIS Processing Flow

The Figure 18-2 illustrates an approach for analysis of hyperspectral data that is
implemented with ENVI.

The following outlines in general terms the implementation of this approach. The
student is expected to follow the procedures below, referring to previous tutorials and
the ENVI User’s Guide for guidance in performing specific tasks where required. The
purpose of this tutorial isn’t to teach you how to run the ENVI tools, but how to apply
the methodology and tools to a general hyperspectral remote sensing problem

Figure 18-2: End-to-End Hyperspectral Processing with ENVI.
MIVIS Processing Flow ENVI Tutorials
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Hyperspectral Techniques for Archeological
Analysis

1. Examine MIVIS radiance data: Load selected MIVIS bands as gray scale
images. Perform animation. Extract radiance signatures for areas of high
variability. Examine radiance spectra for evidence of absorption features.
Determine bad spectral bands. Load color composite images designed to
enhance spectral contrast. Determine spectral subset(s) to use for materials
mapping.

2. Correct MIVIS data to apparent reflectance using the Flat Field method. Use
the file selinunte_ff.roi as the Region of Interest for the flat field.
(Generate the output file selinunte_ff.bil). Examine MIVIS apparent
reflectance data: Load gray scale images. Perform animation. Extract
reflectance signatures for areas of high variability. Examine reflectance spectra
for evidence of absorption features. Determine bad spectral bands. Load color
composite images designed to enhance spectral contrast. Determine spectral
subset(s) to use for mineral mapping. Extract reflectance signatures for
vegetation and geologic materials. Compare to spectral libraries.

3. Apply MNF Transform to a spectral subset of the apparent reflectance data to
find the data’s inherent dimensionality (Generate the output file
selinunte_mnf.bil). Review MNF eigenvalue plot(s) to determine break-
in-slope and relate to spatial coherency in MNF eigenimages. Determine MNF
cut-off between “signal” and “noise” for further analysis.

File Description

selinunte_rad.bil MIVIS 92 band radiance subset

selinunte_rad.hdr ENVI Header for above

mivis_waves.txt Text Wavelength file for MIVIS

File Description

selinunte_ff.roi ROI used for Flat Field correction

selinunte_ff.bil User Generated MIVIS Flat Field
Apparent Reflectance Data

selinunte_ff.hdr ENVI Header for above
ENVI Tutorials Hyperspectral Techniques for Archeological Analysis
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Make your own MNF-Transformed dataset using the file naming convention
below:

4. Apply PPI Analysis to the MNF output to rank the pixels based on relative
purity and spectral extremity. Use the FAST PPI option to perform
calculations quickly in system memory, creating the PPI image. Display the
PPI image, examine the histogram, and threshold to create a list of the purest
pixels, spatially compressing the data.

Generate your own PPI results using the file naming convention below:

5. Perform n-Dimensional Visualization of the high PPI value pixels, using the
high signal MNF data bands to cluster the purest pixels into image-derived
endmembers. Rotate the MNF data interactively in 3-D, or spin in 3-or-more
dimensions and “paint” pixels that occur on the points (extremities) of the
scatterplot. Use Z-Profiles connected to the apparent reflectance data and the
n-D Visualizer to evaluate spectral classes. Use class collapsing to iteratively
find all of the endmembers. Evaluate mixing and endmembers. Save your n-D
results to a save state file (.ndv). Export classes to ROIs and extract mean
spectra. Compare mean spectra to spectral libraries. Use spectral/spatial
browsing to compare image spectra to ROI means.

File Description

selinunte_mnf.bil MNF for 90 MIVIS bands

selinunte_mnf.hdr ENVI Header for above

selinunte_mnf.txt ASCII file of MNF Eigenvalues

selinunte_mnf.sta MNF Statistics

selinunte_ns.sta Noise Statistics

File Description

selinunte_ppi.img Pixel Purity Index Image

selinunte_ppi.hdr ENVI Header for above

selinunte_ppi.cnt PPI count file

selinunte_ppi.roi Thresholded PPI ROI
Hyperspectral Techniques for Archeological Analysis ENVI Tutorials



Tutorial 18: Archaeology Hyperspectral Analysis Case History 417
Extract endmembers and make your own ROI results using the file naming
convention below:

6. Use ENVI’s wide variety of mapping methods to map the spatial occurrence
and abundance of materials at Selinunte. Hint: the temples and portions of the
Acropolis are built of Calcarenite and/or Limestone, which have distinct
spectral signatures (See Figure 18-3).

As a minimum, try the Spectral Angle Mapper (SAM) and MTMF. Use SAM
to determine spectral similarity of image pixels to image endmember spectra.
If time and space permit, try a SAM classification using one of the Spectral
Libraries. Be sure to evaluate the Rule Images. Use the MTMF mapping
method to determine material abundances. Be sure to use both the MF and
Infeasibility images in a 2-D scatter plot to select the best matches (high MF
and low Infeasibility Score). Compare abundance image results to the
endmember spectra and spectral libraries using spatial/spectral browsing.

File Description

selinunte_ppi.ndv Saved n-D Visualizer state

selinunte_ndv.roi n-D Visualizer regions of interest

selinunte_ndvems.txt n-D Visualizer endmember

Figure 18-3: MIVIS Flat Field apparent reflectance spectrum from “Temple E”,
compared to a library spectrum of Calcite (Limestone).
ENVI Tutorials Hyperspectral Techniques for Archeological Analysis
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Generate your own mapping results using the naming convention below:

End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click OK to exit IDL. If
you are using ENVI RT, quitting ENVI will take you back to your operating system.

File Description

selinunte_sam.img Spectral Angle Mapper result

selinunte_sam.hdr ENVI Header for above

selinunte_mtmf.img MTMF results images

selinunte_mtmf.hdr ENVI Header for above
Hyperspectral Techniques for Archeological Analysis ENVI Tutorials
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Overview of This Tutorial

This tutorial presents a case history for use of hyperspectral techniques for vegetation
analysis using 1999 HyMap data of Jasper Ridge, California, USA. It is designed to
be a self-directed example using ENVI’s complete end-to-end hyperspectral tools to
produce image-derived endmember spectra and image maps. For more detail and
step-by-step procedures on performing such a hyperspectral analysis, please execute
the detailed hyperspectral tutorials in this booklet prior to attempting this tutorial.
1999 HyMap data of Jasper Ridge, California, used for the tutorial are copyright
1999 Analytical Imaging and Geophysics (AIG) and HyVista Corporation (All
Rights Reserved), and may not be redistributed without explicit permission from AIG
(info@aigllc.com).

Objectives

1. To examine application of ENVI end-to-end hyperspectral processing
methodology to a vegetation case study.

2. To give students hands-on experience in actually running the procedures rather
than reviewing pre-calculated results (preprocessed results are provided for
comparison).

3. To provide students with guidance to perform data exploration in a loosely
structured framework.

4. To compare analysis results with known ground information.

Tasks

1. Examine HyMap radiance data and evaluate data characteristics and quality.

2. Evaluate Atmospherically Corrected (ATREM), EFFORT-corrected HyMap
data and compare to radiance data.

3. Conduct Spatial/Spectral browsing to evaluate data, determine presence and
nature of spectral variability, and to select wavelength range (s) for further
analysis.

4. Reduce data dimensionality using MNF transform

5. Select spectral endmember candidates using PPI.

6. Evaluate linearity and select endmembers using n-D Visualizer.

7. Map endmember distribution and abundance using ENVI mapping methods.
Compare and contrast results.
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8. Reconcile image and field spectra/ground information.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/spec_lib/veg_lib
envidata/spec_lib/usgs_min
envidata/jsp99hym

File Description

Required Files (envidata/spec_lib/veg_lib)

usgs_veg.sli USGS Vegetation Spectral Library

usgs_veg.hdr ENVI Header for Above

veg_2grn.sli Jasper Ridge, Spectral Library

veg_2grn.hdr ENVI Header for Above

Required Files (envidata/spec_lib/usgs_min)

usgs_min.sli USGS Mineral Spectral Library

usgs_min.hdr ENVI Header for Above

Required Files (envidata/jsp99hym)

jsp99hym_rad.bil HyMap Radiance, VNIR (60 bands)

jsp99hym_rad.hdr ENVI Header for Above

jsp99hym.eff HyMap ATREM with EFFORT Correction Applied

jsp99hym.hdr ENVI Header for Above

jsp99hym_mnf.bil VNIR MNF Transformed data (60 Bands)

jsp99hym_mnf.hdr ENVI Header for Above

jsp99hym_mnf_ns.sta VNIR MNF Noise Statistics

jsp99hym_mnf.txt ASCII file of MNF Eigenvalues

jsp99hym_ppi.img VNIR PPI image

jsp99hym_ppi.hdr ENVI Header for Above

jsp99hym_ppi.cnt PPI Count file
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Note
The files listed are required to run this exercise. Miscellaneous files listed provide
additional information that may be useful. Selected data files have been converted
to integer format by multiplying the reflectance values by 1000 because of disk
space considerations. Values of 1000 in the files represent reflectance values of 1.0.

jsp99hym_ppi.roi ENVI PPI ROI file for use with n-D Visualizer

jsp99hym_ppi.ndv n-D Visualizer Save State from PPI

jsp99hym_ndv_em.roi VNIR ROI File of n-D Visualizer Endmember
locations

jsp99hym_ndv_em.txt VNIR ASCII File of Endmember Spectra

jsp99hym_sam.img VNIR SAM Classes

jsp99hym_sam.hdr ENVI Header for Above

jsp99hym_rul.img VNIR SAM Rules

jsp99hym_rul.hdr ENVI Header for Above

jsp99hym_glt.img Geometry Lookup file for HyMap geocorrection

jsp99hym_glt.hdr ENVI Header for Above

copyright.txt HyMap Copyright Statement

File Description
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Jasper Ridge Background Materials

Jasper Ridge Biological Preserve is a 1200 acre natural area owned by Stanford
University. For additional information on the site, please see the Jasper Ridge
homepage at http://jasper1.stanford.edu/.

The Jasper Ridge site has been used as a remote sensing test site by JPL and others
since the early 1980s. AVIRIS standard datasets are available from JPL for the years
of 1992-98. Detailed maps and ground spectra have been published and are available
from Standford University (see below). This remote sensing test site has been used by
JPL and others since early 1980s.

Figure 19-1: Jasper Ridge Homepage Banner. (Copyright 2000, Jasper Ridge
Biological Preserve, Used With Permission)

Figure 19-2: Jasper Ridge - Portion of USGS Digital Orthophoto Quad.
Copyright 1997, Center for Conservation Biology and JRPB, Stanford University

(Used with Permission).
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Figure 19-3: Jasper Ridge Trail Map and Shaded Relief Map. Copyright 1996,
Center for Conservation Biology and JRPB, Stanford University (Used with

Permission).

Figure 19-4: Jasper Ridge Vegetation Map. Copyright 1996, Center for
Conservation Biology and JRPB, Stanford University (Used with Permission).
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HyMap Processing Flow

Figure 19-5 illustrates an approach for analysis of hyperspectral data that is
implemented with ENVI.

The following procedures outline, in general terms, the implementation of this
approach. The student is expected to follow the procedures, referring to previous
tutorials and the ENVI User’s Guide for guidance in performing specific tasks where
required. The purpose of this tutorial isn’t to teach you how to run the ENVI tools,
but how to apply the methodology and tools to a general hyperspectral remote
sensing problem.

Figure 19-5: End-to-End Hyperspectral Processing with ENVI.
ENVI Tutorials HyMap Processing Flow
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Vegetation Hyperspectral Analysis

1. Examine the Jasper Ridge HyMap radiance data: Load HyMap data as gray
scale images. Perform animation. Extract radiance signatures for areas of high
variability. Examine radiance spectra for evidence of absorption features.
Determine bad spectral bands. Load color composite images designed to
enhance spectral contrast. Determine spectral subset(s) to use for materials
mapping for vegetation and/or minerals.

File Description

jsp99hym_rad.bil HyMap Radiance, VNIR (60 bands)

Figure 19-6: Jasper Ridge HyMap False Color Infrared Composite Image.
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2. Evaluate ATREM Correction (with EFFORT) applied to the HyMap spectral
radiance to remove the bulk of the solar and atmospheric effects, transforming
the data from radiance to apparent surface reflectance. Examine the data using
spectral/spatial browsing and color composites to characterize spectral
variability and determine residual errors. Extract reflectance signatures for
vegetation and geologic materials. Compare to spectral libraries.

3. Apply MNF Transform to the EFFORT data to find the data’s inherent
dimensionality. Review MNF eigenvalue images to determine break-in-slope
and relate to spatial coherency in MNF eigenimages. Determine MNF cut-off
between “signal” and “noise” for further analysis.

Make your own MNF-Transformed dataset or review the results in the files
below:

4. Apply PPI Analysis to the MNF output to rank the pixels based on relative
purity and spectral extremity. Use the FAST PPI option to perform
calculations quickly in system memory, creating the PPI image. Display the
PPI image, examine the histogram, and threshold to create a list of the purest
pixels, spatially compressing the data.

File Description

jsp99hym.eff HyMap ATREM with EFFORT Correction
Applied

jsp99hym.hdr ENVI Header for Above

usgs_veg.sli Vegetation Spectral Library

usgs_min.sli Mineral Spectral Library

veg_2grn.sl Jasper Ridge, Spectral Library

veg_2grn.hdr ENVI Header for Above

File Description

jsp99hym_mnf.bil VNIR MNF Transformed data (60
Bands)

jsp99hym_mnf.hdr ENVI Header for Above

jsp99hym_mnf.txt ASCII file of MNF Eigenvalues

jsp99hym_mnf_ns.sta VNIR MNF Noise Statistics
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Generate your own PPI results and ROIs or review the results in the files
below:

5. Perform n-Dimensional Visualization of the high PPI value pixels, using the
high signal MNF data bands to cluster the purest pixels into image-derived
endmembers. Rotate the MNF data interactively in 3-D, or spin in 3-or-more
dimensions and “paint” pixels that occur on the “points” (extremities) of the
scatterplot. Use Z-Profiles connected to the EFFORT apparent reflectance data
and the n-D Visualizer to evaluate spectral classes. Use class collapsing to

File Description

jsp99hym_ppi.img VNIR PPI image

jsp99hym_ppi.hdr ENVI Header for Above

jsp99hym_ppi.cnt PPI Count file

jsp99hym_ppi.roi ENVI PPI ROI file for use with n-D
Visualizer

Figure 19-7: Jasper Ridge HyMap MNF Bands 1, 2, 3 as RGB image (left) and
Jasper Ridge PPI image (right).
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iteratively find all of the endmembers. Evaluate the linearity of vegetation
mixing and endmembers. Save your n-D results to a save state file (.ndv).
Export classes to ROIs and extract mean spectra. Compare mean spectra to
spectral libraries. Use spectral/spatial browsing to compare image spectra to
ROI means.

Extract endmembers and make your own ROIs or review the
results below:

File Description

jsp99hym.eff HyMap ATREM with EFFORT
Correction Applied

jsp99hym.hdr ENVI Header for Above

jsp99hym_mnf.bil VNIR MNF Transformed data (60
Bands)

jsp99hym_mnf.hdr ENVI Header for Above

jsp99hym_ppi.ndv n-D Visualizer Save State from PPI

jsp99hym_ndv_em.roi VNIR ROI File of n-D Visualizer
Endmember locations

jsp99hym_ndv_em.txt VNIR ASCII File of Endmember Spectra

usgs_veg.sli Vegetation Spectral Library

usgs_min.sli Mineral Spectral Library

veg_2grn.sli Jasper Ridge, Spectral Library

veg_2grn.hdr ENVI Header for Above
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Figure 19-8: Jasper Ridge HyMap Spectral Endmembers from the n-D
Visualizer.
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6. Use ENVI’s wide variety of mapping methods to map the spatial occurrence
and abundance of materials at Jasper Ridge. As a minimum, try the Spectral
Angle Mapper (SAM) and Unconstrained Linear Unmixing. Use SAM to
determine spectral similarity of image spectra to endmember spectra. Perform
your own SAM Classification or review the results below. If time and space
permit, try a SAM classification using one of the Spectral Libraries. Be sure to
evaluate the Rule Images. Use the Unconstrained Linear Unmixing to
determine material abundances. Be sure to examine the RMS error image and
evaluate whether the physical constraints of non-negative and sum to unity (1)
or less have been satisfied. Iterate if time and space permit. Compare
abundance image results to the endmember spectra and spectral libraries using
spatial/spectral browsing. If time and space permit, try running Mixture-Tuned
Matched filtering.

File Description

jsp99hym.eff HyMap ATREM with EFFORT
Correction Applied

jsp99hym.hdr ENVI Header for Above

jsp99hym_mnf.bil VNIR MNF Transformed data (60
Bands)

jsp99hym_mnf.hdr ENVI Header for Above

jsp99hym_ndv_em.txt VNIR ASCII File of Endmember Spectra

jsp99hym_sam.img VNIR SAM Classes

jsp99hym_sam.hdr ENVI Header for Above

jsp99hym_rul.img VNIR SAM Rules

jsp99hym_rul.hdr ENVI Header for Above
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7. Use ENVI’s Georeference from the Input Geometry function to geocorrect the
processed images of the Jasper Ridge to map coordinates. Compare
geocorrected images to image maps of conventional vegetation mapping at
Jasper Ridge.

Figure 19-9: Jasper Ridge SAM classification result using n-D Visualizer
endmembers.

File Description

jsp99hym.eff Bands from HyMap ATREM with EFFORT
Correction Applied or HyMap output products
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jsp99hym.hdr ENVI Header for Above

jsp99hym_glt.img Geometry Lookup file for HyMap geocorrection

jsp99hym_glt.hdr ENVI Header for Above

Figure 19-10: Jasper Ridge HyMap geocorrected SAM Classification Image.

File Description
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Overview of This Tutorial

This tutorial presents a case history for use of hyperspectral techniques for vegetation
analysis using 1994 AVIRIS data from Moffett Field, California, USA. It is designed
to be a self-directed example using ENVI’s complete end-to-end hyperspectral tools
to produce image-derived endmember spectra and image maps. For more detail and
step-by-step procedures on performing such a hyperspectral analysis, please execute
the hyperspectral tutorials in this booklet prior to attempting this tutorial.

Objectives

1. To examine the application of ENVI end-to-end hyperspectral processing
methodology to a near-shore marine case study.

2. To give students hands-on experience in actually running the procedures rather
than reviewing pre-calculated results (preprocessed results are provided for
comparison).

3. To provide students with guidance to perform data exploration in a loosely
structured framework.

4. To compare analysis results with known ground information.

Tasks

1. Examine ATREM-corrected apparent reflectance data and evaluate data
characteristics and quality.

2. Conduct Spatial/Spectral browsing to evaluate data, determine presence and
nature of spectral variability, determine linearity of mixing, and to select
wavelength range (s) for further analysis.

3. Reduce data dimensionality using MNF transform.

4. Select spectral endmember candidates using PPI.

5. Evaluate linearity and select endmembers using n-D Visualizer.

6. Map endmember distribution and abundance using ENVI mapping methods.
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Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/spec_lib/veg_lib
envidata/spec_lib/usgs_min
envidata/m94avsub

File Description

Required Files (envidata/spec_lib/veg_lib)

usgs_veg.sli USGS Vegetation Spectral Library

usgs_veg.hdr ENVI Header for Above

Required Files (envidata/spec_lib/usgs_min)

usgs_min.sli USGS Mineral Spectral Library

usgs_min.hdr ENVI Header for Above

Required Files (envidata/m94avsub)

mof94av.bil AVIRIS ATREM Corrected Data, 500 x 350 x 56
bands

mof94av.hdr ENVI Header for Above

m94mnf.img VNIR MNF Transformed data

m94mnf.hdr ENVI Header for Above

m94mnf.asc VNIR Eigenvalue plot data

m94ppi.img VNIR PPI image

m94ppi.hdr ENVI Header for Above

m94ppi.roi ROI of VNIR PPI threshold

m94_em.asc VNIR ASCII File of Endmember Spectra - all EM

m94_em.roi VNIR ROI File of Endmember Spectra - all EM

m94_ema.asc VNIR ASCII File of Endmember Locations - selected
EM

m94_sam1.img VNIR SAM Classes using M94EM1A.ASC
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Note
The files listed are required to run this exercise. Selected data files have been
converted to integer format by multiplying the reflectance values by 1000 because
of disk space considerations. Values of 1000 in the files represent reflectance values
of 1.0.

Moffett Field Site Background

• Launch site for AVIRIS at Moffett Field.

• Remote Sensing Test Site Used By JPL and others since launch of AVIRIS in
1987.

• AVIRIS Standard Datasets for 1992-97.

• Study area for water variability (salt evaporation ponds with algae), urban
studies, vegetation.

The salt ponds are highly colored and contain a dense biomass of algae and/or
photosynthetic bacteria (Richardson et al., 1994). Accessory bacterial pigments cause
distinct spectral signatures that can be detected using AVIRIS data (Figure 20-1).
These include carotenoids, phycocyanin, and chlorophyll a and b. Application of the
standardized AVIRIS analysis methods described below should lead to the extraction
of endmembers from the data and spatial mapping of their distribution and
abundance. There are obvious mixing non-linearities in the data, however, and care
must be taken to recognize these.

m94_sam1.hdr ENVI Header for Above

m94_rul1.img VNIR SAM Rules

m94_rul1.hdr ENVI Header for Above

m94_unm1.img VNIR Unmixing image using M94EM1A.ASC

m94_unm1.hdr ENVI Header for above

File Description
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Figure 20-1: 1994 Moffett Field AVIRIS Data.
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AVIRIS Processing Flow

The following diagram illustrates an approach for analysis of hyperspectral data that
is implemented with ENVI.

The following outlines in general terms the implementation of this approach. The
student is expected to follow the procedures below, referring to previous tutorials and
the ENVI User’s Guide for guidance in performing specific tasks where required. The
purpose of this tutorial is not to teach you how to run the ENVI tools, but how to
apply the methodology and tools to a general hyperspectral remote sensing problem.

Figure 20-2: End-to-End Hyperspectral Processing with ENVI.
AVIRIS Processing Flow ENVI Tutorials
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Hyperspectral Techniques for Vegetation
Analysis

1. Evaluate the ATREM Correction applied to the JPL-provided AVIRIS spectral
radiance to remove the bulk of the solar and atmospheric effects, transforming
the data from radiance to apparent surface reflectance. Examine the data using
spectral/spatial browsing and color composites to characterize spectral
variability and determine residual errors. Extract reflectance signatures for
water, vegetation, urban areas, and geologic materials. Compare to spectral
libraries.

2. Apply the MNF Transform to the ATREM data to find the data’s inherent
dimensionality. Review MNF eigenvalue plot(s) to determine break-in-slope
and relate to spatial coherency in MNF eigenimages. Determine MNF cut-off
between “signal” and “noise” for further analysis.

File Description

mof94av.bil ATREM Apparent Reflectance

usgs_veg.sli Vegetation Spectral Library

usgs_min.sli Mineral Spectral Library

Figure 20-3: MNF Eigenvalues.
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Make your own MNF-Transformed dataset or review the results in the files
below:

File Description

m94av.bil ATREM Apparent Reflectance

m94mnf.asc VNIR Eigenvalue ASCII Data

m94mnf.img VNIR MNF Eigenimages

Figure 20-4: MNF Bands 1 (upper left) and 20 (lower right)
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3. Apply PPI Analysis to the MNF output to rank the pixels based on relative
purity and spectral extremity. Use the FAST PPI option to perform
calculations quickly in system memory, creating the PPI image. Display the
PPI image, examine the histogram, and threshold to create a list of the purest
pixels, spatially compressing the data.

Generate your own PPI results and ROIs or review the results in the files
below:

4. Perform n-Dimensional Visualization of the high PPI value pixels, using the
high signal MNF data bands to cluster the purest pixels into image-derived
endmembers. Rotate the MNF data interactively in 3-D, or spin in 3-or-more
dimensions and “paint” pixels that occur on the “points” (extremities) of the

Figure 20-5: Pixel Purity Index (PPI) Image

File Description

m94mnf.img VNIR MNF Eigenimages

m94ppi.img VNIR PPI Image

m94ppi.roi VNIR PPI Threshold Results
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scatterplot. Use Z-Profiles connected to the ATREM apparent reflectance data
and the n-D Visualizer to evaluate spectral classes. Use class collapsing to
iteratively find all of the endmembers. Pay particular attention to the linearity
of water mixtures, variability, and endmembers. Save your n-D results to a
save state file (.ndv). Export classes to ROIs and extract mean spectra.
Compare mean spectra to spectral libraries. Use spectral/spatial browsing to
compare image spectra to ROI means.

Extract endmembers and make your own ROIs or review the results below:

5. Use ENVI’s wide variety of mapping methods to map the spatial occurrence
and abundance of materials in the Moffett Field scene. As a minimum, try the
Spectral Angle Mapper (SAM) and Unconstrained Linear Unmixing. Use
SAM to determine spectral similarity to image endmember spectra Perform
your own SAM Classification or review the results below. If time and space
permit, try a SAM classification using one of the Spectral Libraries. Be sure to
evaluate the Rule Images. Use the Unconstrained Linear Unmixing to
determine material abundances or review the results below. Be sure to examine
the RMS error image and evaluate linearity and whether the physical
constrains of non-negative and sum to unity (1) or less have been satisfied.
Iterate if time and space permit. Compare abundance image results to the
endmember spectra and spectral libraries using spatial/spectral browsing. If
time and space permit, try running Mixture-Tuned Matched filtering and/or
Spectral Feature Fitting.

File Description

m94mnf.img VNIR MNF Eigenimages

m94ppi.roi VNIR PPI Threshhold Results

m94av.bil ATREM Apparent Reflectance

m94_em.asc VNIR Saved ASCII Endmember Spectra (all)

m94_ema.asc Selected VNIR Saved ASCII Endmembers

usgs_veg.sli Vegetation Spectral Library

usgs_min.sli Mineral Spectral Library

File Description

m94_em.asc VNIR Saved ASCII Endmember Spectra
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m94_ema.asc Selected Saved ASCII Endmembers

mof94av.bil ATREM Apparent Reflectance

m94_sam1.img VNIR SAM Classes

m94_rul1.img VNIR SAM Rules

m94_unm1.img VNIR Linear Spectral Unmixing Results

usgs_veg.sli Vegetation Spectral Library

usgs_min.sli Mineral Spectral Library

File Description
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Figure 20-6: Spectral Unmixing Results: Red Pigment (UL), Green Pigment (LL),
Vegetation 1(UR), Vegetation 2(LR)
Hyperspectral Techniques for Vegetation Analysis ENVI Tutorials
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Overview of This Tutorial

This tutorial is designed to show you how ENVI's advanced hyperspectral tools can
be used for analysis of multispectral data. To gain a better understanding of the
hyperspectral concepts and tools, please see the ENVI hyperspectral tutorials. For
additional details, please see the ENVI 3.5 User’s Guide or the ENVI On-Line help.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/bh_tmsub

envidata/spec_lib/usgs_min

File Description

Required Files (envidata/bh_tmsub)

bhtmref.img Bighorn Basin, Wyoming Landsat TM Reflectance

bhtmref.hdr ENVI Header for Above

bh_rats.img Band Ratio Image 5/7, 3/1, 3/4 (RGB)

bh_rats.hdr ENVI Header for Above

bhtmiso.img Isodata Classification

bhtmiso.hdr ENVI Header for Above

bhisiev.img Sieve Image of Isodata Classification

bhisiev.hdr ENVI Header for Above

bhiclmp.img Clump Image of the Sieved Classification

bhiclmp.hdr ENVI Header for Above

bhtm.grd Saved Grid for Bighorn TM data

bhtmiso.ann Map Annotation for Bighorn TM data

bhtm_mnf.asc ACII Eigenvalue data for MNF Transform

bhtm_mnf.img MNF Transform Data

bhtm_mnf.hdr ENVI Header for Above
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Background

ENVI was not designed solely as a hyperspectral image processing system. The
decision was made in 1992 to develop a general purpose image processing software
package with a full suite of standard tools in response to the general lack of powerful
yet flexible commercial products capable of handling a wide variety of scientific
image data formats. This included support for panchromatic, multispectral,
hyperspectral, and both basic and advanced radar systems. ENVI presently contains

bhtm_mnf.sta ENVI Statistics File for above

bhtm_ns.sta ENVI Noise statistics for above

bhtm_ppi.img Pixel Purity Index Image

bhtm_ppi.hdr ENVI Header for Above

bhtm_ppi.cnt Counter for PPI analysis

bhtm_ppi.roi Regions of Interest threshold from the PPI

bhtmppi.ndv n-D Visualizer Save State file

bhtm_nd.roi ROIs from n-D Visualizer Analysis

bhtm_em.asc ASCII Spectral Endmembers from n-D

bhtm_sam.img SAM Classification

bhtm_sam.hdr ENVI Header for Above

bhtm_sam.ann Map Annotation for the SAM images

bhtm_rul.img ENVI SAM Rule Images

bhtm_rul.hdr ENVI Header for Above

bhtm_unm.img Linear Spectral Unmixing Result

bhtm_unm.hdr ENVI Header for Above

bhunm_em.asc Endmembers used for Spectral Unmixing

Required Files (envidata/spec_lib/usgs_min)

usgs_min.sli USGS Spectral Library in ENVI format

usgs_min.hdr ENVI Header for above

File Description
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the same basic capabilities as other major image processing systems such as ERDAS,
ERMapper, and PCI. Where ENVI differs is in the many advanced, state-of-the-art
algorithms resulting from active leading-edge remote sensing research. While many
of these features were developed specifically to deal with imaging spectrometer data
or hyperspectral data having up to hundreds of spectral bands, many of these
techniques are applicable to multispectral data and other standard data types. This
tutorial presents a scenario for use of some of these methods for analysis of Landsat
Thematic Mapper data.

This example is broken into two separate parts: 1) a typical multispectral analysis of
TM data using standard or classical multispectral analysis techniques, and 2) analysis
of the same data set using ENVI's hyperspectral tools.
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Standard Multispectral Image Processing

A standard, or classical, Landsat TM analysis scenario might consist of the following
(though many other variations are available within ENVI. See Sabins, 1987 for other
examples):

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To start ENVI in UNIX, enter envi at the UNIX command line.

• To start ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

Read TM Tape or CD

ENVI provides the tools to read standard Landsat Thematic Mapper data from both
tape and CD/disk.

• To read from tape, select File → Tape Utilities → Read Known Tape
Formats → Landsat TM (or NLAPS for new EDC-format tapes) from the
ENVI main menu.

• To read from disk, select File → Open External File → Landsat → Fast, or
for NLAPS data select File → Open External File → Landsat → NLAPS.

• For the purposes of this exercise, the data have already been read in and made
into subsets and the file bh_tmref.img is provided for analysis. This image
has been corrected to reflectance using ENVI’s TM Calibration Utility,
accessed using Basic Tools → Data Specific Utilities → Landsat
TM → Landsat TM Calibration.
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Open and Display Landsat TM Data

To open an image file:

1. Select File → Open Image File on the ENVI main menu.

Note that on some platforms you must hold the left mouse button down to
display the submenus from the Main Menu.

An Enter Data Filenames file selection dialog appears.

2. Navigate to the bh_tmsub subdirectory of the envidata directory on the
ENVI Tutorial and Data CD No. 1 just as you would in any other application
and select the file bhtmref.img from the list and click OK.

The Available Bands List dialog appears on your screen. This list allows you
to select spectral bands for display and processing.

Note that you have the choice of loading either a gray scale or an RGB color
image.

3. Select bands 4, 3, and 2 listed at the top of the dialog by first selecting the
RGB Color radio button in the Available Bands List, then clicking on the
bands sequentially with the left mouse button.

Display and Examine a Color Composite Image

1. To load the image, click Load RGB.

2. Once the image is displayed, select and execute some of the available
functions from the Main Image window menu bar.

3. Resize the image display windows by grabbing one of the corners with the left
mouse button and dragging. Scroll and pan the image by grabbing and
dragging the red outline boxes in the Scroll and Zoom windows. Zoom the
image by clicking with the left mouse button in the + (plus) or – (minus)
graphic in the lower left corner of the Zoom window. The left mouse button
centers the cursor on the clicked pixel.

4. From the Main Image menu bar, select Tools → Cursor Location/Value and
use the interactive cursor to determine location and pixel value.

5. Contrast stretch the images by selecting Enhance → [Image] Stretch Type,
where Stretch Type is Linear, Linear 0-255, Linear 2%, Gaussian,
Equalization, Square Root. In this instance, choose the [Image]
Equalization stretch.
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Conduct a Ratio Analysis

Here you will create Color-Ratio-Composite (CRC) images using standard TM band-
ratio images. This method tries to get around the limitations of relatively broad
spectral bands in Landsat TM data by using ratios of bands to determine relative
spectral slope between bands and thus the approximate shape of the spectral signature
for each pixel. Common band-ratios include: Band-Ratio 5/7 for clays, carbonates,

Figure 21-1: A Color Composite Image showing
Landsat TM Bands 4, 3, 2 (RGB)
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vegetation; band-ratio 3/1 for iron oxide; band-ratios 2/4 or 3/4 for vegetation; and
band-ratio 5/4 also for vegetation.

To create a band-ratio image:

1. Select Transform → Band Ratios from the ENVI main menu.

2. In the Band Ratio Input Bands dialog, select the following Numerator and
Denominator band pairs from the Available Bands list in the dialog (5/7, 3/1,
2/4). Click Enter Pair after each Numerator/Denominator set is chosen, and
repeat for as many band-ratios as desired.

3. Click OK in the Band Ratio Input Bands dialog to calculate the ratios.

Figure 21-2: A Color-Ratio Composite Image
of ratios 5/7, 3/1, and 2/4 (RGB).
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4. In the Band Ratios Parameters dialog, select the Memory radio button to
save the ratios to memory, and click OK.

5. The band ratios now appear in the Available Bands List when complete.

The combination of 5/7, 3/1, 2/4 (RGB) results in an image in which
clays/carbonates are magenta, iron oxides are green, and vegetation is red.
Other ratio combinations and color schemes can be designed to highlight
specific materials.

6. In the Available Bands List, select the 5/7 ratio for R, 3/1 for G, and 2/4 for
B. Select Display #1 → New Display to load and display your CRC image.

7. You can also select File → Open Image File from the ENVI main menu and
choose the CRC image bh_rats.img from the file selection dialog. Display
the result in a New Display from the Available Bands List.

8. In Display #2, use a histogram equalization stretch by selecting
Enhance → [Image] Equalization.

9. Compare the CRC image in Display #3 to the false CIR image in Display #2
above using image linking and dynamic overlays by selecting
Tools → Link → Link Displays, and then clicking and dragging using the left
mouse button in one of the images to display the dynamic overlay. The overlay
area can be resized by clicking and dragging the middle mouse button in the
image.

Run Unsupervised Classification (IsoData)

Unsupervised classification provides a simple way to segment multispectral data
using the data statistics. IsoData calculates class means evenly distributed in the data
space and then iteratively clusters the remaining pixels using minimum distance
techniques. Each iteration recalculates means and reclassifies pixels with respect to
the new means. This process continues until the number of pixels in each class
changes by less than the selected pixel change threshold or the maximum number of
iterations is reached.

1. From the ENVI main menu, select File → Open Image File and choose the
file bhtmiso.img and load as a Gray Scale image using the Available Bands
List. Open the image in a New Display.

2. To perform an IsoData classification, from the ENVI main menu select
Classification → Unsupervised → IsoData. Choose the image
bhtmiso.img and use the default settings in the Classification Input File
dialog.
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3. In the ISODATA Parameters dialog, select the Memory radio button and
click OK to create the IsoData classified image.

4. In the Available Bands List, load the ISODATA image into a New Display.

5. Compare the IsoData classification image to the CRC image and the false CIR
image above using image linking and dynamic overlays by selecting
Tools → Link → Link Displays, and then clicking and dragging using the left
mouse button in one of the images to display the dynamic overlay.

Clump and Sieve, Combine Classes

Once the classification is complete, because classified images often suffer from a
lack of spatial coherency (speckle or holes in classified areas), it is often desirable to
generalize the classes to generalize the classification for operational use. Low pass
filtering could be used to smooth these images, however, the class information would
be contaminated by adjacent class codes. The Sieve Class and Clump Class operators
have been designed to avoid this problem by removing isolated pixels and clumping
together adjacent similar classified areas respectively using morphological operators.

• To sieve classes, select Classification → Post Classification → Sieve Classes
from the ENVI main menu.

Figure 21-3: An IsoData Image.
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• To clump classes, select Classification → Post Classification → Clump
Classes from the ENVI main menu.

1. Load and examine the sieve and clump classes images by selecting
File → Open Image File and choosing bhisiev.img and bhiclmp.img
respectively.

2. In the Available Bands List, load the Sieve and Clump images into New
Displays.

3. Compare the generalized classification images to the ISODATA image using
image linking and dynamic overlays by selecting Tools → Link → Link
Displays, and then clicking and dragging using the left mouse button in one of
the images to display the dynamic overlay.

Annotate and Output Map

The final output from any image processing within ENVI is usually a map-oriented,
scaled image-map for presentation or visual analysis and interpretation. In this case,
the TM data were already geographically referenced, however, ENVI includes full
image-to-image and image-to-map registration capabilities. Please see the
Registration Tutorial or the ENVI 3.5 User’s Guide and on-line tutorials.

ENVI also provides all of the tools to produce fully annotated publication-quality
maps. This includes pixel, map, and geographic (latitude/longitude) grids; scale-bars;

Figure 21-4: Sieve and Clump Classification Generalization. Sieve is on the left,
Clump of the Sieved image on the right.
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declination diagrams and north arrows; text and symbols; polygons, polylines, and
geometric shapes (circles, rectangles); map keys and legends; and image insets. For
additional information on map composition, please see the Map Composition
Tutorial or the ENVI 3.5 User’s Guide and on-line tutorials.

1. To add a grid to the displayed IsoData classification, select Overlay → Grid
Lines from the Main Image window menu bar.

2. In the Grid Lines Parameters dialog, choose File → Restore Setup.

3. In the Enter Grid Parameters Filename dialog, click on the file bhtm.grd
and Open it.

4. To add the grid to the image, click Apply in the Grid Line Parameters dialog.

5. To add map annotation to the displayed IsoData classification, select
Overlay → Annotation from the Main Image window.

6. In the Annotation: Text dialog, choose File → Restore Annotation.

7. In the Enter Annotation Filename dialog, pick the file bhtmiso.ann and
click on Open. The map annotation is loaded onto the image.
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8. Now from the ENVI main menu, close all windows to clean up the work space
by selecting Window → Close All Display Windows.

Figure 21-5: IsoData Classification annotated image-map.
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Analyze Multispectral Data with ENVI's
Hyperspectral Tools

Read TM Tape or CD

As described above, ENVI provides the tools to read standard Landsat Thematic
Mapper data from both tape and CD/disk.

• To read from tape, select File → Tape Utilities → Read Known Tape
Formats → Landsat TM (or NLAPS for new EDC-format tapes) from the
ENVI main menu.

• To read from disk, either select File → Open External
File → Landsat → Fast or for NLAPS data select File → Open External
File → Landsat → NLAPS.

• For the purposes of this exercise, the data have already been read in and made
into subsets and the file bh_tmref.img is provided for analysis. This image
has been corrected to reflectance using ENVI’s TM Calibration Utility,
accessed using Basic Tools → Data Specific Utilities → Landsat
TM → Landsat TM Calibration (see below).

Calibrate TM to Reflectance

A reflectance calibration is required for Landsat TM data to compare image spectra
to library reflectance spectra and to run some of ENVI's hyperspectral routines. ENVI
provides TM calibration through the use of pre-launch gains and offsets calculated
for the Landsat Sensors (Markham and Barker, 1986).

1. From the ENVI main menu bar, select Basic Tools → Data Specific
Utilities → Landsat TM → Landsat TM Calibration.

2. When the TM Calibration Input File dialog appears, choose bhtmref.img
as the image to be calibrated. Click OK.

3. In the TM Calibration Parameters dialog you can enter the calibration
parameters, including the Landsat Satellite (5), the month (August), day (12),
and year of acquisition (1984), and the sun elevation (40). At this time, simply
select the Memory radio button.

4. Choose the Reflectance calibration type and click OK.
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The resulting image approximates reflectance.

Display a Color Composite Image and Extract Spectra

1. In the Available Bands List, click on the RGB Color radio button. Next,
select bands 3, 2, 1 (RGB - True Color) or 4, 3, 2 RGB (Color Infrared) of the
bh_tmref.img open image file. Open a New Display, and click on Load
RGB.

2. Once the image is displayed, select and execute some of the available
functions on the Main Image window menu bar.

3. Scroll the image and zoom the image.

4. Use the interactive cursor to determine location and values.

5. Contrast stretch and/or density slice the images.

6. Extract Z-profiles (reflectance spectra) from the data by selecting
Tools → Profiles → Z Profile in the Main Image window and browse around

Figure 21-6: TM Calibration Parameters
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the image by clicking and dragging the red Zoom window box using the left
mouse button.

7. Now from the ENVI main menu, close all windows to clean up the work space
by selecting Window → Close All Display Windows.

Run Minimum Noise Fraction (MNF) Transformation

MNF Transform is a method similar to Principal Components used to segregate noise
in the data, determine inherent data dimensionality, and reduce computational
requirements for subsequent processing (Green et al., 1988; Boardman and Kruse,
1994). For hyperspectral data (less-so for multispectral data), the MNF divides data
space into two parts; one with large eigenvalues and coherent eigenimages and the
second with near-unity eigenvalues and noise-dominated images. It is used as a
preparatory transformation to put most of the interesting information into just a few
spectral bands and to order those bands from most interesting to least interesting.

Figure 21-7: Landsat TM reflectance spectra.
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See the Hyperspectral Tutorials for additional background information and examples.
To calculate the MNF transformation from the TM reflectance data:

1. Examine the pre-calculated MNF Eigenvalue plot bhtm_mnf.asc by
selecting Window → Start New Plot Window from the ENVI main menu
bar.

2. Load the bhtm_mnf.asc ASCII file using File → Input Data → ASCII
from the plot window menu bar.

3. The Input ASCII File dialog appears. Click OK to plot the input.

Figure 21-8: MNF Transformation Results.
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4. In the Available Bands List, select File → Open Image File to load and
examine the MNF image file bhtm_mnf.img. Be sure to examine both the low
and high MNF bands. In the Available Bands List, open a New Display and
load MNF Band 1.

5. Next, in the Available Bands List, open another New Display and load MNF
Band 6. Look at the two different MNF Bands and note the decrease in spatial
coherency with increasing MNF Band number.

The decreasing eigenvalue with increasing MNF band shown in the eigenvalue plot
above shows how noise is segregated in the higher number MNF bands.

Run PPI to Find Endmembers

The Pixel Purity IndexTM (PPITM) function finds the most spectrally pure or extreme
pixels in multispectral and hyperspectral data (Boardman and Kruse, 1994). These
correspond to the materials with spectra that combine linearly to produce all of the
spectra in the image. The PPI is computed by using projections of n-dimensional
scatterplots to 2-D space and marking the extreme pixels in each projection. The
output is an image (the PPI Image) in which the digital number (DN) of each pixel in
the image corresponds to the number of times that pixel was recorded as extreme.

Figure 21-9: MNF Eigenvalue Plot
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Thus bright pixels in the image show the spatial location of spectral endmembers.
Image thresholding is used to select several thousand pixels for further analysis, thus
significantly reducing the number of pixels to be examined. See the Hyperspectral
Tutorials for additional PPI background information and examples.

1. To start the PPI analysis, select Spectral → Pixel Purity Index → [FAST]
New Output Band from the ENVI main menu.

This calculates the PPI in memory.

Note
If not enough RAM is available in your hardware, you may need to choose
Spectral → Pixel Purity Index → New Output Band, which will execute several
orders of magnitude more slowly.

Figure 21-10: The PPI Image.
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2. In the Available Bands List, select File → Open Image File. In the Enter
Data Filenames dialog select the pre-calculated PPI image, bhtm_ppi.img.

3. Select the PPI file and load it into a New Display.

Alternatively, you can choose the bhtm_mnf.img data as the input file,
spectrally subset to include only those coherent MNF bands (the lower band
number images as determined above).

In the Fast Pixel Purity Index Parameters dialog, enter several thousand
(4000 for instance) as the number of iterations and enter a Threshold Factor
of 3. Click OK.

The PPI image will appear in the Available Bands List when processing has
completed.

4. From the Main Image window menu, select Tools → Region of Interest → 
ROI Tool to load the ROI file bhtm_ppi.roi into the ROI Tool.

Alternatively, display the PPI image and select Tools → Region of
Interest → Band Threshold to ROI in the Main Image window to extract a
Region of Interest by thresholding the image.

Choose the PPI image as the input file, and enter a minimum threshold value of
5, and click OK.

The selected pixels will be entered into ENVI's ROI Tools dialog.

n-D Visualization and Extract Endmembers

Though both the MNF and PPI operations above effectively reduce the data volume
to be analyzed interactively, the high dimensionality of hyperspectral data requires
advanced visualization techniques. ENVI's N-Dimensional Visualizer is an
interactive n-dimensional scatterplotting paradigm that allows real-time rotation of
scatterplots in n-dimensions (Boardman et al., 1995). This is accomplished by casting
the scatterplots from n-D to 2-D to simplify analysis. Animation of the scatterplots
then provides the capability to simultaneously use all bands for interactive analysis.
The scientist's visual skills and scatterplot geometry are used to locate image spectral
endmembers. See the Hyperspectral Tutorials and the ENVI 3.5 User’s Guide and
Online Help for additional background information and examples.

1. From the ENVI main menu, select Spectral → n-Dimensional
Visualizer → Visualize With Previously Saved Data. In the Enter n-D State
Filename dialog, choose the file bhtmppi.ndv to use this in the visualization.
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Alternatively, Select Spectral → n-Dimensional Visualizer → Visualize
With New Data and use the ROI created from the PPI image as described
above and the MNF images as the input data file.

When the n-D Visualizer window and n-D Controls dialog and appear, select
the first three MNF bands by clicking on the band numbers (1, 2, 3) in the
dialog.

Click on the Start/Stop button to start and stop the animation.

2. Look for corners on the scatterplot and then use ENVI's ROI definition
paradigm to draw ROIs encompassing the corner pixels.

3. Select Options → Z Profile from the menu bar at the top of the n-D Controls
dialog and choose the TM reflectance image as the file from which to get the
reflectance spectra.

4. Click the middle mouse button in the n-D Visualizer window to extract
spectra for specific scatterplot locations.
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5. Click the right mouse button in the n-D Visualizer window to extract multiple
spectra.

Figure 21-11: The n-Dimensional Visualizer.
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6. Export the spectral endmembers you have selected in the n-D Visualizer to the
ROI Tool dialog.

Alternatively, instead of collecting your own spectra, load and view the spectra
in the file bhtm_em.asc from the File → Input Data → ASCII option in the
n-D Profile plot window.

Do this in the n-D Controls dialog by selecting Options → Export All from
the dialog menu bar.

7. Plot these spectra by choosing Options → Mean for All Regions in the ROI
Tool dialog.

Figure 21-12: n-Dimensional Visualizer-extracted endmember spectra.
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Compare Image Spectra to Spectral Library

ENVI allows comparison of image spectra to spectra measured in the laboratory and
saved in spectral libraries. Several relatively high spectral resolution spectral libraries
are provided with ENVI.

1. From the ENVI main menu, select Spectral → Spectral
Libraries → Spectral Library Viewer.

2. The Spectral Library Viewer dialog opens. Click on several of the mineral
and/or vegetation spectra names in the list.

The selected spectra will be plotted in a Spectral Library Plots display
window.

3. Open the ENVI spectral library usgs_min.sli from the ENVI Tutorial and
Data CD No. 1 directory envidata\spec_lib\usgs_min with the Open
Spec Lib button in the Spectral Library Input File dialog, then click OK.

4. Compare these high resolution spectra to the TM spectral endmembers.

5. Resample the entire library to the Landsat wavelengths and resolution using
ENVI's spectral tools.

6. Select Spectral → Spectral Libraries → Spectral Library Resampling
from the ENVI main menu.

7. Select the usgs_min.sli spectral library and choose resampling to Landsat
TM5.

8. Click OK and the library will be resampled and placed in the Available Bands
List.

9. Select Spectral → Spectral Libraries → Spectral Library Viewer from the
ENVI main menu.

10. Choose the library you just created and click on several of the mineral and
vegetation spectra to display their resampled spectra.

11. Compare these spectra to the Landsat TM image spectra.
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Spectral Angle Mapper Classification

The Spectral Angle Mapper (SAM) measures the similarity of unknown and
reference spectra in n-dimensions. The angle between the spectra treated as vectors in
n-space is the spectral angle, this is illustrated in 2-dimensions in Figure 21-14
below. This method assumes that the data have been reduced to apparent reflectance
and uses only the direction of the spectra, and not their length. Thus the SAM
classification is insensitive to illumination effects. See the Hyperspectral Tutorials
and the ENVI 3.5 User’s Guide and on-line help for additional background
information and examples.

To start SAM:

1. From the Main Image window, select Tools → Region of Interest → ROI
Tool. Use File → Restore ROIs to load the ROIs from the file bhtm_em.asc.

Alternatively, select Classification → Supervised → Spectral Angle
Mapper.

Enter the Landsat TM reflectance data bhtmref.img as the input file.

Figure 21-13: Comparison of image and library spectra.
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When the Endmember Collection:SAM dialog appears, select
Import → from ROI from Input File and choose the ROIs you created in the
n-D Visualizer window.

2. In the Endmember Collection:SAM dialog, click Apply and enter the output
file names to start the classification.

The results of the classification will be a set of rule images corresponding to
the number of endmembers you selected and a SAM Classification Image. The
rule images show the best matches in black when first displayed, however,
these are typically inverted to better show the matches as bright pixels in the
displayed rule images, select Tools → Color Mapping → ENVI Color
Tables from the Main Image window menu bar and reverse the Stretch Bottom
and Stretch Top slider bars to invert the image.

The following figure (Figure 21-15) shows the best match for each pixel
(within the default threshold of 0.10 radians) color coded for each endmember.

Figure 21-14: 2-D SAM Classification Schematic.
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Linear Spectral Unmixing

Image pixels typically represent areas of from 1 to several square meters. Within
these pixels, the Earth's surface is composed of mixtures of materials; pure pixels are
extremely rare (Boardman). The mixed spectrum received by most imaging systems
is a linear combination of the pure or endmember spectra, each weighted by their
fractional abundance of area. Mixed pixels can be analyzed using a mathematical
model where the observed spectrum is the result of multiplication of the mixing
library of pure endmember spectra by the endmember abundances. Mixing can also
be visualized, however, using a geometric model; this is the basis of ENVI's 2-D
Projections of n-dimensional scatterplots. See ENVI’s Hyperspectral Tutorials and

Figure 21-15: SAM Classification Result.
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the ENVI 3.5 User’s Guide and on-line tutorials for additional unmixing background
information and examples.

To perform linear spectral unmixing using ENVI:

1. Display the pre-calculated results in bhtm_unm.img.

Alternatively, use the endmember spectra from the n-D Visualizer above.

Select Spectral → Mapping Methods → Linear Spectral Unmixing and
choose the TM calibrated reflectance data as the input file.

Select Import → from ROI from Input File from the menu bar at the top of
the Endmember Collection:Unmixing dialog, choose the ROIs you created
in the n-D Visualizer window, and then click Apply.

When complete, the spectral unmixing endmember image will appear in the
Available Bands List.

2. Display these images from the Available Bands List, and the RMS (error)
image generated during the analysis.

Figure 21-16: Aerial Mixing=Linear Mixing (Left) and
Linear Spectral Mixing (Right).
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Bright values in the abundance images represent high abundances; the Cursor
Value/Location function can be used to examine the actual values.

• By default ENVI utilizes an unconstrained unmixing algorithm. This means if
you don't select the correct endmembers, the results will not be quantitatively

Figure 21-17: Linear Spectral Unmixing Abundance images
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correct. If you observe negative abundances for any of the endmembers, or the
abundances for all of the endmembers for the same pixel sum to a quantity
greater than 1, then the unmixing doesn't make any physical sense. The best
way to correct this is to run ENVI's unmixing iteratively and to examine the
abundance images and RMS error image.

• Look for high errors in the RMS image, extract the spectra for these areas
and re-run the unmixing with the new endmember set.

When the RMS image doesn't have any more high errors, and all of the abundance
images are non-negative and sum to less than one, then the unmixing is completed.
This iterative method is much more accurate than trying to artificially constrain the
mixing, and even after extensive iteration, also effectively reduces the compute time
by several orders of magnitude compared to the constrained method.

• Optionally, if you are confident that you have all of the endmembers, run the
unmixing again and click on Apply a unit sum constraint.

Figure 21-18: Linear Spectral Unmixing Results.
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Annotate and Output Map

As previously described, the final output from any image processing within ENVI is
usually a map-oriented, scaled image-map for presentation or visual analysis and
interpretation. In this case, the TM data were already geographically referenced,
however, ENVI includes full image-to-image and image-to-map registration
capabilities. Please see the Registration Tutorial in this volume or the ENVI 3.5
User’s Guide and on-line help. ENVI also provides all of the tools to produce fully
annotated publication-quality maps. This includes pixel, map, and geographic
(latitude/longitude) grids; scale-bars; declination diagrams and north arrows; text and
symbols; polygons, polylines, and geometric shapes (circles, rectangles); map keys
and legends; and image insets. For additional information on map composition,
please see the Map Composition Tutorial or the ENVI 3.5 User’s Guide or on-line
help.

End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click OK to confirm
your exit from IDL. If you are using ENVI RT, quitting ENVI will take you back to
your operating system.
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Summary

A wide variety of advanced tools have been developed for analysis of imaging
spectrometer (hyperspectral data). These tools are mature and are being used
operationally for analysis of AVIRIS and other data sets. We don't have hyperspectral
data for many of the areas we would like to investigate, however, widely available
multispectral data can be analyzed using some of the hyperspectral tools. ENVI
allows users to use approaches developed for analysis of hyperspectral data to
provide new insight to the use and analysis of multispectral data sets.
Summary ENVI Tutorials
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Overview of This Tutorial

This tutorial is designed to introduce you to HDF data and analysis of Multispectral
Imagery from the MODIS/ASTER Airborne Simulator (MASTER) sensor. The
exercise covers opening and reading HDF-format files, extracting spatial and spectral
subsets and spectra, comparison of spectra to spectral libraries and classical
multispectral processing. For additional details on specific functions, please see the
ENVI User's Guide or the ENVI On-Line help. This MASTER dataset and other
MASTER data are available for purchase from NASA through the EROS Data
Center, Sioux Falls, SD.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 2

Path: envidata/cup99mas

Background

MASTER is designed to collect simulation data in support of the ASTER and
MODIS instrument teams in the areas of algorithm development, calibration, and
validation. Operated by NASA (see http://masterweb.jpl.nasa.gov/), MASTER is a
50-band scanner covering approximately the 0.4 - 14 micrometer range. The
instrument operates on the NASA Beachcraft B200, DC-8 or ER-2 aircraft to produce
spatial resolutions of 5-50m. Spectral band positions are designed to simulate both
ASTER and MODIS.

MASTER data are delivered via EROS Data Center in Hierarchical Data Format
(HDF). HDF is a multi-object file format for the transfer of graphical and numerical
data between machines, and allows the user to create, access, and share scientific data
in a form that is self-describing and network-transparent. “Self-describing” means
that a file includes information defining the data it contains. “Network-transparent”
means that a file is represented in a form that can be accessed by computers with
different ways of storing integers, characters, and floating-point numbers. HDF data
supported in ENVI include raster format images, images stored in 2 or 3-D scientific
data format, and plots stored in 1-D scientific data format.

File Description

9900511f.hdf MASTER date, Cuprite, Nevada

header.txt Text Header with data information
Overview of This Tutorial ENVI Tutorials
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The HDF Format and Processing of MASTER
Data

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To start ENVI in Unix, enter envi at the UNIX command line.

• To start ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

Open a HDF File and Review Data Items

1. Select File → Open External File → Generic Formats → HDF. Click on
990051f.hdf and Open. The HDF Dataset Selection dialog will appear
listing the available HDF data contained in the file.

Figure 22-1: HDF Dataset Selection dialog
ENVI Tutorials The HDF Format and Processing of MASTER Data
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2. Click on the HDF dataset labeled (50x1):Left50%ResponseWavelength
in the Select HDF Datasets: list and then click OK to plot the data. This
dataset contains the center wavelengths for the MASTER HDF data.

3. Select Edit → Data Parameter from the plot window and add symbols to the
plot by selecting a symbol name from the Symbol pull-down button in the
Data Parameters dialog. Enlarge the plot 2 or 3 times its initial size by
dragging one of the corners so that you can see the markers for the individual
band centers.

4. Use the interactive plot cursor to read the wavelength values by clicking and
dragging with the left mouse button on the plot. The values for the band
centers are listed at the bottom of the plot as you move the cursor. The far right
number represents the band center of the selected band in micrometers. Note
the MASTER coverage from approximately 0.4 - 14 micrometers.

Open the HDF File and Load image

1. Select File → Open External File → Generic Formats → HDF. Click on
990051f.hdf and Open. The HDF Dataset Selection dialog will appear
listing the available HDF data contained in the file.

2. Scroll to the bottom of the Select HDF Datasets: list in the HDF Dataset
Selection dialog and click on the HDF dataset labeled
(716x50x2028):CalibratedData and then click OK. Select the BIL
radio button in the HDF Data Set Storage Order dialog and click OK to load
the image data into the Available Band List dialog. This dataset contains the
image data for the Cuprite, Nevada, MASTER HDF data.

3. Click on Band 4 in the Available Bands List and Load Band to display the
image. ENVI directly reads the HDF data.

4. Examine the displayed data, then select File → Close All Files in the main
ENVI menu to close the display and data.

Open and Display MASTER HDF File

Use ENVI’s MASTER HDF reading capability to open a MASTER HDF file.

1. Select File → Open External File → Thermal → MASTER, click on the
990051f.hdf and Open. Alternatively, select File → Open Image File and
double click on 990051f.hdf and ENVI will automatically recognize the file
format. The 50 MASTER bands and their associated wavelengths will appear
in the Available Bands List dialog.
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2. Click on the RGB radio button in the Available Bands List dialog, then
sequentially on Bands 5, 3, 1 and Load RGB to display a MASTER true-color
image.

Spatially/Spectrally Subset VNIR/SWIR

1. Resize the Main Image window to cover a small area of interest centered on
Cuprite, Nevada by clicking and dragging one of the window corners to the
desired size. Cuprite is in the lower right corner of the displayed image.

2. Perform simultaneous spatial and spectral subsetting by selecting Basic
Tools → Resize Data (Spatial/Spectral) from the ENVI main menu and
clicking on the 9900511f.hdr file in the Resize Data Input File dialog.

3. Click on the Spatial Subset button in the Resize Data Input File dialog, then
Subset by Image in the Select Spatial Subset dialog. Move the red box in the
Subset Function dialog using the left mouse button until an appropriate subset
is outlined, then click OK and then OK in the Select Spatial Subset dialog.

4. Click on the Spectral Subset button in the Resize Data Input File dialog,
then Clear in the File Spectral Subset dialog. Select bands 1-25 by clicking
and dragging on the names using the left mouse button, or by entering the 1-25
range at the bottom of the dialog, then clicking Add Range. Click OK to
return to the Resize Data Input File dialog and click OK again.

5. Enter an output filename (resizedimage for example) in the Resize Data
Parameters dialog, then click OK to spatially and spectrally resize the data.

Empirical Reflectance Calibration

1. Click on the RGB radio button in the Available Bands List dialog, then
sequentially on Bands 5, 3, 1 and Load RGB to display a the resized
MASTER true-color image.

2. Choose Tools → Profiles → Z Profile (Spectrum) from the Main Image
window menu bar to display a spectrum of MASTER bands 1-25 (0.46 - 2.396
micrometers). Note the shape of the spectrum, corresponding to the shape of
the solar irradiance spectrum modified by atmospheric absorption.
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Perform a quick (rough) atmospheric correction using the empirical Flat Field
Correction by choosing a spectrally flat region of interest and then dividing the
average spectrum for that region into the spectrum for each pixel in the image.

3. Double-click in the Main Image window to start the Cursor Location/Value
dialog and move the cursor around the image to locate Stonewall Playa (a
bright area in the lower right corner of the image) in the vicinity of 565 and
1622.

4. Select Overlay → Region of Interest to start the ROI Tool, then draw a
region of interest in the Playa by clicking with the left mouse button, closing
with the right mouse button and fixing with a second right mouse button click.
Be sure to click the Off radio button in the ROI Tool when finished to turn off
ROI mouse control.

Figure 22-2: MASTER radiance spectrum
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5. Select Basic Tools → Calibration Utilities → Flat Field from the ENVI
main menu, select the spatially/spectrally subsetted file you created, and click
OK.

6. Click on Region #1 in the Select ROI for Calibration: field of the Flat field
Calibration Parameters dialog, enter an output filename (calibration for
example), and click OK to start the Flat Field correction.

Display a Color Composite Image and Extract Spectra

1. As in the steps above, select bands 5, 3, 1 (RGB - True Color) from the
Available Bands List dialog and click on Load RGB.

2. Once the image is displayed, start a spectral profile by choosing
Tools → Profiles → Z Profile (Spectrum) from the Main Image window
menu bar to display a spectrum of MASTER bands 1-25 (0.46 - 2.396

Figure 22-3: MASTER true-color composite for Cuprite Nevada with Flat-Field
ROI marked in red.
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micrometers). Note the corrected spectrum, corresponding to apparent
reflectance or relative reflectance (relative to the flat-field spectrum).

3. Use the interactive cursor to examine spectra for pixels throughout the image.
Look at areas that appear red on the true-color image for Fe+3 absorption
features near 0.87 micrometers (Band 9). Also zoom in on the 2.0 - 2.4
micrometer portion of the spectrum using the middle mouse button in the plot
and observe absorption features near 2.2 and 2.3 micrometers caused by clays
and carbonates respectively.

Compare Image Spectra

Compare the image spectra to spectra in the spectral library:

1. Select Spectral → Spectral Libraries → Spectral Library Viewer from the
ENVI main menu, click on Open Spectral Library at the bottom of the
Spectral Library Input File dialog and open the file usgs_min.sli and
click OK in the Spectral Library Input File dialog. Click on the spectrum
name alunite1.spc in the main list of the Spectral Library Viewer dialog
to display a spectrum for the mineral alunite. Click on budding1.spc to
display a spectrum of buddingtonite, calcite1.spc for calcite, and
kaolini1.spc for the mineral kaolinite. Stack the spectra by choosing
Options → Stack Data in the Spectral Library Plots window.

2. Use the image spectral profile to select MASTER spectra for the same
minerals. Browse through the data and examine the spectra for features near
2.2 and 2.3 micrometers. Extract a spectrum for 521:1587 (alunite), 424:1578
(buddingtonite), 239:1775 (calcite), and 483:1674 (kaolinite).

3. Select Options → New Window: Blank in the plot window to start a new plot
and use ENVI’s spectral drag-and-drop capabilities to drag spectra into the
window for comparison. Click using the right mouse button in the spectral
profile to display spectra names, click and drag using the left mouse button on
the spectral name to drag-and-drop the spectra into the window. Compare the
image spectra to the library spectra and the differences between the image
spectra.
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Figure 22-4: Spectral library reflectance spectra for selected minerals (left) and
MASTER reflectance spectra thought to be characteristic of the same materials

in the image.
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Image Processing with SAM

Use the image spectra to perform a Spectral Angle Mapper (SAM) classification of
the MASTER data. SAM measures the similarity of unknown and reference spectra
in n-dimensions. The angle between the spectra treated as vectors in n-space is the
spectral angle. This method assumes that the data have been reduced to apparent
reflectance and uses only the direction of the spectra, and not their length. Thus the
SAM classification is insensitive to illumination effects. See the Hyperspectral

Figure 22-5: Comparison of Spectral library reflectance spectra for selected
minerals and their corresponding MASTER apparent reflectance spectra from

the image.
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Tutorials and the ENVI User’s Guide and on-line help for additional background
information and examples.

To perform the SAM Classification:

1. Select Classification → Supervised → Spectral Angle Mapper or
Spectral → Mapping Methods → Spectral Angle Mapper from the ENVI
main menu.

2. Choose the MASTER apparent reflectance (flat field) data you created as the
input file in the Spectral Angle Mapper Input File dialog and subset to only
bands 20-25 by clicking on Spectral Subset and either entering the range or
clicking on the desired bands then clicking OK.

3. From the spectral plot containing the MASTER spectra you extracted from the
data, click the right mouse button to display the spectra names. Now click
using the left mouse button on each of the spectra names and drag into the
small black draw window at the top of the Endmember Collection: SAM
dialog. The spectrum name will be listed in the dialog. Select Options → Plot
Endmembers to confirm that you have the right endmember spectra.

4. Click Apply in the Endmember Collection: Sam dialog, enter the output file
names (spectralmapping for example), and click OK to start the
classification. The results of the classification will be a set of rule images
corresponding to the number of endmembers you selected and a SAM
Classification Image.

5. Display the SAM image by selecting the image in the Available Bands List,
clicking on the Gray Scale radio button and then Load Band. Compare the
SAM map to the color composite image. Select Tools → Link
Displays → Link and use the dynamic overlay to look at the spatial locations
of specific mapped minerals. Use the spectral profile tool to verify the spectral
match.

6. You can also use the rule images to evaluate the spectral matches. The rule
images show the best matches in black when first displayed, however, these
are typically inverted to better show the matches as bright pixels in the
displayed rule images. Display each of the rule images and select
Tools → Color Mapping → ENVI Color Tables from the Main Display
window menu bar and reverse the Stretch Bottom and Stretch Top slider bars
to invert the image. Select Tools → Link Displays → Link and use the
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dynamic overlay to look at the spatial locations of specific mapped minerals.
Use the spectral profile tool to verify the spectral match.

Figure 22-6: MASTER Spectral Angle Mapper result for Cuprite Nevada. Colors
correspond to colors of endmember spectra in previous figures.
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Overview of This Tutorial

This tutorial is designed to introduce you to analysis of Long-Wave Infrared (LWIR)
Multispectral Imagery from the MODIS/ASTER Airborne Simulator (MASTER)
sensor. The exercise covers opening and reading HDF-format files, extracting spatial
and spectral subsets, examination of LWIR spectra to define key spectral bands,
decorrelation stretching of color composites to enhance LWIR spectral differences,
and comparison of SWIR and LWIR mapping results. For additional details on
specific functions, please see the ENVI 3.5 User’s Guide or the ENVI On-Line Help.
This MASTER dataset and other MASTER data are available for purchase from
NASA through the EROS Data Center, Sioux Falls, SD.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 2

Path: envidata/cup99mas

Background

MASTER is designed to collect simulation data in support of the ASTER and
MODIS instrument teams in the areas of algorithm development, calibration, and
validation. Operated by NASA (see http://masterweb.jpl.nasa.gov/), MASTER is a
50-band scanner covering approximately the 0.4 - 14 micrometer range. The
instrument operates on the NASA Beachcraft B200, DC-8 or ER-2 aircraft to produce
spatial resolutions of 5-50m. Spectral band positions are designed to simulate both
ASTER and MODIS.

MASTER data are delivered via EROS Data Center in Hierarchical Data Format
(.hdf). HDF is a multi-object file format for the transfer of graphical and numerical
data between machines, and allows the user to create, access, and share scientific data
in a form that is self-describing and network-transparent. “Self-describing” means
that a file includes information defining the data it contains. “Network-transparent”
means that a file is represented in a form that can be accessed by computers with
different ways of storing integers, characters, and floating-point numbers. HDF data

File Description

9900511f.hdf Cuprite MASTER data in HDF format

header.txt MASTER ASCII Header file
Overview of This Tutorial ENVI Tutorials
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supported in ENVI include raster format images, images stored in 2 or 3-D scientific
data format, and plots stored in 1-D scientific data format.

In the longwave infrared (LWIR, 8-14 micrometers), emission spectra of typical
rocks indicate that this region is best suited for determining rock types based on shifts
of the emissivity minimum from around 8.5 µm for framework silicates (quartz and
feldspars) to progressively longer wavelengths for sheet and chain silicates, and
isolated SiO4. The MASTER sensor is unique in that it provides full coverage of the
0.4 - 14 µm region in 50 spectral bands.
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Long-Wave Infrared MSI Data Using MASTER

Open and Display MASTER HDF File

Use ENVI’s MASTER HDF capabilities to open the MASTER HDF file.

1. Select File → Open External File → Thermal → MASTER. Select
990051f.hdf in the cup99mas subdirectory. Alternatively, select
File → Open Image File and double click on 990051f.hdf and ENVI will
automatically recognize the file format. The 50 MASTER bands and their
associated wavelengths appear in the Available Bands List.

2. Click on the RGB radio button in the Available Bands List, then sequentially
on Bands 46, 44, 41. Click Load RGB to display a MASTER LWIR color
composite image.

Spatially/Spectrally Subset LWIR Data

1. Resize the Main Image window to cover a small area of interest centered on
Cuprite, Nevada by clicking and dragging one of the window corners to the
desired size. Cuprite is in the lower right corner of the displayed image.

Note
If you plan to perform the final comparison of SWIR and LWIR results at the
end of this tutorial, you should run the MASTER HDF/SWIR analysis (in the
previous tutorial) first and make sure that you extract the same spatial subset
for this tutorial.

2. Perform simultaneous spatial and spectral subsetting by selecting Basic
Tools → Resize Data (Spatial/Spectral) from the ENVI main menu and
clicking on the 9900511f.hdr file in the Resize Data Input File dialog.

3. Click on the Spatial Subset button, then Subset by Image in the Spatial
Subset dialog. Move the red box in the Subset Function dialog using the left
mouse button until an appropriate subset is outlined, and click OK. Then click
OK in the Spatial Subset dialog.

4. Click on the Spectral Subset button in the Resize Data Input File dialog,
then select Clear in the File Spectral Subset dialog. Select bands 41-50 (7.8 -
12.8 micrometers) by clicking and dragging on the names using the left mouse
button, or by entering the 41 and 50 for the range at the bottom of the dialog.
Clicking Add Range and OK to return to the Resize Data Input File dialog.
Click OK again.
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5. Enter an output filename in the Resize Data Parameters dialog, then click
OK to spatially and spectrally resize the data.

Display Various Bands

1. Select Band 41 in the Available Bands List, click on the Gray Scale radio
button, and Load Band to display a gray scale image.

2. Animate all of the resized LWIR bands to look at variability by choosing
Tools → Animation from the Main Image Window menu bar and clicking OK
in the Animation Image Parameters dialog. The 10 MASTER LWIR bands
will be loaded and ENVI will cycle through them. Note that most of the
variability displayed is caused by differential heating, not by between-band
spectral differences. Ideally these data should be atmospherically corrected,
then converted to emissivity to enhance spectral differences, however, to
simplify this tutorial, we will substitute selection of key image bands using
LWIR spectra, and enhancement using decorrelation stretching.

3. Change the animation speed and review individual frames to compare the
images, and select File → Cancel when finished. If desired, display individual
bands of interest using the Available Bands List and compare in different
displays using image linking and dynamic overlays.

Review LWIR Spectra/Spectral Features

ENVI includes spectral libraries from Johns Hopkins University containing spectra
for selected materials from 0.4 to 14 micrometers. The apparently seamless
reflectance spectra over this region of rocks and soils were generated using two
different instruments, both equipped with integrating spheres for measurement of
directional hemispherical reflectance. Under most conditions, the infrared portion of
these data can be used to calculate emissivity using Kirchhoff's Law (E = 1 - R).

For the purposes of this tutorial, however, highs in the reflectance spectra from the
JHU spectral library can be considered equivalent to lows expected in emissivity
spectra.

1. Select Spectral → Spectral Libraries → Spectral Library Viewer from the
main ENVI menu bar. Click on the Open Spec Lib... button, navigate to the
jhu_lib directory, and choose the spectral library minerals.sli. Click
OK.

2. Click on the first Quartz (Si02) and the second Calcite CaCO3 (calcite 1) in the
Spectral Library Viewer to display reflectance spectra of quartz and calcite
respectively. Select Edit Æ Plot Parameters to change the range of the
wavelength axis to be in between 8 and 13. Notice the maxima for quart
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(silica) near 9 micrometers (indicated by the dotted red line in the following
figure), and the lack of such a feature in Calcite. We can use this information to
help find all of the silica-rich areas imaged by the MASTER data.

Design and Display Color Composites

Based on spectra, use these steps to design and display color composites.

1. Use the left mouse button in the Spectral Library Plots window to examine the
nature of the two spectra. Look for contrasts between the two in the 8-14
micrometer range and equate contrasting wavelength positions to the
MASTER LWIR spectral bands.

2. Bands 46, 44, and 41 (10.085, 9.054, and 7.793 micrometers) bracket the
prominent silica feature near 9.0 micrometers. Click on the RGB Color radio
button in the Available Bands List and sequentially select these three bands
for display.

Figure 23-1: LWIR Reflectance Spectra
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3. Observe the image colors and relate to the expected relative contributions
based on the LWIR library spectra. Note that the colors don’t match the
expected colors very well. This is because the effect of temperature
overwhelms the spectral differences. The bands are highly correlated because
of differential heating of the rocks and soils.

Perform Decorrelation Stretch

Use Decorrelation stretch to enhance color differences. Decorrelation stretching
provides a means of removing the high correlation commonly found in LWIR
multispectral data.

Note
While ENVI provides a specific decorrelation routine, similar results can be
obtained by using a sequence of forward PCA, contrast stretching, and inverse PCA
transforms.

Figure 23-2: MASTER Color Composite image of Bands 46, 44, 41 (RGB)
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Decorrelation stretching requires three bands (a stretched color composite) for input.

1. If you don’t have a color image displayed, load bands 46, 44, and 41 for the
RGB bands as described above.

2. Select Transform → Decorrelation Stretch from the ENVI main menu and
click on the Display # of the displayed color composite in the Decorrelation
Stretch Input File dialog.

3. Enter an output filename and click OK to produce the decorrelated image.

4. Click on the RGB Color radio button in the Available Bands List and
sequentially choose the R DS, G DS, and B DS bands then click on Load RGB
to display the decorrelated image as shown in Figure 23-3. Try other color
combinations as well.

Figure 23-3: MASTER Decorrelated Color Composite Image of
Bands 46, 44, 41 (RGB)
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Compare LWIR and SWIR Results

Compare the Spectral Angle Mapper (SAM) result from the previous MASTER
exercise with the decorrelated LWIR image.

1. Load the SAM result in one display and the decorrelated image in a second
display.

2. Select Tools → Link Displays → Link and use the dynamic overlay to
compare the distribution of minerals mapped using the SWIR data versus the
distribution of silica (red areas) on the decorrelated image.

The following figure shows the MASTER decorrelated color composite image (left)
and the SAM classification image (right). In the following image, using SAM color
coding, red represents kaolnite, green represents buddingtonite, blue represents
alunite, and yellow represents carbonate.

Perform Combined SWIR/LWIR Analysis

Utilize the MASTER data in a combined analysis by following the methodology
described in the hyperspectral tutorials. Try utilizing bands 1-25 and bands 41-50
together in a combined hyperspectral analysis. Use the following steps as a guide.

Figure 23-4: MASTER Decorrelated Color Composite Image of Bands 46, 44, 41
(RGB), Left, and SAM Classification of MASTER SWIR Data, Right
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1. Open the Cuprite MASTER HDF file, extract the SWIR and LWIR bands
using spectral and spatial subsetting to build a combined data cube.

2. Select Transform → MNF Rotation → Forward MNF, create a MNF
output file, perform the MNF analysis by looking at the spectral bands and the
eigenvalue plots, then choose a reduced number of MNF bands for further
analysis.

3. Choose Spectral → Pixel Purity Index → [FAST New Output Band] and
run for around 10,000 iterations to find the key endmember spectra thus
reducing the spectral dimensionality. Threshold the PPI to a ROI with around
5000 pixels.

4. Select Spectral → N-Dimensional Visualizer → Visualize with New data
and choose the PPI region of interest for input. Rotate the n-dimensional
scatterplot in high-dimensions and select extreme pixels by drawing ROIs in
the n-D visualizer and exporting to Image ROIs.

5. Use ENVI’s spectral mapping methods (Spectral → Mapping
Methods → Desired Method to produce image maps utilizing the combined
datasets. Compare these results to the SWIR and LWIR results above.
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Overview of This Tutorial

This tutorial is designed to give you a working knowledge of ENVI's basic tools for
processing single-band SAR data (such as RadarSat, ERS-1, JERS-1).

Files Used in this Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/rsat_sub

Background

Concepts for processing SAR with ENVI

Most standard ENVI processing functions are inherently radar capable including all
display capabilities, stretching, color manipulations, classification, registration,
filters, geometric rectification, etc. Specific Radar menu items are also included
under the Radar menu for specific ENVI routines that are particularly useful for radar

File Description

lea_01.001 Radarsat Leader file

bonnrsat.img Radarsat image subset

bonnrsat.hdr ENVI Header for above

rsi_f1.img Frost filter result

rsi_f1.hdr ENVI Header for above

dslice.dsr Density Slice level save file

rsi_f2.img Laplacian filter result

rsi_f2.hdr ENVI Header for above

rsi_f3.img Laplacian Filter result with 0.9 addback

rsi_f3.hdr ENVI Header for above

rsi_fus.img Simulated Fused TM and Radarsat

rsi_fus.hdr ENVI Header for above

rsi_map.jpg Radarsat map composition example
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processing. Many of these can also be accessed from their functional areas on the
ENVI main menu. ENVI provides standard and advanced tools for analysis of
detected radar images as well as advanced SAR systems such as JPL's fully
polarimetric AIRSAR and SIR-C systems. ENVI can process ERS-1/ERS-2, JERS-1,
RADARSAT, SIR-C, X-SAR, and AIRSAR data as well as any other detected SAR
data set. In addition, ENVI is designed to handle radar data distributed in the CEOS
format, and should be able to handle data from other radar systems that distribute
their data in this format.

RadarSat Data

The ENVI software completed a RADARSAT Endorsement Review on 02/29/95.
ENVI's Radarsat capabilities were demonstrated using ENVI 2.5 on a Pentium 133
running Microsoft Windows NT 3.51. All ENVI SAR capabilities are fully cross-
platform portable, running identically on supported UNIX, Intel PC, and
Macintosh/Power Macintosh systems. The demonstration consisted of the following
components:

• CEOS Header Browsing

• Ingest Verification

• Path Image (SGF) from CD-ROM

• Path Image - ScanSAR (SCN) from CD-ROM

• Sample Point Target Grid (Beam 51, SGF) from 8mm Tape

• ENVI Features Demonstration - histograms, contrast stretching, band math,
filters, display, hard copy output, etc.

• Radiometric Enhancements

• Speckle Reduction

• Texture Analysis

• Edge Enhancement

• Registrations - Image-to-image, Vector, Map

• IHS Data Merge

Radarsat's review showed that ENVI already had most of the RADARSAT Level 1
and Level 2 capabilities including the following:

Level 1

• Existing features are all radar capable
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• Specific required features are already available in ENVI 2.0 at no extra cost

• Speckle reduction filters - Lee, Local Sigma, Bit Errors

• Texture Analysis - Data Range, First Moment, Second Moment, RMS

• Edge Enhancements - high pass, laplacian, directional

• Radiometric enhancements - linear, piecewise linear, gaussian, arbitrary,
LUTs

• Handling of 16 bit data files

Level 2

• Image-to-Image registration

• Image-to-Vector registration

• Image-to- Map registration

• Mosaicking

• RGB to HIS conversion and data merging

Radarsat-Specific Routines Added Starting with ENVI 2.5

ENVI RADARSAT-specific ingest routines and other modifications were added for
ENVI version 2.5 including:

• RADARSAT CEOS Reader for CD-ROM, Disk, and Tape with 16 bit or
8 bit ingest

• Compression on ingest

• RADARSAT CEOS Header/Trailer Browser

• Support for the following Platforms: UNIX (SUN, SGI, HP, IBM, DEC), Intel
PC (Windows 3.1, Windows NT, Windows 95), Macintosh and Power
Macintosh

ENVI Version 2.5 was certified as Radarsat Compatible on 02/29/95 and SAR
support has subsequently been improved with every version upgrade.
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Single-Band SAR Processing Scenario

This section of the tutorial describes a typical single-band SAR processing scenario
from data input through processing and analysis, to publication-quality and/or map
output. Data used for the example are a subset of a Radarsat 1 Path Image, Fine Beam
2, December 17, 1995, Bonn, Germany.

Read CEOS Data, Display Data, and Review Quality

ENVI provides the tools to read Generic CEOS data tapes and Radarsat Data from
both Tape and CD-ROM.

• For tape reading, select File → Tape Utilities → Read Known Tape
Formats → Radarsat CEOS

• To read original RadarSat data from disk or CD select
Radar → Open/Prepare Radar File → Radarsat

1. For the purposes of this tutorial, a Radarsat image subset has already been
extracted. From the ENVI main menu, select File → Open Image File and
choose the file bonnrsat.img from the rsat_sub directory.

2. Load the image into an ENVI display window by choosing the band name in
the Available Bands List and clicking on Load Image at the bottom of the
dialog.

Figure 24-1 shows the image subset of the Radarsat Image of Bonn, Germany, with a
2% Linear Stretch applied. These data were acquired during the Radarsat
commissioning phase and should not be used for scientific analysis or interpretation.
Data are copyright, Radarsat, 1995.
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Review CEOS Header

Many SAR data sets are distributed in CEOS format. ENVI provides generic tools to
read CEOS headers and display CEOS header information on-screen. ENVI also has
tools specifically designed to read Radarsat CEOS headers, which contain additional
information.

1. Select Radar → Open/Prepare Radar File → View RADARSAT Header.

2. Choose the RadarSat leader file lea_01.001 or one of the other files to
extract the CEOS information and display on-screen.

Figure 24-1: Radarsat Subset of Bonn, Germany with 2% Linear Stretch Applied
Single-Band SAR Processing Scenario ENVI Tutorials
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Contrast Stretching (Square Root)

Radar data typically cover a large range of data values. As seen above, default linear
stretches do not do a very good job of contrast enhancing most radar images. ENVI's
square-root stretch provides a means of spreading radar data out better over a given
range of gray scales than other types of stretches, thus permitting improved display of
Radar images. Figure 24-3 shows a square-root stretch of the Radarsat image of Bonn
Germany. Compare to the linear contrast stretch above.

1. To perform a square-root stretch with ENVI, display the image to be stretched
and select

2. Enhance → [Image] Square-Root.

Figure 24-2: Radarsat CEOS Header Information From the Leader File
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The stretch will be applied to the data based on the statistics of the data in the
Main Display window.

3. Display the image in a new window and select Tools → Link → Link
Displays to link the square-root image back to the 2% linear stretch image.
Click and drag using the left mouse button to compare the two images using
the dynamic overlay.

Remove Speckle using Adaptive Filters

Adaptive filters provide a means of removing radar speckle from images without
seriously affecting the spatial characteristics of the data. The Frost filtered image
shown below is a considerable improvement over the unfiltered data. The Frost filter,
an exponentially damped, circularly symmetric filter that uses local statistics, is used
to reduce speckle while preserving edges in the data. The pixel being filtered is
replaced with a value calculated based on the distance from the filter center, the

Figure 24-3: Radarsat Image with Square Root
Contrast Stretch Applied
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damping factor, and the local variance. Compare to the images above and to the
dynamic overlay image below. To perform the Frost Filter on the Radarsat data:

1. Select Radar → Adaptive Filters → Frost.

2. Choose bonnrsat.img as the input image and use the default filter size (3x3)
and Damping factor (1.0). Enter an output filename and click OK, or load the
pre-saved file rsi_f1.img to a second display using a square root stretch.

3. Select Tools → Link → Link Displays to link the Frost filtered image back to
the 2% linear stretch image. Click and drag using the left mouse button to
compare the two images using the dynamic overlay.

Figure 24-4: Frost Filter Result
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Density Slice

Density slicing provides a means of visually enhancing radar differences based on
image brightness. The density sliced image below has four levels, with higher radar
backscatter in the warmer colors.

1. In the Frost Filtered image display choose Tools → Color Mapping → 
Density Slice.

2. Enter the desired ranges and colors in the Density Slice dialog by choosing
File → Restore Ranges and selecting the file dslice.dsr. Then click Apply
in the Density Slice dialog to density slice the image.

3. Use dynamic overlays to compare to the gray scale images above.

Figure 24-5: Density sliced Radarsat Image
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Edge Enhancement

A Laplacian Filter can be used to enhance edges in SAR data and other data types.
This is a convolution filter with a kernel (for a 5 x 5 filter) of:

1. From the ENVI main menu, select Filter → Convolutions to open the
Convolutions and Morphology Tool. Click Convolutions → Laplacian.

2. Set the Kernel Size to 5 x 5 and click Quick Apply to select the
bonnrsat.img and click OK. Alternately, view the pre-saved file
rsi_f2.dat.

Applying the kernel in this fashion strongly enhances the edges and causes loss
of most of the radiometric information.

3. Choose the filter as above, but enter the value of 90 for the Image Add Back
value. Use bonnrsat.img and the default parameters to create a new output
file or view the pre-saved file rsi_f3.dat. (See Figure 24-6).

4. Compare the result to the filtered image and to the original data using dynamic
overlays.

0 0 -1 0 0

0 -1 -2 -1 0

-1 -2 16 -2 -1

0 -1 -2 -1 0

0 0 -1 0 0
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Data Fusion

One of the strengths of SAR data is its highly complementary nature with respect to
other data sets. Radar data provides a wealth of spatial information that isn't present
in many other types of image data. Conversely, however, SAR data doesn't have
much compositional information, which is typically expressed in multispectral
optical data sets. This situation leads naturally to the use of combined SAR/Optical
data.

The most common means of combining data sets is the use of Intensity, Hue,
Saturation (IHS) transforms to combine a multispectral, color-composite image with
a monochromatic SAR sharpening band. ENVI provides a simple tool to conduct data
merging using IHS.

No optical data set was available that corresponded to the Bonn Radarsat data so you
are not able to perform this function with these data. The example and figure below,
however, illustrate a simulated image showing IHS-Merged Data of an unrelated
Landsat Thematic Mapper data set. This image is designed to give you an idea of how
a merged SAR/Optical dataset might appear. ENVI also provides a Color
Normalization (Brovey) transform for data fusion.

Figure 24-6: Edge Enhancement Results; Left Image is Laplacian,
Right is with 90% Add Back
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1. Given 3-band color composite image, select Transform → Image
Sharpening → HSV and then enter the three bands for the color composite
into the Select Input RGB Input Bands dialog.

2. Select the single band SAR image.

If the two images have the same spatial dimension, ENVI goes ahead with the fusion.
If the two data sets are both georeferenced, but with different pixel sizes, ENVI
resamples low resolution image to match the high resolution image, then fuses the
two data sets.

Figure 24-7: Simulated TM-Radarsat Data Fusion Result
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Image-Map Output

The final output from any image processing within ENVI is usually a map-oriented,
scaled image-map for presentation or visual analysis and interpretation. Radar data
can be used in map composition like any other data set. If map registration is desired,
ENVI includes full image-to-image and image-to-map registration capabilities.
Please see the Map Registration tutorial or the ENVI 3.5 User’s Guide or On-line
Help for more information.

ENVI also provides all of the tools to produce fully annotated publication-quality
maps. This includes pixel, map, and geographic (latitude/longitude) grids; scale-bars;
declination diagrams and north arrows; text and symbols; polygons, polylines, and
geometric shapes (circles, rectangles); map keys and legends; and image insets. For
additional information on map composition, please see the Map Composition tutorial
in this volume, or the ENVI 3.5 User’s Guide or On-line Help.

Figure 24-8: Radarsat Image-Map Composition
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End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click Yes to end the
session. If you are using ENVI RT, quitting ENVI will take you back to your
operating system.
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Summary

ENVI is fully radar capable (Radarsat Level 2 Certified); most of ENVI's routines
work transparently with SAR data. ENVI also provides a series of specialized tools
for analysis of both single-band and polarimetric, multifrequency Radar data. A
typical scenario might consist of Reviewing the CEOS header, reading the CEOS
data, displaying and contrast stretching, removing speckle using an adaptive filter,
density slicing, edge enhancement, data fusion, and map composition. These tools
provide end-to-end SAR processing capabilities, including tape/CD-ROM input,
processing, analysis, and publication output within a single software system.
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Analysis
The following topics are covered in this tutorial:
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Overview of This Tutorial

The following tutorial demonstrates the use of ENVI’s radar data analysis functions.
Data from the Spaceborne Imaging Radar-C (SIR-C) for Death Valley, California are
used in this example. The data were obtained by SIR-C onboard the Space Shuttle
Endeavor in April 1994.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/ndv_sirc

Background: SIR-C/SAR

SIR-C is a polarimetric synthetic aperture radar that uses two microwave
wavelengths: L-band (24 cm) and C-band (6 cm). The SIR-C radar system was flown
as a science experiment on the Space Shuttle Endeavor in April (SRL-1) and October

File Description

Required Files

ndv_l.cdp L-band SIR-C subset in ENVI Compressed Data
Product .cdp format.

pol_sig.roi Saved Regions of Interest (ROI).

texture.dsr Saved Density Slice Range .dsr file.

Generated Files

ndv_l.syn Synthesized images (~2.5 Mb, also generates .hdr
file).

ndv_l2.syn Synthesized images in dB (~5 Mb, also generates .hdr
file).

ndv_gam.img Gamma filter result (~0.6 Mb, also generates .hdr file).

ndv_gr.img Slant to ground range result (~0.9 Mb, also generates
.hdr file).

ndv_hh.tex Texture filter result (~2.5 Mb, also generates .hdr file).

envi.ps Output ENVI postscript file (~3.8 Mb).
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1994 (SRL-2), collecting high quality SAR data over many sites around the world (a
second radar system—“X-SAR”—was also flown on this mission, but these data are
not discussed or processed here). Additional information about SIR-C is available on
the NASA/JPL Imaging Radar Home Page on the World Wide Web at
http://southport.jpl.nasa.gov/.

Analyzing SIR-C Data

The data used in this tutorial are a subset of L-band “Single Look Complex” (SLC)
SIR-C data that cover the northern part of Death Valley, including Stovepipe Wells, a
site of active sand dunes and extensive alluvial fans at the base of mountains. These
data have been pre-processed by reading/subsetting from tape and multilooking
(averaging) to 13 m square pixels. The data are provided in a special ENVI
“Compressed Data Product (.cdp) format. This is a non-image format similar to the
tape format and can not be viewed until images are “synthesized” for specific
polarizations.

The first two functions described in this example—reading the data tape and
“multilooking”— have been pre-applied to the SIR-C data. We include the sections
here for completeness in dealing with SIR-C data. Skip to the section “Synthesize
images - Start The Actual Work Here” if you are not interested in reading about data
input and preparation.

Read a SIR-C CEOS Data Tape

Note
The file used for this exercise has already been read from tape and saved in a file.
Instructions on reading a SIR-C tape are included here only for completeness.

1. Select File → Tape Utilities → Read Known Tape Formats → SIR-C
CEOS to read a SIR-C CEOS data tape into ENVI.

The SIRC Format - Load Tape dialog will appear. See the Tape Reading
section of the ENVI User’s Guide for details on the SIR-C tape-reading
function. To read a tape:

2. Enter the tape device name and let the record size default to 65,536.

3. Click OK.

The tape will be scanned to determine what SIR-C files it contains and a dialog
will appear, allowing you to select the desired data sets. By default, ENVI will
read all of the data files on the tape.

4. If you do not want to read all of the data files, click Clear and then click on the
box next to each desired file. When the files are selected, click OK.
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5. The selected data files can be subset and multilooked independently as they are
being read from tape. We recommend, however, that multilooking be
performed on disk files unless insufficient disk space is available, as this
function is extremely slow from tape.

6. Click on a filename, then click on Spatial Subset or Multi-Look to enter
parameters for the data file and enter an output filename.

Each input file must have an output filename. By convention, the output filenames
should take the form filename_c.cdp and filename_l.cdp for the C- and L-
bands, respectively.

The SIR-C data will be read from the tape and one compressed scattering matrix
output file created for each data set selected.

Multilook SIR-C Data

Multilooking is a method for reducing speckle noise in SAR data and for changing
the size of a SAR file. SIR-C data can be multilooked to a specified number of looks,
number of lines and samples, or azimuth and range resolutions.

Note
The SIR-C file used in this tutorial was a single look dataset that had a range
resolution of 13 m and an azimuth size of 5 m. Multilooking has already been
performed in the azimuth direction to make 13 m square pixel sizes. Instructions on
Multilooking are included here only for completeness in dealing with SIR-C data.
To multilook a dataset:

1. Select Radar → Polarimetric Tools → Multilook Compressed
Data → SIR-C Multilook.

2. When the Input Data Product Files dialog appears, click Open File and
select the input file.

ENVI will detect whether the file contains L- or C- band data and display the
file name in the appropriate field of the dialog.

3. Click OK.

4. Select the file to multilook by selecting the box next to the name. You can
select multiple files.

5. Enter any one of three values—number of looks, number of pixels, or pixel
size—and the other two will be calculated automatically. Both integer and
floating point number of looks are supported.
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6. Enter the desired values in the appropriate box for both Samples (range) and
Lines (azimuth).

7. Enter the base file name in the appropriate text box and click OK.
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Synthesize Images

Note
Begin the tutorial exercises here.

The SIR-C quad-polarization data provided with this tutorial and available on tape
from JPL are in a non-image, compressed format. Accordingly, images of the SIR-C
data must be mathematically synthesized from the compressed scattering matrix data.
You can synthesize images of any transmit and receive polarization combinations
desired.

1. Select Radar → Polarimetric Tools → Synthesize SIR-C Data.

2. When the Input Product Data Files dialog appears, click Open File to
display a standard file selection dialog and navigate to the
envidata/ndv_sirc directory.

3. Select the file ndv_l.cdp from the list. When the filename appears in the
Selected Files L: field, click OK.

The Synthesize Parameters dialog appears.

Figure 25-1: Synthesize Parameters Dialog.
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Default Polarization Combinations

Four standard transmit/receive polarization combinations—HH, VV, HV, and TP—
will be listed in the “Select Bands to Synthesize” list in the Synthesize Parameters
dialog. By default, these bands are selected to be synthesized.

1. Enter the output filename ndv_l.syn with its correct path in the Enter
Output Filename field.

2. Select Byte from the Output Data Type pulldown menu. This will scale the
output data to byte values. Make the appropriate selections and click OK.

Note
If you will be doing quantitative analysis, the output should remain in
floating point format.

An ENVI Status Window will appear and after a short wait, the file
NDV_L.SYN will be created, and four bands corresponding to the four
polarization combinations will be added to the Available Bands List, which
appears automatically.

Other Polarization Combinations

The transmit and receive ellipticity and orientation angles determine the polarization
of the radar wave used to synthesize an image. The ellipticity angle falls between -45
and 45 degrees and determines the “fatness” of the ellipse. The orientation angle is
measured with respect to horizontal and ranges from 0 to 180 degrees.

You can synthesize images of non-default polarization combinations by entering the
desired parameters as follows.

1. Select Radar → Polarimetric Tools → Synthesize SIR-C Data. The file
ndv_l.cdp should still appear in the Selected Files field.

2. Click OK.

3. Enter -45 and 135 in the Transmit Ellip and Orien fields respectively and -45
and 135 in the Receive Ellip and Orien fields respectively.

4. Click the Add Combination button. This will produce a right hand circular
polarization image.

5. Enter 0 in both the Transmit Ellip and Receive Ellip fields and 30 in both the
Orien fields for both Transmit and Receive.
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6. Click the Add Combination button. This will produce a linear polarization
with an orientation angle of 30 degrees.

7. Click Clear under the list of standard polarization combinations to turn off
synthesis of the standard polarization bands which have already been
generated.

8. Select Yes radio button for Output in dB?. This will produce images that are
in decibels and therefore have values typically between -50 and 0.

9. Enter the output filename ndv_l2.syn and click OK.

The file ndv_l2.syn will be created, and two bands corresponding to the two
polarization combinations will be added to the Available Bands List.

Figure 25-2: Synthesize Parameters Dialog with non-standard orientation and
ellipticity angles.
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Display Images

1. Click on the band named [L-TP]: ndv_l.syn in the Available Bands List, and
click Load Band. The SIR-C L-band total power image will be displayed in a
new window.

2. Investigate the image using the Scroll and Zoom windows.

Figure 25-3: L-Band SIR-C Total Power Image with Gaussian stretch applied.
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3. Select Enhance → Interactive Stretching from the Main Image Display
window menu bar. A window containing a histogram plot of the data in the
image window appears.

The histogram plot shows the current stretch with (between the vertical dotted
lines) on the input histogram and the corresponding DN values in the text
boxes.

4. Click the left mouse button on and drag the dotted vertical lines to change the
stretch or enter the desired DN values into the appropriate fields.

5. Enter 5% in the left text box in the dialog and enter 95% in the right text box.

6. Select Stretch Type → Gaussian (initially set to Linear) and the stretch will
be automatically applied This will perform a gaussian stretch with a 5% low
and high cut-off.

7. Also try to compare the linear and square-root stretches.

8. To display a color composite image, select the RGB Color radio button in the
Available Bands List.

9. Click on the [L-HH]: ndv_l.syn, [L-VV]: ndv_l.syn, and [L-HV]: ndv_l.syn
bands.

10. Select New Display from the Display pulldown menu in the Available Bands
List. to start a new display window.

11. Click Load RGB to display the HH band in red, VV in green, and HV in blue.

12. Adjust the stretch as desired (Gaussian and Square Root both work well on all
three bands).

13. Display the other synthesized bands as desired.

The color variations in the images are caused by variations in the radar reflectivity of
the surfaces. The bright areas in the sand dunes are caused by scattering of the radar
waves by vegetation (mesquite bushes). The alluvial fans show variations in surface
texture due to age and composition of the rock materials.
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Define ROIs for Polarization Signatures

Polarization signatures can be extracted from the SIR-C compressed scattering matrix
for a Region of Interest (ROI) or a single pixel in a polarimetric radar image. ROIs
are defined by selecting pixels or by drawing lines or polygons within an image.

1. Select Overlay → Region of Interest in the window containing the grayscale
L-TP image. The ROI Tool dialog appears.

2. Four ROIs were previously defined and saved for use in extracting polarization
signatures for the purposes of this tutorial. Restore the pre-saved ROIs by
selecting File → Restore ROIs and selecting the filename pol_sig.roi.

A dialog box will appear stating that the regions were restored. Click OK.

3. Regions named veg, fan, sand, and desert pvt will appear in the
Available Regions of Interest list box and will be drawn in the image
window.

Regions can be drawn in both the image and zoom windows and can consist of
any combination of polygons, lines, and pixels.

You can also draw your own Regions of Interest using ENVI’s standardized
ROI tools.

Figure 25-4: Predefined ROIs for Polarization Signatures
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4. Select the type of region to draw by clicking in the box next to ROI_TYPE →
and then Polygon, Polyline, or Point.

• Draw polygons by clicking the left mouse button to select the endpoints of
line segments or holding down the mouse button and moving the cursor for
continuous drawing. Click the right mouse button once to close the
polygon and a second time to accept the polygon

• Draw polylines in the same manner as polygons. Click the left mouse
button to define the line endpoints and click the right button to end the
polyline and again to accept the polyline

• Point mode is used to select individual pixels. Click the left mouse button
to add the pixel currently under the cursor to the ROI.

Multiple polygons, lines, and pixels may be selected for each ROI.

5. Click New Region to define another ROI, enter a name, and choose a color.

6. Draw a second ROI.

ROIs can be saved to a file and restored at a later time by choosing File → Save ROI
in the ROI Tool dialog.

Extract Polarization Signatures

Polarization signatures are 3-D representations of the complete radar scattering
characteristics of the surface for a pixel or average of pixels. They show the
backscatter response at all combinations of transmit and receive polarizations and are
represented as either co-polarized or cross-polarized. Co-polarized signatures have
the same transmit and receive polarizations. Cross-polarized signatures have
orthogonal transmit and receive polarizations. Polarization signatures are extracted
from the compressed scattering matrix data using the ROIs for pixel locations.
Polarization signatures are displayed in viewer windows; the figure below shows an
example.
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To extract your own polarization signatures:

1. Select Radar → Polarimetric Tools → Extract polarization
Signatures → SIR-C. The filename ndv_l.cdp should appear in the Input
Data Product Files dialog. If not, click Open File and select this file.

2. Click OK. The Polsig Parameters dialog will appear.

3. Select the four ROIs (veg, fan, sand, and desert pvt) by clicking Select
All.

4. Select the Memory radio button and then click OK.

Four Polarization Signature Viewer dialogs will appear, one for each ROI. The
polarization signatures are displayed as both 3-D wire mesh surface plots and
as 2-D gray scale images.

Figure 25-5: Polarization Signature Viewer.
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The X and Y axes represent ellipticity and orientation angles and the vertical
axis can be selectively plotted as intensity, normalized intensity, or dB by
selecting the desired option from the Polsig_Data pulldown menu.

5. Polarization signature statistics are displayed at the bottom of the Polarization
Signature Viewer window.

Notice the range of intensity values for the different surfaces. The smoother
surfaces — sand and desert pvt — have low Z values. The rough surfaces —
fan and veg — have higher Z values. The minimum intensity indicates the
“pedestal height” of the polarization signature. The rougher surfaces have
more multiple scattering and therefore have higher pedestal heights than the
smoother surfaces. The shape of the signature also indicates the scattering
characteristics. Signatures with a peak in the middle show a Bragg-type
(resonance) scattering mechanism.

6. Change the Z axis by selecting Polsig_Data → Normalized from the
pulldown menu.

This normalizes the signature by dividing by its maximum and plots it between
0 and 1. This representation shows the difference in pedestal heights and
shapes better, but removes the absolute intensity differences.

Alternately select Polsig_Data → Co-Pol and Cross-Pol to toggle between
co-polarized and cross-polarized signatures.

7. Use the left mouse button to drag a 2-D cursor on the polarization signature
image on the right side of the plot. Note the corresponding “3-D” Cursor in the
polarization plot.

8. Click the left mouse button and drag on one of the axes to rotate the
polarization signature in real time.

9. The signatures can be output by selecting File → Save Plot As in the
Polarization Signature Viewer window or directly to a printer using File →
Print

10. When you have finished examining the polarization signatures, select
File → Cancel to close the Polarization Signature Viewer window.

Use Adaptive Filters

Adaptive filters are used to reduce the speckle noise in a radar image while
preserving the texture information. Statistics are calculated for each kernel and used
as input into the filter allowing it to adapt to different textures within the image.
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1. Select Radar → Adaptive Filters → Gamma. The Gamma Filter Input
File dialog will appear with a list of open files. The filters can be run on an
entire file or an individual band.

2. Click on the arrow toggle button next to the Select By File field to toggle to
Select By Band and list the bands in the files.

3. Select the band [L-HH]:NDV_L.SYN and click OK. The Gamma Filter
Parameters dialog will appear.

4. Specify a Filter Size (NxN) of 3 and the Number of Looks to 1.000 and output
the result to memory by selecting the Memory radio button.

5. Click OK. The resulting image name will appear in the Available Bands List
as Gamma ([L-HH]: NDV_L.SYN).

Display the Filter Result

1. Select the Gray Scale radio button and then select the band name in the
Available Bands List.

2. Select New Display” from the pulldown Display button at the bottom of the
Available Bands List to start a new display window, then click Load Band.

3. Select Enhance → [Image] Square Root in the Main window to perform a
Square Root stretch on the image.

You can use dynamic overlays to compare the results of the Gamma filter to
the original image.

4. Display the original band by selecting [L-HH]: NDV_L.SYN in the Available
Bands List, starting a new display and clicking Load Band.

5. Perform a quick Square Root stretch on this image as well.

6. Select Tools → Link → Link Displays. The Link Displays dialog will
appear.

7. Make sure that Yes appears only next to the names of the two displays that
contain the Gamma filtered and original images and click OK.

Dynamic overlay is activated automatically when the windows are linked.

8. Click the left mouse button in either image to cause a small portion of the
second linked image (the overlay) to appear in the first image (the base).

The overlay is active in both windows simultaneously and in the Zoom
window.
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9. Move the overlay by clicking and holding the left mouse button and moving
the cursor.

10. Change the size of the overlay by pressing the middle mouse button and
dragging the corner of the overlay to the desired location.

11. Compare the Gamma Filter image to the original data.

12. Turn the dynamic overlay feature off by selecting Tools → Link → Unlink
Displays or Dynamic Overlay Off in the Main window.

Slant-to-Ground Range Transformation

Slant range radar data have a geometric distortion in the range direction. The true or
ground range pixel sizes vary across the range direction because of the changing
incidence angles. This geometric distortion is corrected by resampling the slant range
data to create ground range pixels that are a fixed size. The slant-to-ground range
transformation requires information about the instrument orientation. For SIR-C data,
the necessary information is found in the CEOS header.

Preview the CEOS header using Radar → Open/Prepare Radar File → View
Generic CEOS Header and selecting the file ndv_l.cdp. Scroll down the CEOS
Header Report and note that the line spacing (azimuth direction) is 5.2 meters while
the pixel spacing (slant range direction) is 13.32 meters. The Slant-to-Ground-Range
function will be used to resample the output image to a square 13.32 m pixel, thus
removing slant-range geometric distortion.

1. Select Radar → Slant to Ground Range → SIR-C.

2. When the Enter SIR-C Parameters Filename dialog appears, select the file
ndv_l.cdp. The Slant Range Correction Input File dialog will appear.

3. Select the file ndv_l.syn and click OK. The Slant to Ground Range
Correction Dialog will appear and all of the pertinent information will be
filled in from the CEOS header in the .cdp file.

4. Enter 13.32 in the Output pixel size field to generate square ground-range
pixels.

5. Select Bilinear as the Resampling Method, enter ndv_gr.img as the output
filename, and click OK. The input image is resampled to 1152 13.32m sized
square pixels.

6. Display this image and compare it with the slant range image.
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Use Texture Analysis

Texture is the measure of the spatial variation in the grey levels in the image as a
function of scale. It is calculated within a processing window of user-selected size.
The texture measures demonstrated in this tutorial are Occurrence Measures,
including Data Range, Mean, Variance, Entropy, and Skewness. These terms are
explained in the ENVI User’s Guide and on-line help. Texture is best calculated for
radar data that has not had any resampling or filtering applied.

1. Select Radar → Texture Filters → Occurrence Measures.

2. When the Texture Input File dialog appears, click the Select By toggle
button and select Band and then select the band [L-HH]: ndv_l.syn and
click OK.

3. In the Occurrence Texture Parameters dialog, deselect all of the Textures to
Compute except for Data Range, change the Processing Window: Rows and
Cols to 7 x 7, enter an output filename ndv_hh.tex, and click OK.

An ENVI Status Window will appear and after a short wait the new band will
be listed in the Available Bands List.

Create Color-coded Texture Map

Display the resulting Data Range texture image by clicking on the band name Data
Range:[L-HH] in the Available Bands List and clicking Load Band.

1. Perform a quick square root stretch on the image.

2. Select Tools → Color Mapping → Density Slice in the Main Image display.

3. Select the Data Range:[L-HH] band in the Density Slice Band Choice
dialog and click OK.

4. In the Density Slice dialog, apply the default ranges by clicking on Apply.
Examine this image with respect to the original data using image linking and
dynamic overlays.

5. Now select Tools → Cursor Location/Value in the Main window and look at
the Data Range values while roaming around the image.

6. Try creating your own density sliced image or use the predetermined color-
coded density slice TEXTURE.DSR saved for your use by selecting
File → Restore Ranges in the Density Slice dialog, selecting the file
texture.dsr and clicking Open, and then Apply.

This density slice shows the various textures in the image in distinct colors.
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Display and density slice some of the other texture measures and use dynamic
overlays to compare to each other and the original data.

Create an Image-Map for Output

1. With the Data Range texture measure displayed, add a border around the
image to place a key and text annotation.

2. Select Overlay → Annotation in the main window.

3. When the Annotation dialog appears, select Options → Set Display Borders.

4. Enter 100 in the upper text box, select a Border Color of White, and click
OK. This will make a 100 pixel white border at the top of the image.

5. Position the Main Image indicator box in the Scroll window at the top of the
image to display the portion of the image with border.

6. Place a title at the top of the image by entering a title into the text field in the
center of the dialog.

7. Enter 16 in the Size field to change the font size and change the Color to
Black.

8. Place the title on the image by using the left mouse button to position it and
clicking the right button to fix the location.

Multiple text items can be placed on the image in this manner and the font size,
type, color, and thickness can be changed.

9. Put a color table ramp in the top border of the image for a color-code key by
selecting Object → Color Ramp in the Annotation dialog.

10. Enter Min and Max values of 0 and 255 respectively, set Inc to 4, and the font
Size to 14 to annotate the color ramp.

11. Position the color ramp using the left mouse button and fix the location by
clicking the right mouse button.

12. Add any other objects desired to the image using the annotation dialog.

13. Save the image to a PostScript file by selecting File → Save Image
As → Postscript File.

14. Enter an output filename or let the name default to ndv_hh.ps. and click OK.
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15. Optionally, output directly to your printer by selecting File → Print.

End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click OK to exit IDL. If
you are using ENVI RT, quitting ENVI will take you back to your operating system.
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Analysis of DEMs and
TOPSAR
The following topics are covered in this tutorial:
Overview of This Tutorial . . . . . . . . . . . . . 542
Display and Convert the Data . . . . . . . . . . 544

Analysis of JPL Polarimetric SAR Data . . 551

Displaying and Analyzing DEMs . . . . . . 555
Summary . . . . . . . . . . . . . . . . . . . . . . . . . 564
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Overview of This Tutorial

This tutorial uses Polarimetric SAR data and a Digital Elevation Model (DEM)
generated from JPL’s TOPSAR (interferometric SAR) data for Tarrawarra, Australia.
Data Courtesy of JPL. The exercise demonstrates input and display of the SAR data
and display and analysis of the DEM using standard tools within ENVI. For the
DEM, these include data input; grayscale and color-density-sliced display; generation
and overlay of elevation contours, use of ENVI’s X, Y, and arbitrary profiles
(transects) to generate terrain profiles; generation of slope, aspect, and shaded relief
images; and 3-D perspective viewing and image overlay.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/topsar

File Description

Required Files

ts0218_c.vvi C-Band VV-polarization image, integer format.
Original name ts0218_c.vvi2

ts0218_c.cor C-Band Correlation image: original name
ts0218_c.corgr

ts0218_c.dem C-Band-Derived, integer-scaled DEM: original name
ts0218_c.demi2

ts0218_c.inc C-Band incidence angle image: original name
ts0218_c.incgr

ts0218_l.dat L-Band stokes matrix data

ts0218_p.dat P-Band stokes matrix data

Generated Files

ts0218lp.syn L- and P-Band Synthesized data

ts0218lp.hdr Generated ENVI Header for above

ts_cgam.img Generated Gamma filtered image

ts_cgam.hdr Generated ENVI Header file for above
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Note
This dataset includes all of the typical files provided by JPL for a TOPSAR
distribution tape or CD. Some of the filenames have been changed from JPL’s
standard naming convention because they would have non-unique ENVI header
names using DOS 8.3 filenames, and thus could not be used directly by systems
supporting only the DOS convention (Windows 3.1). The original filenames are
indicated in the file descriptions.

Background - TOPSAR and DEMs

TOPSAR data are a polarimetric Synthetic Aperture Radar (SAR) dataset generated
by an airborne SAR system flown by Jet Propulsion Laboratory (JPL).

Description of the Dataset

The data consist of fully polarimetric (quad polarized) data for both P- and L-band
and a C-Band VV-polarization image. The Digital Elevation Model (DEM) provided
is generated by JPL using SAR interferometry using the C-Band antenna. Also
provided are the correlation image and an incidence angle image generated from the
C-band data.

ts_ped.img Generated Pedestal Height image

ts_ped.hdr Generated ENVI Header for above

topsar.img Generated DEM image scaled to meters, C-VV scaled
to Sigma Zero, and incidence angle and correlation
images

topsar.hdr Generated ENVI Header for above

File Description
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Display and Convert the Data

In this section of the tutorial, you will display the data and convert them to physical
parameters. JPL provides several images for display including the C-Band VV,
C-Band correlation image, and C-Band Incidence Angle image, which are easily
displayed using ENVI TOPSAR routines. The P- and L-Band data are provided as
non-viewable Stokes Matrix data and images must be synthesized as described
below.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To start ENVI in UNIX, enter envi at the UNIX command line.

• To start ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

View the TOPSAR Headers

1. Select Radar → Open/Prepare Radar File → View AIRSAR/TOPSAR
Header.

Note
Note that on some platforms you must hold the left mouse button down to
display the submenus from the Main Menu.

An AIRSAR/TOPSAR Input File selection dialog appears.

2. Navigate to the topsar subdirectory of the envidata directory on the ENVI
Tutorial and Data CD No. 1 just as you would in any other application and
select ts0218_c.vvi.

The AIRSAR File Information dialog appears listing information from the
embedded AIRSAR Integrated Processor headers.

3. Review the New Header, Parameter Header, and the Calibration Header
sections.
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4. Repeat the above for the DEM file ts0218_c.dem, viewing the New Header,
Parameter Header, and the TOPSAR DEM Header, in place of the above
Calibration Header.

Load and Display the Raw C-Band image

1. Select Radar → TOPSAR Tools → Open TOPSAR File and choose the file
ts0218_c.vvi.

This opens the TOPSAR C-Band data and displays without converting the data
to physical units (Sigma Zero), utilizing the embedded AIRSAR/TOPSAR
header to get the required file information. This also loads the image into the
Available Bands List.

Note
This file can also be opened from File → Open External File →
Radar → TOPSAR. You could also open this file using the generic file
opening procedure, File → Open Image File, but you would have to
manually enter the file parameters.

2. Make sure that the Gray Scale radio button is selected, choose the image at the
top of the dialog, and click on Load Band to load the image.

3. Examine the geometry and characteristics of the image. Start the Cursor
Location/Value dialog by selecting Tools → Cursor Location/Value from
the Main Image Display menu bar.

This is a ground-range C-Band VV-polarization image scaled to integer
format. A scaling factor must be applied to the data to convert to Sigma Zero
(radar backscatter coefficient).

4. Review the image pixel values, observing the general magnitude of the
numbers (integer values).

Load and Display the Raw DEM image

1. Select Radar → TOPSAR Tools → Open TOPSAR File and choose the file
ts0218_c.dem.

This opens the TOPSAR DEM data, utilizing the embedded
AIRSAR/TOPSAR header to get the required file information and loads the
image into the Available Bands List. You could also open this file using
File → Open Image File, but you would have to manually enter the file
parameters.
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2. Display the image by clicking on the band name in the Available Bands List,
select New Display and then on Load Band. Select Tools → Cursor
Location/Value and review the image pixel values, observing the general
magnitude of the numbers (integer values).

The image displayed is in RAW Digital Number, as stored in the DEM file.

3. Select Tools → Link → Link Displays and use ENVI’s dynamic overlay
capabilities to compare the two images.

Convert the C-Band Data to Sigma Zero and DEM to Meters

1. Select Radar → TOPSAR Tools → Convert TOPSAR Data and choose the
file ts0218_c.vvi. This opens the TOPSAR Conversion Parameters
dialog. ENVI automatically identifies all of the TOPSAR data present in this
dataset based on the TOPSAR file naming convention. The VV Polarization,
Correlation, Incidence Angle, and DEM images will be opened. The C-VV

Figure 26-1: TOPSAR C-Band VV Image.
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data will automatically be converted to Sigma Zero and the DEM to meters
based upon values present in the TOPSAR headers.

2. Subset the number of lines in the TOPSAR Conversion Parameters dialog to
1061 by clicking on the Spatial Subset button and changing the To parameter
for Line from the ending line value of 1140 to 1061. This will match the size
of the C-band data and DEM to the P- and L-band data. Click OK.

3. Enter the output filename topsar.img and click OK to start the conversion.
The four images are placed in the Available Bands List.

4. Display the C-VV Sigma Zero image by clicking on the VV Polarization band
name in the Available Bands List, selecting a New Display, and then clicking
on Load Band. Select Tools → Cursor Location/Value and review the image
pixel values, observing the general magnitude of the numbers (Sigma Zero).

5. Select Tools → Link → Link Displays and use ENVI’s dynamic overlay
capabilities to compare the two C-VV images (Raw vs Sigma Zero).

6. Display the DEM (meters) image by clicking on the DEM (m) band name in
the Available Bands List, selecting a New Display, and then clicking Load
Band. From the Display menu in the Main Image window, select
Tools → Cursor Location/Value and review the image pixel values,
observing the general magnitude of the numbers (Elevation in meters).

Note the large negative number (approximately -2911) associated with holes in
the DEM and the image border. These are not valid elevations and these areas
should be excluded from analysis using ENVI’s masking functions.
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7. Select Tools → Link → Link Displays and use ENVI’s dynamic overlay
capabilities to compare the two DEM images (Raw vs Elevation in meters).

Synthesizing the P- and L-band Data

Both the L-Band and P-Band data are distributed by JPL in compressed Stokes
Matrix format. These data can not be displayed directly by most image processing
systems. ENVI provides utilities to decompress the data and synthesize to image
format.

1. Select Radar → Open/Prepare Radar File → Synthesize AIRSAR Data
from the ENVI main menu.

Figure 26-2: TOPSAR DEM Image
Display and Convert the Data ENVI Tutorials



Tutorial 26: Analysis of DEMs and TOPSAR 549

EN
2. Click on Open File in the Input Stokes Matrix Files dialog, select the file
ts0218_l.dat in the Enter Compressed Stokes Matrix Filename dialog.
Both the L and P band Stokes Matrix file names will be entered into the dialog.

3. Click OK to open the Synthesize Parameters dialog. The “standard”
polarization bands, L-HH, L-VV, L-HV, L-TP (total power), P-HH, P-VV, P-
HV, and P-TP (total power) are automatically entered into the dialog.

If additional polarizations are desired, enter the Transmit and Receive
Ellipticity and Orientation angles into the appropriate text boxes in the upper
left part of the dialog and click on Add Combination.

4. Select Byte as the Output Data Type from the pull-down menu originally
labeled Floating Point, enter the output filename ts0218lp.syn with its
correct path, and click OK to synthesize the images.

5. Select one or more of the synthesized bands to display as a gray scale or an
RGB image using the Available Bands List, and display the image in a New
Display.

Figure 26-3: Synthesize Parameters Dialog
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6. Compare the L-Band and C-Band VV data to the C-Band VV data using image
linking and dynamic overlays.

Figure 26-4: TOPSAR P-Band VV Image
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Analysis of JPL Polarimetric SAR Data

This section of the tutorial describes some of the analysis options for general analysis
of SAR data as well as selected polarimetric analysis capabilities. For additional SAR
processing information see the ENVI 3.5 User’s Guide.

General Concepts for processing SAR with ENVI

Most standard ENVI processing functions are inherently radar capable including all
display capabilities, stretching, color manipulations, classification, registration,
filters, geometric rectification, etc. Specific Radar menu items are also included
under the Radar menu for specific ENVI routines that are particularly useful for radar
processing. Many of these can also be accessed from their functional areas on the
ENVI main menu. ENVI provides standard and advanced tools for analysis of
detected radar images as well as advanced SAR systems such as JPL's fully
polarimetric AIRSAR and SIR-C systems. ENVI can process ERS-1/ERS-2, JERS-1,
RADARSAT, SIR-C, X-SAR, and AIRSAR data as well as any other detected SAR
data set. In addition, ENVI is designed to handle radar data distributed in the CEOS
format, and should be able to handle data from other radar systems that distribute
their data in this format.

Remove Speckle using Adaptive Filters

Adaptive filters provide a means of removing radar speckle from images without
seriously affecting the spatial characteristics of the data. The Gamma Filter and other
adaptive filters provide considerable improvement over the unfiltered data. To
perform the Gamma Filter on the AIRSAR data:

1. Select Radar → Adaptive Filters → Gamma, and select the input image
ts0218_c.vvi. Click OK. This opens the Gamma Filter Parameters
dialog.

2. Use the default filter size (3) and Number of Looks (1.000). Enter the output
filename ts_cgam.img, and click OK.
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Edge Enhancement

A Laplacian Filter can be used to enhance edges in SAR data and other data types.
This is a convolution filter with a kernel (for a 5 x 5 filter) of:

Of course, applying the kernel in this fashion strongly enhances the edges and causes
loss of most of the radiometric information.

1. From the ENVI main menu, select Filter → Convolutions. Then select
Convolutions → Laplacian. Enter a kernel size of 5x5. To avoid loss of the
radiometric information, select to add back part of the original image as
follows.

2. Apply add-back to a filtered image, enter a percentage of the original image to
to added back (between 0 and 100%) in the Convolution and Morphology
Tool. Click Quick Apply and select Band 1 of the ts0218_c.vii image.
This displays the image in a new Display window. If desired, change the
Image Add Back value and redisplay.

Compare Images using Linked Images and Dynamic Overlay

Compare images generated above to each other and the original data using ENVI's
dynamic overlay capabilities. To compare the images using Dynamic Overlay:

1. Display the two images in separate displays and contrast stretch as described
above.

2. Select Tools → Link → Link Displays.

3. Select the appropriate display numbers and click OK to link the two images.
Compare them by dragging the dynamic overlay with the left mouse button.

Polarimetric Analysis

ENVI provides a full suite of tools for analyzing Polarimetric SAR data. These
include generation and display of specific polarization images, a phase image, and
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pedestal height image as well as extraction of polarization signatures and generation
of a scattering classification image.

Display Multifrequency, Polarimetric SAR Images

The synthesized images produced above form the basis for image analysis of
polarimetric data.

1. Display one of the synthesized images by selecting the [L-HH] band of
ts0218lp.syn in the Available Bands List and clicking on Load Band.

2. Start an animation by choosing Tools → Animation from the Image Display
menu. In the Animation Input Parameters dialog, hold down the Ctrl key and
click on the two total power image ([L-TP] and [P-TP]) to deselect them. Click
OK to start the animation. Observe the different frequencies and polarizations
and compare the SAR response for various materials to determine a 3-band
combination that will maximize spectral contrast.

3. When finished, select File → Cancel to end the animation.

4. Load a multifrequency, multipolarization AIRSAR image into the display as
an RGB image using your selected bands from above, or load the P-HH, L-
HH, and the C-VV image as RGB and observe the color differences associated
with various materials. Experiment with different contrast stretches using both
the Main Display and the Zoom windows to maximize color differences in the
image.

Examine Polarization Signatures

Polarization signatures are 3D representations of the complete scattering
characteristics for a single pixel or ROI in terms of the orientation angle and
ellipticity angle of the transmitted and received radar waves. These signatures can be
used to observe the scattering characteristics of materials and surfaces and to
determine what polarization images to generate to maximize image contrast between
materials as viewed in the SAR data.

1. Position the cursor over an area that appeared to change significantly in the
animation by clicking at the desired location in the Main Image Display
window using the left mouse button.

2. Choose Tools → Polarization Signatures → AIRSAR, click on the Open
File button, and choose the L-Band Stokes Matrix data ts0218_l.dat.Both
the L-Band and P-Band Stokes Matrix filenames will be entered into the Input
Stokes Matrix Files dialog. Click OK to start the Polarization Signature
Viewer window.
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3. Choose Options → Extract Current Pixel to extract an L-Band polarization
signature for the current pixel. Choose Frequency → [ ]P to display the
corresponding P-Band polarization signature. Select the Polsig_Data menu
item to see the different surface plotting options. Select Polsig_Data →
Cross-Pol to display and compare the cross-polarized signature.

4. Click and drag using the left mouse button in the image on the right side of the
plot to display the interactive 2D, 3D cursor. Read the cursor values in the
lower left corner of the plot. Observe the maximum contrast orientation and
ellipticity angles in the plot and optionally synthesize and display an image
with these parameters as described above.

5. Click on one of the polsig plot axes and drag to rotate the 3-D polsig in real
time.

6. Select File → Cancel to exit the function.

Pedestal Height Image

1. Generate a pedestal height image for the AIRSAR data by choosing
Radar → Polarimetric Tools → Pedestal Height Image → AIRSAR,
clicking OK in the Input Stokes Matrix Files dialog, entering the output
filename ts_ped.img and clicking OK.

2. Display the image by clicking on the band name in the Available Bands List
and clicking on Load Band.

This image provides a measure of the amount of multiple scatter of the radar
wave for every pixel by averaging the following four polarization
combinations:

• Orientation 0 degrees, Ellipticity -45 degrees

• Orientation 90 degrees, Ellipticity -45 degrees

• Orientation 0 degrees, Ellipticity 45 degrees

• Orientation 90 degrees, Ellipticity 45 degrees.

A higher pedestal height value in the image indicates greater multiple
scattering, generally a rougher surface.

3. Select Tools → Cursor Location/Value from the Main Image Display menu
bar to start the Cursor Location/Value window and examine the pedestal height
values for this image.
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Displaying and Analyzing DEMs

This portion of the tutorial describes ENVI’s tools for processing and analyzing
Digital Elevation Models. While this tutorial refers specifically to the TOPSAR
DEM, all of these methods and tools are fully applicable to any DEM data set.

Display the DEM Converted to Meters

1. If not already displayed, display the band DEM (m) from the generated file
topsar.img (created using the steps described in the section “Convert the C-
Band Data to Sigma Zero and DEM to Meters” on page 546).

2. Select Tools → Cursor Location/Value and examine the pixel values of the
DEM.

This DEM has had a scaling function applied to convert these data to physical
parameters; the elevation in meters. The formula for this conversion is on page 21 of
the AIRSAR Integrated Processor Documentation, version 0.01, May 1995. The
required information for this conversion is obtained from the TOPSAR DEM header,
in this case, consisting of an ELEVATION INCREMENT of 0.1 and the
ELEVATION OFFSET of 365.6. Also note that after this conversion, bad pixels
(borders, radar shadows in the DEM, etc.) will have the value -2911.099. You
probably will want to generate a mask for these areas using ENVI masking
capabilities to set these values to zero (see the ENVI 3.5 User’s Guide for details).

X and Y Elevation Profiles

ENVI provides tools for extracting elevation profiles along either the X or Y
directions.

1. From the DEM (m) image display menu, select Tools → Profiles → X Profile
and then Tools → Profiles → Y Profile to extract the profiles for the two
directions.

Move these two plots off to the side of the DEM (m) image display so you can see
them while moving the cursor in the display.
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2. Click and drag using the left mouse button in the image display window to
generate new elevation profiles when the left mouse button is released. The
position of the red bar in the X and Y profiles marks the position of the center
of the Zoom window along the profile. Click and drag in the Zoom window
using the left mouse button for continuous updating.

3. Close the two profiles by choosing File → Cancel from each plot window.

Arbitrary Elevation Transect

ENVI also allows extraction of elevation profiles along multiple arbitrary transects.

1. Select Tools → Profiles → Arbitrary Profile (Transect) to extract a profile
along an arbitrary transect.

2. Click using the left mouse button in the Main Display Window to draw each
segment of the desired transect. You can hold down the left mouse button and
draw if desired.

3. Click the right mouse button once to close the last line segment and a second
time to extract the profile. Draw one or more profiles using the Arbitrary
Profile tool. Each additional profile will be assigned a new color and number.

Figure 26-5: TOPSAR Horizontal and Vertical DEM Topographic Profiles
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Note
Profiles can also be drawn in the Scroll or Zoom windows by selecting the
appropriate window in the Spatial Profile Tool dialog.

ENVI’s standard plot controls can be used to read the elevation off of the plot.

4. Click the left mouse button in the Plot window and drag along the profile. The
Zoom Window tracks the profile in the Main Image Display.

5. Zoom in on portions of the plot using the middle mouse button to draw a box
and zoom back out by clicking the middle mouse button below the plot axis.

6. Close the profiles by selecting File → Cancel in the Spatial Profile Tool
dialog.

Figure 26-6: TOPSAR DEM Arbitrary Transects (top) and Profiles (bottom)
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Color Density Slice the DEM

Density slicing provides a means of visually enhancing radar differences based on
image brightness.

1. Select Tools → Color Mapping → Density Slice in the Main Image display
containing the DEM in meters. Choose the DEM file data and click OK.

2. Click Clear Ranges in the Density Slice dialog to clear the default ranges
(necessary because of the holes and mask values).

3. Enter the value 0 in the Min text box. Select Options → Add New Ranges
to open the Add Density Slice Ranges dialog.

4. Enter 0.0 for the Range Start, 700.00 for the Range End, and 10 for # of
Ranges, then click OK. Click Apply in the Density Slice dialog to density
slice the image.

5. Load the gray scale DEM into a second image by clicking on the band name,
selecting a New Display and Load Band in the Available Bands List.

6. Use Dynamic Overlays to compare to the gray scale density sliced images.

Overlay of Elevation Contours

ENVI can generate elevation contours from the DEM data and overlay either on the
DEM itself, or on another co-registered image.

1. If the DEM image is still displayed, and the Color Density Slice is turned on,
turn it off by selecting File → Cancel in the Density Slice dialog. If the DEM
is not displayed, display the DEM (m) band as a gray scale image by clicking
on the band name for the meters DEM in the Available Bands List followed
by Load Band.

2. Choose Overlay → Contour Lines in the Main Image Display window and
choose DEM (m) as the input contour band.

3. Click on Clear Levels in the Contour Plot dialog, enter 0.0 in the Min text
box, and choose Options → Add New Levels. Enter 0 for the Level Start, 50
for the level increment, and 15 for the number of levels, then click OK.

4. Click Apply in the Contour Plot dialog to plot the DEM contours on the DEM
image. Examine the relation between contour lines and image brightness.
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5. Now display one of the synthesized images by selecting the [L-HH] band of
ts0218lp.syn in the Available Bands List and clicking on Load Band.

The contour lines will be overlain on the SAR band data.

6. Select File → Cancel from the Contour Plot dialog to remove the contour
lines.

Figure 26-7: TOPSAR DEM with Generated Elevation Contours
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Basic 3-D Perspective Viewing and Image Overlay

ENVI can generate interactive 3-D perspective views from DEM data and also
overlay co-registered image data (Note: this requires that your display be set for at
least 32k colors). TOPSAR provides the ideal data for this procedure because the
standard dataset includes registered DEM and SAR data.

1. To start this option, display either the DEM or the image to be overlain on the
3-D SurfaceView. Redisplay the meters DEM image DEM (m) by clicking on
the band name and then the Load Band button in the Available Band List
and/or redisplay the L-HH SAR band by clicking on the band name, selecting
New Display, and then Load Band at the bottom of the Available Band List.

Figure 26-8: TOPSAR C-Band Data with DEM-Generated Elevation Contours
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2. Select Topographic → 3D SurfaceView from the ENVI main menu to start
the 3-D SurfaceView function and choose the display to use for the overlain
image. Choose the display containing the DEM (m) image.

3. Choose the TOPSAR DEM image as the associated DEM input file and click
OK.

4. In the 3D SurfaceView Input Parameters dialog, Enter a value of 0 into the
DEM min plot value text box, change the vertical exaggeration to 20, the
image resolution to Full, and click OK.

5. The 3-D perspective will be displayed with a gray-scale overlay. A wire-mesh
can be displayed by selecting Surface → Wire in the 3D SurfaceView
window. The left mouse button controls image rotation, the middle mouse
button panning, and the right mouse button zooming.

See the 3D SurfaceView and Fly-through tutorial or ENVI 3.5 User’s Guide for
additional details on how to run this function.

Generation of Slope, Aspect, and Shaded Relief

ENVI provides tools for processing DEMs to extract parametric information
including slope and aspect, and to generate lambertian (shaded relief) surfaces. A
plane is fit to a 3-pixel by 3-pixel box centered over each pixel and the slope and
aspect of the plane calculated. The slope is measured in degrees, from 0 to 90. Aspect
angle is measured with 0 degrees to the north with increasing angles in a clockwise
direction. A root mean square (rms) error image is also generated indicating the
planarity of the 9 pixel box.

1. Select Topographic → Topographic Modeling from the ENVI main menu.
Click on the meters DEM band name DEM (m) in the Topo Model Input
DEM dialog and click OK.

2. Click on the Compute Sun Elevation and Azimuth button in the Topo
Model Parameters dialog and select November 11, 1996, 12:00:00 hours as
the time and enter -37 degrees, 21 minutes, 0 seconds and 145 degrees 17
minutes, 0 seconds respectively for the latitude and longitude. Click OK to
return to the Topo Model Parameters dialog.

3. Enter a X and Y pixel size of 10 meters, and the output filename
ts_model.img and click OK to generate the slope, aspect, shaded relief, and
RMS images.
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4. Click sequentially on each of the band names in the new image, start a New
Display, and then Load Band to display the parameter images in separate
image windows. Use ENVI’s dynamic overlays and the Cursor
Location/Value dialog to examine the relations between the DEM and the
parameter images.

Image-Map Output

The final output from any image processing within ENVI is usually a map-oriented,
scaled image-map for presentation or visual analysis and interpretation. Radar data
can be used in map composition like any other data set. The TOPSAR data are
inherently map-registered, so creating an output map is simply a matter of adding all
of the standard map composition elements such as pixel, map, and geographic
(latitude/longitude) grids; scale-bars; declination diagrams and north arrows; text and
symbols; polygons, polylines, and geometric shapes (circles, rectangles); map keys
and legends; and image insets.

Figure 26-9: Wire-Mesh Perspective View of TOPSAR DEM (left), and L-HH,
LHV, PHV Data Draped on TOPSAR-generated Perspective View (right)
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EN
For additional information on map composition, see the Map Composition tutorial or
the ENVI 3.5 User’s Guide. An example of a TOPSAR map composition is shown
below.

End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click Yes to end the
session. If you are using ENVI RT, quitting ENVI will take you back to your
operating system.

Figure 26-10: TOPSAR Shaded Relief Image with Map and Geographic
Coordinates Superimposed.
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Summary

ENVI provides tools for end-to-end polarimetric SAR processing as well as a suite of
tools for working with standard DEMs and DEMS generated from interferometric
SAR data. These are fully integrated into the ENVI processing environment and may
be utilized along with other non-SAR-specific routines to provide optimized analysis
and map output.
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ENVI Topographic
Tools
The following topics are covered in this tutorial:
Overview of This Tutorial . . . . . . . . . . . . . 566 ENVI Topographic Tools . . . . . . . . . . . . . 567
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Overview of This Tutorial

This tutorial is designed to give you a working knowledge of ENVI's Topographic
Analysis Tools. Data provided include processed TM data and a 25m DEM of an area
in the Austrian Alps. Selected tools reviewed include grayscale and color-density-
sliced display; generation and overlay of elevation contours, use of ENVI's X, Y, and
arbitrary profiles (transects) to generate terrain profiles; generation of slope, aspect,
and shaded relief images; extraction of Topographic Feature Parameters (peak, ridge,
pass, plane, channel, pit), and 3-D perspective viewing and image overlay.

The TM image used is Landsat 5 acquired 21-Mar-87 (192-27). The scene is centered
on the “Hohe Tauern” area just south of Salzburg, Austria. The river Salzach runs
from W-E. The town of “Zell am See” lies near the distinctive cross of 2 valleys. This
is a “pseudo-true color” image made from a combination of VNIR bands. Data
Courtesy of Research Systems International Ltd, UK, Digital Elevation Data ©
Eastern Geo Ltd 1999, Distributed by NPA Group, Edenbridge, Kent, UK,
Tel: +44 1732 865023.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/alptmdem

Note
The files listed are required to run this exercise. You should also be able to produce
similar results with their own coregistered image and digital elevation model
(DEM) data.

File Description

alps_tm.img Landsat TM data, Swiss Alps

alps_tm.hdr ENVI Header for above

alps_dem25m.img 25m spatial resolution digital elevation model (DEM)

alps_dem25m.hdr ENVI header for above
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ENVI Topographic Tools

ENVI provides general tools that can be used for analysis of topographic data. These
include image display; color slicing; image contouring; X, Y, and arbitrary profiles;
and Georeferenced Cursor Location/Value. A variety of DEM-specific tools are also
provided for processing digital elevation data (DEM) to generate geomorphic
measures. These include Slope, Aspect, Shaded Relief, Profile Convexity, Plan
Convexity, Longitudinal Convexity, Cross Sectional Convexity, Minimum
Curvature, Maximum Curvature, and RMS Error. Other Topographic feature
parameters that can be calculated include Peak, Ridge, Pass, Plane, Channel, and Pit.
Finally, ENVI provides 3-D visualization and analysis tools (the ENVI 3-D
SurfaceView). For additional details about ENVI’s Topographic Tools, please see the
ENVI 3.5 User’s Guide or ENVI On-Line-Help.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To open ENVI in UNIX, enter ENVI at the UNIX command line.

• To open ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

Select and Display the DEM

Display Grayscale Image

1. Select File → Open Image File.

An Enter Data Filenames file selection dialog appears.

2. Select the DEM alps_dem25m.img from the list and click Open.

3. First select the gray scale display option by clicking on the Gray Scale radio
button in the Available Bands List.

4. Select the DEM band name in the dialog by clicking on the name in the
Available Bands List with the left mouse button.

The band you have chosen is displayed in the field marked Selected Band:.
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5. Click on the Load Band button in the Available Bands List to load the image
into a new display. Open, load, and display the alps_tm.img TM data in a
second display.

6. Double-click in the image to start ENVI’s Cursor Location/Value dialog and
browse spatially to familiarize yourself with the data (elevation values are
meters).

Color-Code the DEM

• Select Tools → Color Mapping → ENVI Color Tables from the Main Image
window, scroll to the bottom of the list of Color Tables:, and select Rainbow
+ White. The DEM will be color coded from black, purple, blue, green
yellow, red, to white (low elevation to high elevation). Try applying various
available color tables and select one that best shows the elevation differences.

Figure 27-1: Gray scale DEM image, Austrian Alps.
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DEM Contour Overlays

1. Select Overlay → Contour Lines from the Main Image window, choose the
25m DEM as the source of the contour information by clicking on the band
name in the Contour Band Choice dialog and then clicking OK. Click on the
Apply button to plot the default contour lines on the DEM image.

2. Experiment with your own contour lines by clicking Clear Levels in the
dialog, then choosing Options → Add New Levels from the Contour Plot
dialog and entering your desired Level Start, Level Inc (increment), and # of
Levels in the appropriate text boxes in the Add Contour Levels dialog.

3. Compare the Landsat and the DEM using Tools → Link → Link Displays.

Figure 27-2: Color-coded, contoured DEM image, Austrian Alps.
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Terrain Profiles

ENVI provides tools for extracting elevation profiles along either the X or Y
directions, or along an arbitrary transect.

1. Select Tools → Profiles → X Profile and then Tools → Profiles → Y Profile
in the Main Image window menu bar to extract profiles for the two directions.

2. Click and drag using the left mouse button to generate new elevation profiles
when the left mouse button is released. The position of the red bar in the X and
Y profiles marks the position of the center of the Zoom window along the
profile. For continuous updating, click and drag using the left mouse button.

3. Close the two profiles by choosing Window → Close All Plot Windows from
the ENVI main menu.

4. Select Tools → Profiles → Arbitrary Profile (Transect) from the Main
Image window menu bar to extract a profile along an arbitrary transect.

5. Click using the left mouse button in the Main Image window to draw each
segment of the desired transect. You can hold down the left mouse button and
draw if desired.

6. Click the right mouse button once to close the last line segment and a second
time to extract the profile. Draw one or more profiles using the Arbitrary
Profile tool. Each additional profile will be assigned a new color and
numbered.

Figure 27-3: X- and Y-spatial profiles, Austrian Alps DEM.
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7. Profiles can also be drawn in the Scroll or Zoom windows by selecting the
appropriate window in the Spatial Profiler Tool dialog.

ENVI’s standard plot controls can be used to read the elevation off of the plot.

8. Click the left mouse button in the plot and drag along the profile. The Zoom
window will track the profile in the Main Image window.

9. Zoom in on portions of the plot using the middle mouse button to draw a box
and zoom back out by clicking the middle mouse button below the plot axis.

10. Close the profiles by selecting File → Cancel in the Spatial Profiler Tool
dialog.

Topographic Modeling

ENVI can be used to generate geomorphic measures including Slope, Aspect, Shaded
Relief, Profile Convexity, Plan Convexity, Longitudinal Convexity, Cross Sectional
Convexity, Minimum Curvature, Maximum Curvature, and RMS Error.

1. Select Topographic → Topographic Modeling from the ENVI main menu,
click on the 25m DEM file name in the Topo Model Input DEM dialog, and
click OK.

2. Choose the measures desired in the Topo Model Parameters dialog by
clicking on the appropriate parameter names (See the ENVI User’s Guide and
On-Line Help for details about the specific measures).

3. Click on the Compute Sun Elevation and Azimuth button and enter today’s
date, GMT of 10:0:0, and Lat (latitude of) 47 degrees and Lon (longitude) of
13 degrees. Click OK and ENVI will automatically calculate and enter the sun
elevation and azimuth

4. Enter an output name (topomodel for example) and click OK to generate the
parameter images.

5. Examine the Topographic Model images. Note that there are artifacts and
patterns in these apparently associated with processes used to generate the
DEM (see in particular the Shaded Relief Image). This is not apparent in the
contrast-stretched DEM itself, but is enhanced and is a problem in the product
images. Try minimizing these effects in the product images by selecting
Enhance → Filter → Smooth or Enhance → Filter → Median and
observing the results on the displayed image. Try other filters if desired.
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6. Go back and smooth the original DEM image and re-calculate the geomorphic
measures. Select Filter → Convolutions or Morphology from the ENVI main
menu, then choose Convolutions → Median. Change the Kernel Size to 7
using the spin box and click on Apply to File, select the 25m DEM, click OK,
enter the output filename (medianfilter for example) and click OK in the
Convolution Parameters dialog to generate the filtered image. Select
File → Cancel to close the Convolutions and Morphology Tool dialog.

7. Recalculate the Topographic Model by selecting
Topographic → Topographic Modeling from the ENVI main menu, using
the smoothed 25m DEM file as the input file in the Topo Model Input DEM
dialog, and clicking OK.

8. Choose the measures desired in the Topo Model Parameters dialog by
clicking on the appropriate parameter names.

9. Click on the Compute Sun Elevation and Azimuth button and enter today’s
date, GMT of 10:0:0, and Lat (latitude of) 47 degrees and Lon (longitude) of
13 degrees. Click OK and ENVI will automatically calculate and enter the sun
elevation and azimuth

10. Display the Topographic Model images derived from the smoothed DEM and
compare to the original and smoothed DEM images and the Topographic
Model images derived from the original DEM using Tools → Link → Link
Displays.
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Topographic Feature Parameters

ENVI can be used to produce additional topographic feature parameters (Peak,
Ridge, Pass, Plane, Channel, and Pit) that help characterize the terrain.

1. Select Topographic → Topographic Features from the ENVI main menu,
choose the smoothed 25m DEM data file in the Topographic Feature Input
DEM dialog and click OK.

2. Change the Kernel Size to 7, enter an output filename (topofeature for
example), and click OK to start the processing.

3. Display the feature image in a new display by first clicking the Gray Scale
radio button in the Available Bands List, clicking on the image name in the

Figure 27-4: Shaded Relief image, Austrian Alps.
ENVI Tutorials ENVI Topographic Tools



574 Tutorial 27: ENVI Topographic Tools
Available Bands List, then clicking Load Band. (The feature image is
actually a classification image, which is automatically color-coded according
to feature).

4. Select Overlay → Annotation from the Main Image window menu bar and
choose Object → Map Key from the menu bar in the Annotation dialog.

5. Select a foreground color of black using the Color selection pull-down menu
and a background color of white using the Back selection pull-down menu in
the Annotation dialog.

6. Click the left mouse button in the image to display the map key in the image,
the right mouse button to place the annotation.

7. Compare the feature image classification to the DEM and to the Topographic
Model images using Tools → Link → Link Displays and dynamic overlays
and evaluate the success of the feature classification procedure.

Figure 27-5: Topographic Feature Classified image, Austrian Alps.
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3D Visualization

If you are running ENVI on a Windows system, you must set the display to 16 bit or
24 bit color mode before starting ENVI.

Start the ENVI 3D SurfaceView Function

1. Select Topographic → 3D SurfaceView from the ENVI main menu to start
the function.

2. If more than one display window is open, select the display window that
contains the desired image (try both the Landsat TM image and the color-
coded DEM) in the 3D SurfaceView:Select Input Display dialog.

3. Select the digital elevation model (DEM) input file from the Associated DEM
Input File dialog by clicking on the DEM band name. Click on OK to start the
3D SurfaceView Input Parameters dialog.

4. Select the desired DEM Resolution (number of pixels) check box(es) used for
the 3D plot. The DEM will be resampled to the selected resolution.

Figure 27-6: 3-D SurfaceView Input Parameters dialog.
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Note
Using higher DEM resolutions will significantly slow the visualization and should
only be used when sufficient computing power is available. More than one
resolution can be selected. Typically you will want to use the lowest resolution (64)
while you are determining the best flight path. Then a higher resolution can be used
to display your final fly-through sequence.

5. Enter a value for the Vertical Exaggeration. Increasing the number increases
the amount of exaggeration.

6. Click OK to start the visualization.

Interactive 3-D Visualization Controls

The mouse cursor and buttons are used to interactively rotate, translate (pan), and
scale the 3D surface. Try this for your -D SurfaceView as described below.

1. Clicking and dragging with the left mouse button in a horizontal direction in
the 3D SurfaceView rotates the surface around the Z axis. Clicking and
dragging with the left mouse button in a vertical direction rotates the surface
around the X axis.

2. Clicking and dragging with the middle mouse button in the 3D SurfaceView
translates (pans the image) in the corresponding direction.

3. Clicking and dragging to the right with the right mouse button in the 3D
SurfaceView increases the zoom factor. Clicking and dragging to the left with
the right mouse button decreases the zoom factor.

4. Double-clicking with the left mouse button on a pixel in the 3D SurfaceView
moves the Zoom window to that pixel in the Main Image window containing
the draped image. Selected functions that are active in the display window can
be linked to the 3D cursor location by double-clicking using the left mouse
button (see 3D SurfaceView as an Analysis Tool below).

The rotation, translation, and zoom factor can also be controlled, and the
surface plot can be reset to its original position from the Options pull-down
menu in 3D SurfaceView window (see below).
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Additional details on using the 3D SurfaceView controls are described in the
ENVI 3D Surface View and Fly-Through tutorial.

Figure 27-7: 3-D SurfaceView. Top view shows DEM, bottom view is Landsat
TM on DEM.
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End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click OK to exit IDL. If
you are using ENVI RT, quitting ENVI will take you back to your operating system.
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3D Surface View and
Fly-Through Using
ENVI

The following topics are covered in this tutorial:
Overview of This Tutorial . . . . . . . . . . . . . 580 3D Visualization Using ENVI . . . . . . . . . 581
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Overview of This Tutorial

This tutorial is designed to give you a working knowledge of ENVI's 3D
SurfaceView and Fly-Through capabilities. This function allows you to overlay a
gray scale or color composite image over a digital elevation model (DEM) as a 3D
Surface View, interactively change the 3D visualization, and create a 3D Fly-through.
The 3D SurfaceView function also provides limited analysis capabilities. For
additional details, please see the ENVI User's Guide or ENVI On-Line-Help.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/bh_3d

Note
The files listed are required to run this exercise. You should also be able to produce
similar results with their own coregistered image and digital elevation model
(DEM) data.

File Description

bhtmsat.img Bighorn Basin Landsat TM bands 3, 2, 1 (Saturation
Enhanced)

bhtmsat.hdr ENVI Header for Above

bhdemsub.img 30-meter resolution USGS digital elevation model
(DEM)

bhdemsub.hdr ENVI Header for Above

bhdemsub.pat Fly-through path file

bhdemsub.ann Fly-through path annotation file
Overview of This Tutorial ENVI Tutorials



Tutorial 28: 3D Surface View and Fly-Through Using ENVI 581
3D Visualization Using ENVI

ENVI provides comprehensive capabilities for viewing and analyzing image data in 2
dimensions. The ENVI 3D SurfaceViewTM tool is the first step towards extending
these capabilities into 3 dimensions.

ENVI's three-dimensional surface viewing function allows display of a digital
elevation model (DEM) as a wire frame, ruled grid or points, or with a gray scale or
color image draped over it. The 3D surface can be rotated, translated, and zoomed in
or out in real-time using the mouse cursor. Each 3D “view” can be added to a list to
be used later for animation. A “fly-through” of the three-dimensional datasets is
achieved using the saved views or a predefined flight path drawn interactively using
ENVI's annotation tool. The vertical exaggeration, vertical and horizontal view
angles, and altitude are controlled via user selectable parameters. The cursor is also
linked to the draped 3D image allowing extraction of profiles in the X, Y, and spectral
directions as well as cursor locations and values utilizing the 3D projection.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To open ENVI in UNIX, enter envi at the UNIX command line.

• To open ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

Loading a 3D SurfaceView

If you are running ENVI on a Windows system, you must set the display to 16 bit or
24 bit color mode before starting ENVI.

To start ENVI's 3D SurfaceView function:

Open and Display the Landsat TM Data

To open the image file:

1. Select File → Open Image File on the ENVI main menu.

An Enter Data Filenames file selection dialog appears.

2. Select the file bhtmsat.img from the list and click OK.
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The Available Bands List dialog will appear on your screen. This list allows
you to select spectral bands for display and processing.

Note
ENVI 3.5 will automatically perform Steps 3 and 4.

3. Select bands 1, 2, and 3 listed at the top of the dialog by first selecting the
RGB Color radio button in the Available Bands List, then clicking on the
bands sequentially with the left mouse button.

The bands you have chosen are displayed in the appropriate fields in the center
of the dialog.

4. Click Load RGB to load the image into a new display.

Figure 28-1: Bighorn Basin, Wyoming Saturation Enhanced Landsat TM Data.
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You can adjust the displayed contrast stretch using ENVI’s contrast enhancement
tools accessed from the Enhance menu in the Main Image window.

Open and Display the DEM as a Gray Scale Image

While the DEM data should be opened prior to starting the 3D SurfaceView
function, displaying the DEM image is not required. It is a good idea, however, to do
this routinely when starting the 3D SurfaceView function to ensure that you have a
matched DEM/Image pair.

To open the DEM image file:

1. Select File → Open Image File.

An Data Filenames dialog appears.

2. Select the file bhdemsub.img from the list and click Open.

Note
ENVI 3.5 will automatically perform Steps 3, 4, and 5.

3. First select the Gray Scale display option by clicking on the Gray Scale radio
button in the Available Bands List.

4. Select the DEM band name in the dialog by clicking on the name in the
Available Bands List with the left mouse button.

Figure 28-2: Bighorn Basin, Wyoming DEM.
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The band you have chosen is displayed in the field marked Selected Band:.

5. Click New Display then click Load Band in the Available Bands List to load
the image into a new display.

The DEM will be loaded as a gray scale image.

Start the ENVI 3D SurfaceView Function

1. Select Topographic → 3D SurfaceView to start the function.

2. If more than one display window is open, select the display window that
contains the desired image in the 3D SurfaceView: Select Input Display
dialog.

3. Select the digital elevation model (DEM) input file (or other 3D data set) from
the Associated DEM Input File dialog by clicking on the DEM band name.
Perform any spatial subsetting as desired and click on OK to start the 3D
SurfaceView Input Parameters dialog.

Figure 28-3: 3D SurfaceView Input
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4. Select the desired DEM Resolution (number of pixels) check box(es) used for
the 3D plot. The DEM will be resampled to the selected resolution.

Note
Using higher DEM resolutions will significantly slow the visualization and should
only be used when sufficient computing power is available. More than one
resolution can be selected. Typically you will want to use the lowest resolution (64)
while you are determining the best flight path. Then a higher resolution can be used
to display your final fly-through sequence.

5. Enter the DEM minimum and maximum plot values if desired to clip values
from the displayed DEM. (this can be used to cut out background pixels or
limit the elevation range of the DEM). DEM values lower than the minimum
value and higher than the max value will not be plotted in the 3D views.

6. Enter a value for the Vertical Exaggeration. Increasing the number increases
the amount of exaggeration.

7. Select either Full or Other image resolution. If Other is selected, the image is
resampled to the number of pixels selected for the DEM.

8. Click on the Spatial Subset button and select a spatial subset of the image, if
desired.

9. Use the defaults or enter the desired pixel size in the X Pixel Size and Y Pixel
Size text boxes.

10. Click OK to start the visualization.

Interactive Control of 3D Visualization

The mouse cursor and buttons are used to interactively rotate, translate (pan),
and scale the 3D surface. Try this for your 3D SurfaceView as described
below.

Clicking and dragging with the left mouse button in a horizontal direction in
the 3D SurfaceView rotates the surface around the Z axis. Clicking and
dragging with the left mouse button in a vertical direction rotates the surface
around the X axis.
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Clicking and dragging with the middle mouse button in the 3D SurfaceView
translates (pans the image) in the corresponding direction.

Figure 28-4: Two 3D SurfaceViews rotated using the left mouse button.

Figure 28-5: Two 3D SurfaceViews translated (panned)
using the middle mouse button.
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Clicking and dragging to the right with the right mouse button in the 3D
SurfaceView increases the zoom factor. Clicking and dragging to the left with the
right mouse button decreases the zoom factor.

Double-clicking with the left mouse button on a pixel in the 3D SurfaceView moves
the ENVI Zoom Window to that pixel in the Main Image window containing the
draped image. Selected functions that are active in the display window can be linked
to the 3D cursor location by double-clicking using the left mouse button (see “3D
SurfaceView as an Analysis Tool” on page 595 for more information).

Note
The rotation, translation, and zoom factor can also be controlled, and the surface
plot can be reset to its original position by from the SurfaceView Controls dialogs
(see Figure 28-7 and Figure 28-8).

The 3D SurfaceView Control Dialogs

The 3D SurfaceView Control dialogs are accessed by selecting Options → Controls
Dialog from the 3D SurfaceView window, where a control dialog is either
Rotate/Scale/Trans Controls or Motion Controls. These controls determine what
kind of 3D surface is displayed; how the surface is displayed; fine control over

Figure 28-6: Two 3D SurfaceViews with different zoom
factors set using the right mouse button.
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rotation, translation, and zoom factor; animation of the surface; and image, printer, or
VRML output.

Type of Visualization

Several options are available for the 3D SurfaceView. The surface can be displayed
as an image overlay (draped image), as a wireframe surface, as a ruled XZ wireframe,
as a ruled YZ wireframe, or as individual points.

1. To view the 3D surface as a draped image, select Surface → Texture in the
3D SurfaceView dialog. Try displaying with and without interpolation by
selecting Options → Interpolation:None or
Options → Interpolation:Bilinear. No interpolation is the default.

2. Try the different wireframe options by selecting the desired option from the
Surface and Option menus. Examples are shown below.

Figure 28-7: The 3D SurfaceView Control dialogs.
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Figure 28-8: Examples of the different types of wireframe options for the 3D
SurfaceView: Upper left, wireframe; Upper right, ruled XZ;

Lower left, ruled YZ; Lower right, Points.
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Visualization Fine Controls

The 3D SurfaceView RST Controls dialog (select Options → Rotate/Scale/Trans
Controls) provides the means to make fine adjustments to the visualization.

To change the rotation of the surface plot:

1. Enter a value, in degrees, in the Rotation Inc spin box to change the rotation
increment.

2. Click on the arrows next to the Rotation text label to rotate in a specific
direction. The left arrow rotates clockwise around the Z axis, the right arrow
counter clockwise around the Z axis, the up arrow away from the viewer
around the X axis, and the down arrow towards the viewer around the X axis.

To translate the surface plot:

1. Enter a value in the Translation Inc text box to change the translation
increment.

2. Click on the arrows next to the Trans text label to move the image in the
direction shown by the arrows.

To zoom in and out of the image:

1. Enter a value in the Scaling Inc text box to change the zoom increment.

2. Click on the plus and minus buttons next to the Scaling text label to
respectively increase or decrease the zoom factor.

Other Visualization Controls

To change the color of the background from the 3D SurfaceView dialog, select
Options → Change Background Color.

To change the vertical exaggeration from the 3D SurfaceView dialog, select
Options → Change Vertical Exaggeration and enter the desired value. Higher
factors increase the vertical exaggeration.

To reset the surface view to the default view from the 3D SurfaceView dialog, select
Options → Reset View.

To set the view to a specific position and viewing direction/angle, select
Options → Position Controls (see section below).

To animate the current flight path, select Options → Motion Controls.(see section
below).

To turn the annotation flight line trace off and on, select Options → Annotation
Trace: Off or On.(see section below).
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The SurfaceView Positioning Dialog

The 3D SurfaceView can also be controlled by setting the view to a specific position
and viewing direction/angle.

1. Select Options → Position Controls from the 3D SurfaceView window and
the SurfaceView Position Controls dialog will appear.

2. Select a viewing position by starting the Cursor Location/Value dialog in the
Main Image window (Tools → Cursor Location/Value) and reading either
the pixel or map coordinates for the desired location. Enter these coordinates
into the SurfaceView Positioning dialog. A good starting point is Sample 3600
and Line 3000.

3. Try varying the Azimuth, Elevation, and Height Above Ground parameters
to see how they change the 3D SurfaceView. Start with an Azimuth (look
direction) of 90, an Elevation (look angle) of -90 (looking straight down), and
a height above ground of 2000 m. Change the height from 2000 to 1000 to 500.

4. Use the interactive rotation and zooming to see the 3D SurfaceView from the
selected viewpoint.

Figure 28-9: The SurfaceView Positioning dialog.
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Building and Playing a User-Defined Visualization Sequence

ENVI’s 3D SurfaceView function can be used to build an animation sequence or 3D
“Fly-Through” of the 3D visualization.

Try restoring a previously saved flight path and playing the animation sequence.

1. Select Options → Motion Controls to display the SurfaceView Motion
Controls dialog.

2. Select File → Restore Sequence from File in the SurfaceView Motion
Controls dialog and choose bhdemsub.pat as the flight path to be restored.

3. Enter a value of 500 into the Frames spin box and click on the Play Sequence
button to play the flight path. Click Stop Sequence to stop the fly-through.

Now try interactively defining your own flight path and flying through the data:

1. Clear the current path by clicking on the Clear button in the SurfaceView
Motion Controls dialog. Use the mouse or arrow buttons to select the starting
3D SurfaceView and click the Add button in the SurfaceView Motion
Controls dialog to add this projection as the starting point of the flight path.

2. Use the mouse or arrow buttons to select another 3D view and click the Add
button to add this view to the flight path. Repeat this step until you have
selected as many visualization steps as desired (2 minimum are required).
When the visualization is played, the flight path will be smoothly interpolated
between the different views.

Click on the path view number and click Replace to replace a projection in the
flight path list. Click on the path view number and click Delete to delete a
projection in the flight path list. Click on Clear to clear the flight path list.

3. Enter the number of frames to be used in the “fly-through” animation and the
flight path will be smoothly interpolated. A larger number of frames will be
smoother, but slow down the animation.

4. Click the Play Sequence button to animate the fly-through.

Use the Options → Animate Sequence from the SurfaceView Motion Controls
dialog to build a full animation and control the speed and direction of the fly-through
(see “Animate Sequence” below).
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Using ENVI Annotation to Build a Visualization Sequence

1. Select Options → Motion:Annotation Flight Path from the SurfaceView
Motion Controls dialog to use a flight path drawn on the image in the display
window using ENVI annotation. A polyline, polygon, rectangle, or ellipse
annotation object can be used to define the flight path. Saved annotation files
can also be input.

2. Select the flight path from a saved annotation file option by choosing the Input
Annotation from File radio button, selecting bhdemsub.ann and choosing
the 1st annotation object (a green polyline). The selected annotation file and
number of nodes are shown in the middle of the dialog and the flight path
plotted on the surface. Enter Frames of 500. To smooth the flight path using a
running average of points along the line, enter a Flight Smooth Factor of
1000. Enter a Flight Clearance of 1000. Set the Up/Down look angle to -60.
A vertical look angle of -90 degrees looks straight down at the surface. A look
angle of 0 degrees looks straight ahead (horizontal). Leave the Right/Left look
angle at 0. A horizontal look angle of -90 degrees looks to the left, a look angle
of 0 degrees looks straight ahead, and a look angle of 90 degrees looks to the
right. Click on Play Sequence to animate the fly-through. Try different values
in each of the parameters and observe the effect they have on the visualization.
Also try flying over the surface at a constant elevation by clicking the arrow
radio button until Flight Clearance appears and entering the desired elevation
above sea level.

3. Next select the flight path from the saved annotation file by choosing
File → Input Annotation from File from the SurfaceView Motion Controls
dialog, select bhdemsub.ann and choosing the 2nd annotation object (a red
ellipse). Enter Frames of 100, a Flight Smooth Factor of 10000 and a Flight
Clearance of 1000. Set the Up/Down look angle to -60 and leave the
Left/Right look angle at 0. Click on Play Sequence to animate the fly-
through. Try different values in each of the parameters and observe the effect
they have on the visualization.

4. Now try creating your own annotation objects and doing the fly-through by
selecting Overlay → Annotation in the Main Image window, selecting
File → Input Annotation from Display, and clicking on Play Sequence.
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The Animate Sequence Option

The Animate Sequence option allows control of the speed and direction of the 3D
SurfaceView animation.

1. Set up the flight path from the ellipse in the saved annotation file as described
above, set Frames to 100, then select Options → Animate Sequence from
the SurfaceView Motion Controls dialog to load the individual frames into
the animation.

The 3D SurfaceView Controls dialog changes to show an interactive tool for
controlling the animation (See Figure 28-10).

2. Control the speed of the fly-through by increasing the value in the Speed spin
box. Higher values result in faster animation.

3. Control the direction of the fly-through by clicking on the appropriate bitmap
button at the bottom of the dialog. The buttons are from left to right: reverse
animation, forward animation, continuous forward/reverse animation, pause
animation.

4. When the animation is paused, clicking and dragging the slider steps through
the animation one or more frames at a time.

Figure 28-10: The SurfaceView Control dialog when Animate Sequence is
selected.
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5. Select File → Cancel to return to the SurfaceView Motion Controls dialog.

Saving Visualizations and Output

The ENVI 3D SurfaceView function also offers several options to save the
visualization results and/or path.

• Click File → Save Sequence to File in the SurfaceView Motion Controls
dialog to save the current path to an ENVI path (.pat) file that can be restored
to a 3D visualization session.

• Click File → Restore Sequence Path from File from the SurfaceView
Motion Controls dialog to restore a saved flight path when the visualization is
in the User Defined mode.

• Click File → Input Annotation from Display from the SurfaceView Motion
Controls dialog to get annotation from the current display when the
visualization is in the Annotation mode.

• Click File → Input Annotation from File from the SurfaceView Motion
Controls dialog to get annotation from an ENVI annotation file when the
visualization is in the Annotation mode.

• Select File → Save Surface As → Image File from the 3D SurfaceView to
output the currently displayed view to an ENVI image.

• Select File → Print from the 3D SurfaceView to perform direct printing of
the currently displayed view.

• Select File → Save Surface As → VRML from the 3D SurfaceView to
output the 3D visualization to a VRML file that can be viewed using programs
such as Netscape Navigator.

3D SurfaceView as an Analysis Tool

ENVI’s 3D SurfaceView tool provides powerful visualization capabilities for
viewing images draped on digital elevation models. Because of the way ENVI’s
windows and dialogs can be dynamically linked, this function also provides the
capability to do analysis using the 3D SurfaceView in conjunction with other ENVI
capabilities. Currently support is provided for:

• Cursor Tracking/Pixel Locator

• The Spatial and Spectral Pixel editors

• X and Y Profiles

• Z-Profiles (Spectral Profiles) and the Spectral Analyst
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To utilize the 3D SurfaceView for analysis:

1. Display the desired 3D surface using the methods described above and start
one of the ENVI interactive functions above from the displayed image to be
analyzed.

2. Cursor Location: Select Tools → Cursor Location/Value in the Main Image
window. Read the cursor location (pixel and map coordinates) and value by
moving the cursor in the 3D SurfaceView window.

3. Spatial and Spectral Pixel Editors: Select Tools → Spatial Pixel Editor or
Tools → Spectral Pixel Editor in the Main Image window. Double-click
using the left mouse button on the desired pixel in the 3D SurfaceView
window to position the cursor in the ENVI display windows to the appropriate
location. Edit the desired pixel values.

4. X and Y Profiles: Select Tools → Profiles → X Profile or
Tools → Profiles → Y Profile in the Main Image window. Double-click using
the left mouse button on the desired pixel in the 3D SurfaceView window to
position the cursor in the ENVI display windows to the appropriate location.
The X and/or Y Profiles will be updated to match the selected cursor location
and the location will be marked with a red vertical line in the selected profile.

5. Z-Profile (Spectral Profile): Select Tools → Z Profile or
Tools → Profiles → Additional Z Profile in the Main Image window.
Double-click using the left mouse button on the desired pixel in the 3D
SurfaceView window to position the cursor in the ENVI display windows to
the appropriate location. The Z Profile(s) spectrum will be extracted from the
data to match the selected cursor location.

6. Spectral Analyst: Display a Z profile, then select Spectral → Spectral
Analyst from the ENVI main menu. Open the desired spectral library by
clicking on the Open Spectral Library button in the Spectral Analyst Input
Spectral Library dialog and choosing the library name. Click on OK in the
Edit Identify Methods Weighting dialog that appears. Select Options → Auto
Input via Z-Profile in the Spectral Analyst dialog to link the Spectral Analyst
to a specific spectral profile. Once the Spectral Analyst is set up, double click
using the left mouse button on the desired pixel in the 3D SurfaceView
window to position the cursor in the ENVI display windows to the appropriate
location. The Z Profile(s) spectrum will be extracted from the data to match the
selected cursor location and the Spectral Analyst will calculate a match to the
library spectrum.
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End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click OK to exit IDL. If
you are using ENVI RT, quitting ENVI will take you back to your operating system.
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Introduction to ENVI
User Functions
The following topics are covered in this tutorial:
Overview of This Tutorial . . . . . . . . . . . . . 600
Programming in ENVI . . . . . . . . . . . . . . . 601

User Defined Band Math Routines . . . . . 602
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Overview of This Tutorial

This tutorial provides basic information on programming in ENVI. It covers the
basics for creating user-defined band math functions and User Functions, including
creating compound widgets and writing data-tiling operations. This tutorial assumes
that you are familiar with the Interactive Data Language (IDL) and that you
understand how to write functions and procedures in IDL. ENVI Runtime users
cannot program in ENVI.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/user_fun
envidata/bldr_reg

File Description

Required Files (envidata/user_fun)

bm_divz1.pro Simple Band MathTM Function

bm_divz2.pro Revised Band MathTM Function

tp_divz1.pro ENVI User Function

tp_divz2.pro Revised ENVI User Function

Required Files (envidata/bldr_reg)

bldr_tm.img Boulder Thematic Mapper Data

bldr_tm.hdr ENVI Header for above
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Programming in ENVI

ENVI provides a variety of interfaces for executing user-written routines. User
routines are written in the Interactive Data Language (IDL). IDL routines are written
as functions or procedures and named with a .pro extension. This tutorial shows
examples of two of these techniques — Band Math and User Functions. For
descriptions of the ENVI programming functions used in this tutorial, see the ENVI
3.5 User’s Guide or online help.

ENVI processes data spatially or spectrally depending on the requirements of the
function and on the input file storage format. If a function only operates either
spatially or spectrally, then the data must be accessed accordingly. If a process can be
performed either spatially or spectrally, however, then ENVI operates on the data
based on the file storage format. The three file storage formats that ENVI uses are
Band Sequential (BSQ), Band Interleave by Line (BIL), or Band Interleave by Pixel
(BIP). See the ENVI 3.5 User’s Guide, online help, or ENVI Tutorials.

ENVI allows processing of image data larger than available memory. This is
accomplished by breaking the data up into usable pieces or “tiles,” processing the
tiles separately, then reassembling the tiles into the output image. A tile is a piece of
data processed in memory by ENVI. The size of a spatial tile is determined by the
ENVI configuration item image tile size and is set by the user to optimize memory
usage without exceeding the computer’s physical memory size. Spatial tiles always
include all the samples being processed and as many lines as possible. Spectral tiles
on the other hand, are defined by the number of samples (ns) and the number of bands
(nb) being processed. A BIL spectral tile is (ns, nb) and a BIP spectral tile is (nb, ns).
Spectral tiles will always be this size and are unrelated to the set image tile size.

The basic process for a tiling operation in ENVI is as follows:

Initialize the ENVI tiles

Loop on the number of tiles

request the tile

process the tile

[write result of the processing to disk or memory]

end loop

[Enter the data into Available Bands List]
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User Defined Band Math Routines

This portion of the exercise will familiarize you with editing and compiling a .pro
file (an IDL program). The compiled function is executed using ENVI’s Band Math
routine. Band math uses ENVI’s tiling capabilities for handling large images. You
will create a simple band math function that performs a mathematical expression
using two bands. The optional keyword CHECK will enable divide-by-zero checking
and the keyword DIV_ZERO will be used to set divide by zeros to another value.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To open ENVI on UNIX, enter envi at the UNIX command line.

• To open ENVI on Windows or Macintosh, double-click on the ENVI icon.

The ENVI main menu will appear when the program has successfully loaded and
executed.

Open TM Data

To open the Boulder, Colorado Thematic Mapper (TM) data:

1. Select File → Open Image File from the ENVI main menu.

Note
On some platforms you must hold the left mouse button down to display the
submenus from the main menu.

2. Select the file envidata/bldr_reg/bldr_tm.img and click Open.

The Available Bands List dialog will appear on your screen with the 6 available TM
bands listed. This list allows you to select spectral bands for display and processing.

Edit the Band Math Function

Normally, you would open an editor and type the following IDL function, however,
this function has already been saved in the envidata/user_fun directory as
bm_divz2.pro.

If you choose to enter the function yourself, use IDL’s text editor or your favorite
editor, enter the text below, and save the function as bm_divz2.pro.
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function bm_divz2, b1, b2, check=check, div_zero=div_zero
if (keyword_set(check)) then begin

; If div_zero is set then use it otherwise use zero
if (n_elements(div_zero) gt 0) then $

temp_value = div_zero $
else $

temp_value = 0.0
; Find all the locations where the band is zero
temp = float(b1) - b2
ptr = where(temp eq 0, count)
; Temporarly set the divide by zero cases to divide by 1
if (count gt 0) then $

temp(ptr) = 1
; Perform the ratio
result = (float(b1) + b2) / temp
; If any divide by zeros then set the output
if (count gt 0) then $

result(ptr) = temp_value
endif else begin

; Just do the ratio and ignore divide by zeros
result = (float(b1) + b2) / (float(b1) - b2)

endelse
return, result

end

Compile the Band Math Function

To compile the updated function:

1. Select File → Compile IDL Module from the ENVI main menu.

2. In the Enter Module Filename dialog, navigate to the envidata/user_fun
directory (or the directory where you saved the file if you created it manually),
select the file bm_divz2.pro, and click Open.

3. To make sure that the function compiled, look in the IDL output log window.

On Windows and Macintosh, this is the output log window. On UNIX, it is the
shell window from which ENVI was started. The following line will appear if
the module compiled successfully:

% Compiled module BM_DIVZ2

4. Edit and fix any errors for modules that did not compile successfully.

Run the Band Math Function

The new function can now check for divide by zeros and can set them to an error
value. To run the compiled function:
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1. Select Basic Tools → Band Math.

2. When the Band Math dialog appears, enter the following in the “Enter an
expression:” input text box:

bm_divz2(b1,b2, /check, div_zero=1.0)

3. Click OK.

4. When the Variables to Band Pairings dialog appears, select “B1” in the
“Variables used in expression” field.

5. In the “Available Bands List field, select “Band 2”.

6. Select “B2” in the “Variables used in expression” field.

7. In the “Available Bands List” field, select “Band 3”. The “Variables used in
expression” field should contain the following:

B1 - Band 2(0.5600):bldr_tm.img
B2 - Band 3(0.6600):bldr_tm.img

8. Select the File radio button, enter an output filename, and click OK.

Display the Result

1. In the Available Bands List dialog, click the Display button and select New
Display.

2. Select the band math result we just created, “Band Math (bm_divz2(b1,b2,
/check, div_zero=1.0))”, and click Load Band.

Any pixels that caused a divide be zero now have the value 1.0.

Creating a User Function

The process of creating an ENVI User Function consists of adding a menu item,
creating an event handler that defines the widget interface, using data tiling for
accessing the data, and adding the output bands to the Available Bands List. The User
Function you will create performs the same mathematical expression as the band
math example above. The code has been saved in the file tp_divz1.pro.

Editing envi.men

User functions can be added to the envi.men file and run from the menu like the rest
of the ENVI routines.

1. Copy the envi.men file from the ENVI installation menu subdirectory to
another directory and filename.
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2. Select File → Preferences from the ENVI main menu. The System
Pereferences dialog will appear. Select User Defined Files in this dialog.

3. Enter the new filename (including its directory path) in the Default ENVI
Menu File field of the Preferences: User Defined Files dialog.

Exit ENVI so that you can update the envi.men file to include your new
routine.

4. To quit your ENVI session, select File → Exit or Quit from the ENVI main
menu and click Yes.

5. Edit your new ENVI menu file and add the lines:

0 {User Functions}
1{User Band Ratio1} {user ratio} {tp_divz1}
1{User Band Ratio2} {user ratio} {tp_divz2}

where 1 indicates the menu level, {User Band Ratio} is the menu item name,
{user ratio} is the name of the uvalue, and {tp_divz1} or {tp_divz2} is the
name of the event handler.

6. Save and close the new ENVI menu file.

Creating an Event Handler

This portion of the exercise will familiarize you with creating ENVI event handlers
for user-defined functions. You will use the ENVI file selection function and ENVI’s
compound widgets.

Edit the Event Handler

Enter the following code using your text editor or use the file included in the
user_fun directory under the filename tp_divz1.pro.

The first thing to do in the routine is to extract the UVALUE and compare it the
UVALUE in the ENVI menu file.

After receiving the uvalue the event handler selects the input file. ENVI_SELECT is
used for file selection and spatial and spectral subsetting. Returned from
ENVI_SELECT are the input file id (FID), the band dimensions (DIMS), and the
selected bands (POS). If the returned FID equals –1, then the “Cancel” button was
selected and the event handler must exit.

Since the processing routine is performing the same mathematical expression as the
band math example, we need to make sure that at lease two bands are selected. If the
improper number of bands are selected then ENVI_ERROR is used to give a warning
message and the event handler exits.
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Input parameters entered on the command line in the Band Math exercise are now
entered using ENVI compound widgets.

• Use WIDGET_AUTO_BASE to create a widget base which allows auto-
management of widget events.

• Use row and column bases for positioning the compound widgets
WIDGET_MENU and WIDGET_PARAM to replace the keywords in the
Band Math example.

• WIDGET_MENU creates the “Check for divide by 0?” using an exclusive list
to make a “Yes/No” button.

• WIDGET_PARAM accepts an input value that is used as the replacement for
the divide by zero.

• WIDGET_PARAM accepts a floating point number (DT=4) with three digits
past the decimal points (FIELDS=3) with a default value of zero
(DEFAULT=0.0).

• Finally, WIDGET_OUTFM is used to prompt for the output filename or
memory option.

• Each of the compound widgets sets the keyword /AUTO, giving
AUTO_WID_MNG the responsibility of managing the compound widgets.

• AUTO_WID_MNG returns a structure with the tag names defined by the
uvalue of each compound widget.

• In addition, the structure contains the tag accept, which is set to one if the you
select “OK” and zero if the “Cancel” button is selected.

In this example, we print the selections for “Check for divide by 0?” and the “Divide
by zero value”. The next exercise will use the same event handler but pass the
arguments to the tile processing routine.

pro tp_divz1, ev
widget_control, ev.id, get_uvalue=uvalue

if (uvalue eq 'user ratio') then begin

envi_select, title='Ratio Input File', fid=fid, dims=dims, $
pos=pos

if (fid eq -1) then return
; We will just do a ratio of the first two band
; from the pos array so make sure there are at
; least two bands are selected
if (n_elements(pos) lt 2) then begin

mstr = 'You must select two bands to ratio.'
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envi_error, mstr, /warning
return

endif
; Create a compound widget for the input parameters
base = widget_auto_base(title='Ratio Parameters')
sb = widget_base(base, /column, /frame)
sb1 = widget_base(sb, /row)
mw = widget_menu(sb1, prompt='Check for divide by 0 ? ', $

list=['Yes','No'], /excl, default_ptr=0, rows=0, $
uvalue='check', /auto)

sb1 = widget_base(sb, /row)
wp = widget_param(sb1, prompt='Divide by zero value', $

dt=4, field=3, xs=6, uvalue='div_zero', default=0.0, /auto)
sb = widget_base(base, /column, /frame)
ofw = widget_outfm(sb, func='envi_out_check', $

uvalue='outf', /auto)

; Automanage the widget
result = auto_wid_mng(base)
if (result.accept eq 0) then return
check = (result.check eq 0)
div_zero = result.div_zero
help, result.outf, /st
print, check
print, div_zero

endif
end

If you are creating your own file, save this routine as tp_divz1.pro in the same
directory as the new envi menu file or use the tp_divz1.pro in the user_fun
directory.

Running the User Function

Follow the procedures below to compile and run the User Function from within
ENVI.

Start ENVI

• To open ENVI on UNIX, enter envi at the UNIX command line.

• To open ENVI on Windows or Macintosh, double-click on the ENVI icon.

The ENVI main menu will appear when the program has successfully loaded and
executed.

Open TM Data

To open the TM data:
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1. Select File → Open Image File.

Note
On some platforms, you must hold the left mouse button down to display the
submenus from the main menu.

2. In the Enter Data Filenames dialog, navigate to the envidata/bldr_reg
directory, select the file bldr_tm.img, and click OK or Open depending on
your operating system.

Compile the Event Handler

To compile the newly created event handler:

1. Select File → Compile IDL Module from the ENVI main menu.

2. When the Enter Module Filename dialog appears, navigate to the location of
the saved function, tp_divz1.pro, and select the file.

3. To make sure that the function compiled, look in the IDL command window.

On Windows and Macintosh, this is the output log window. On UNIX, it is the
shell window from which ENVI was started. The following line will appear if
the module compiled successfully:

% Compiled module TP_DIVZ1

4. Edit and fix any errors for modules that did not compile successfully.

Run the Event Handler

1. Select User Functions → User Band Ratio1.

2. In the Ratio Input File selection dialog, select the file bldr_tm.img and
click OK. The Ratio Exercise Parameters dialog will appear and allow the
selection of divide by zero checking, the divide by zero value, and an output
filename.

3. Select the No button for “Check for divide by 0”.

4. Enter 1.0 for the “Divide by zero value”.

5. Enter tp_divz1.img as the output filename.

6. Click OK.

7. Look in the IDL command log window to see the values printed at the bottom
of the event handler.
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Write the Tiling Routines

Follow the procedures below to create the tiling routines that allow ENVI to process
large image files.

Creating the Tiling Routine

This portion of the exercise will familiarize you with creating ENVI tile processing
routines. You will use the band math example and convert it to a tiling routine which
uses the newly created event handler.

Updating the Event Handler

The first thing to do in the processing routine sets up the IO error handling. Next,
ENVI_FILE_QUERY is used to get the filename (FNAME) and X and Y starting
pixel (XSTART and YSTART). The filename is used for the processing status report
and XSTART and YSTART are just used in the output image header.

The tile processing routine allows both output to file and memory, file operations
open the output file for writing and memory output allocates a float array. Next, the
ENVI tiles are initialized using ENVI_INIT_TILE. Since the processing routine uses
two bands simultaneously the MATCH_ID is used on the second ENVI_INIT_TILE
forcing processing tiles from the two bands to be the same size.
ENVI_REPORT_INIT and ENVI_REPORT_INC set up a processing status widget
and the report increment respectively.

Now that everything is initialized the processing routine can just loop over the
number of tiles. At the start of each loop the processing status is updated and a check
is made to see if the “Cancel” button was selected. The calls to ENVI_GET_TILE
with the TILE_IDs return the data to process. Each tile is processed with the
mathematical expression from the Band Math exercise. After processing the data
memory items are written to the variable mem_res otherwise the result is written to a
file.

Now that the processing is completed, ENVI_ENTER_DATA or
ENVI_SETUP_HEAD enter the new image into ENVI. Memory items use
ENVI_ENTER_DATA while output to disk uses ENVI_SETUP_HEAD to open the
file and write the ENVI header file (.hdr). Finally, the tile pointers and report are
cleaned up using ENVI_TILE_DONE and ENVI_REPORT_INIT.

In the event handler replace the print statements with the call to the processing
routine show below.

tp_divz_doit, fid=fid, pos=pos, dims=dims, check=check, $
out_name=result.outf.name, div_zero=div_zero, $
in_memory=result.outf.in_memory
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Here is the new code for tp_divz2.pro. You can enter this using your favorite
editor or use the file tp_divz2.pro saved in the user_fun directory.

pro tp_divz_doit, fid=fid, pos=pos, dims=dims,check=check,$
out_name=out_name, in_memory=in_memory, $
div_zero=div_zero, r_fid=r_fid
; Set up the error catching and initialize optional keywords
!error = 0
on_ioerror, trouble
in_memory = keyword_set(in_memory)

; Get the file xstart and ystart and calculate ns and nl
envi_file_query, fid, fname=fname, xstart=xstart, $

ystart=ystart
ns = dims(2) - dims(1) + 1
nl = dims(4) - dims(3) + 1

; Either alloate a memory array or open the output file
get_lun, unit
if (in_memory) then $

mem_res = fltarr(ns, nl) $
else $

openw, unit, out_name

; Initialize the data tiles
tile_id1 = envi_init_tile(fid, pos(0), $

num_tiles=num_tiles, xs=dims(1), xe=dims(2), $
ys=dims(3), ye=dims(4), interleave=0)

tile_id2 = envi_init_tile(fid, pos(1), match_id=tile_id1)

; Setup the processing status report
if (in_memory) then tstr = ‘Output to Memory’ $
else tstr = ‘Output File: ‘ + out_name
envi_report_init, [‘Input File: ‘ + fname, tstr], $

title=’Ratio Processing’, base=rbase, /interupt

envi_report_inc, rbase, num_tiles

; Loop over each processing tile
for i=0, num_tiles-1 do begin

envi_report_stat, rbase, i, num_tiles, cancel=cancel
if (cancel) then begin

!error = envi_cancel_val()
goto, trouble

endif

; Retrieve the tile data
data1 = envi_get_tile(tile_id1, i, ys=ys, ye=ye)
data2 = envi_get_tile(tile_id2, i)
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; Perform the ratio
if (keyword_set(check)) then begin

; Find all the locations where the band is zero
temp = float(data1) - data2
ptr = where(temp eq 0.0, count)

; Temporarly set the divide by zero cases to divide
; by 1, do the ratio, and then set the divide by zero
; to div_zero
if (count gt 0) then $

temp(ptr) = 1

result = (float(data1) + data2) / temp

if (count gt 0) then $
result(ptr) = div_zero

endif else begin

; Just do the ratio and ignore divide by zeros
result = (float(data1) + data2) / $

(float(data1) - data2)
endelse

if (in_memory) then $
mem_res(0,ys-dims(3)) = result $

else $
writeu, unit, result

endfor

; Process error messages
!error = 0

trouble: if (!error ne 0) then $
envi_io_error, 'Ratio Processing', unit=unit
free_lun, unit

if (!error eq 0) then begin
descrip = 'Ratio Processing'
if (in_memory) then $

envi_enter_data, mem_res, descrip=descrip, $
xstart=xstart+dims(1), ystart=ystart+dims(3), $
r_fid=r_fid $

else $
envi_setup_head, fname=out_name, ns=ns, nl=nl, nb=1, $

data_type=4,interleave=0, xstart=xstart+dims(1), $
ystart=ystart+dims(3), /write, /open, r_fid=r_fid, $
descrip=descrip
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endif

; Clean up the tile pointer and the status report
envi_tile_done, tile_id1
envi_tile_done, tile_id2
envi_report_init, base=rbase, /finish

end

pro tp_divz2, ev
widget_control, ev.id, get_uvalue=uvalue

if (uvalue eq 'user ratio') then begin

envi_select, title='Ratio Input File', fid=fid, dims=dims, $
pos=pos

if (fid eq -1) then return

; We will just do a ratio of the first two band
; from the pos array so make sure there are at
; least two bands are selected
if (n_elements(pos) lt 2) then begin

mstr = 'You must select two bands to ratio.'
envi_error, mstr, /warning
return

endif

; Create a compound widget for the input parameters
base = widget_auto_base(title='Ratio Parameters')
sb = widget_base(base, /column, /frame)
sb1 = widget_base(sb, /row)
mw = widget_menu(sb1, prompt='Check for divide by 0 ? ', $

list=['Yes','No'], /excl, default_ptr=0, rows=0, $
uvalue='check', /auto)

sb1 = widget_base(sb, /row)
wp = widget_param(sb1, prompt='Divide by zero value', $

dt=4, field=3, xs=6, uvalue='div_zero', default=0.0, /auto)

sb = widget_base(base, /column, /frame)
ofw = widget_outfm(sb, func='envi_out_check', $

uvalue='outf', /auto)

; Automanage the widget
result = auto_wid_mng(base)
if (result.accept eq 0) then return
check = (result.check eq 0)
div_zero = result.div_zero

tp_divz_doit, fid=fid, pos=pos, dims=dims, check=check, $
out_name=result.outf.name, div_zero=div_zero, $
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in_memory=result.outf.in_memory
endif

end

Compile the Tile Processing Routine

To compile the updated tile processing routine:

1. Select File → Compile IDL Module from the ENVI main menu.

2. In the Enter Module Filename dialog, navigate to the location of the saved
function, tp_divz2.pro, and select the file.

3. To make sure that the function compiled, look in the IDL command window.

On Windows and Macintosh, this is the output log window. On UNIX, it is the
shell window from which ENVI was started. The following line will appear if
the module compiled successfully:

% Compiled module TP_DIVZ2

4. Edit and fix any errors for modules that did not compile successfully.

Run the Tile Processing Routine

1. Select User Functions → User Band Ratio2.

2. When the Ratio Input File selection dialog appears, select bldr_tm.img in
the “Select Input File” field.

3. Click the Spectral Subset button.

4. In the File Spectral Subset dialog, select only bands 2 and 3 (hold the Shift
key down while clicking make more than one selection), and click OK.

5. In the Ratio Input File selection dialog, click OK. The Ratio Exercise
Parameters dialog will appear and allow the selection of divide by zero
checking, replacement value, and output to memory or file.

6. Select the Yes button for “Check for divide by 0”.

7. Enter 1.0 for “Divide by zero value”.

8. Select the File button, enter a filename, and click OK.

The resulting image will be placed into the Available Bands List dialog.
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Display the Result

Select the newly created band in the Available Bands List dialog and click Load
Band to display the image. This image should be the same as the Band Math example
for the case that checked for divide by zero values.

Notes on Autocompiling

The two routines created in this tutorial can be set up to autocompile for future ENVI
sessions. To autocompile, place the two .pro files in the save_add directory of the
ENVI installation and restart ENVI. They will be compiled whenever ENVI is
started.

End the ENVI Session

This concludes the tutorial. You can quit your ENVI session by selecting File → Exit
(Quit on UNIX) from the ENVI main menu, then click Yes.
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Introduction to ENVI
Plot Functions
The following topics are covered in this tutorial:
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Overview of This Tutorial

This tutorial provides information on how to implement an ENVI “Plot Function”.
This is a user-defined function called from the “Plot Function” pulldown menu on
any ENVI plot window. This exercise covers the basics for creating user-defined plot
functions and setting up the ENVI “useradd.txt” file to enable automatic installation
of the functions in the plot menu structure.This tutorial assumes that you are familiar
with the “Interactive Data Language (IDL)” and understand how to write functions
and procedures in IDL. ENVI Runtime users cannot program in IDL, however, the
plot functions provided with this tutorial can be viewed with any text editor and
installed for use with either ENVI or ENVI Runtime.

Files Used in This Tutorial

CD-ROM: ENVI 3.5 Tutorial and Data CD No. 2

Path: envidata/user_fun
envidata/cup95avsub

envidata/spec_lib

File Description

Required Files (envidata/user_fun)

pf_1st_derivative.pro Plot function to take the 1st derivative of a
spectrum

pf_2nd_derivative.pro Plot function to take the 2nd derivative of a
spectrum

useradd.txt Modified (replacement) version of useradd.txt

Required Files (envidata/cup95avsub)

cup95eff.int Cuprite Effort-Corrected ATREM calibrated
apparent reflectance data 50 bands (integer).

Required Files (envidata/spec_lib)

usgs_min.sli USGS mineral spectral library

usgs_min.hdr ENVI Header for above
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ENVI Plot Functions

ENVI Plot Functions provide a method for applying algorithms to data in any plot
window. When a plot function is selected, “normal” plot data (all the spectra in the
plot window) are passed to the user-defined function. The plot function is applied to
the data, and the results data are returned to the plot window where they are
displayed. Once the plot function is selected, the function is applied to every
spectrum placed in that window until a different plot function is selected.

ENVI provides a standard set of plot functions and also allows users to define custom
plot functions. Custom plot functions are added to ENVI by entering the menu name
and function into the useradd.txt file in the menu directory of the ENVI
installation.

Creating a Plot Function

Plot functions can be created using the IDL editor, or any other text editor.

1. If you are running ENVI, select File → Open in the main IDL window. If you
are using ENVI Runtime, start your text editor.

2. Navigate to the envidata/user_fun directory and open the file
pf_1st_derivative.pro. You should see the following code:

function pf_1st_derivative, x, y, bbl, bbl_list, _extra=_extra
ptr= where (bbl_list eq 1, count)
result = fltarr(n_elements(y))
if (count ge 3) then $

result(ptr) = deriv (x[ptr], y[ptr])
return, result
end

This function accepts the X and Y data, a list of bad bands, and excluding the
bad bands takes the first derivative of the Y value and returns it to the plot
window. For additional information on specific function parameters, see “plot
function” in the ENVI User’s Guide or On-Line Help.

3. Follow the same procedure to open the file pf_2nd_derivtive.pro. When
you are satisfied that you understand how the functions work, close the files
and continue.
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Adding the Plot Function

Add the plot function by editing the useradd.txt file:

1. If you are running ENVI, select File → Open in the main IDL window. If you
are using ENVI Runtime, start your text editor.

2. Navigate to the USER_FUN directory and open the file “useradd.txt”. You
should see the following:

{plot} {Normal} {sp_normal} {type=0}
{plot} {Continuum Removed} {sp_continuum_removed} {type=1}
{plot} {Binary Encoding} {sp_binary_encoding} {type=0}
{plot} {1st Derivative} {pf_1st_derivative} {type=0}
{plot} {2nd Derivative} {pf_2nd_derivative} {type=0}

{identify} {Spectral Angle Mapper} {SAM} {envi_identify_sam} {0,.78539816}
{identify} {Spectral Feature Fitting} {SFF} {envi_identify_sff} {0,.1}
{identify} {Binary Encoding} {BE} {envi_identify_be} {0,1.}

Plot functions use the {plot} tag to differentiate them from other functions.
The format for a plot function is:

{plot} {Button Name} {function_name} {type=n}

where

{plot} = Tag to indicate the following definition is a plot function.

{Button Name} = Menu button name for the Plot Functions pulldown
menu.

{function_name} = Name of the plot function to call.

{type=n} = Type of plot function updates. Set type=0 to call the plot
function only when new data is available. Set type=1 to call the plot
function when new data is available or the plot is zoomed.

3. Observe the plot function calls for the pf_1st_derivative and
pf_2nd_derivative functions. When you are satisfied you understand the
calls, close the editor and continue.

Set up ENVI to Run the Plot Functions

ENVI requires that IDL functions be located in the ENVI save_add directory. The
useradd.txt file should be in the ENVI menu directory.

Use the appropriate operating system routines (eg: “cp” on UNIX, or Windows
Explorer on Microsoft Windows) to copy these files to the appropriate directories.
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Running the Plot Function

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To open ENVI in UNIX, enter envi at the UNIX command line.

• To open ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu will appear when the program has successfully loaded and
executed.

Open a Spectral Library and Plot Spectra

1. Select Spectral → Spectral Libraries → Spectral Library Viewer from the
ENVI main menu and click Open Spectral Library at the bottom of the
Spectral Library Input File dialog.

2. Navigate to the usgs_min directory, and open the Spectral Library file
usgs_min.sli. Click OK at the bottom of the Spectral Library Input File
dialog to display the Spectral Library Viewer dialog.

3. Click on one or more spectra in Spectral Library Viewer dialog to display
library spectra in a Spectral Library Plots window.

Figure 30-1: “Normal “spectrum (left), and 1st Derivative spectrum (right)
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4. Select Plot Function → 1st Derivative from the pulldown menu at the top of
the Plot Window to utilize the Plot Function pf_1st_deriv.pro. The 1st
derivative spectra of all plots will calculated and be displayed in the plot
window.

5. Select Plot Function → 2nd Derivative from the pulldown menu at the top of
the Plot Window to utilize the Plot Function pf_2nd_deriv.pro. The 2nd
derivative spectra of all plots will calculated and be displayed in the plot
window.

6. Select Plot Function → Normal to return to the standard reflectance
spectrum.

End the ENVI Session

This concludes the Plot Function Tutorial. You quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then click OK to exit IDL. If
you are using ENVI RT, quitting ENVI will take you back to your operating system.
ENVI Plot Functions ENVI Tutorials


	Online Guide
	Contents
	Preface
	Introducing ENVI
	About These Tutorials
	Tutorial Data Files
	Mounting the CD-ROM for UNIX Systems


	ENVI Quick Start
	Overview of This Tutorial
	Files Used in This Tutorial

	Getting Started with ENVI
	Start ENVI
	Load a Gray Scale Image
	Open an Image File
	Familiarize Yourself with the Displays
	Scroll Window
	Image Window
	Zoom Window
	Main Image Display Menu Bar


	Apply a Contrast Stretch
	Apply a Color Map
	Cycle Through All Bands (Animate)
	Scatter Plots and Regions of Interest
	Load a Color Composite (RGB) Image
	Classify an Image
	Dynamically Overlay Images
	Overlaying and Working with Vectors
	Finish Up


	Introduction to ENVI
	Overview of This Tutorial
	Files Used in This Tutorial

	Working with ENVI
	ENVI File Formats
	ENVI Windows and Displays
	Menus in ENVI Windows

	The Available Bands List

	Basic ENVI Functions
	Start ENVI
	Open an Image File
	Familiarize Yourself with the Displays
	Drag the Zoom Indicator Box
	Zoom In and Out and Pan the Zoom Window
	Scroll the Image
	Resize the Windows
	Scroll Bars

	Use the Mouse Button Descriptions
	Display the Cursor Location
	Display Image Profiles
	Perform Quick Contrast Stretching
	Display Interactive Scatter Plots
	Load a Color Image
	Link Two Displays
	Dynamic Overlays

	Select Regions Of Interest
	Other types of ROIs
	Working with ROIs

	Annotate the Image
	Annotation Types
	Placing Annotation
	Saving and Restoring Annotation
	Editing Previously Placed Annotation
	Suspending the Annotation Function Temporarily

	Add Grid Lines
	Save and Output an Image
	Saving your Image in ENVI Image Format

	End the ENVI Session


	Introduction to Panchromatic Data and Vector Overlays
	Overview of This Tutorial
	Files Used in This Tutorial

	Panchromatic Data and Vector Overlays
	Start ENVI
	Open a Panchromatic (SPOT) Image File
	Select and Load an Image Band
	Spatially Browse the Image
	Perform Interactive Contrast Stretching
	Linear
	Equalize
	Gaussian

	Color Mapping
	Pixel Locator
	Display the Georeferenced Cursor Location
	Apply an Interactive Filter
	Choose a Filter
	Display Image in a Second Display and Apply a Different Filter
	Compare Images Using Dynamic Overlays

	Review GeoSpot Map Information
	Open and Overlay DXF Vector Files
	Basic Map Composition
	Add Grid Lines
	Annotate the Image with a Map Key
	Saving and Restoring Annotation
	Suspending the Annotation Function Temporarily


	Save and Output an Image (Burn-In)
	Save your Image in GEOTIFF Format
	End the ENVI Session



	Multispectral Classification
	Overview of This Tutorial
	Files Used in This Tutorial

	Examine Landsat TM Color Images
	Start ENVI
	Open and Display Landsat TM Data
	Review Image Colors
	Cursor Location/Value
	Examine Spectral Plots
	Unsupervised Classification
	K-Means
	Isodata

	Supervised Classification
	Select Training Sets Using Regions of Interest (ROI)
	Restore Predefined ROIs
	Create Your Own ROIs

	Classical Supervised Multispectral Classification
	Parallelepiped
	Maximum Likelihood
	Minimum Distance
	Mahalanobis Distance


	Spectral Classification Methods
	The Endmember Collection Dialog
	Binary Encoding Classification
	Spectral Angle Mapper Classification
	Rule Images

	Post Classification Processing
	Class Statistics
	Confusion Matrix
	Clump and Sieve
	Combine Classes
	Edit Class Colors
	Overlay Classes

	Interactive Classification Overlays
	Classes to Vector Layers
	Classification Keys Using Annotation
	End the ENVI Session


	Image Georeferencing and Registration
	Overview of This Tutorial
	Files Used in This Tutorial

	Georeferenced Images in ENVI
	Georeferenced Data and Image-Map
	Start ENVI
	Open and Display SPOT Data
	Edit Map Info in ENVI Header
	Cursor Location/Value
	Overlay Map Grids
	Overlay Map Annotation

	Output to Image or Postscript
	Saving Your Image in ENVI Image Format
	Saving your Image to Postscript

	Direct Printing

	Image to Image Registration
	Open and Display Landsat TM Image File
	Display the Cursor Location/Value
	Start Image Registration and Load GCPs
	Working with GCPs
	Warp Images
	Compare Warp Results
	Examine Map Coordinates
	Close All Files

	Image to Map Registration
	Open and Display Landsat TM Image File
	Select Image-to-Map Registration and Restore GCPs
	Add Map GCPs Using Vector Display of DLGs
	RST and Cubic Convolution Warp
	Display Result and Evaluate
	Close Selected Files

	HSV Merge of Different Resolution Georeferenced Data Sets
	Display 30 m TM Color Composite
	Display 10 m SPOT Data
	Perform HVS Sharpening
	Display 10 m Color Image
	Overlay Map Grid
	Overlay Annotation
	Output Image Map
	End the ENVI Session


	Georeferencing Images Using Input�Geometry
	Overview of This Tutorial
	Files Used in This Tutorial

	Georeferencing Using Input Geometry
	Uncorrected HyMap Hyperspectral Data
	Start ENVI
	Open and Display HyMap Data
	Examine Uncorrected Data
	Examine IGM files
	Geocorrect Image Using IGM File
	Display and Evaluate Correction Results
	Examine GLT Files
	Geocorrect Image using GLT File
	Display and Evaluate Correction Results
	Using Build GLT with Map Projection
	Overlay Map Grids
	Output to Image
	Saving your Image in ENVI Image Format

	Direct Printing
	End the ENVI Session


	Orthorectification Using ENVI
	Overview of This Tutorial
	Files Used in this Tutorial

	Orthorectification in ENVI
	Steps for Orthorectification Using ENVI
	Aerial Photo Orthorectification Example
	Building the Interior Orientation
	Building the Exterior Orientation
	Orthorectifying the Air Photo

	SPOT Image Orthorectification Example
	Building the Exterior Orientation
	Orthorectifying the SPOT Image


	Tips for Successful Orthorectification
	Spatial Resolution
	Resampling During the Orthorectification
	Accuracy of GCPs
	Minimum DEM Value
	Output Pixel Size


	Mosaicking Using ENVI
	Overview of This Tutorial
	Files Used in this Tutorial

	Mosaicking in ENVI
	General Topics
	Start ENVI
	Preparing Images
	Open the Files

	Histogram Matching
	Feathering
	Edge Feathering
	Cut-Line Feathering

	Virtual Mosaics

	Steps for Creating a Pixel-Based Mosaic
	Set up the Mosaicking Dialog
	Import Images
	Importing Images Without Feathering
	Importing Images With Feathering
	Importing Images With a Background Value to Ignore

	Create a Virtual Mosaic or an Output Mosaic


	Pixel-Based Mosaicking Example
	Import and Position Images

	Georeferenced Mosaicking Example
	Create the Georeferenced Mosaic Image
	Load the Mosaic Template

	Optionally Input and Position Images
	View the Top Image, Cutline and Virtual, Non-Feathered Mosaic
	Create the Output Feathered Mosaic

	Additional Options in the Pixel Based and Georeferenced Mosaicking Dialogs
	End the ENVI Session


	Landsat TM and SPOT Data Fusion Using ENVI
	Overview of This Tutorial
	Files Used in This Tutorial

	Data Fusion
	Preparing Images

	London, UK, Data Fusion Example
	Read and Display ERMapper Images
	Resize Images to Same Pixel Size
	Perform Manual HSI Data Fusion
	Forward HSV Transform
	Create a Stretched SPOT Image to Replace TM Band Value
	Inverse HSV Transform
	Display Results

	ENVI Automated HSV Fusion
	Display Results, Link and Compare

	Brest, France, Data Fusion Example
	Open and Display Images
	Resize Images to Same Pixel Size
	Fuse Using ENVI Methods
	Display and Compare Results
	End the ENVI Session


	Landsat TM and SAR Data Fusion Using ENVI
	Overview of This Tutorial
	Files Used in This Tutorial

	Data Fusion
	Preparing Images

	Rome, Italy, Data Fusion Example
	Read and Display Images
	Register the TM images to the ERS image
	Perform HSI Transform to Fuse Data
	Display and Compare Results
	End the ENVI Session


	Vector Overlay and GIS�Analysis
	Overview of This Tutorial
	Sources and Files Used in this Tutorial
	ESRI Data and Maps Version 1 CD-ROM
	Space Imaging EOSAT CarterraTM Agriculture Sampler Data
	Required Files


	Vector Overlay and GIS Concepts
	Capabilities
	Concepts
	ENVI Vector Files (.evf)
	The Available Vectors List
	Create World Boundaries

	The Vector Window Parameters Dialog
	ENVI Attributes


	Part 1: Stand-Alone Vector GIS
	Start ENVI
	Open an ArcView Vector File (Shape File)
	Work with Vector Point Data
	Create the USA State Boundaries Using IDL Map Sets
	Work with Vector Polygon Data
	Get Vector Information and Attributes
	View Attributes and Point-and-Click Query
	Query Attributes
	Annotate Map Key in Vector Window
	Close all Windows and Files

	Part 2: Raster and Vector Processing
	Load Image Data to Combined Image/Vector Display
	Open a Vector Layer and Load to Image Display
	Track Attributes with the Cursor
	Heads-up (On-screen) Digitizing
	Edit Vector Layers
	Query Operations
	Vector-to-Raster Conversions
	Image-Map Output
	Close All Windows and Files

	Raster to Vector Conversions
	Export ROI to Vector Layer
	Load Image Data to Image Display
	Load Predefined ROIs
	Convert ROIs to Vectors
	Close All Windows and Files

	Export Classification Image to Vector Polygons
	Load and Display a Classification Image
	Generalize the Classification Image.
	Create the Vector Polygons

	End the ENVI Session


	Map Composition Tutorial
	Overview of This Tutorial
	Files Used in This Tutorial

	Map Composition in ENVI
	Getting Started
	Open and Display Landsat TM Data
	Build the QuickMap Template
	Elements for Customizing Map Layouts
	Adding Virtual Borders
	Automatically When Using Image Grids in ENVI QuickMap

	Using the Display Preferences
	Using the Annotation Function

	Adding Grid Lines
	Working with Annotation
	Text and Symbol Annotation
	Polygon and Shape Annotation
	Line and Arrow Annotation
	Map Scale Annotation
	Declination Diagrams
	Map Key Annotation
	Color Ramp Annotation
	Image Insets as Annotation
	Plot Insets as Annotation

	Overlaying Classification Images
	Overlaying Contour Lines
	Incorporating Regions of Interest
	Overlaying Vector Layers

	Customize the Map Layout
	Load the QuickMap Template

	Save the Results
	Saving for Future Modification
	Saving as a “Burned-in” Image
	Saving as an Image File

	Printing
	End the ENVI Session


	Introduction to Hyperspectral Data and Analysis
	Overview of This Tutorial
	Files Used in This Tutorial
	Background: Imaging Spectrometry

	Introduction to Basic ENVI Spectral Processing
	Start ENVI
	Display a Gray Scale Image
	Display a Color Image
	Link Two Displays
	Extract Spectral Profiles
	Current Spectrum
	Collect Spectra

	Animate the Data
	Working with Cuprite Radiance Data
	Load AVIRIS Radiance Data
	Extract Radiance Spectra
	Compare the Radiance Spectra
	Load Spectral Library Reflectance Spectra
	Compare Image and Library Spectra
	Close the Windows


	Compare Radiance and ATREM
	Background: ATREM Calibration
	Continue or Restart ENVI
	Load Radiance Data and Start the Z-Profiler
	Load ATREM Apparent Reflectance Data and Start the Z Profiler
	Link Images and Compare Spectra
	Close the Windows

	Compare Atmospheric Corrections
	Background: Atmospheric Correction
	Flat Field Correction
	Internal Average Relative Reflectance (IARR)
	Empirical Line Calibration
	Continue or Restart ENVI and Select Spectral Library of Calibration Results Spectra

	Select Atmospherically Corrected Spectra from Spectral Library
	Compare Corrected Spectra
	Optional: Browse Corrected Data Files
	End the ENVI Session
	References


	Basic Hyperspectral Analysis
	Overview of This Tutorial
	Files Used in This Tutorial

	Spectral Libraries / Reflectance Spectra
	Start ENVI and Load AVIRIS data
	Display a Grayscale Image
	Browse Image Spectra and Compare to Spectral Library
	Identify Spectra
	Close Windows and Plots
	Define Regions of Interest
	Create New Region of Interest
	Load Previously Saved Regions of Interest
	Extract Mean Spectra from ROIs

	Discriminate Mineralogy
	Close Plot Windows and ROI Controls

	2-D Scatter Plots
	Examine 2-D Scatter Plots
	Density Slice the Scatter Plot
	Scatter Plot Dancing Pixels
	Image Dancing Pixels
	Scatter Plots Linked to a Spectral Profile
	Scatter Plot ROIs
	Image ROIs
	Scatter Plots and Spectral Mixing

	End the ENVI Session

	References

	Selected Mapping Methods Using Hyperspectral Data
	Overview of This Tutorial
	Files Used in This Tutorial

	Removal of Residual Calibration Errors
	Open and Load the 1995 EFFORT-Corrected Data
	Compare ATREM and Effort Spectra
	Close All Files, Displays, and Plots

	Spectral Angle Mapper Classification
	Select Image Endmembers
	Execute SAM
	Select Spectral Library Endmembers
	Review SAM Results
	Optional: Generate new SAM Classified Images Using Rule Classifier
	Close Files and Plots

	Spectral Feature Fitting and Analysis
	Open and Load the Continuum-Removed Data
	To Create Your Own Data
	To Use Pre-Calculated Data

	Open and Load the 1995 EFFORT-Corrected Data
	Compare Continuum-removed spectra and EFFORT Spectra
	Compare Continuum-Removed and Effort Images
	Close the Effort Display and Spectral Profile
	Open and Load the SFF Scale and RMS Images
	To Create Your Own Data
	To Use Pre-Calculated Data

	2-D Scatterplots of SFF Results
	Spectral Feature Fitting Ratios — “Fit” Images
	To Create Your Own Data
	To Use Pre-Calculated Data

	End the ENVI Session

	References

	Advanced Hyperspectral Analysis
	Overview of This Tutorial
	Files Used in This Tutorial

	Open the 1995 Effort-Corrected Data
	MNF Transform Data, Endmembers, and Spectral Unmixing
	Background: Minimum Noise Fraction
	Open and Load MNF Image
	Compare MNF Images
	Examine MNF Scatter Plots
	Use Scatter Plots to Select Endmembers

	Pixel Purity Index
	Display and Analyze the Pixel Purity Index
	Threshold PPI to Regions of Interest

	n-Dimensional Visualization
	Compare n-D Data Visualization with 2-D Scatter Plot
	Use the n-D Visualizer
	Paint Your Own Endmembers
	Use the n-D Class Controls
	Link the n-D Visualizer to Spectral Profiles
	Link the Spectral Analyst to the n-D Visualizer Spectra
	Load Individual Spectra Into the n-D Visualizer
	Collapse Classes in the n-D Visualizer
	Export Your Own ROIs
	Save Your n-D Visualizer State
	Restore n-D Visualizer Saved State
	Close all Displays and Other Windows

	Spectral Mapping
	What Causes Spectral Mixing
	Modeling Mixed Spectra
	Practical Unmixing Methods

	Unmixing Results
	Open and Display the Unmixing Results
	Determine Abundance
	Display a Color Composite

	Mixture-Tuned Matched Filtering
	Perform Your Own Mixture-Tuned Matched Filtering
	Display and compare the EFFORT and MNF Data
	Collect the MNF Endmember Spectra for Use in MTMF
	Calculate MTMF Images
	Display MTMF Results
	Display Scatter Plots of MF Score versus Infeasibility

	End the ENVI Session

	References

	Hyperspectral Signatures and Spectral Resolution
	Overview of This Tutorial
	Files Used in This Tutorial
	Background
	Spectral Modeling and Resolution

	Case History: Cuprite, Nevada, USA
	Start ENVI
	Open a Spectral Library File
	View Library Spectra
	View Landsat TM Image and Spectra
	View GEOSCAN Data
	View GER63 Data
	View HyMap Data
	View AVIRIS Data
	Evaluate Sensor Capabilities
	End the ENVI Session

	Draw Conclusions
	References

	Geologic Hyperspectral Analysis Case History
	Overview of This Tutorial
	Objectives
	Tasks
	Files Used in This Tutorial
	Cuprite Background Materials

	HyMap Processing Flow
	Geologic Hyperspectral Analysis
	End the ENVI Session


	Archaeology Hyperspectral Analysis Case History
	Overview of This Tutorial
	Objectives
	Tasks
	Files Used in This Tutorial
	Selinunte/MIVIS Background Materials

	MIVIS Processing Flow
	Hyperspectral Techniques for Archeological Analysis
	End the ENVI Session


	Vegetation Hyperspectral Analysis Case History
	Overview of This Tutorial
	Objectives
	Tasks
	Files Used in This Tutorial
	Jasper Ridge Background Materials

	HyMap Processing Flow
	Vegetation Hyperspectral Analysis

	Near-Shore Marine Hyperspectral Case History
	Overview of This Tutorial
	Objectives
	Tasks
	Files Used in This Tutorial
	Moffett Field Site Background

	AVIRIS Processing Flow
	Hyperspectral Techniques for Vegetation Analysis
	References

	Multispectral Processing Using ENVI's Hyperspectral Tools
	Overview of This Tutorial
	Files Used in This Tutorial
	Background

	Standard Multispectral Image Processing
	Start ENVI
	Read TM Tape or CD
	Open and Display Landsat TM Data
	Display and Examine a Color Composite Image
	Conduct a Ratio Analysis
	Run Unsupervised Classification (IsoData)
	Clump and Sieve, Combine Classes
	Annotate and Output Map

	Analyze Multispectral Data with ENVI's Hyperspectral Tools
	Read TM Tape or CD
	Calibrate TM to Reflectance
	Display a Color Composite Image and Extract Spectra
	Run Minimum Noise Fraction (MNF) Transformation
	Run PPI to Find Endmembers
	n-D Visualization and Extract Endmembers
	Compare Image Spectra to Spectral Library
	Spectral Angle Mapper Classification
	Linear Spectral Unmixing
	Annotate and Output Map
	End the ENVI Session

	Summary
	References

	Introduction to HDF Format and Processing of MASTER Data
	Overview of This Tutorial
	Files Used in This Tutorial
	Background

	The HDF Format and Processing of MASTER Data
	Start ENVI
	Open a HDF File and Review Data Items
	Open the HDF File and Load image
	Open and Display MASTER HDF File
	Spatially/Spectrally Subset VNIR/SWIR
	Empirical Reflectance Calibration
	Display a Color Composite Image and Extract Spectra

	Compare Image Spectra
	Image Processing with SAM


	Introduction to Long�Wave Infrared MSI Data Using MASTER
	Overview of This Tutorial
	Files Used in This Tutorial
	Background

	Long�Wave Infrared MSI Data Using MASTER
	Open and Display MASTER HDF File
	Spatially/Spectrally Subset LWIR Data
	Display Various Bands
	Review LWIR Spectra/Spectral Features
	Design and Display Color Composites
	Perform Decorrelation Stretch
	\Compare LWIR and SWIR Results
	Perform Combined SWIR/LWIR Analysis


	Basic SAR Processing and Analysis
	Overview of This Tutorial
	Files Used in this Tutorial
	Background
	Concepts for processing SAR with ENVI
	RadarSat Data
	Level 1
	Level 2

	Radarsat-Specific Routines Added Starting with ENVI 2.5


	Single-Band SAR Processing Scenario
	Read CEOS Data, Display Data, and Review Quality
	Review CEOS Header
	Contrast Stretching (Square Root)

	Remove Speckle using Adaptive Filters
	Density Slice
	Edge Enhancement
	Data Fusion
	Image-Map Output
	End the ENVI Session

	Summary

	Polarimetric SAR Processing and Analysis
	Overview of This Tutorial
	Files Used in This Tutorial
	Background: SIR-C/SAR
	Analyzing SIR-C Data
	Read a SIR-C CEOS Data Tape
	Multilook SIR-C Data



	Synthesize Images
	Default Polarization Combinations
	Other Polarization Combinations
	Display Images
	Define ROIs for Polarization Signatures
	Extract Polarization Signatures
	Use Adaptive Filters
	Display the Filter Result

	Slant-to-Ground Range Transformation
	Use Texture Analysis
	Create Color-coded Texture Map

	Create an Image-Map for Output
	End the ENVI Session


	Analysis of DEMs and TOPSAR
	Overview of This Tutorial
	Files Used in This Tutorial
	Background - TOPSAR and DEMs
	Description of the Dataset


	Display and Convert the Data
	Start ENVI
	View the TOPSAR Headers
	Load and Display the Raw C-Band image
	Load and Display the Raw DEM image
	Convert the C-Band Data to Sigma Zero and DEM to Meters
	Synthesizing the P- and L-band Data

	Analysis of JPL Polarimetric SAR Data
	General Concepts for processing SAR with ENVI
	Remove Speckle using Adaptive Filters
	Edge Enhancement
	Compare Images using Linked Images and Dynamic Overlay
	Polarimetric Analysis
	Display Multifrequency, Polarimetric SAR Images
	Examine Polarization Signatures
	Pedestal Height Image


	Displaying and Analyzing DEMs
	Display the DEM Converted to Meters
	X and Y Elevation Profiles
	Arbitrary Elevation Transect
	Color Density Slice the DEM
	Overlay of Elevation Contours
	Basic 3-D Perspective Viewing and Image Overlay
	Generation of Slope, Aspect, and Shaded Relief
	Image-Map Output
	End the ENVI Session

	Summary

	ENVI Topographic Tools
	Overview of This Tutorial
	Files Used in This Tutorial

	ENVI Topographic Tools
	Start ENVI
	Select and Display the DEM
	Display Grayscale Image

	Color-Code the DEM
	DEM Contour Overlays
	Terrain Profiles
	Topographic Modeling
	Topographic Feature Parameters
	3D Visualization
	Start the ENVI 3D SurfaceView Function

	Interactive 3-D Visualization Controls
	End the ENVI Session


	3D Surface View and Fly-Through Using ENVI
	Overview of This Tutorial
	Files Used in This Tutorial

	3D Visualization Using ENVI
	Start ENVI
	Loading a 3D SurfaceView
	Open and Display the Landsat TM Data
	Open and Display the DEM as a Gray Scale Image
	Start the ENVI 3D SurfaceView Function

	Interactive Control of 3D Visualization
	The 3D SurfaceView Control Dialogs
	Type of Visualization
	Visualization Fine Controls
	Other Visualization Controls

	The SurfaceView Positioning Dialog
	Building and Playing a User-Defined Visualization Sequence
	Using ENVI Annotation to Build a Visualization Sequence
	The Animate Sequence Option
	Saving Visualizations and Output
	3D SurfaceView as an Analysis Tool
	End the ENVI Session


	Introduction to ENVI User Functions
	Overview of This Tutorial
	Files Used in This Tutorial

	Programming in ENVI
	User Defined Band Math Routines
	Start ENVI
	Open TM Data
	Edit the Band Math Function
	Compile the Band Math Function
	Run the Band Math Function

	Display the Result
	Creating a User Function
	Editing envi.men
	Creating an Event Handler
	Edit the Event Handler


	Running the User Function
	Start ENVI
	Open TM Data
	Compile the Event Handler
	Run the Event Handler

	Write the Tiling Routines
	Creating the Tiling Routine
	Updating the Event Handler
	Compile the Tile Processing Routine
	Run the Tile Processing Routine
	Display the Result
	Notes on Autocompiling

	End the ENVI Session


	Introduction to ENVI Plot Functions
	Overview of This Tutorial
	Files Used in This Tutorial

	ENVI Plot Functions
	Creating a Plot Function
	Adding the Plot Function
	Set up ENVI to Run the Plot Functions
	Running the Plot Function
	Start ENVI
	Open a Spectral Library and Plot Spectra

	End the ENVI Session



