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Overview of This Tutorial

This tutorial leads you through a typical multispectral classification procedure using
Landsat TM data from Canon City, Colorado. Results of both unsupervised and
supervised classifications are examined and post classification processing including
clump, sieve, combine classes, and accuracy assessment are discussed. It is assumed
that you are already generally familiar with multispectral classification techniques.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 2

Path: envidata/can_tm

File Description

can_tmr.img Boulder Colorado TM Reflectance

can_tmr.hdr ENVI Header for Above

can_km.img K MEANS Classification

can_km.hdr ENVI Header for Above

can_iso.img ISODATA Classification

can_iso.hdr ENVI Header for Above

classes.roi Regions of Interest (ROI) for Supervised
Classification

can_pcls.img Parallelepiped Classification

can_pcls.hdr ENVI Header for Above

can_bin.img Binary Encoding Result

can_bin.hdr ENVI Header for Above

can_sam.img SAM Classification Result

can_sam.hdr ENVI Header for Above

can_rul.img Rule image for SAM classification

can_rul.hdr ENVI Header for Above

can_sv.img Sieved Image
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can_sv.hdr ENVI Header for Above

can_clmp.img Clump of sieved image

can_clmp.hdr ENVI Header for Above

can_comb.img Combined Classes image

can_comb.hdr ENVI Header for Above

can_ovr.img Classes overlain on gray scale image

can_ovr.hdr ENVI Header for Above

can_v1.evf Vector layer generated from class #1

can_v2.evf Vector layer generated from class #2

File Description
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Examine Landsat TM Color Images

This portion of the exercise will familiarize you with the spectral characteristics of
Landsat TM data of Canon City, Colorado, USA. Color composite images will be
used as the first step in locating and identifying unique areas for use as training sets in
classification.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To start ENVI in UNIX, enter envi at the UNIX command line.

• To start ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

Open and Display Landsat TM Data

To open an image file:

1. Select File → Open Image File on the ENVI main menu.

Note
On some platforms you must hold the left mouse button down to display the
submenus from the ENVI main menu.

An Enter Data Filenames file selection dialog appears.

2. Navigate to the can_tm subdirectory of the envidata directory on the ENVI
Tutorial and Data CD No. 2 just as you would in any other application and
select the file can_tmr.img from the list and click OK.

The Available Bands List dialog appears on your screen. This list allows you
to select spectral bands for display and processing.

Note
You have the choice of loading either a gray scale or an RGB color image.
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3. Select the RGB Color radio button in the Available Bands List, and then
click on bands 4, 3, and 2 sequentially with the left mouse button.

The bands you have chosen are displayed in the appropriate fields in the center
of the dialog.

4. Click on the Load RGB button to load the image into a new display.

Review Image Colors

Use the displayed color image as a guide to classification. This image is the
equivalent of a false color infrared photograph. Even in a simple three-band image,
it’s easy to see that there are areas that have similar spectral characteristics. Bright
red areas on the image represent high infrared reflectance, usually corresponding to
healthy vegetation, either under cultivation, or along rivers. Slightly darker red areas
typically represent native vegetation, in this case in slightly more rugged terrain,
primarily corresponding to coniferous trees. Several distinct geologic and
urbanization classes are also readily apparent as is urbanization.

The following figure shows the resulting Main Image window for these bands.

Figure 3-1: Canon City Landsat TM Data.
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Cursor Location/Value

Use ENVI’s Cursor Location/Value dialog to preview image values in the displayed
spectral bands. To bring up a dialog box that displays the location of the cursor in the
Main Image, Scroll, or Zoom windows.

1. Select Tools → Cursor Location/Value from the Main Image window menu
bar.

Alternatively, double-click the left mouse button in the image display to toggle
the Cursor Location/Value dialog on and off.

2. Move the cursor around the image and examine the data values in the dialog
for specific locations. Also note the relation between image color and data
value.

3. Select Files → Cancel in the Cursor Location/Value dialog to dismiss when
finished.

Examine Spectral Plots

Use ENVI’s integrated spectral profiling capabilities to examine the spectral
characteristics of the data.

1. Choose Tools → Profiles → Z Profile (Spectrum) from the Main Image
window menu bar to begin extracting spectral profiles.

2. Examine the spectra for areas that you previewed above using color images
and the Cursor/Location Value dialog by clicking the left mouse button in
any of the display group windows. Note the relations between image color and
spectral shape. Pay attention to the location of the image bands in the spectral
profile, marked by the red, green, and blue bars in the plot.
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3. Select File → Cancel in the Spectral Profile dialog to dismiss it.

Unsupervised Classification

Start ENVI’s unsupervised classification routines from the ENVI main menu, by
choosing Classification → Unsupervised → K-Means or IsoData, or review the
pre-calculated results of classifying the image in the can_tm directory.

K-Means

Unsupervised classification uses statistical techniques to group n-dimensional data
into their natural spectral classes. The K-Means unsupervised classifier uses a cluster
analysis approach which requires the analyst to select the number of clusters to be
located in the data, arbitrarily locates this number of cluster centers, then iteratively
repositions them until optimal spectral separability is achieved.

Choose K-Means as the method, use all of the default values and click on OK, or
review the results contained in can_km.img.

1. Open the file can_km.img, click on the Gray Scale radio button in the
Available Bands List, click on the band name at the top of the list, select New
Display on the Display button pull-down menu, and then Load Band.

Figure 3-2: Spectral Plots from Canon City TM Data.
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2. From the Main Image display menu, select Tools → Link → Link Displays
and click OK in the dialog to link the images.

3. Compare the K-MEANS classification result to the color composite image by
clicking and dragging using the left mouse button to move the dynamic
overlay around the image.

4. When finished, select Tools → Link → Unlink Display to remove the link
and dynamic overlay.

If desired, experiment with different numbers of classes, change thresholds, standard
deviations, and maximum distance error values to determine their effect on the
classification.

Isodata

IsoData unsupervised classification calculates class means evenly distributed in the
data space and then iteratively clusters the remaining pixels using minimum distance
techniques. Each iteration recalculates means and reclassifies pixels with respect to
the new means. This process continues until the number of pixels in each class
changes by less than the selected pixel change threshold or the maximum number of
iterations is reached.

Choose IsoData as the method, use all of the default values and click on OK, or
review the results contained in can_iso.img.

1. Open the file can_iso.img, click on the Gray Scale radio button in the
Available Bands List, click on the band name at the top of the list, select the
Display #1 button and choose New Display on the pull-down menu. Then
click on the Load Band button.

2. Select Tools → Link → Link Displays. Click OK to link this image to the
color composite image and the K-MEANS result.

3. Compare the IsoData classification result to the color composite image by
clicking and dragging using the left mouse button to move the dynamic
overlay around the image. Toggle the dynamic overlay of the third image by
holding the left mouse button down and simultaneously clicking on the middle
mouse button. Compare the ISODATA and K-MEANS classifications.

4. Select File → Cancel to dismiss the two image displays.

If desired, experiment with different numbers of classes, change thresholds, standard
deviations, maximum distance error, and class pixel characteristic values to
determine their effect on the classification.
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Supervised Classification

Supervised classification requires that the user select training areas for use as the
basis for classification. Various comparison methods are then used to determine if a
specific pixel qualifies as a class member. ENVI provides a broad range of different
classification methods, including Parallelepiped, Minimum Distance, Mahalanobis
Distance, Maximum Likelihood, Spectral Angle Mapper, Binary Encoding, and
Neural Net. Examine the processing results below, or use the default classification
parameters for each of these classification methods to generate your own classes and
compare results.

To perform your own classifications from the ENVI main menu, select
Classification → Supervised → [method], where [method] is one of the supervised
classification methods in the pull-down menu (Parallelepiped, Minimum Distance,
Mahalanobis Distance, Maximum Likelihood, Spectral Angle Mapper, Binary
Encoding, or Neural Net). Use one of the two methods below for selecting training
areas, also known as regions of interest (ROIs).

Select Training Sets Using Regions of Interest (ROI)

As described in Tutorial 1, “Introduction to ENVI” and summarized here, ENVI lets
you easily define regions of interest (ROIs) typically used to extract statistics for
classification, masking, and other operations. For the purposes of this exercise, you
can either use predefined ROIs, or create your own.

Restore Predefined ROIs

1. Use pre-selected regions of interest by starting the #1 ROI Tool dialog by
choosing from the #1 Main Image menu bar Overlay → Region of Interest.

2. In the #1 ROI Tool dialog choose File → Restore ROIs.

3. The Enter ROI Filename dialog opens. Select CLASSES.ROI as the input file
to restore.

Create Your Own ROIs

1. Select Overlay → Region of Interest from the Main Image window menu
bar. The ROI Tool dialog for the display group appears.

2. In the Main Image window draw a polygon that represents the new region of
interest. To accomplish this, do the following.

• Click the left mouse button in the Main Image window to establish the first
point of the ROI polygon.
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• Select further border points in sequence by clicking the left button again,
and close the polygon by clicking the right mouse button.The middle
mouse button deletes the most recent point, or (if you have closed the
polygon) the entire polygon. Fix the polygon by clicking the right mouse
button a second time.

• ROIs can also be defined in the Zoom and Scroll windows by choosing the
appropriate radio button at the top of the ROI Controls dialog.

When you have finished defining an ROI, it is shown in the dialog’s list of
Available Regions, with the name, region color, and number of pixels
enclosed, and is available to all of ENVI’s classification procedures.

3. To define a new ROI, click the New Region button.

• You can enter a name for the region and select the color and fill patterns
for the region by clicking on the Edit button to bring up the Edit ROI
Parameters dialog. Define the new ROI as described above.

Classical Supervised Multispectral Classification

The following methods are described in most remote sensing textbooks and are
commonly available in today’s image processing software systems.

Parallelepiped

Parallelepiped classification uses a simple decision rule to classify multispectral data.
The decision boundaries form an n-dimensional parallelepiped in the image data
space. The dimensions of the parallelepiped are defined based upon a standard
deviation threshold from the mean of each selected class.

1. Pre-saved results are in the file can_pcls.img. Examine these or perform
your own classification using the CLASSES.ROI regions of interest described
above. Try using the default parameters and various standard deviations from
the mean of the ROIs.

2. Use image linking and dynamic overlay to compare this classification to the
color composite image and previous unsupervised classifications.
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Maximum Likelihood

Maximum likelihood classification assumes that the statistics for each class in each
band are normally distributed and calculates the probability that a given pixel belongs
to a specific class. Unless a probability threshold is selected, all pixels are classified.
Each pixel is assigned to the class that has the highest probability (i.e., the maximum
likelihood).

1. Perform your own classification using the CLASSES.ROI regions of interest
described above. Try using the default parameters and various probability
thresholds.

2. Use image linking and dynamic overlay to compare this classification to the
color composite image and previous unsupervised and supervised
classifications.

Minimum Distance

The minimum distance classification uses the mean vectors of each ROI and
calculates the Euclidean distance from each unknown pixel to the mean vector for
each class. All pixels are classified to the closest ROI class unless the user specifies

Figure 3-3: Parallelepiped Classification Image.
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standard deviation or distance thresholds, in which case some pixels may be
unclassified if they do not meet the selected criteria.

1. Perform your own classification using the CLASSES.ROI regions of interest
described above. Try using the default parameters and various standard
deviations and maximum distance errors.

2. Use image linking and dynamic overlay to compare this classification to the
color composite image and previous unsupervised and supervised
classifications.

Mahalanobis Distance

The Mahalanobis Distance classification is a direction sensitive distance classifier
that uses statistics for each class. It is similar to the Maximum Likelihood
classification but assumes all class covariances are equal and therefore is a faster
method. All pixels are classified to the closest ROI class unless the user specifies a
distance threshold, in which case some pixels may be unclassified if they do not meet
the threshold.

1. Perform your own classification using the CLASSES.ROI Regions of Interest
described above. Try using the default parameters and various maximum
distance errors.

2. Use image linking and dynamic overlay to compare this classification to the
color composite image and previous unsupervised and supervised
classifications.

Spectral Classification Methods

The following methods are described in the ENVI 3.5 User’s Guide. These were
developed specifically for use on Hyperspectral data, but provide an alternative
method for classifying multispectral data, often with improved results that can easily
be compared to spectral properties of materials. They typically are used from the
Endmember Collection dialog using image or library spectra, however, they can also
be started from the classification menu, Classification → Supervised → [method],
where [method] represents one of the methods shown in the pull-down menu.

The Endmember Collection Dialog

The Endmember Collection:Parallel dialog is a standardized means of collecting
spectra for supervised classification from ASCII files, regions of interest, spectral
libraries, and statistics files.

1. To start the Classification Input File dialog from the ENVI main menu, select
Spectral → Mapping Methods → Endmember Collection.



Tutorial 3: Multispectral Classification 101

ENVI Tutorials Examine Landsat TM Color Images

This dialog can also be started by choosing Classification → Endmember
Collection from the ENVI main menu.

2. In the Classification Input File dialog, click on the Open File button at the
bottom of the dialog.

3. A new file selection dialog appears. In the Please Select a File dialog, choose
the input file can_tmr.img and click Open (Windows) or OK (UNIX). The
can_tmr.img file will appear in the Select Input File: section of the
Classification Input File dialog.

4. Click on the can_tmr.img file within the Select Input File: section of this
dialog and then click OK.

5. This brings up the Endmember Collection:Parallel dialog.

The Endmember Collection dialog appears with the Parallelepiped classification
method selected by default. The available classification and mapping methods are
listed by choosing Algorithm → [method] from the Endmember Collection dialog
menu bar, where [method] represents one of the methods available: currently
including Parallelepiped, Minimum Distance, Manlanahobis Distance,
Maximum Likelihood, Binary Encoding, and the Spectral Angle Mapper (SAM).

Figure 3-4: Endmember Collection dialog.
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Binary Encoding Classification

The binary encoding classification technique encodes the data and endmember
spectra into 0s and 1s based on whether a band falls below or above the spectrum
mean. An exclusive OR function is used to compare each encoded reference
spectrum with the encoded data spectra and a classification image is produced. All
pixels are classified to the endmember with the greatest number of bands that match
unless the user specifies a minimum match threshold, in which case some pixels may
be unclassified if they do not meet the criteria.

1. Pre-saved Binary Encoding results are in the file can_bin.img. These were
created using a minimum encoding threshold of 75%. Examine these or
perform your own classification using the CLASSES.ROI regions of interest
described above. To do your own classification, select Algorithm → Binary
Encoding from the menu bar.

2. Use the predefined regions of interest in the file CLASSES.ROI. From the
Endmember Collection dialog menu bar, select Import → from ROI from
Input File.

3. The Input Regions of Interest dialog appears. Click the Select All Items
button, and click OK.

4. You can view the Endmember Spectra plots for the ROIs from the
Endmember Collections dialog menu bar by choosing Options → Plot
Endmembers.

5. In the Endmember Collections dialog click on Apply. This brings up the
Binary Encoding Parameters dialog box.

6. In the Binary Encoding Parameters dialog, click the Memory radio button in
the Output Result to section.

7. Click on the spin button for the Output Rule Images text field to change it to
No and click OK at the bottom of the dialog to start the classification.

8. Use image linking and dynamic overlays to compare this classification to the
color composite image and previous unsupervised and supervised
classifications.

Spectral Angle Mapper Classification

The Spectral Angle Mapper (SAM) is a physically-based spectral classification that
uses the n-dimensional angle to match pixels to reference spectra. The algorithm
determines the spectral similarity between two spectra by calculating the angle
between the spectra, treating them as vectors in a space with dimensionality equal to
the number of bands.
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1. Pre-saved SAM Classification results are in the file can_sam.img. Examine
these or perform your own classification using the CLASSES.ROI Regions of
Interest described above, which will be listed in the Endmember Collection
dialog. To do your own classification, select Algorithm → Spectral Angle
Mapper from the Endmember Collection menu bar. Click Apply to start the
classification.

2. If performing your own classification, enter the output filename
can_tmr.sam for the SAM classification image in the Endmember Collection
dialog. Also enter the filename can_rul.img as the rule output image name
and click OK at the bottom of the dialog to start the classification.

3. Use image linking and dynamic overlays to compare this classification to the
color composite image and previous unsupervised and supervised
classifications.

Rule Images

ENVI creates images that show the pixel values used to create the classified image.
These optional images allow users to evaluate classification results and to reclassify
if desired based on thresholds. These are gray scale images; one for each ROI or
endmember spectrum used in the classification.

Figure 3-5: Rule Image for Canon City Landsat TM, Spectral Angle Mapper
Classification. Stretched to show best matches (low spectral angles) as bright

pixels.
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The rule image pixel values represent different things for different types of
classifications, for example:

1. For the SAM classification above, load the classified image and the rule
images into separate displays and compare using dynamic overlays. Invert the
SAM rule images using Tools → Color Mapping → ENVI Color Tables and
dragging the Stretch Bottom and Stretch Top sliders to opposite ends of the
dialog. Areas with low spectral angles (more similar spectra) should appear
bright.

2. Create classification and rule images using the other methods. Use dynamic
overlays and Cursor Location/Value to determine if better thresholds could
be used to obtain more spatially coherent classifications.

3. If you find better thresholds, select Classification → Post
Classification → Rule Classifier from the ENVI main menu.

4. Double-click the can_tmr.sam input file to bring up the Rule Image
Classifier Tool, enter a threshold to create a new classified image. Compare
your new classification to the previous classifications.

Post Classification Processing

Classified images require post-processing to evaluate classification accuracy and to
generalize classes for export to image-maps and vector GIS. ENVI provides a series
of tools to satisfy these requirements

Classification Method Rule Image Values

Parallelepiped Number of bands that satisfied the parallelepiped
criteria.

Minimum Distance Sum of the distances from the class means

Maximum Likelihood Probability of pixel belonging to class

Mahalanobis Distance Distances from the class means

Binary Encoding Binary Match in Percent

Spectral Angle Mapper Spectral Angle in Radians (smaller angles indicate
closer match to the reference spectrum)
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Class Statistics

This function allows you to extract statistics from the image used to produce the
classification. Separate statistics consisting of basic statistics (minimum value,
maximum value, mean, std deviation, and eigenvalue), histograms, and average
spectra are calculated for each class selected.

1. Choose Classification → Post Classification → Class Statistics to start the
process and select the Classification Image can_pcls.img and click OK.

2. Next select the image used to produce the classification can_tmr.img and
click OK.

3. Use the Class Selection dialog to choose the classes for statistics. Click on
Select All Items, then OK.

4. Finally, choose the statistics to be calculated in the Compute Statistics
Parameters dialog, click OK at the bottom of the Compute Statistics
Parameters dialog.

Several plots and reports will appear, depending on the statistics options selected.

Confusion Matrix

ENVI’s confusion matrix function allows comparison of two classified images (the
classification and the “truth” image), or a classified image and ROIs. The truth image
can be another classified image, or an image created from actual ground truth
measurements.

Figure 3-6: Statistics reports from Parallelepiped Classification of Canon City,
CO, Thematic Mapper data.
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1. Select Classification → Post Classification → Confusion
Matrix → [method], where [method] is either Using Ground Truth Image,
or Using Ground Truth ROIs.

2. For the Ground Truth Image Method, compare the Parallelepiped and SAM
methods by entering the two filenames can_sam.img and can_pcls.img
and clicking OK (for the purposes of this exercise, we are using the
can_pcls.img file as the ground truth).

3. Use the Match Classes Parameters dialog to pair corresponding classes from
the two images and click OK.

4. Use Output Result to radio button to output the result to Memory and then
click OK in the Confusion Matrix Parameters dialog.

5. Examine the confusion matrix and confusion images. Determine sources of
error by comparing the classified image to the original reflectance image using
dynamic overlays, spectral profiles, and Cursor Location/Value.

6. For the Using Ground Truth ROIs method, select the classified image
can_sam.img to be evaluated.

7. Match the image classes to the ROIs loaded from CLASSES.ROI, and click
OK to calculate the confusion matrix.

8. Click OK in the Confusion Matrix Parameters dialog.

9. Examine the confusion matrix and determine sources of error by comparing
the classified image to the ROIs in the original reflectance image using
spectral profiles, and Cursor Location/Value.
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Clump and Sieve

Clump and Sieve provide means for generalizing classification images. Sieve is
usually run first to remove the isolated pixels based on a size (number of pixels)
threshold, and then clump is run to add spatial coherency to existing classes by
combining adjacent similar classified areas. Compare the pre-calculated results in the
files can_sv.img (sieve) and can_clmp.img (clump of the sieve result) to the
classified image can_pcls.img (parallelepiped classification) or calculate your
own images and compare to one of the classifications.

Figure 3-7: Confusion Matrix using a second classification image as Ground
Truth.
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1. To execute the function, select Classification → Post Classification → Sieve
Classes, choose one of the classified images, enter an output to Memory and
click OK.

2. Use the output of the sieve operation as the input for clumping. Choose
Classification → Post Classification → Clump Classes, choose the
previously-made image from memory and click OK.

3. Output to memory and click OK in the Clump Parameters dialog.

4. Compare the three images and reiterate if necessary to produce a generalized
classification image.

Combine Classes

The Combine Classes function provides an alternative method for classification
generalization. Similar classes can be combined to form one or more generalized
classes.

1. Examine the pre-computed image can_comb.img or perform your own
combinations as described below.

2. Select Classification → Post Classification → Combine Classes.

3. Select the can_sam.img file in the Combine Classes Input File dialog and
click OK.

4. Choose Region 3 to combine with Unclassified, click on Add Combination,
and then OK in the Combine Classes Parameters dialog. Output memory and
click OK.

5. Compare the combined class image to the classified images and the
generalized classification image using image linking and dynamic overlays.

Edit Class Colors

When a classification image is displayed, you can change the color associated with a
specific class by editing the class colors.

1. Select Tools → Color Mapping → Class Color Mapping in the Main Image
Display window.

2. Click on one of the class names in the Class Color Mapping dialog and
change the color by dragging the appropriate color sliders or entering the
desired data values. Changes are applied to the classified image immediately.
To make the changes permanent, select Options → Save Changes in the
dialog.
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Overlay Classes

Overlay classes allows the user to place the key elements of a classified image as a
color overlay on a gray scale or RGB image.

1. Examine the pre-calculated image can_ovr.img or create your own
overlay(s) from the can_tmr.img reflectance image and one of the classified
images above.

2. Select Classification → Post Classification → Overlay Classes from the
ENVI main menu.

3. Choose the current display as an input for class overly from the Available
Bands List dialog.

4. Select can_tmr.img band 3 for each RGB band (band 3 for the R band,
band 3 for the G band, and band 3 for the B band) in the Input Overlay RGB
Image Input Bands dialog and click OK.

5. Use can_comb.img as the classification input in the Classification Input File
dialog.

6. Click OK and then choose Region #1 and Region #2 in the Class Overlay to
RGB Parameters dialog to overlay on the image. Output to memory and click
OK to complete the overlay.

7. Load the overlay image into an image display and compare with the classified
image and the reflectance image using linking and dynamic overlays.

Interactive Classification Overlays

In addition to the methods above for working with classified data, ENVI also
provides an interactive classification overlay tool. This tool allows you to
interactively toggle classes on and off as overlays on a displayed image, to edit
classes, get class statistics, merge classes, and edit class colors.

1. Display band 4 of can_tmr.img as a gray scale image using the Available
Bands List dialog.

2. From the Main Image window menu bar, select Overlay → Classification.

3. Choose one of the available classified images (a good choice is
can_sam.img) in the Interactive Class Tool Input File dialog and click OK.

The Interactive Class Tool dialog will appear and each class will be listed
with it’s corresponding colors.
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4. Click in each On check box to change the display of each class as an overlay
on the gray scale image.

5. Try the various options for assessing the classification under the Options
menu.

6. Choose various options under the Edit menu to interactively change the
contents of specific classes.

7. Select File → Save Image As → [Device] in the Main Image window (where
[Device] is either Postscript or Image) to burn in the classes and output to a
new file.

8. Select File → Cancel to exit the interactive tool.

Classes to Vector Layers

Load the pre-calculated vector layers onto the gray scale reflectance image for
comparison to raster classified images, or execute the function and convert one of the
classification images to vector layers. You can use the following steps to load the pre-
calculated vector layers produced from the clumped classification image above:

1. Select Overlay → Vectors in the Main Image window with the clumped
image can_clmp.img displayed.

2. Choose File → Open Vector File → ENVI Vector File in the Vector
Parameters dialog and choose the files can_v1.evf and can_v2.evf. Choose
Select All Layers in the Available Vectors List dialog, then choose Load
Selected. Select the can_dmp.img. From the Vector Parameters dialog, click
Apply to load the vector layers onto the image display. The vectors derived
from the classification polygons will outline the raster classified pixels.

To complete your own classification to vector conversion:

1. Select Classification → Post Classification → Classification to Vector and
choose the generalized image can_clmp.img within the Raster to Vector
Input Band dialog.

2. Select Region #1 and Region #2 and enter the root name canrtv and click
OK to begin the conversion.

3. Select the two regions in the Available Vectors List dialog click on Load
Selected at the bottom of the dialog.

4. Choose the correct display number in the Load Vector dialog for the gray
scale reflectance image and the vector layers will be loaded into the Vector
Parameters dialog. Click Apply to display the vectors over the image. Use
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Edit Layers to change the colors and fill of the vector layers to make them
more visible.

Classification Keys Using Annotation

ENVI provides annotation tools to put classification keys on images and in map
layouts. The classification keys are automatically generated.

1. Choose Overlay → Annotation from the Main Image window menu bar for
either one of the classified images, or for the image with the vector overlay.

2. Select Object → Map Key to start annotating the image. You can edit the key
characteristics by clicking on the Edit Map Key Items button in the
Annotation: Map Key dialog and changing the desired characteristics.

3. Click and drag the map key using the left mouse button in the display to place
the key.

4. Click in the display with the right mouse button to finalize the position of the
key. For more information about image annotation, please see the ENVI 3.5
User’s Guide.

End the ENVI Session

This concludes the Tutorial. You can quit your ENVI session by selecting
File → Exit (Quit on UNIX) on the ENVI main menu, then clicking OK to exit IDL.

Figure 3-8: Classification image with classification key.
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If you are using ENVI RT, quitting ENVI will take you back to your operating
system.
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Tutorial 4:

Image Georeferencing
and Registration

The following topics are covered in this tutorial:

Overview of This Tutorial . . . . . . . . . . . . . 114
Georeferenced Images in ENVI . . . . . . . . 116

Georeferenced Data and Image-Map . . . . . 117

Image to Image Registration . . . . . . . . . . 125
Image to Map Registration . . . . . . . . . . . . 132

HSV Merge of Different Resolution
Georeferenced Data Sets . . . . . . . . . . . . . 139
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Tutorial 7:

Mosaicking Using ENVI

The following topics are covered in this tutorial:

Overview of This Tutorial . . . . . . . . . . . . . 174
Mosaicking in ENVI . . . . . . . . . . . . . . . . . 176

Pixel-Based Mosaicking Example . . . . . . 183
Georeferenced Mosaicking Example . . . . 187
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Overview of This Tutorial

This tutorial is designed to give you a working knowledge of ENVI's image
mosaicking capabilities. For additional details, please see the ENVI 3.5 User’s Guide
or the ENVI Online Help.

Files Used in this Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 1

Path: envidata/avmosaic

File Description

Pixel-Based Mosaicking

dv06_2.img AVIRIS Scene 02

dv06_2.hdr ENVI Header for above

dv06_3.img AVIRIS Scene 03

dv06_3.hdr ENVI Header for above

dv06a.mos Mosaic Template for end-to-end AVIRIS mosaic

dv06b.mos Mosaic Template for feathered overlapping AVIRIS
mosaic

dv06_fea.img Feathered Mosaic image

dv06_fea.hdr ENVI Header for above

Georeferenced Mosaicking

lch_01w.img Warped, histogram matched image

lch_01w.hdr ENVI Header for above

lch_01w.ann Cut-line feathering annotation for above

lch_02w.img Warped, histogram matched image

lch_02w.hdr ENVI Header for above

lch_a.mos Mosaic Template for Georeferenced Image
Mosaicking
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lch_mos1.img Georeferenced mosaic result

lch_mos1.hdr ENVI Header for above

File Description
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Mosaicking in ENVI

Mosaicking is the art of combining multiple images into a single composite image. It
can be used to combine pixel-based images, to lay out images for publication or map
composition, or as a means for combining georeferenced images into an image
covering a larger geographic area. ENVI provides interactive capabilities for placing
pixel-based images within a mosaic, and automated placement of georeferenced
images within a georeferenced output mosaic. The software provides tools for
common mosaic requirements such as blending edges (feathering), image border
transparency, and histogram matching. ENVI's Virtual Mosaic capability allows
users to optionally create and display mosaics without creating large output files.

General Topics

The following sections walk you through some of the preparation required to make
mosaics in ENVI. The actual exercises begin with the section “Pixel-Based
Mosaicking Example” on page 183 or alternatively, for georeferenced mosaics, in the
section “Georeferenced Mosaicking Example” on page 187.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To open ENVI in UNIX, enter envi at the UNIX command line.

• To open ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

Preparing Images

Raw image data can be mosaicked together if desired (ENVI can be used to easily
produce multiband mosaics of multiple data types), however, most mosaics are for
output and usually require scaling (contrast stretching), and histogram matching to
minimize image differences in the output mosaic.

The first step in creating a mosaic using ENVI is usually to contrast stretch the
images. This is done by displaying the bands to be mosaicked and either using one of
ENVI's quick (default) stretches or using ENVI's interactive contrast stretching
capabilities.
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Start in either of the following Pixel-Based (“Steps for Creating a Pixel-Based
Mosaic” on page 180) or the Georeferenced Image Mosaic (“Create the
Georeferenced Mosaic Image” on page 187) sections and open the appropriate
images by navigating to the avmosaic subdirectory of the envidata directory on
the ENVI Tutorial and Data CD No. 1, selecting the desired image file and opening it
just as you would in any other application.

Open the Files

1. Select File → Open Image File. An Enter Data Filenames file selection
dialog appears. Select the desired file.

Note
On some platforms you must hold the left mouse button down to display the
submenus from the Main Menu.

2. Display the image(s) by selecting the desired bands in the Available Bands
List and clicking Load Band.

3. Select Enhance → [Image] Linear 2% to stretch the displayed image, or
select Enhance → Interactive Stretching.

4. Stretch the image to enhance the desired image features and output to memory
or a new file by selecting File → Save Image As → Image File in the Main
Display window.

Histogram Matching

When mosaicking two or more images that overlap, it is usually necessary to choose
a base image and balance gray scale values in the rest of the images to match the base
image. This is called histogram matching (Richards, 1993). ENVI provides an
interactive tool to perform histogram matching. The procedure for performing the
histogram matching is described below.

The following steps are provided for information and are not to be executed as part of
this tutorial.

1. Display the two images to be histogram matched in two display windows.
Select one of the images as the base image and stretch that image as desired
using either the default stretches under the Enhance menu or
Enhance → Interactive Stretching.

2. Identify the overlap areas, position the Zoom windows of both images within
the overlap, and resize and/or reposition the Zoom window to cover exactly the
same region in both images (try to cover as large an area as possible and a
broad range of cover types).
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3. Select Enhance → Histogram Matching from the Main Image Display menu
bar of the image you want to match to the base image. The Histogram
Matching Input dialog appears.

4. Select the display number of the base image to match, click on the Zoom radio
button, and then click OK.

The output histogram from the base image is applied to the histogram of the
second image and histogram matching is complete. The two images should
now have the same gray scale characteristics.

5. Save the two contrast stretched images by selecting File → Save Image
As → Image File in both Main Displays.

6. Select to save the stretched files either to memory or to new output files.

7. Repeat for additional overlapping images as required.

You may want to try the histogram matching yourself on the input file for the
“Georeferenced Mosaicking Example” on page 187. However, for the purpose of this
exercise, the pre-stretched, histogram-matched images lch_01w.img and
lch_02w.img are provided as input to the georeferenced mosaicking function.

Feathering

It is often desirable to blend or blur the seams between mosaicked images. ENVI
provides the capability of feathering the edges of overlapping areas using either edge
feathering or cutline feathering over a user specified distance. To use feathering when
mosaicking images, import the bottom image without feathering. Import the
overlapping images with feathering, either edge or cutline, as desired.

Edge Feathering

Edge Feathering uses the distance
specified in the Edge feathering
distance (pixels) text box in the
Mosaic Entry Input Parameters
dialog to blend the image seams along
the edges of the image. The edge
feathering distance specified is blended
using a linear ramp that averages the
two images across that distance. For
example, if the specified distance is 20
pixels, 0% of the top image is used in
the blending at the edge and 100% of
the bottom image is used to make the

Figure 7-1: Edge Feathering
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output image. At the specified distance (20 pixels) in from the edge, 100% of the top
image is used to make the output image and 0% of the bottom image is used. At 10
pixels in from the edge, 50% of each image is used to make the output image.

Cut-Line Feathering

Cut-Line Feathering uses the distance
specified in the Cutline feathering
distance (pixels) text box and the
annotation file selected from Ann File in
the Mosaic Entry Input Parameters
dialog to blend the image boundaries.
Cutlines must be defined using the
annotation tools prior to mosaicking.
The annotation file must contain a
polyline defining the cutline that is
drawn from edge-to-edge and a symbol
placed in the region of the image that
will be cut off. The cutline distance
specified is used to create a linear ramp that averages the two images across that
distance from the cutline outwards. For example, if the specified distance is 20 pixels,
100% of the top image is used in the blending at the cutline and 0% of the bottom
image is used to make the output image. At the specified distance (20 pixels) out
from the cutline, 0% of the top image is used to make the output image and 100% of
the bottom image is used. At 10 pixels in from the cutline, 50% of each image is used
to make the output image.

Virtual Mosaics

ENVI allows use of the mosaic template file as a means of constructing a “Virtual
Mosaic” — a mosaic that can be displayed and used by ENVI without actually
creating the mosaic output file.

1. To create a virtual mosaic, create the mosaic and save the template file using
File → Save Template in the Image Mosaicking dialog. This creates a small
text file describing the mosaic layout

2. To use the virtual mosaic, select File → Open Image File from the ENVI
main menu and open the mosaic template file. All of the images used in the
mosaic are opened and their bands are listed in the Available Bands List.
Display or process any of the bands in the virtual mosaic, and ENVI treats the
individual images as if they were an actual mosaic output file. The new
processed file has the specified size of the mosaic and the input files are in
their specified positions within the mosaic.

Figure 7-2: Cutline Feathering
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Steps for Creating a Pixel-Based Mosaic

The following describes the steps required to create a pixel-based image mosaic.

Set up the Mosaicking Dialog

1. Select Map → Mosaicking → Pixel Based from the ENVI main menu.

The pixel-based option can also be used to place georeferenced images, where
the georeferencing information will not be retained. Pixel-based images can
also be placed within a georeferenced image using the
Map → Mosaicking → Georeferenced option.

2. For pixel-based images, set the size of the output mosaic by entering the
desired size in pixels in X Size (Samples) and Y Size (Line) parameters in the
dialog.

3. Also set the “Snap” factor, which controls a grid to which images will be
placed or snapped (for example, a snap of 5 means that pixel-based images will
be placed at the nearest intersection of a pixel grid with 5 x 5 pixel spacing).
Set the snap factor by selecting Options → Set Snap Value.

Import Images

Use one of the following methods to import images depending on the type of mosaic
and whether the images have overlapping areas.

Importing Images Without Feathering

Images that do not overlap, or images that do not require blending should be imported
using the Import file without feathering option as follows:

1. Select Import → Import file without feathering from the menu bar in the
pixel-based or georeferenced Mosaicking dialog.

2. Open and select the desired image in the Mosaic Input File dialog and
spectrally and/or spatially subset it if desired.

The image description will be listed in the dialog, and a graphic representing
the image and its position in the mosaic will be displayed in the draw widget
within the dialog.

3. Open and import the remaining images in the mosaic in the same fashion.
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Importing Images With Feathering

Images that overlap may require feathering of the overlap areas to avoid obvious
seams in the final mosaic.

1. Select Import → Import file with feathering from the menu bar in the
Mosaicking dialog.

If cutline feathering is being used, the cutline must already have been drawn as
a polyline annotation and saved to an annotation file as described in the section
“Cut-Line Feathering” on page 179.

2. For both cutline and edge feathering, specify a distance over which to feather
as described in “Feathering” on page 178.

Feathering blends adjoining images, but mosaicking with feathering is
computationally intensive and requires a long time to run, especially for large
mosaics.

Importing Images With a Background Value to Ignore

This option allows image transparency for overlapping images.

1. Select Import → Import file with feathering regardless of whether or not
you want to feather the images. This allows you to set a background value to
ignore when images overlay one another.

2. If feathering (which is used for mosaicking images with constant digital
number value borders) is desired, enter the desired values, however, if
feathering is not desired, leave the feathering values set to zero.

3. Enter the data value to be ignored in the labeled text box.

The overlap areas with this value will be transparent, allowing underlying images to
show through. This value will also be ignored during the feathering process if
selected.

Create a Virtual Mosaic or an Output Mosaic

Complete one of the following steps, either creating a template (virtual mosaic) or
creating an output mosaic:

1. To create a virtual mosaic, described in “Virtual Mosaics” on page 179, select
File → Save Template, enter the output filename, and click OK. To view this
mosaic, select File → Open Image File from the ENVI main menu, choose
the mosaic template file as the input file and click Open. Click on the mosaic
band name in the Available Bands List and then Load Band to automatically
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get the required images and display the virtual mosaic to the ENVI Image
Display.

2. Alternatively, to actually create the mosaic as a new file, select File → Apply
in the Mosaic dialog and enter an output filename. The output mosaic is a
standard ENVI file and can be displayed using the Available Bands List.
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Pixel-Based Mosaicking Example

This section leads you through creation of pixel-based mosaics using ENVI’s
mosaicking tools.

1. Start the ENVI pixel-based mosaic function by selecting
Map → Mosaicking → Pixel Based from the ENVI main menu.

2. The Pixel Based Image Mosaicking dialog appears.

Import and Position Images

To position pixel-based images:

1. Import each of the following two images, dv06_2.img and dv06_3.img, by
selecting Import → Import file without feathering from the Pixel Based
Image Mosaicking dialog.

2. Specify the mosaic size by entering the 614 for the X Size and 1024 for the Y
Size in the text boxes at the top of the Pixel Based Image Mosaicking dialog.

3. Click on the second image in the list of images in the dialog (dv06_3.img).

Figure 7-3: The Pixel Based Image Mosaicking Dialog
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The current position of the image in pixels will be listed in the text box at the
bottom of the dialog.

4. Change the image position by entering the desired XO (x offset) and YO (y
offset) values in pixels in the corresponding text boxes. Enter a value of 513
for the YO for dv06_3.img to place it directly below dv06_2.img.

Note
Images can also be positioned by clicking and holding the left mouse button on the
desired image in the mosaic diagram on the right side of the dialog, dragging the
selected image to the desired location, and releasing the left mouse button to place
the image.

5. Select File → Apply from the Pixel Based Image Mosaicking dialog menu
and enter the output filename dv06.img and click OK to create the mosaic.

6. Choose File → Save Template from the Pixel Based Image Mosaicking
dialog and enter the output filename dv06a.mos.

7. Display the mosaicked image by clicking on the dv06a.mos band name in
the Available Bands List and then clicking Load Band.

The second part of this example shows positioning of the two images into a
composite mosaic image, accomplished by either entering the XO and YO values, or
dragging the images to the desired locations within the dialog. The example also
includes edge feathering.



Tutorial 7: Mosaicking Using ENVI 185

ENVI Tutorials Pixel-Based Mosaicking Example

1. Using the images already displayed, enter a value of 768 into both the Mosaic
X Size and Y Size text boxes to change the size of the output mosaic

2. Left-click within the green graphic outline of image #2 in the Pixel Based
Image Mosaicking dialog. Drag the #2 image to the lower right hand corner of
the diagram.

3. Edit the mosaic characteristics by selecting Options → Edit Entry in the
Pixel Based Image Mosaicking dialog. Enter a value of 25 for the Edge
Feathering Distance and a Background Data Value to Ignore of 0, and click
OK. Repeat for the second image.

4. Choose File → Save Template and enter the output filename dv06b.mos.
Click on the mosaic template name in the Available Bands List and select

Figure 7-4: Two Single-band AVIRIS Images (left) and the Final Seamless Join
of the Two (right)
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Load Band to display it. No feathering is performed when using virtual
mosaic.

5. Now make the same image as a feathered mosaic by actually creating the
output file. In the Pixel Based Image Mosaicking dialog, select
File → Apply and click OK.

6. Enter an output filename, and a Background Value of 255, then click OK.
Display the mosaic now listed in the Available Bands List in a new display
window.

7. Compare the virtual mosaic and the feathered mosaic using image linking and
dynamic overlays.

The following figure shows the feathered output mosaic produced by overlapping the
two AVIRIS scenes as described above.

Figure 7-5: The Final Feathered Mosaic
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Georeferenced Mosaicking Example

Putting together georeferenced, overlapping images requires considerable
preparation, including histogram matching and usually feathering. The following
sections of this tutorial describe some of the requirements and how to accomplish
these using ENVI.

Create the Georeferenced Mosaic Image

1. Start the ENVI Georeferenced Mosaic function by selecting
Map → Mosaicking → Georeferenced from the ENVI main menu.

Load the Mosaic Template

Select File → Restore Template and select the file lch_a.mos. This opens the files
and restores the mosaic parameters necessary for a georeferenced, feathered mosaic.

Figure 7-6: The Georeferenced Image Mosaicking Dialog
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Optionally Input and Position Images

Optionally, to manually position the georeferenced images and set the feathering
options, import the images individually. Images will automatically be placed in their
correct geographic locations. The location and size of the georeferenced images will
determine the size of the output mosaic.

View the Top Image, Cutline and Virtual, Non-Feathered Mosaic

1. In the Available Bands List, select the file lch_01w.img and display as a
gray scale by clicking on the band name and then the Load Band button.

2. Choose Overlay → Annotation from the Main Image Display menu bar to
start the Annotation dialog.

3. Select File → Restore Annotation and choose the file lch_01w.ann to
display the cutline used to blend the two images in this mosaic.

4. Display the second image lch_02w.img and examine the nature of the cutline
with respect to this image.

5. View the virtual, non-feathered mosaic. Select File → Open Image File from
the ENVI main menu and choose lch_a.mos as the input file. Load this
image to a new display using the Available Bands List and examine the non-
feathered edge between the two images used to create the mosaic.

Create the Output Feathered Mosaic

1. Select File → Apply in the Georeferenced Image Mosaicking dialog and
enter the output filename lch_mos.img and click OK to create the feathered
mosaic.

2. Close the two Image Display Windows containing the individual warped
images and load the mosaic image into a new display.

3. Compare the feathered mosaic to the non-feathered mosaic using image
linking and dynamic overlays.
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In the following figure, the left images show the warped, histogram-matched images
with the cutline selected. The right image is the mosaic resulting from using cutline
feathering.

Figure 7-7: Examples of Georeferenced Image Mosaicking
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Additional Options in the Pixel Based and Georeferenced
Mosaicking Dialogs

The following list describes additional options when using the mosaicking dialogs:

• To edit the characteristics of an image, such as modifying feathering distances,
setting the Background Data Value to Ignore (transparency), or changing the X
and Y image offsets, select Options → Edit Entry and enter the desired
values.

• To replace an image currently in a mosaic with another image of the same size,
select the image to be replaced, and select Options → Replace Entry and
select the image to use for the replacement.

• To delete the currently selected image from the mosaic, select
Options → Delete Entry.

• To remove all images from the mosaic and clear the mosaic, select
Options → Clear All Entries.

The following Pixel Based Image Mosaicking dialog options are available only for
pixel-based images:

• To float the pixel-based image to the top of the stack of overlapping images,
click on the image in the list, or the mosaic diagram, and select
Options → Percolate Entry.

• To center all of the current images in the mosaic as a group, select
Options → Center Entries.

• To place an image as if their upper left corner has the x, y coordinates of (1,1),
select Options → Do Not Use Image Offset.

Do this for images which were previously created as subsets from other larger
images and which have an image offset value. This means that the upper left
corner of the image has X and Y values corresponding to its position in the
original image.

• To place images in the mosaic at the location specified by its location in the
original image from which it was subset, select Options → Use Image Offset.

End the ENVI Session

You can quit your ENVI session by selecting File → Exit (Quit on UNIX) in the
ENVI main menu, then click Yes to end the session. If you are using ENVI RT,
quitting ENVI will take you back to your operating system.
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Tutorial 8:

Landsat TM and SPOT
Data Fusion Using
ENVI
The following topics are covered in this tutorial:

Overview of This Tutorial . . . . . . . . . . . . . 192
Data Fusion . . . . . . . . . . . . . . . . . . . . . . . . 193

London, UK, Data Fusion Example . . . . . 194
Brest, France, Data Fusion Example . . . . 198


