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Overview of This Tutorial

This tutorial provides basic information about ENVI and some suggestions for your
initial investigations of the software. It is designed to introduce first-time ENVI users
to the basic concepts of the package and to explore some of its key features. It
assumes that you are already familiar with general image-processing concepts.

Files Used in This Tutorial

CD-ROM: ENVI Tutorial and Data CD No. 2

Path: envidata/can_tm

File Description

can_tmr.img Cañon City, CO TM Data

can_tmr.hdr ENVI Header for Above
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Working with ENVI

ENVI uses a graphical user interface (GUI) to provide point-and-click access to
image processing functions. You select menu choices and functions using a three-
button mouse.

Note
If you are using ENVI for Windows with a two-button mouse, you can simulate a
middle mouse button press by holding down the Control key and pressing the left
mouse button. If you are using ENVI for Macintosh, hold down the Option key
while pressing the mouse button to simulate a middle mouse button press, or hold
down the Command key while pressing the mouse button to simulate a right mouse
button press.

When you start ENVI, the ENVI main menu appears as a menu bar. Clicking with
the left mouse button on any of the ENVI main menu topics brings up a menu of
options, which may in turn contain submenus with further options. The choices
selected from these submenus will often bring up dialog boxes that allow you to enter
information or set parameters relating to the ENVI function you have selected.

ENVI File Formats

ENVI uses a generalized raster data format consisting of a simple flat binary file and
a small associated ASCII (text) header file. This file format permits ENVI to use
nearly any image file, including those that contain their own embedded header
information.

Generalized raster data is stored as a binary stream of bytes in either Band Sequential
(BSQ), Band Interleaved by Pixel (BIP), or Band Interleaved by Line (BIL) format.

• BSQ is the simplest format, with each line of data followed immediately by the
next line of the same spectral band. BSQ format is optimal for spatial (X, Y)
access to any part of a single spectral band.

• BIP format provides optimal spectral processing performance. Images stored
in BIP format have the first pixel for all bands in sequential order, followed by
the second pixel for all bands, followed by the third pixel for all bands, etc.,
interleaved up to the number of pixels. This format provides optimum
performance for spectral (Z) access of the image data.

• BIL format provides a compromise in performance between spatial and
spectral processing and is the recommended file format for most ENVI
processing tasks. Images stored in BIL format have the first line of the first
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band followed by the first line of the second band, followed by the first line of
the third band, interleaved up to the number of bands. Subsequent lines for
each band are interleaved in similar fashion.

ENVI supports a variety of data types: byte, integer, long integer, floating-point,
double-precision floating-point, complex, and double-precision complex.

The separate text header file provides information to ENVI about the dimensions of
the image, any embedded header that may be present, the data format, and other
pertinent information. The header file is normally created (with your input) the first
time a particular data file is read by ENVI. You can view and edit it at a later time by
selecting File → Edit ENVI Header from the ENVI menu bar. You can also
generate ENVI header files outside ENVI, using a text editor.

ENVI Windows and Displays

As you work with ENVI, a number of different windows and dialog boxes will
appear on your screen. These allow you to manipulate and analyze your image. The
most important of these displays is a group of three windows that display your image,
allow you to move around in it, and allow you to magnify different areas. This group
of windows is collectively referred to as the Display group (Figure 1-1). The Display
group consists of:

• The Main Image Window – This window is where all or part of your image is
displayed at full resolution (one screen pixel is one data pixel).

• The Scroll Window – If your entire image does not fit in the Main Image
window, the Scroll window will appear. The Scroll window displays a
subsampled reduced-size version of the entire image, which allows you to
select the portion that is displayed in the Main Image window. A colored box
in the Scroll window indicates the spatial location and coverage of the full-
resolution Main Image display window. A number in the title bar of the Scroll
window tells you what reduction factor has been applied to the image to
display the full spatial extent within the Scroll window.

• The Zoom Window – This window displays an enlarged version of a selected
portion of the Main Image window. A colored box in the Main Image display
indicates the spatial location and coverage of the Zoom window. A number in
the title bar of the Zoom window tells you what zoom factor has been applied
to the image.

You may have any number of displays open on the screen at any time. There are a
wide variety of other types of ENVI windows with which you may work, including
scatter plots, spectral profiles, spectral plots, and vector windows.
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Figure 1-1: An ENVI Display group: the Main Image, Scroll, and Zoom windows.
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Menus in ENVI Windows

The Main Image display window has its own internal menus, which provide access to
interactive display and analysis functions (Figure 1-2). These menus appear as a
standard menu bar at the top of each Main Image display window. You can select
options from it as you do from any other ENVI menu.

Figure 1-2: The Overlay menu in the Main Image window
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The Available Bands List

ENVI provides access to both image files and to the individual spectral bands in
those files. The Available Bands List is a special ENVI dialog that contains a list of
all the available image bands in all open files (Figure 1-3).

Use the Available Bands List to load both color and gray scale images into a display
by starting a new display or selecting the display number from the pull-down list of
displays, clicking on the appropriate radio button, then selecting the desired bands
from the list by clicking on the band name(s).

The File pull-down menu at the top of the Available Bands List dialog provides
access to file opening and closing, file information, and the Cancel button. The
Options menu provides a function to find the band closest to a specific wavelength,
show the currently displayed bands, allows toggling between full and shortened band
names in the list, and the capability to fold all of the bands in a single open image into
just the image name. Folding and unfolding the bands into single image names or lists

Figure 1-3: The Available Bands List dialog
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of bands can also be accomplished by clicking on the + (plus) or – (minus) symbols
to the left of the file name in the Available Bands List dialog.
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Basic ENVI Functions

This section of the tutorial takes you on a step-by-step tour of ENVI’s basic
functions.

Start ENVI

Before attempting to start the program, ensure that ENVI is properly installed as
described in the installation guide.

• To open ENVI in UNIX, enter envi at the UNIX command line.

• To open ENVI from a Windows or Macintosh system, double-click on the
ENVI icon.

The ENVI main menu appears when the program has successfully loaded and
executed.

Open an Image File

To open an image file:

1. Select File → Open Image File.

Note that on some platforms you must hold the left mouse button down to
display the submenus from the Main Menu.

An Enter Input Data File file selection dialog appears.

2. Navigate to the CAN_TM subdirectory of the envidata directory on the ENVI
ENVI Tutorial and Data CD No. 2 just as you would in any other application
and select the file can_tmr.img from the list and click OK.

The Available Bands List dialog appears on your screen (Figure 1-3). This list
allows you to select spectral bands for display and processing.

You now have the choice of loading either a gray scale or an RGB color image.

3. Select one of the bands listed at the top of the dialog by clicking on the band
with the left mouse button.

The band you have chosen is displayed in the field marked Selected Band:.

4. Click the Load Band button to load the image into a new display.

Note
The Main Image window has a menu bar (Figure 1-2).
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Familiarize Yourself with the Displays

When the image loads, an ENVI image display appears on your screen. The display
consists of a Main Image window, a Scroll window, and a Zoom window (See Figure
1-1). These three windows are intimately linked; changes to one window are mirrored
in the others. To get a feel for how the display windows interact, try the following:

Drag the Zoom Indicator Box

• Note the small red box in the center of the Main Image window. This box
indicates the area of the image displayed in the Zoom window. You can drag
the box from place to place in the Main Image window by clicking inside the
box with the left mouse button and dragging it to a new position. The Zoom
window is updated automatically to show the new area when you release the
mouse button

• You can also reposition the zoom indicator box by placing the crosshair cursor
in the Main Image window and clicking the left mouse button. The zoom
region will be centered around the position you have chosen.

• Finally, if you click outside the zoom indicator box with the middle mouse
button and hold and drag the box to a new position, the Zoom window is
updated as you move the box.

• You can close either the Zoom and/or Scroll windows if you don’t want to
display them. They can again be displayed by selecting Window → Show
Scroll Window or Window → Show Zoom Window from the Main Image
window menu bar.

Zoom In and Out and Pan the Zoom Window

• Move the mouse cursor in the Zoom window and click the left mouse button to
reposition the magnified area by centering the zoomed area on the selected
pixel.

• Clicking and holding the left mouse button in the Zoom window while
dragging causes the Zoom window to pan within the Main Image display.

• Click the right mouse button in the Zoom window to toggle the menu graphic
on or off. The menu graphic is made up of three icons in the lower left corner
of the Zoom window.

• Clicking the left mouse button on the – (minus) graphic zooms down by a
factor of 1. Clicking the middle mouse button on this graphic zooms down by a
factor of 2. Clicking the right mouse button on the graphic returns the Zoom
window to the default zoom factor.
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• Clicking the left mouse button on the + (plus) graphic zooms up by a factor of
1. Clicking the middle mouse button on this graphic zooms doubles the Zoom
factor. Clicking the right mouse button on the graphic returns the Zoom
window to the default zoom factor.

• Click the left mouse button on the right (third) graphics box to toggle the
Zoom window crosshair cursor. Click the middle mouse button on this graphic
to toggle the Main Image crosshair cursor. Click the right mouse button on this
graphic to toggle the zoom box in the Main Image window on or off.

• Double-click the left mouse button on the right (third) graphics box to toggle
interpolation in the Zoom window. Double-click the right mouse button in this
graphic to toggle scroll bars on the Main Image window.

Scroll the Image

A red box in the Scroll window indicates what portion of the entire image is currently
displayed in the Main Image window. You can move the selected area by clicking
inside the scroll indicator box with the left mouse button and dragging the box to a
new position. The displays in the Main Image and Zoom windows are updated when
you release the mouse button. You can also reposition the scroll indicator box by
clicking at the desired location outside of the box using the left mouse button (as for
the Zoom window box above). If you click, hold and drag the left mouse button in
this fashion, the Main Image window is updated as you drag (the speed depends on
your computer resources).

Resize the Windows

You can resize the display windows the same way you would resize windows in other
applications, by dragging any of the corners. Note, however, that you cannot make
the Main Image window larger than the image size. When the Main Image window is
large enough to display the entire image, the Scroll window is unnecessary and is
automatically removed from your screen. The Scroll window reappears if the Main
Image window is resized smaller than the full image.

Scroll Bars

The Main Image window can also have optional scroll bars, which provide an
alternate method for moving through the Scroll image, allowing you to select which
portion of the image appears in the Image window. To add scroll bars, select
File → Preferences from the Main Image window menu bar. Click on the arrow
toggle button next to the Scroll Bars text field in the dialog to toggle scroll bars on,
then click OK at the bottom of the dialog. The portion of the image displayed in the
Main Image window can now be controlled by clicking and dragging the scroll bars
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using the left mouse button. Scroll bars can be turned on by default for all images
from the ENVI menu bar by selecting File → Preferences → Display Defaults and
clicking on the toggle button for the Image window scroll bars as described above.

Use the Mouse Button Descriptions

ENVI has many interactive functions, and the mouse button combinations and
actions are different for each one. The Mouse Button Descriptions dialog is
provided to tell you what the mouse buttons do in each graphics window.

• To start the Mouse Button Descriptions dialog, select Window → Mouse
Button Descriptions from either the Main Image window menu bar, or from
the ENVI main menu bar.

Now whenever your cursor is in an ENVI display or graphics window, the mouse
button assignments will be listed in this dialog. MB1 is the left mouse button, MB2 is
the middle mouse button, and MB3 is the right mouse button.

Display the Cursor Location

• To display the cursor location and value, select Window → Cursor
Location/Value from the ENVI main menu or the Main Image window menu
bar.

The Cursor Location / Value dialog box appears displaying the location of
the cursor in the Main Image, Scroll, or Zoom windows (Figure 1-4). The
dialog also displays the screen value (color) and the actual data value of the
pixel underneath the crosshair cursor.

• To dismiss the dialog, select Cancel from the pull-down File menu at the top
of the Cursor Location /Value dialog.

• The Cursor Location/Value dialog can also be started/stopped by double-
clicking using the left mouse button in the Main Image window.
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Display Image Profiles

X (horizontal), Y (vertical), and Z (spectral) profile plots can be selected and
displayed interactively. These profiles show the data values across an image line (X),
column (Y), or spectral bands (Z).

1. Select Tools → Profiles → X Profile from the Main Image display menu bar
to display a window plotting data values versus sample number for a selected
line in the image (Figure 1-5).

2. Repeat the process, selecting Y Profile to display a plot of data value versus
line number, and selecting Z Profile to display a spectral plot (Figure 1-5).

Note
The Mouse Button Descriptions dialog contains the descriptions of the mouse
button actions in the Profile displays.

3. Position the Profile plot windows so you can see all three at once.

A red crosshair extends to the top and bottom and to the sides of the Main
Image window. The red lines indicate the line or sample locations for the
vertical or horizontal profiles.

4. Move the crosshair around the image (just as you move the zoom indicator
box) to see how the three image profile plots are updated to display data on the
new location.

Figure 1-4: The Cursor Location/Value dialog displays the screen and data
values of the selected pixel.
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5. Close the profile plots by selecting File → Cancel from within each plot
window.

Perform Quick Contrast Stretching

You can perform quick contrast stretches using default parameters and data from
either the Main Image window, the Zoom window, or the Scroll window. Using the
Enhance menu from the Main Image window menu bar, you can apply various
contrast stretches (Linear, Linear 0-255, Linear 2%, Gaussian, Equalization, and
Square Root).

1. Try the various stretches using the Main Image, Zoom, and Scroll as the
stretch data source.

2. Compare the effects of the various Linear, Gaussian, Equalization, and Square
Root stretches in the Display group windows.

Display Interactive Scatter Plots

You can plot the data values of two selected image bands versus each other in a
scatter plot to graphically display the overlapping values.

1. Select Tools → 2D Scatter Plots from the Main Image window menu bar.

The Scatter Plot Band Choice dialog appears, in which you choose the two
image bands to compare.

Figure 1-5: The Horizontal (X) Profile (left) and Spectral (Z) Profile (right) plots.
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2. Select one band for the X axis and another band for the Y axis and click OK.

It may take a few seconds for ENVI to extract and tabulate the data values.

3. Once the scatter plot has appeared (Figure 1-6), position the mouse cursor
anywhere in the Main Image window and drag with the left mouse button
pressed.

Pixel values contained in a ten-pixel by ten-pixel box surrounding the
crosshair will be highlighted in red on the scatter plot.

Note
The Mouse Button Descriptions dialog tells you the functions of the different
mouse button actions when applied in the Scatter Plot display.

4. Move the cursor around in the Main Image window to observe the dancing
pixels effect.

5. You can also use the scatter plot to highlight specific data values in the Main
Image window. Place the mouse cursor in the scatter plot window and click
and drag with the middle mouse button.

Figure 1-6: An Interactive Scatter Plot comparing band 1 values to band 4
values.
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A ten-pixel-square box will appear in red on the plot. Pixels with the values
contained in the box are highlighted on the image in the Main Image window
and appear to dance, as you drag the cursor in the Scatter Plot display moving
the 10-by-10 pixel area.

6. From the Scatter Plot menu bar, select File → Cancel to close the Scatter Plot
window.

Load a Color Image

1. If the Available Bands List dialog is not already on your screen, call it up
again from the ENVI Main menu bar by selecting Window → Available
Bands List (Figure 1-3).

2. Set up to load a color image in a second display by clicking on the radio button
labelled RGB Color in the Available Bands List dialog.

3. Select a band for each color (red, green, blue) from the list by clicking on the
band name. The radio buttons for assigning the R, G, and B colors
automatically advance when you click on a band name in the list.

4. When all three colors have band names associated with them, click the Display
#1 menu button to open a New Display from the pull-down menu.

5. Now, click on the Load RGB button to load the image in the new display.

Link Two Displays

Link the two displays together for comparison. When you link two displays, any
action you perform on one display (scrolling, zooming, etc.) is echoed in the linked
display. To link the two displays you have on screen now do the following.

1. From either of the two Main Image menu bars, select Tools → Link → Link
Displays. This opens the Link Displays dialog box.

2. Click OK in the Link Displays dialog to establish the link.

3. Now try scrolling or zooming in one display group and observe as your
changes are mirrored in the second display.

Dynamic Overlays

ENVI’s multiple Dynamic Overlay feature allows you to dynamically superimpose
parts of one or more linked images onto the other image. Dynamic overlays are
turned on automatically when you link two displays, and may appear in either the
Main Image window or the Zoom window.
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1. To start, click the left mouse button to see both displays completely overlaid
on one another.

2. To create a smaller overlay area, position the mouse cursor anywhere in either
Main Image window (or either Zoom window) and hold down and drag with
the middle mouse button. Upon button release, the smaller overlay area is set
and a small portion of the linked image will be superimposed on the current
image window.

3. Now click the left mouse button and drag the small overlay window around the
image to see the overlay effects.

4. You can resize the overlay area at any time by clicking and dragging the
middle mouse button until the overlay area is the desired size.

Select Regions Of Interest

ENVI lets you define regions of interest (ROIs) in your images. ROIs are typically
used to extract statistics for classification, masking, and other operations.

1. From the Main Image window menu bar, select Overlay → Region of
Interest. The ROI Tool dialog for that Main Image display will appear
(Figure 1-7).

2. Draw a polygon that represents the region of interest.

Figure 1-7: The ROI Tool dialog with two regions defined.
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• Click the left mouse button in the Main Image window to establish the first
point of the ROI polygon.

• Select further border points in sequence by clicking the left button again,
and close the polygon by clicking the right mouse button.The middle
mouse button deletes the most recent point, or (if you have closed the
polygon) the entire polygon. Click the right mouse button a second time to
fix the polygon.

• ROIs can also be defined in the Zoom and Scroll windows by selecting the
appropriate window radio button in the ROI Tool dialog.

When you have finished defining an ROI, it is shown in the dialog in the
Available Regions of Interest list, with the name, region color, and number of
pixels enclosed (Figure 1-7).

3. To define a new ROI, click the New Region button.

• You can enter a name for the region and select the color and fill patterns
for the region by clicking on the Edit button.

Other types of ROIs

ROIs can also be defined as polylines or as a collection of individual pixels by
selecting the desired ROI type from the ROI_Type pull-down menu. See the ENVI
3.5 User’s Guide or the hypertext online help for further discussion of these types of
ROI.
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Working with ROIs

You can define as many ROIs as you wish in any image (Figure 1-8).

1. Once you have created the ROI definitions, you can erase them from the
display (leaving the definition in the list) by selecting the ROI from the
Available Regions of Interest list and clicking on the Erase button.

2. Clicking on the Stats button allows you to view statistics about the ROI you
select.

3. Clicking the Delete button permanently deletes the selected ROI definitions
from the list.

4. The other buttons and options under the pull-down menus at the top of the
ROI Tool dialog let you calculate ROI means, save your ROI definitions, load
saved definitions, or display or delete all the definitions in the list.

Region of interest definitions are retained in memory after the ROI Tool dialog is
closed, unless you explicitly delete them. This means the ROIs are available to other
ENVI functions even if they are not displayed.

Figure 1-8: An image with two regions of interest (ROIs) defined.
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Annotate the Image

ENVI’s flexible annotation features allow you to add text, polygons, color bars, and
other symbols to your plots and images.

1. To annotate an image, select Overlay → Annotation from the Main Image
menu bar. The Annotation: Text dialog for that Main Image window will
appear (Figure 1-9).

2. To annotate plots, 3-D surfaces, and similar objects, select
Options → Annotation from the plot window menu bar.

Annotation Types

The Annotation: Text dialog allows you to choose from a variety of annotation
types. Different types are selected from the Object menu and include Text, Symbols,
Rectangles, Ellipses, Polygons, Polylines, Arrows, Map Scale Bars and Declination
Diagrams, Map Keys, Color Table Ramps, and Images. By default, the Annotation
dialog starts up with Text selected. Other fields in the dialog let you control the size,
color, placement, and angle of the annotation text. When you select different

Figure 1-9: The Annotation dialog, in Text mode.
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annotation types from the Object menu, the fields in the dialog change to display
options appropriate to the new type.

Placing Annotation

Try placing a text annotation in your Main Image window:

1. Type some text in the text field of the Annotation: Text dialog.

2. Select a font, color, and size from the appropriate menus and parameters in the
dialog, then position the mouse pointer in the Main Image window and press
the left mouse button.

Note
The Mouse Button Description dialog describes the mouse button interactions
within annotation.

Your text is displayed in the window at the point you chose (Figure 1-10).

3. Drag the handle using the left mouse button to position the text in the window.

• You can continue to change the annotation’s properties and position by
changing the fields in the dialog box or dragging the text or symbol while
holding down the left mouse button.

4. When you are satisfied with the annotation, press the right mouse button to fix
the annotation in position.

Figure 1-10: An annotated image.
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Saving and Restoring Annotation

1. You can save your image annotation by selecting File → Save Annotation
from the Annotation: Text dialog menu bar.

2. This opens the Output Annotation Filename dialog in which you specify a
path and filename with a .ann extension for the saved annotation.

Note
If you do not save your annotation in a file, it will be lost when you close the
Annotation: Text dialog (you will be prompted to save the annotation if you close
without first saving).

3. You can also restore saved annotation files by selecting File → Restore
Annotation in the Annotation: Text dialog.

Editing Previously Placed Annotation

To edit an annotation element that has already been set in the image, do the
following.

1. Select Object → Selection/Edit in the Annotation: Text dialog.

2. Draw a box around the annotation you wish to edit by clicking and dragging
with the left mouse button.

3. When the handle reappears, Click and drag the handle and annotation to move
and configure the item just as you would a new annotation.

Suspending the Annotation Function Temporarily

1. To suspend annotation operations and return to normal ENVI functionality
temporarily, select the Off radio button at the top of the Annotation: Text
dialog.

This allows you to use the scroll and zoom features in your display without
losing your annotations.

2. To return to the annotation function, select the radio button in the Annotation:
Text dialog for the window you are annotating.

Leave your annotation on the Main Image window as you complete this tutorial.
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Add Grid Lines

Try adding a grid (Figure 1-11) to your image.

1. To overlay grid lines on your image, select Overlay → Grid Lines in the
Main Image window. This brings up the Grid Line Parameters dialog box.

Note
An image border is automatically added when you overlay grid lines.

2. You can adjust the grid line attributes by setting the line thickness and color
and the grid spacing using the Options → Edit Pixel Grid Attributes pull-
down menu from the Grid Lines Parameters dialog. This selection brings up
the Edit Pixel Attributes dialog box.

3. In the Edit Pixel Attributes dialog, you can change the color, thickness and
grid spacing for the labels, lines, box and corners of the grid. When the
attributes are set up to your satisfaction, click OK in the Edit Pixel Attributes
dialog to apply the changes to the grid on the images.

4. When you have added a satisfactory grid, click Apply in the Grid Line
Parameters dialog.
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Save and Output an Image

ENVI gives you several options for saving and outputting your filtered, annotated,
gridded images. You can save your work in ENVI’s image file format, or in several
popular graphics formats (including Postscript) for printing or importing into other
software packages. You can also output directly to a printer.

Saving your Image in ENVI Image Format

To save your work in ENVI’s native format (as an RGB file):

1. From the Main Image window menu bar, select File → Save Image
As → Image File. The Output Display to Image File dialog appears.

Figure 1-11: An annotated image with a grid overlaid.
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2. Select 24-Bit color or 8-Bit gray scale output, graphics options (including
annotation and gridlines), and borders.

If you have left your annotated and gridded color image on the display, both
the annotation and grid lines will be automatically listed in the graphics
options.

You can also select other annotation files to be applied to the output image.

3. Select output to Memory or File using the desired radio button.

• If output to File is selected, enter an output filename.

Note
If you select other graphics file formats from the Output File Type button
which, by default is set to ENVI, your choices will be slightly different.

4. Click OK to save the image.

Note
This process saves the current display values for the image, not the actual
data values.

End the ENVI Session

You can quit your ENVI session by selecting File → Exit (Quit on UNIX) on the
ENVI main menu, then click OK to terminate ENVI when prompted.
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